Autore Topic: flatpak ha dipendenze gtk  (Letto 61 volte)

Offline paolomi

  • *
  • Post: 290
  • Reputazione: 21
  • Akabei... con spacchettamento a destra
    • Mostra profilo
flatpak ha dipendenze gtk
« il: 19 Agosto 2019 ore 21:47 »
Per avere un'esperienza solo QT, ho disabilitato il repo [gtk] e ho scoperto che il pacchetto flatpak che è presente in [desktop] ha tra le proprie dipendenze appstream-glib il quale dipende da gtk3.

Quindi bisogna provare a togliere gtk3 da appstream-glib e se non è possibile va spostato in [gtk]
Usare Chakra senza PulseAudio

«L'anno prossimo passerò a pulseaudio» (frase detta da me alcuni anni fa… e ancora valida!)

Offline FranzMari

  • *
  • Post: 2814
  • Reputazione: 103
  • [Senior Packager]
    • Mostra profilo
    • IMHO blog
Re:flatpak ha dipendenze gtk
« Risposta #1 il: 27 Agosto 2019 ore 10:01 »
Grazie per la segnalazione!
La prossima volta, per favore, apri una segnalazione su GitLab, selezionando il repository di appartenenza del pacchetto oggetto del report.
«Il valore dell'essere umano si determina nella misura in cui sia grande o piccola la sua capacità di contribuire al bene collettivo.» Jigorō Kanō

Offline paolomi

  • *
  • Post: 290
  • Reputazione: 21
  • Akabei... con spacchettamento a destra
    • Mostra profilo
Re:flatpak ha dipendenze gtk
« Risposta #2 il: 28 Agosto 2019 ore 13:39 »
Grazie per la risposta!  Ne terrò conto per la prossima volta :beer:


Certo che pensare che per usare flatpak bisogna installare le gtk, mi cadono le braccia  :(

Se avessi fatto io 6 al superenalotto, avrei speso una valanga di soldi per QTizzare tutto  :P
Usare Chakra senza PulseAudio

«L'anno prossimo passerò a pulseaudio» (frase detta da me alcuni anni fa… e ancora valida!)

Offline FranzMari

  • *
  • Post: 2814
  • Reputazione: 103
  • [Senior Packager]
    • Mostra profilo
    • IMHO blog
Re:flatpak ha dipendenze gtk
« Risposta #3 il: 10 Settembre 2019 ore 09:59 »
Risolto, abbiamo rimosso la dipendenza da gtk3
«Il valore dell'essere umano si determina nella misura in cui sia grande o piccola la sua capacità di contribuire al bene collettivo.» Jigorō Kanō

Offline paolomi

  • *
  • Post: 290
  • Reputazione: 21
  • Akabei... con spacchettamento a destra
    • Mostra profilo
Re:flatpak ha dipendenze gtk
« Risposta #4 il: 14 Settembre 2019 ore 21:48 »
non si riesce a installare flatpak perché manca gcab che è in [gtk].

Citazione
unable to satisfy dependency 'gcab' required by appstream-glib

Se guardo le dipendenze di gcab mi dice che dipende solo da glib2, non vedo dipendenze da pacchetti che stanno in [gtk].

Morale della favola:
o gcab va in [desktop] (o core, vedete voi)
o flatpak e appstream-glib vanno in [gtk]
o lasciate tutto così, ma mi pare veramente brutto avere flatpak in [desktop] che non si può installare perché bisogna abilitare il repo [gtk]
Usare Chakra senza PulseAudio

«L'anno prossimo passerò a pulseaudio» (frase detta da me alcuni anni fa… e ancora valida!)

 

Template by Homey | Sito ufficiale | Disclaimer