Autore Topic: Problema aggiornamenti  (Letto 486 volte)

Offline mrcrowley

  • *
  • Post: 876
  • Reputazione: -1
    • Mostra profilo
Problema aggiornamenti
« il: 05 Giugno 2017 ore 00:07 »
Codice: [Seleziona]
errore: impossibile eseguire l'operazione richiesta (file in conflitto)
kmime: /usr/share/locale/bg/LC_MESSAGES/libkmime5.mo è già presente nel filesystem
kmime: /usr/share/locale/wa/LC_MESSAGES/libkmime5.mo è già presente nel filesystem
kmailtransport: /usr/share/locale/bg/LC_MESSAGES/kio_smtp.mo è già presente nel filesystem
kontactinterface: /usr/share/locale/bg/LC_MESSAGES/kontactinterfaces5.mo è già presente nel filesystem
kontactinterface: /usr/share/locale/wa/LC_MESSAGES/kontactinterfaces5.mo è già presente nel filesystem
libkleo: /usr/share/locale/bg/LC_MESSAGES/libkleopatra.mo è già presente nel filesystem
kldap: /usr/share/locale/bg/LC_MESSAGES/kio_ldap.mo è già presente nel filesystem
libkdepim: /usr/share/locale/bg/LC_MESSAGES/libkdepim.mo è già presente nel filesystem
libkdepim: /usr/share/locale/wa/LC_MESSAGES/libkdepim.mo è già presente nel filesystem
grantleetheme: /usr/share/locale/bg/LC_MESSAGES/libgrantleetheme.mo è già presente nel filesystem
messagelib: /usr/share/locale/bg/LC_MESSAGES/libmessagelist.mo è già presente nel filesystem
messagelib: /usr/share/locale/bg/LC_MESSAGES/libmessageviewer.mo è già presente nel filesystem
messagelib: /usr/share/locale/wa/LC_MESSAGES/libmessagelist.mo è già presente nel filesystem
messagelib: /usr/share/locale/wa/LC_MESSAGES/libmessageviewer.mo è già presente nel filesystem
messagelib: /usr/share/locale/wa/LC_MESSAGES/libtemplateparser.mo è già presente nel filesystem
akregator: /usr/share/locale/bg/LC_MESSAGES/akregator.mo è già presente nel filesystem
ark: /usr/share/locale/bg/LC_MESSAGES/ark.mo è già presente nel filesystem
kholidays: /usr/share/locale/bg/LC_MESSAGES/libkholidays5_qt.qm è già presente nel filesystem
kholidays: /usr/share/locale/wa/LC_MESSAGES/libkholidays5_qt.qm è già presente nel filesystem
calendarsupport: /usr/share/locale/bg/LC_MESSAGES/calendarsupport.mo è già presente nel filesystem
calendarsupport: /usr/share/locale/wa/LC_MESSAGES/calendarsupport.mo è già presente nel filesystem
kio-extras: /usr/share/locale/bg/LC_MESSAGES/kfileaudiopreview5.mo è già presente nel filesystem
kio-extras: /usr/share/locale/bg/LC_MESSAGES/kio5_activities.mo è già presente nel filesystem
kio-extras: /usr/share/locale/wa/LC_MESSAGES/kfileaudiopreview5.mo è già presente nel filesystem
kio-extras: /usr/share/locale/wa/LC_MESSAGES/kio5_activities.mo è già presente nel filesystem
dolphin: /usr/share/locale/bg/LC_MESSAGES/dolphin.mo è già presente nel filesystem
dolphin: /usr/share/locale/wa/LC_MESSAGES/dolphin.mo è già presente nel filesystem
gwenview: /usr/share/locale/bg/LC_MESSAGES/gwenview.mo è già presente nel filesystem
gwenview: /usr/share/locale/wa/LC_MESSAGES/gwenview.mo è già presente nel filesystem
kalarmcal: /usr/share/locale/bg/LC_MESSAGES/libkalarmcal5.mo è già presente nel filesystem
kalarmcal: /usr/share/locale/wa/LC_MESSAGES/libkalarmcal5.mo è già presente nel filesystem
kcalc: /usr/share/locale/bg/LC_MESSAGES/kcalc.mo è già presente nel filesystem
kcalc: /usr/share/locale/wa/LC_MESSAGES/kcalc.mo è già presente nel filesystem
mailimporter: /usr/share/locale/bg/LC_MESSAGES/libmailimporter.mo è già presente nel filesystem
kdepim-addons: /usr/share/locale/bg/LC_MESSAGES/cryptopageplugin.mo è già presente nel filesystem
kdepim-addons: /usr/share/locale/bg/LC_MESSAGES/korganizer_plugins.mo è già presente nel filesystem
kdepim-addons: /usr/share/locale/bg/LC_MESSAGES/messageviewer_application_mstnef_plugin.mo è già presente nel filesystem
kdepim-addons: /usr/share/locale/bg/LC_MESSAGES/messageviewer_text_calendar_plugin.mo è già presente nel filesystem
kdepim-addons: /usr/share/locale/bg/LC_MESSAGES/messageviewer_text_vcard_plugin.mo è già presente nel filesystem
kdepim-addons: /usr/share/locale/wa/LC_MESSAGES/korganizer_plugins.mo è già presente nel filesystem
kdepim-runtime: /usr/share/locale/bg/LC_MESSAGES/accountwizard_contacts.mo è già presente nel filesystem
kdepim-runtime: /usr/share/locale/bg/LC_MESSAGES/accountwizard_ical.mo è già presente nel filesystem
kdepim-runtime: /usr/share/locale/bg/LC_MESSAGES/accountwizard_imap.mo è già presente nel filesystem
kdepim-runtime: /usr/share/locale/bg/LC_MESSAGES/accountwizard_kolab.mo è già presente nel filesystem
kdepim-runtime: /usr/share/locale/bg/LC_MESSAGES/accountwizard_mailbox.mo è già presente nel filesystem
kdepim-runtime: /usr/share/locale/bg/LC_MESSAGES/accountwizard_maildir.mo è già presente nel filesystem
kdepim-runtime: /usr/share/locale/bg/LC_MESSAGES/accountwizard_pop3.mo è già presente nel filesystem
kdepim-runtime: /usr/share/locale/bg/LC_MESSAGES/accountwizard_vcard.mo è già presente nel filesystem
kdepim-runtime: /usr/share/locale/bg/LC_MESSAGES/accountwizard_vcarddir.mo è già presente nel filesystem
kdepim-runtime: /usr/share/locale/bg/LC_MESSAGES/akonadi_newmailnotifier_agent.mo è già presente nel filesystem
kdepim-runtime: /usr/share/locale/bg/LC_MESSAGES/kio_akonadi.mo è già presente nel filesystem
kdepim-runtime: /usr/share/locale/bg/LC_MESSAGES/kio_pop3.mo è già presente nel filesystem
knotes: /usr/share/locale/bg/LC_MESSAGES/knotes.mo è già presente nel filesystem
konsole: /usr/share/locale/bg/LC_MESSAGES/konsole.mo è già presente nel filesystem
konsole: /usr/share/locale/wa/LC_MESSAGES/konsole.mo è già presente nel filesystem
marble: /usr/share/locale/bg/LC_MESSAGES/marble.mo è già presente nel filesystem
marble: /usr/share/locale/wa/LC_MESSAGES/marble.mo è già presente nel filesystem
libkgeomap: /usr/share/locale/bg/LC_MESSAGES/libkgeomap.mo è già presente nel filesystem
libksane: /usr/share/locale/bg/LC_MESSAGES/libksane.mo è già presente nel filesystem
libksane: /usr/share/locale/wa/LC_MESSAGES/libksane.mo è già presente nel filesystem
print-manager: /usr/share/locale/bg/LC_MESSAGES/plasma_applet_org.kde.plasma.printmanager.mo è già presente nel filesystem
print-manager: /usr/share/locale/bg/LC_MESSAGES/print-manager.mo è già presente nel filesystem
spectacle: /usr/share/locale/bg/LC_MESSAGES/spectacle.mo è già presente nel filesystem
Si sono verificati degli errori, nessun pacchetto è stato aggiornato.

Che faccio ??

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Problema aggiornamenti
« Risposta #1 il: 05 Giugno 2017 ore 08:11 »
sul forum internazionale stanno suggerendo di forzare l'aggiornamento.

Anche se non capisco come mai ci siano questi errori  ???

Offline mrcrowley

  • *
  • Post: 876
  • Reputazione: -1
    • Mostra profilo
Re:Problema aggiornamenti
« Risposta #2 il: 05 Giugno 2017 ore 08:41 »

Sarebbe questo https://chakralinux.org/forum/   ???

Ciaociao

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo

Offline FranzMari

  • *
  • Post: 2809
  • Reputazione: 103
  • [Senior Packager]
    • Mostra profilo
    • IMHO blog
Re:Problema aggiornamenti
« Risposta #4 il: 06 Giugno 2017 ore 12:17 »
Forzare gli aggiornamenti non è mai una buona soluzione.
Come già detto molte altre volte, bisogna verificare a quali pacchetti appartengono i file già installati sul sistema: nella maggior parte dei casi si tratta di pacchetti non più necessari e/o rimossi dai repository e che possono essere disinstallati dal sistema, in modo che non si presentino ulteriori problemi successivamente.
«Il valore dell'essere umano si determina nella misura in cui sia grande o piccola la sua capacità di contribuire al bene collettivo.» Jigorō Kanō

Offline mrcrowley

  • *
  • Post: 876
  • Reputazione: -1
    • Mostra profilo
Re:Problema aggiornamenti
« Risposta #5 il: 06 Giugno 2017 ore 19:16 »

Quindi potrebbe essere utile, dare prima il comando per l' eliminazione di pacchetti non più utilizzati giusto ???

Che sarebbe ??


Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Problema aggiornamenti
« Risposta #6 il: 06 Giugno 2017 ore 19:59 »
Sarebbe il caso prima di vedere quei file a che pacchetto appartengono. Sia per capire se ci sono dei problemi nei repository, sia se eventualmente c'è qualcosa che non va nel sistema.
Non sei il primo utente che ha questi file, ma ad esempio a me non è capitato.

pacman -Qo /path/nomefile

ti dice che pacchetto contiene il file. Se non ti trova niente significa che sono file orfani e puoi sovrascriverli.

Offline mrcrowley

  • *
  • Post: 876
  • Reputazione: -1
    • Mostra profilo
Re:Problema aggiornamenti
« Risposta #7 il: 07 Giugno 2017 ore 09:06 »
Codice: [Seleziona]
/usr/share/locale/bg/LC_MESSAGES/libkmime5.mo è contenuto in kde-l10n-bg 16.04.1-1
[massimiliano@massimiliano-pc ~]$ sudo pacman -Qo /usr/share/locale/wa/LC_MESSAGES/libkmime5.mo
/usr/share/locale/wa/LC_MESSAGES/libkmime5.mo è contenuto in kde-l10n-wa 16.04.1-1
[massimiliano@massimiliano-pc ~]$ sudo pacman -Qo /usr/share/locale/bg/LC_MESSAGES/kio_smtp.mo
/usr/share/locale/bg/LC_MESSAGES/kio_smtp.mo è contenuto in kde-l10n-bg 16.04.1-1
[massimiliano@massimiliano-pc ~]$ sudo pacman -Qo /usr/share/locale/bg/LC_MESSAGES/kontactinterfaces5.mo
/usr/share/locale/bg/LC_MESSAGES/kontactinterfaces5.mo è contenuto in kde-l10n-bg 16.04.1-1


Offline mrcrowley

  • *
  • Post: 876
  • Reputazione: -1
    • Mostra profilo
Re:Problema aggiornamenti
« Risposta #8 il: 07 Giugno 2017 ore 09:39 »
Edit
Ma che ci fanno queste localizzazioni, Bulgara e Walloon di KDE nel mio sistema !!!???
Soluzione: posso rimuoverle o forzo l' installazione ??

« Ultima modifica: 07 Giugno 2017 ore 09:50 da mrcrowley »

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Problema aggiornamenti
« Risposta #9 il: 07 Giugno 2017 ore 11:39 »
rimuovi prima tutte le localizzazioni inutili! almeno ti assicuri di aver fatto un po' di pulizia. Altrimenti rimuovendole dopo avrai problemi (rischi di eliminare i file che ti servirebbero).

EDIT: che poi questi pacchetti manco esistono più...   :o

Offline FranzMari

  • *
  • Post: 2809
  • Reputazione: 103
  • [Senior Packager]
    • Mostra profilo
    • IMHO blog
Re:Problema aggiornamenti
« Risposta #10 il: 07 Giugno 2017 ore 11:41 »
Edit
Ma che ci fanno queste localizzazioni, Bulgara e Walloon di KDE nel mio sistema !!!???
Soluzione: posso rimuoverle o forzo l' installazione ??

[...] nella maggior parte dei casi si tratta di pacchetti non più necessari e/o rimossi dai repository e che possono essere disinstallati dal sistema, in modo che non si presentino ulteriori problemi successivamente.

rimuovi
«Il valore dell'essere umano si determina nella misura in cui sia grande o piccola la sua capacità di contribuire al bene collettivo.» Jigorō Kanō

Offline mrcrowley

  • *
  • Post: 876
  • Reputazione: -1
    • Mostra profilo
Re:Problema aggiornamenti
« Risposta #11 il: 07 Giugno 2017 ore 11:42 »
-R   e basta ??
« Ultima modifica: 07 Giugno 2017 ore 11:44 da mrcrowley »

Offline mrcrowley

  • *
  • Post: 876
  • Reputazione: -1
    • Mostra profilo
Re:Problema aggiornamenti
« Risposta #12 il: 07 Giugno 2017 ore 16:32 »
[EDIT]
Li ho disinstallati con -R  e ripetuto l' aggiornamento .... adesso viene completato correttamente.
Il fatto però è che ci sono, e vengono infatti aggiornati, molti pacchetti (come temevo) di localizzazioni di kde, che sinceramente non capisco a cosa servono.
Vi allego uno screenshot.
Come ho detto prima, non sarebbe meglio avere solo la localizzazione IT e EN (US) ed eliminare le altre ???

Saluti
« Ultima modifica: 07 Giugno 2017 ore 16:38 da mrcrowley »

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Problema aggiornamenti
« Risposta #13 il: 07 Giugno 2017 ore 17:49 »
Ti ringrazio per la segnalazione, io ne avevo 4 che non centravano niente e li ho appena rimossi  ;)

Offline mrcrowley

  • *
  • Post: 876
  • Reputazione: -1
    • Mostra profilo
Re:Problema aggiornamenti
« Risposta #14 il: 07 Giugno 2017 ore 17:56 »
Mi fa piacere aver fatto qualcosa di utile a te, una volta tanto  :)

Mi diresti però come fare x togliere tutte le mie in eccesso, senza far casini ?

 

Template by Homey | Sito ufficiale | Disclaimer