Autore Topic: errore nel build installazione interrotta  (Letto 176 volte)

Offline pabform

  • *
  • Post: 42
  • Reputazione: 0
  • Siamo ciò che pensiamo
    • Mostra profilo
    • Bad Rooster
errore nel build installazione interrotta
« il: 09 Agosto 2016 ore 13:23 »
Codice: [Seleziona]
code]The build failed.
Dependencies for `cairo-dock-plugins' are not met, not building...

Ciao, non so se sia la giusta sezione e me ne scuso.
Da un po' di tempo subito dopo avere installato chakra, ho installato cairo-dock da ccr, installazione ok.
Installazione plugins, parte regolarmente ma si ferma quasi alla fine, il messaggio dice: (vedi sopra)
 Ho pensato che ci sia il pacchetto difettoso, visto che anche a distanza di tempo il comportamento non cambia, comunque io non so compilare, cosa posso fare?  :-X
« Ultima modifica: 09 Agosto 2016 ore 13:28 da pabform »
Chakra Ian, PCLinuxOS, Linux Rosa, OpenSuse, Mint,  Debian, Sabayon.

Offline Cylon

  • *
  • Post: 1960
  • Reputazione: 78
  • CYbernetic Life fOrm Node
    • Mostra profilo
Re:errore nel build installazione interrotta
« Risposta #1 il: 09 Agosto 2016 ore 18:58 »
il messaggio dice tutto.. non hai tutte le dipendenze installate... leggendo da ccr dovresti aver installate queste dipendenze:

Citazione
curl
dbus-glib
glu
gtk3
librsvg
We are the Cylons. Lower your firewalll and surrender.Your PC will adapt to service our GNU/Linux systems. Resistance is futile. Extermination of human race has began!
                                                                     Non rispondo a PM

Offline pabform

  • *
  • Post: 42
  • Reputazione: 0
  • Siamo ciò che pensiamo
    • Mostra profilo
    • Bad Rooster
Re:errore nel build installazione interrotta
« Risposta #2 il: 10 Agosto 2016 ore 17:31 »
Scusa ma non capisco questi comandi, se digito curl mi da di eseguire curl --help
il secondo non produce nulla, tra l'altro i carattere del testo sono piccolissimi e non riesco a leggere (sono quasi cieco) non  riesco ad andare avanti, ma non vorrei che il tuo disturbo diventi troppo. mi spieghi cosa sono quei codici?
con "glu" mi dice "comando non trovato" stessa cosa con gtk3..... ???
« Ultima modifica: 10 Agosto 2016 ore 17:34 da pabform »
Chakra Ian, PCLinuxOS, Linux Rosa, OpenSuse, Mint,  Debian, Sabayon.

Offline whoami

  • *
  • Post: 1562
  • Reputazione: 64
  • Quando c'era init i log arrivavano in orario!
    • Mostra profilo
Re:errore nel build installazione interrotta
« Risposta #3 il: 10 Agosto 2016 ore 19:01 »
Sarebbero pacchetti da installare con pacman...

Ma non avevi già scritto rispetto a questo problema di cairo-plugins? Mi ricordo che se ne era parlato e che il problema è proprio il ccr che non va... E che finché qualche anima pia non lo aggiusta, mi spiace, ma nulla da fare...
echo "VQF AHELME I BI CI WECPF"| tr "ETAOINSHRDLUBCFGJMQPVWZYXK" "A-Z"

Offline FranzMari

  • *
  • Post: 2810
  • Reputazione: 103
  • [Senior Packager]
    • Mostra profilo
    • IMHO blog
Re:errore nel build installazione interrotta
« Risposta #4 il: 10 Agosto 2016 ore 21:09 »
Credo che il problema sia ancora quello che avevi indicato nell'altro topic
Ciao, in CCR cairo-dock e cairo-dock-plugins ci sono e gtk viene caricato regolarmente, tuttavia l'installazione parte regolarmente, ma  verso la fine dell'operazione mi dà:
Codice: [Seleziona]
attenzione: impossibile risolvere "vte-common", una dipendenza di "vte3"
:: Il seguente pacchetto non può essere aggiornato a causa di alcune dipendenze irrisolvibili:
      vte3

:: Vuoi ignorare il seguente pacchetto per questo aggiornamento? [s/N]
e sia che io dica si o dica no l'installazione termina ma i plugins continuano a non esserci, in fondo all'operazione rispondendo si il codice è così:
Codice: [Seleziona]
==> Estrazione dei sorgenti in corso...
  -> Estrazione di webkitgtk-2.4.7.tar.xz usando bsdtar in corso...
==> Rimozione dell'esistente directory $pkgdir/ in corso...
==> Avvio di build() in corso...
patching file Source/WebCore/xml/XMLViewer.css
patching file Source/WebCore/xml/XMLViewer.js
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking for perl... /usr/bin/perl
checking for python... /usr/bin/python
checking for ruby... /usr/bin/ruby
checking for bison... /usr/bin/bison
checking for mv... /usr/bin/mv
checking for grep... /usr/bin/grep
checking for gperf... /usr/bin/gperf
checking for flex... /usr/bin/flex
checking for gawk... gawk
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking whether gcc understands -c and -o together... yes
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking for a BSD-compatible install... /usr/bin/install -c
checking for special C compiler options needed for large files... no
checking for _FILE_OFFSET_BITS value needed for large files... no
configure: error: Compiler GCC >= 4.7 or Clang >= 3.3 is required for C compilation
==> ERRORE: Si è verificato un errore in build().
    L'operazione sta per essere interrotta...
The build failed.
Dependencies for `cairo-dock-plugins' are not met, not building...
riesci a capire che cosa non funziona?

come ha detto whoami, quel pacchetto richiede dipendenze che non sono obsolete.
Se ho tempo provo a sistemare, ma non ti prometto nulla.
«Il valore dell'essere umano si determina nella misura in cui sia grande o piccola la sua capacità di contribuire al bene collettivo.» Jigorō Kanō

 

Template by Homey | Sito ufficiale | Disclaimer