Autore Topic: Kdenlive non vede più la videocamera  (Letto 477 volte)

Offline valgal

  • *
  • Post: 41
  • Reputazione: 2
    • Mostra profilo
Kdenlive non vede più la videocamera
« il: 31 Maggio 2016 ore 10:52 »
Ragazzi, come da titolo post, dopo gli ultimi aggiornamenti Kdenlive non riesce più a vedere la videocamera, però con dvgrab riesco a scaricare i video.... Qualcuno sa cosa è sucesso? Ah, dimenticavo, la videocamera è collegata tramite scheda firewire, ma fino a qualche tempo fa non aveva mai avuto problemi.

Offline valgal

  • *
  • Post: 41
  • Reputazione: 2
    • Mostra profilo
Re:Kdenlive non vede più la videocamera
« Risposta #1 il: 31 Maggio 2016 ore 10:54 »
... e comunque mi crasha spessisimo... anche questo non mi era mai successo... >:( >:( >:( >:(

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Kdenlive non vede più la videocamera
« Risposta #2 il: 31 Maggio 2016 ore 11:12 »
per il firewire non so come aiutarti... altri programmi riescono ad accedervi? almeno capiamo se è un problema di tutto il sistema o di solo kdenlive.

per quanto riguarda i crash, puoi lanciare da linea di comando così vediamo di capirne il motivo. Potrebbe anche essere qualche libreria che necessita di essere ricompilata. O comunque un bug da segnalare ai dev di kdenlive.
Per il discorso librerie il comando chakra-check-links può essere di aiuto.

Offline valgal

  • *
  • Post: 41
  • Reputazione: 2
    • Mostra profilo
Re:Kdenlive non vede più la videocamera
« Risposta #3 il: 31 Maggio 2016 ore 11:54 »
Ciao Dino, non credo sia il firewire, come ho detto con il comando dvgrab riesco ad accedere alla camera e a scaricare i video...

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo

Offline valgal

  • *
  • Post: 41
  • Reputazione: 2
    • Mostra profilo
Re:Kdenlive non vede più la videocamera
« Risposta #5 il: 31 Maggio 2016 ore 21:41 »
Ok, mi sembrano i miei stessi problemi... Non ho testato Kino e Lives, ma nel bug 361597 si dice che non funzionano mentre nell'atro si dice che funzionano... Chi ci capisce... :(

Offline D4li4

  • *
  • Post: 9
  • Reputazione: 1
    • Mostra profilo
Re:Kdenlive non vede più la videocamera
« Risposta #6 il: 02 Giugno 2016 ore 23:18 »
quando si incasina kdenlive dipende dalla versione di ffmpeg installata e da MLT   ::) ciao

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Kdenlive non vede più la videocamera
« Risposta #7 il: 03 Giugno 2016 ore 07:02 »
[risolto]
al momento in testing su una macchina kdenlive mi crasha all'avvio. nessun messaggio di errore, niente.  :-\
« Ultima modifica: 05 Giugno 2016 ore 10:07 da dinolib »

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Kdenlive non vede più la videocamera
« Risposta #8 il: 03 Giugno 2016 ore 10:03 »
altra macchina di testing funziona.

Quella che crasha è un i5 mobile con scheda intel+nvidia (e crasha anche lanciando con optimus).
Questa dove parte è un desktop i7 con scheda intel integrata.

Mi sento spiazzato, non riesco proprio a capire cosa accada. Dovrei usare il debugger... vai a ricordarti come si fa  ;D ;D
« Ultima modifica: 05 Giugno 2016 ore 10:07 da dinolib »

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Kdenlive non vede più la videocamera
« Risposta #9 il: 03 Giugno 2016 ore 10:05 »
Proverò questa. posto qui almeno stasera se riesco mi ricordo
https://forum.kde.org/viewtopic.php?f=265&t=126310
« Ultima modifica: 05 Giugno 2016 ore 10:06 da dinolib »

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Kdenlive non vede più la videocamera
« Risposta #10 il: 05 Giugno 2016 ore 10:00 »
Niente, cagata mia. Avevo messo da una vita mlt-git (perchè crashava quello ufficiale) e non l'avevo mai rimesso a posto.
Dal backtrace si vede che l'errore arriva da lì.
Rimesso mlt e ora kdenlive funziona. Scusate per il casino.

Codice: [Seleziona]
Program received signal SIGSEGV, Segmentation fault.
0x00007fffc448bc74 in ?? () from /usr/lib/libQtGui.so.4
(gdb) backtrace
#0  0x00007fffc448bc74 in ?? () from /usr/lib/libQtGui.so.4
#1  0x00007ffff7dea27a in call_init.part () from /lib64/ld-linux-x86-64.so.2
#2  0x00007ffff7dea38b in _dl_init () from /lib64/ld-linux-x86-64.so.2
#3  0x00007ffff7dee830 in dl_open_worker () from /lib64/ld-linux-x86-64.so.2
#4  0x00007ffff7dea124 in _dl_catch_error () from /lib64/ld-linux-x86-64.so.2
#5  0x00007ffff7dedfd1 in _dl_open () from /lib64/ld-linux-x86-64.so.2
#6  0x00007fffeff66fc9 in ?? () from /usr/lib/libdl.so.2
#7  0x00007ffff7dea124 in _dl_catch_error () from /lib64/ld-linux-x86-64.so.2
#8  0x00007fffeff675e1 in ?? () from /usr/lib/libdl.so.2
#9  0x00007fffeff67061 in dlopen () from /usr/lib/libdl.so.2
#10 0x00007ffff6dc0fc4 in mlt_repository_init () from /usr/lib/libmlt.so.6
#11 0x00007ffff6dc06f8 in mlt_factory_init () from /usr/lib/libmlt.so.6
#12 0x00007ffff6b8d62b in Mlt::Factory::init(char const*) () from /usr/lib/libmlt++.so.3
#13 0x0000000000747e46 in BinController::BinController (this=0xfaea70, profileName=...)
    at /chakra/desktop/kdenlive/src/kdenlive-16.04.1/src/mltcontroller/bincontroller.cpp:36
#14 0x00000000007e1eef in Core::initialize (this=0xc6cd60) at /chakra/desktop/kdenlive/src/kdenlive-16.04.1/src/core.cpp:63
#15 0x00000000007c338e in MainWindow::MainWindow (this=0xc29770, MltPath=..., Url=..., clipsToLoad=..., parent=<optimized out>, __in_chrg=<optimized out>,
    __vtt_parm=<optimized out>) at /chakra/desktop/kdenlive/src/kdenlive-16.04.1/src/mainwindow.cpp:214
#16 0x0000000000468c93 in main (argc=<optimized out>, argv=<optimized out>) at /chakra/desktop/kdenlive/src/kdenlive-16.04.1/src/main.cpp:127
« Ultima modifica: 05 Giugno 2016 ore 10:06 da dinolib »

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Kdenlive non vede più la videocamera
« Risposta #11 il: 05 Giugno 2016 ore 19:11 »
per curiosità prova il pacchetto di CCR:
kdenlive-applications15.04-git

edit: oppure kdenlive-git, appena ci ho messo mano (lo sto facendo ora...)
edit2; fatto, puoi provare
« Ultima modifica: 05 Giugno 2016 ore 19:43 da dinolib »

Offline valgal

  • *
  • Post: 41
  • Reputazione: 2
    • Mostra profilo
Re:Kdenlive non vede più la videocamera
« Risposta #12 il: 10 Giugno 2016 ore 11:35 »
Ciao! Sono stato un po' impegnato e non ho potuto provare i pacchetti git, ma ho notato che anche su altre distro kdenlive non funziona mentre kino si...

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Kdenlive non vede più la videocamera
« Risposta #13 il: 10 Giugno 2016 ore 18:35 »
la versione git è la più recente disponibile dagli sviluppatori. Se qualcosa è stato sistemato lo puoi vedere qui. Per questo te la suggerivo.

 

Template by Homey | Sito ufficiale | Disclaimer