Autore Topic: "Failed to start Rotate log files" dopo aggiornamento.  (Letto 885 volte)

Offline mrcrowley

  • *
  • Post: 876
  • Reputazione: -1
    • Mostra profilo
"Failed to start Rotate log files" dopo aggiornamento.
« il: 27 Aprile 2016 ore 09:59 »
Codice: [Seleziona]
$ systemctl status logrotate.service -l
● logrotate.service - Rotate log files
   Loaded: loaded (/usr/lib/systemd/system/logrotate.service; static; vendor preset: disabled)
   Active: failed (Result: exit-code) since mer 2016-04-27 09:39:10 CEST; 15min ago
  Process: 467 ExecStart=/usr/bin/logrotate /etc/logrotate.conf (code=exited, status=1/FAILURE)
 Main PID: 467 (code=exited, status=1/FAILURE)

apr 27 09:39:09 massimiliano-pc systemd[1]: Starting Rotate log files...
apr 27 09:39:10 massimiliano-pc logrotate[467]: error: bad top line in state file /var/lib/logrotate.status
apr 27 09:39:10 massimiliano-pc systemd[1]: logrotate.service: Main process exited, code=exited, status=1/FAILURE
apr 27 09:39:10 massimiliano-pc systemd[1]: Failed to start Rotate log files.
apr 27 09:39:10 massimiliano-pc systemd[1]: logrotate.service: Unit entered failed state.
apr 27 09:39:10 massimiliano-pc systemd[1]: logrotate.service: Failed with result 'exit-code'.


Codice: [Seleziona]
$ cat /var/lib/logrotate.status
# Creato da NetworkManager

option rfc3442-classless-static-routes code 121 = array of unsigned integer 8;
option ms-classless-static-routes code 249 = array of unsigned integer 8;
option wpad code 252 = string;

also request rfc3442-classless-static-routes;
also request ms-classless-static-routes;
also request static-routes;
also request wpad;
also request ntp-servers;


Che posso fare ??

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:"Failed to start Rotate log files" dopo aggiornamento.
« Risposta #1 il: 27 Aprile 2016 ore 11:00 »
non è che hai fatto casino? questo file non sembra proprio quello che dovrebbe essere...

boh, prova a:
- stoppa il servizio
- rinomina il .status  in  .old
- riavvia il servizio

Il mio .status:
Codice: [Seleziona]
$cat  /var/lib/logrotate.status
logrotate state -- version 2
"/var/log/samba/smbd.log" 2015-11-15-0:0:5
"/var/log/cups/page_log" 2016-4-26-7:51:32
"/var/log/samba/nmbd.log" 2015-11-15-0:0:5
"/var/log/cups/error_log" 2016-4-26-7:51:32
"/var/log/clamav/clamd.log" 2015-9-19-0:0:0
"/var/log/samba/log.smbd" 2016-4-26-7:51:32
"/var/log/lircd" 2015-10-1-0:0:0
"/var/log/cups/access_log" 2016-4-26-7:51:32
"/var/log/wtmp" 2015-9-19-0:0:0
"/var/log/samba/*.log" 2015-9-19-0:0:0
"/var/log/btmp" 2016-4-1-0:0:0
"/var/log/samba/log.nmbd" 2016-4-26-7:51:32
"/var/log/cups/cups-pdf_log" 2016-4-20-0:1:1
"/var/log/clamav/freshclam.log" 2015-9-19-0:0:0

Offline mrcrowley

  • *
  • Post: 876
  • Reputazione: -1
    • Mostra profilo
Re:"Failed to start Rotate log files" dopo aggiornamento.
« Risposta #2 il: 27 Aprile 2016 ore 11:11 »

Grande ... come sempre !! Tutto ok !!
Sicuramente ho fatto casino nell' ultimo aggiornamento .... ricordo che all' inizio chiedeva di sostituire un pacchetto con un'altro (che non ho letto tra quelli che dovevano riguardare l'aggiornamento) e consigliava di rispondere N.
Io invece, dopo aver letto le news in cui dicevano che dovrebbe esser stato sicuro rispondere si a tutte le richieste, ho risposto S.   :-\

Grazie ancora.  :beer:

Offline mrcrowley

  • *
  • Post: 876
  • Reputazione: -1
    • Mostra profilo
Re:"Failed to start Rotate log files" dopo aggiornamento.
« Risposta #3 il: 27 Aprile 2016 ore 11:13 »

Aspe ... il mio è un pò scarno ... anche se non ho più l' errore.  ???

Codice: [Seleziona]
$ systemctl status logrotate.service -l
● logrotate.service - Rotate log files
   Loaded: loaded (/usr/lib/systemd/system/logrotate.service; static; vendor preset: disabled)
   Active: inactive (dead)

E' normale ?

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:"Failed to start Rotate log files" dopo aggiornamento.
« Risposta #4 il: 27 Aprile 2016 ore 11:40 »
prova con:
Codice: [Seleziona]
sudo systemctl start  logrotate.service perchè non sembra attivo.

poi vedi lo status il file status.
Abilita anche il servizio se vuoi che parta all'avvio (enable).

Se ci sono problemi controlla anche il journal:
Codice: [Seleziona]
sudo journalctl -p err

Offline mrcrowley

  • *
  • Post: 876
  • Reputazione: -1
    • Mostra profilo
Re:"Failed to start Rotate log files" dopo aggiornamento.
« Risposta #5 il: 28 Aprile 2016 ore 10:36 »
Ora mi dà questo:

Codice: [Seleziona]
$ systemctl status logrotate.service -l
● logrotate.service - Rotate log files
   Loaded: loaded (/usr/lib/systemd/system/logrotate.service; static; vendor preset: disabled)
   Active: inactive (dead) since gio 2016-04-28 10:29:59 CEST; 2min 0s ago
  Process: 458 ExecStart=/usr/bin/logrotate /etc/logrotate.conf (code=exited, status=0/SUCCESS)
 Main PID: 458 (code=exited, status=0/SUCCESS)

apr 28 10:29:58 massimiliano-pc systemd[1]: Starting Rotate log files...
apr 28 10:29:59 massimiliano-pc systemd[1]: Started Rotate log files.

Va bene ... o no ??  ???

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:"Failed to start Rotate log files" dopo aggiornamento.
« Risposta #6 il: 28 Aprile 2016 ore 12:05 »
logrotate gira ogni tot, non sta sempre attivo. A me il fatto che dica SUCCESS è... un successo  ;D

Dovrebbe andare bene, stesso mio output.
A me i log si ruotano. Controlla anche tu.

Qui spiega alcune cose: https://wiki.archlinux.org/index.php/Logrotate

I file da vedere sono:
/etc/logrotate.conf
/usr/lib/systemd/system/logrotate.timer
/var/lib/logrotate.status

Offline mrcrowley

  • *
  • Post: 876
  • Reputazione: -1
    • Mostra profilo
Re:"Failed to start Rotate log files" dopo aggiornamento.
« Risposta #7 il: 28 Aprile 2016 ore 21:28 »
 ??? ??? ???

c'è qualcosa che non va .... al successivo riavvio non è ripartito
Codice: [Seleziona]
$ systemctl status logrotate.service -l
● logrotate.service - Rotate log files
   Loaded: loaded (/usr/lib/systemd/system/logrotate.service; static; vendor preset: disabled)
   Active: inactive (dead)

Offline mrcrowley

  • *
  • Post: 876
  • Reputazione: -1
    • Mostra profilo
Re:"Failed to start Rotate log files" dopo aggiornamento.
« Risposta #8 il: 28 Aprile 2016 ore 21:35 »
logrotate.status

Codice: [Seleziona]
logrotate state -- version 2
"/var/log/cups/page_log" 2016-4-27-11:0:0
"/var/log/cups/error_log" 2016-4-27-11:0:0
"/var/log/samba/log.smbd" 2016-4-27-11:0:0
"/var/log/lircd" 2016-4-27-11:0:0
"/var/log/cups/access_log" 2016-4-27-11:0:0
"/var/log/wtmp" 2016-4-27-11:0:0
"/var/log/samba/*.log" 2016-4-27-11:0:0
"/var/log/btmp" 2016-4-27-11:0:0
"/var/log/samba/log.nmbd" 2016-4-27-11:0:0
"/var/log/cups/cups-pdf_log" 2016-4-27-11:0:0

logrotate.timer

Codice: [Seleziona]
[Unit]
Description=Daily rotation of log files

[Timer]
OnCalendar=daily
AccuracySec=12h
Persistent=true

logrotate.conf

Codice: [Seleziona]
# see "man logrotate" for details
# rotate log files weekly
weekly

# keep 4 weeks worth of backlogs
rotate 4

# restrict maximum size of log files
#size 20M

# create new (empty) log files after rotating old ones
create

# uncomment this if you want your log files compressed
#compress

# Logs are moved into directory for rotation
# olddir /var/log/archive

# Ignore pacman saved files
tabooext + .pacorig .pacnew .pacsave

# Arch packages drop log rotation information into this directory
include /etc/logrotate.d

/var/log/wtmp {
    monthly
    create 0664 root utmp
    minsize 1M
    rotate 1
}

/var/log/btmp {
    missingok
    monthly
    create 0600 root utmp
    rotate 1
}

Offline whoami

  • *
  • Post: 1562
  • Reputazione: 64
  • Quando c'era init i log arrivavano in orario!
    • Mostra profilo
Re:"Failed to start Rotate log files" dopo aggiornamento.
« Risposta #9 il: 29 Aprile 2016 ore 07:21 »
Devi abilitarlo con sudo systemctl enable logorate
echo "VQF AHELME I BI CI WECPF"| tr "ETAOINSHRDLUBCFGJMQPVWZYXK" "A-Z"

Offline mrcrowley

  • *
  • Post: 876
  • Reputazione: -1
    • Mostra profilo
Re:"Failed to start Rotate log files" dopo aggiornamento.
« Risposta #10 il: 29 Aprile 2016 ore 08:42 »
L'avevo fatto ... e sembrava aver funzionato ....

Inviato dal mio HTC One utilizzando Tapatalk


Offline mrcrowley

  • *
  • Post: 876
  • Reputazione: -1
    • Mostra profilo
Re:"Failed to start Rotate log files" dopo aggiornamento.
« Risposta #11 il: 29 Aprile 2016 ore 13:34 »

Niente. Ad ogni riavvio non riparte. Devo ridare sempre Start ed Enable.
Non vorrei ci fosse altro, perchè anche il desktop viene caricato in maniera sballata. Alle volte mancano dei plasma, altre delle applicazioni ... booh !!
Ora ho fatto l' aggiornamento e non l' ha eseguito, restituendo:
Codice: [Seleziona]
kde-runtime: /usr/share/icons/default.kde4 è già presente nel filesystem

Offline FranzMari

  • *
  • Post: 2814
  • Reputazione: 103
  • [Senior Packager]
    • Mostra profilo
    • IMHO blog
Re:"Failed to start Rotate log files" dopo aggiornamento.
« Risposta #12 il: 29 Aprile 2016 ore 14:57 »
Ora ho fatto l' aggiornamento e non l' ha eseguito, restituendo:
Codice: [Seleziona]
kde-runtime: /usr/share/icons/default.kde4 è già presente nel filesystem

http://forum.chakra-project.it/index.php/topic,6912
«Il valore dell'essere umano si determina nella misura in cui sia grande o piccola la sua capacità di contribuire al bene collettivo.» Jigorō Kanō

Offline mrcrowley

  • *
  • Post: 876
  • Reputazione: -1
    • Mostra profilo
Re:"Failed to start Rotate log files" dopo aggiornamento.
« Risposta #13 il: 29 Aprile 2016 ore 18:37 »
Grazie Franz, l' aggiornamento è andato a buon fine.

Il problema del logrotate però continua. All' avvio da sempre:

Codice: [Seleziona]
$ systemctl status logrotate.service
● logrotate.service - Rotate log files
   Loaded: loaded (/usr/lib/systemd/system/logrotate.service; static; vendor preset: disabled)
   Active: inactive (dead)

Almeno non mi dà più l' errore nel journal.

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:"Failed to start Rotate log files" dopo aggiornamento.
« Risposta #14 il: 30 Aprile 2016 ore 07:53 »
vedi se almeno è nei timer:

Codice: [Seleziona]
$ systemctl list-timers --all

 

Template by Homey | Sito ufficiale | Disclaimer