Autore Topic: dopo aggiornamento: errore nell'installazione[Risolto]  (Letto 383 volte)

Offline fabbrilli

  • *
  • Post: 156
  • Reputazione: 3
    • Mostra profilo
dopo aggiornamento: errore nell'installazione[Risolto]
« il: 14 Aprile 2016 ore 12:44 »
ciao ragazzi, come titolo vanno in conflitto:
Codice: [Seleziona]
Dimensione totale dei pacchetti da installare:  1206,55 MiB
Dimensione netta dell'aggiornamento:             -11,23 MiB

:: Vuoi procedere con l'installazione? [S/n] s
(127/127) verifica delle chiavi presenti nel por...  [############################] 100%
(127/127) verifica dell'integrità dei pacchetti      [############################] 100%
(127/127) caricamento dei file dei pacchetti         [############################] 100%
(127/127) controllo dei conflitti in corso           [############################] 100%
errore: impossibile eseguire l'operazione richiesta (file in conflitto)
ki18n: /usr/share/locale/ca/LC_SCRIPTS/ki18n5/ki18n5.js è già presente nel filesystem
ki18n: /usr/share/locale/ca@valencia/LC_SCRIPTS/ki18n5/ki18n5.js è già presente nel filesystem
Si sono verificati degli errori, nessun pacchetto è stato aggiornato.
:: Synchronizing ccr database...
 ccr                                        11  11 [##############################] 100%
:: Starting full ccr upgrade...
 local database is up to date
[fabio@fabio ~]$
non so dove mettere mano, senza far danni, mi aiutate?
« Ultima modifica: 20 Aprile 2016 ore 00:27 da fabbrilli »

Offline blupenguin

  • *
  • Post: 366
  • Reputazione: 23
    • Mostra profilo
Re:dopo aggiornamento: errore nell'installazione
« Risposta #1 il: 14 Aprile 2016 ore 14:18 »
hai provato ad aggiornare forzando il pacchetto? Puoi usare il comando:

Codice: [Seleziona]
pacman -Syu --force

Offline fabbrilli

  • *
  • Post: 156
  • Reputazione: 3
    • Mostra profilo
Re:dopo aggiornamento: errore nell'installazione
« Risposta #2 il: 14 Aprile 2016 ore 14:26 »
 :P grazie.  :-* sembra tutto ok. :beer:

Offline FranzMari

  • *
  • Post: 2808
  • Reputazione: 103
  • [Senior Packager]
    • Mostra profilo
    • IMHO blog
Re:dopo aggiornamento: errore nell'installazione
« Risposta #3 il: 14 Aprile 2016 ore 17:45 »
Forzare l'installazione di un pacchetto senza prima aver fatto qualche verifica, non mi sembra una grande idea francamente.

«Il valore dell'essere umano si determina nella misura in cui sia grande o piccola la sua capacità di contribuire al bene collettivo.» Jigorō Kanō

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:dopo aggiornamento: errore nell'installazione
« Risposta #4 il: 14 Aprile 2016 ore 19:34 »
franz intende dire che se pacman segnala che un file già esiste, bisogna almeno verificare se esiste per sporcizia di vecchi pacchetti, se appartiene ad altri pacchetti (e quindi va segnalato), o se sono file magari creati da installazioni manuali di qualche programma (make install o cose del genere).

Intanto per vedere se il file appartiene ad un altro pacchetto (questo andava fatto PRIMA di forzare l'installazione):
Codice: [Seleziona]
pacman -Qo /usr/share/locale/ca/LC_SCRIPTS/ki18n5/ki18n5.js
Se non appartiene ad altri pacchetti installati già si può forzare con molta più tranquillità.

Offline fabbrilli

  • *
  • Post: 156
  • Reputazione: 3
    • Mostra profilo
Re:dopo aggiornamento: errore nell'installazione
« Risposta #5 il: 15 Aprile 2016 ore 15:00 »
franz intende dire che se pacman segnala che un file già esiste, bisogna almeno verificare se esiste per sporcizia di vecchi pacchetti, se appartiene ad altri pacchetti (e quindi va segnalato), o se sono file magari creati da installazioni manuali di qualche programma (make install o cose del genere).

Intanto per vedere se il file appartiene ad un altro pacchetto (questo andava fatto PRIMA di forzare l'installazione):
Codice: [Seleziona]
pacman -Qo /usr/share/locale/ca/LC_SCRIPTS/ki18n5/ki18n5.js
Se non appartiene ad altri pacchetti installati già si può forzare con molta più tranquillità.
grazie a tutti ragazzi  :P comunque riporto quanto mi ha restituito il terminale dal comando datomi da dino:
Codice: [Seleziona]
[fabio@fabio ~]$ pacman -Qo /usr/share/locale/ca/LC_SCRIPTS/ki18n5/ki18n5.js
/usr/share/locale/ca/LC_SCRIPTS/ki18n5/ki18n5.js è contenuto in kde-l10n-ca 15.12.3-1
[fabio@fabio ~]$

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:dopo aggiornamento: errore nell'installazione
« Risposta #6 il: 15 Aprile 2016 ore 15:07 »
e perchè mai avresti installato la lingua catalana!?!?

Offline fabbrilli

  • *
  • Post: 156
  • Reputazione: 3
    • Mostra profilo
Re:dopo aggiornamento: errore nell'installazione
« Risposta #7 il: 15 Aprile 2016 ore 19:04 »
 :o ma.. sinceramente non ho installato nulla. ha fatto tutto da solo, in fase di installazione. ::)

Offline FranzMari

  • *
  • Post: 2808
  • Reputazione: 103
  • [Senior Packager]
    • Mostra profilo
    • IMHO blog
Re:dopo aggiornamento: errore nell'installazione
« Risposta #8 il: 17 Aprile 2016 ore 14:07 »
Ecco, sarebbe bastato rimuovere quel pacchetto superfluo per risolvere. ;)
Forzare l'installazione di un pacchetto va sempre considerata come ultima risorsa.

I pacchetti della lingua rimanevano installati dopo l'installazione del sistema, è un problema che dovrebbe essere stato risolto con l'ultima release.
«Il valore dell'essere umano si determina nella misura in cui sia grande o piccola la sua capacità di contribuire al bene collettivo.» Jigorō Kanō

Offline fabbrilli

  • *
  • Post: 156
  • Reputazione: 3
    • Mostra profilo
Re:dopo aggiornamento: errore nell'installazione
« Risposta #9 il: 18 Aprile 2016 ore 18:17 »
 grazie franz, purtroppo non ho avuto pazienza. se attendevo un pochino, t'avrei dato retta,  :-\ ormai ... è andata così.

Offline FranzMari

  • *
  • Post: 2808
  • Reputazione: 103
  • [Senior Packager]
    • Mostra profilo
    • IMHO blog
Re:dopo aggiornamento: errore nell'installazione
« Risposta #10 il: 19 Aprile 2016 ore 11:44 »
grazie franz, purtroppo non ho avuto pazienza. se attendevo un pochino, t'avrei dato retta,  :-\ ormai ... è andata così.

Lezione per la prossima volta che capita ;)

Segna il topic come risolto, per favore
«Il valore dell'essere umano si determina nella misura in cui sia grande o piccola la sua capacità di contribuire al bene collettivo.» Jigorō Kanō

 

Template by Homey | Sito ufficiale | Disclaimer