Autore Topic: Openshot 2.0.6 errore python  (Letto 841 volte)

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Openshot 2.0.6 errore python
« Risposta #15 il: 08 Aprile 2016 ore 21:02 »
installa openshot-qt da ccr.

ah, leggevo su aur che forse serve anche python3-pip. Ma serve solo x l'installazione non per l'avvio di openshot.

L'errore è esattamente lo stesso?
Fammi sapere, altrimenti rimuovo e reinstallo quello che ho qui.

PS: sono in testing con kde-staging abilitato

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Openshot 2.0.6 errore python
« Risposta #16 il: 08 Aprile 2016 ore 21:03 »
FRANZ: ma hai messo nei repo la versiona patchata? perchè ho installato quella dei repo ed è tornato a non funzionare.

Offline FranzMari

  • *
  • Post: 2810
  • Reputazione: 103
  • [Senior Packager]
    • Mostra profilo
    • IMHO blog
Re:Openshot 2.0.6 errore python
« Risposta #17 il: 09 Aprile 2016 ore 23:04 »
FRANZ: ma hai messo nei repo la versiona patchata? perchè ho installato quella dei repo ed è tornato a non funzionare.

No, l'ho testata in locale ed ho visto che non funziona, quindi non l'ho caricata.
Penso sia un problema di sorgenti, nel PKGBUILD di Arch usano un altro archivio.
«Il valore dell'essere umano si determina nella misura in cui sia grande o piccola la sua capacità di contribuire al bene collettivo.» Jigorō Kanō

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Openshot 2.0.6 errore python
« Risposta #18 il: 10 Aprile 2016 ore 08:31 »
io ho usato il PKGBUILD che ti ho postato

Offline FranzMari

  • *
  • Post: 2810
  • Reputazione: 103
  • [Senior Packager]
    • Mostra profilo
    • IMHO blog
Re:Openshot 2.0.6 errore python
« Risposta #19 il: 10 Aprile 2016 ore 10:02 »
Ok, trovato il problema: nel nostro PKGBUILD non venivano create due cartelle distinte per i due pacchetti, mentre in quello di Arch sì.
Addirittura l'errore di sintassi appariva in fase di packaging!

Codice: [Seleziona]
==> Starting package_python3-httplib2()...
running install
running build
running build_py
running install_lib
creating /chakra/desktop/python-httplib2/pkg/python3-httplib2/usr
creating /chakra/desktop/python-httplib2/pkg/python3-httplib2/usr/lib
creating /chakra/desktop/python-httplib2/pkg/python3-httplib2/usr/lib/python3.5
creating /chakra/desktop/python-httplib2/pkg/python3-httplib2/usr/lib/python3.5/site-packages
creating /chakra/desktop/python-httplib2/pkg/python3-httplib2/usr/lib/python3.5/site-packages/httplib2
copying build/lib/httplib2/__init__.py -> /chakra/desktop/python-httplib2/pkg/python3-httplib2/usr/lib/python3.5/site-packages/httplib2
copying build/lib/httplib2/iri2uri.py -> /chakra/desktop/python-httplib2/pkg/python3-httplib2/usr/lib/python3.5/site-packages/httplib2
copying build/lib/httplib2/cacerts.txt -> /chakra/desktop/python-httplib2/pkg/python3-httplib2/usr/lib/python3.5/site-packages/httplib2
copying build/lib/httplib2/socks.py -> /chakra/desktop/python-httplib2/pkg/python3-httplib2/usr/lib/python3.5/site-packages/httplib2
byte-compiling /chakra/desktop/python-httplib2/pkg/python3-httplib2/usr/lib/python3.5/site-packages/httplib2/__init__.py to __init__.cpython-35.pyc
  File "/usr/lib/python3.5/site-packages/httplib2/__init__.py", line 911
    print "connect: (%s, %s) ************" % (self.host, self.port)
                                         ^
SyntaxError: invalid syntax

byte-compiling /chakra/desktop/python-httplib2/pkg/python3-httplib2/usr/lib/python3.5/site-packages/httplib2/iri2uri.py to iri2uri.cpython-35.pyc
byte-compiling /chakra/desktop/python-httplib2/pkg/python3-httplib2/usr/lib/python3.5/site-packages/httplib2/socks.py to socks.cpython-35.pyc
writing byte-compilation script '/tmp/tmp2b_fr6gb.py'
/usr/bin/python3 -OO /tmp/tmp2b_fr6gb.py
  File "/usr/lib/python3.5/site-packages/httplib2/__init__.py", line 911
    print "connect: (%s, %s) ************" % (self.host, self.port)
                                         ^
SyntaxError: invalid syntax

removing /tmp/tmp2b_fr6gb.py
running install_egg_info
running egg_info
creating python3/httplib2.egg-info
writing top-level names to python3/httplib2.egg-info/top_level.txt
writing python3/httplib2.egg-info/PKG-INFO
writing dependency_links to python3/httplib2.egg-info/dependency_links.txt
writing manifest file 'python3/httplib2.egg-info/SOURCES.txt'
reading manifest file 'python3/httplib2.egg-info/SOURCES.txt'
reading manifest template 'MANIFEST.in'
writing manifest file 'python3/httplib2.egg-info/SOURCES.txt'
Copying python3/httplib2.egg-info to /chakra/desktop/python-httplib2/pkg/python3-httplib2/usr/lib/python3.5/site-packages/httplib2-0.9.2-py3.5.egg-info
running install_scripts
==> Tidying install...
  -> Purging unwanted files...
  -> Removing libtool files...
  -> Removing static library files...
  -> Compressing man and info pages...
  -> Stripping unneeded symbols from binaries and libraries...
==> Creating package "python3-httplib2"...

Aggiungendo un paio di righe alla funziona prepare() ho risolto tutto.
Le patch non servono a quanto pare.
«Il valore dell'essere umano si determina nella misura in cui sia grande o piccola la sua capacità di contribuire al bene collettivo.» Jigorō Kanō

 

Template by Homey | Sito ufficiale | Disclaimer