Autore Topic: aggiornamenti non possibili  (Letto 320 volte)

Offline fabbrilli

  • *
  • Post: 157
  • Reputazione: 3
    • Mostra profilo
aggiornamenti non possibili
« il: 09 Marzo 2016 ore 19:01 »
buona sera, ragazzi, ho bisogno di chiarimenti. non riesco più ad aggiornare;
Codice: [Seleziona]
[fabio@fabio ~]$  ccr -Syu
[sudo] password di fabio:
:: Sincronizzazione dei database in corso...
 lib32 è aggiornato
 core è aggiornato
 desktop                    839,8 KiB  1166K/s 00:01 [############################] 100%
 gtk è aggiornato
:: Aggiornamento del sistema in corso...
risoluzione delle dipendenze in corso...
ricerca dei pacchetti in conflitto in corso...
errore: impossibile eseguire l'operazione richiesta (impossibile soddisfare le dipendenze)
:: tomahawk: richiede liblastfm
:: Synchronizing ccr database...
 ccr                                          5  5 [##############################] 100%
:: Starting full ccr upgrade...
 local database is up to date
[fabio@fabio ~]$ sudo pacman -S liblastfm
risoluzione delle dipendenze in corso...
ricerca dei pacchetti in conflitto in corso...
:: liblastfm e liblastfm-qt4 vanno in conflitto. Vuoi rimuovere liblastfm-qt4? [s/N] s
errore: impossibile eseguire l'operazione richiesta (impossibile soddisfare le dipendenze)
:: amarok: richiede liblastfm-qt4
[fabio@fabio ~]$ sudo pacman -S liblastfm-qt4
risoluzione delle dipendenze in corso...
ricerca dei pacchetti in conflitto in corso...
errore: impossibile eseguire l'operazione richiesta (impossibile soddisfare le dipendenze)
:: tomahawk: richiede liblastfm
[fabio@fabio ~]$

 ::) quì mi fermo. sapete delle mie conoscenze scarse, o per meglio dire nulle  :-[
ieri ho provato e riprovato, anche a cercare nel forum, senza dovervi "rompere" ma sono costretto ad arrendermi e chiedervi aiuto

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:aggiornamenti non possibili
« Risposta #1 il: 09 Marzo 2016 ore 19:51 »
se i due pacchetti vanno in conflitto è dura.
Puoi provare a rimuovere forzatamente (-Rdd) il pacchetto liblastfm-qt4 e installare l'altro (liblastfm). A quel punto vedi se amarok funge ancora. Se funziona aggiorna il sistema.

Ma ricorda di questa forzatura, nei futuri aggiornamenti potrebbe causare dei problemi. Ammesso che ora sblocchi la situazione

Offline fabbrilli

  • *
  • Post: 157
  • Reputazione: 3
    • Mostra profilo
Re:aggiornamenti non possibili
« Risposta #2 il: 09 Marzo 2016 ore 20:51 »
grazie caro, è partito (intendo sbloccato)  >: ( purtroppo) anche amarock, ma...preferisco aggiornare.
non capisco:
Citazione
Ma ricorda di questa forzatura, nei futuri aggiornamenti potrebbe causare dei problemi.
questa affermazione. intendi che se ho dato quel comando, poi avrò problemi nei futuri aggiornamenti?

Offline Lazy

  • *
  • Post: 731
  • Reputazione: 10
  • Fondatore Comunità Italiana di Chakra
    • Mostra profilo
Re:aggiornamenti non possibili
« Risposta #3 il: 09 Marzo 2016 ore 22:32 »
Scegli tra Amarok e Tomahawk quello che preferisci e rimuovi l'altro, a quel punto ti tieni liblastfm nella versione che richiede il software scelto

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:aggiornamenti non possibili
« Risposta #4 il: 10 Marzo 2016 ore 07:34 »
se fanno la stessa cosa, lazy non ha tutti i torti. io tomhawkwkyqweq manco l'avevo mai sentito nominare  ;D ;D

Con il fatto della forzatura intendo dire che il prossimo aggiornamento di amarok potrebbe non riuscire perchè cerca di installare (se ancora non l'hanno cambiata) la dipendenza con qt4. Andando in conflitto potrebbe lamentarsi. In tal caso sai perchè  ;)

Offline fabbrilli

  • *
  • Post: 157
  • Reputazione: 3
    • Mostra profilo
Re:aggiornamenti non possibili
« Risposta #5 il: 10 Marzo 2016 ore 13:04 »
grazie a tutti. per quanto riguarda amarok, mi è piaciuto sin dalle origini in quanto lo ritengo completo, mentre  Tomahawk non lo conosco e debbo ancora studiarlo. in ogni caso, di nuovo thanks.

 

Template by Homey | Sito ufficiale | Disclaimer