Autore Topic: Jre 7  (Letto 1108 volte)

Offline stes

  • *
  • Post: 19
  • Reputazione: 1
    • Mostra profilo
Jre 7
« il: 01 Ottobre 2015 ore 21:37 »
Avrei necessitá di installare zimbra desktop client... Solo mi richiede il pacchetto jre... Ho cercato e trovato su CCR... Ma ottengo un errore di verifica... Qualcuno sa come posso risolvere ?

Grazie

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Jre 7
« Risposta #1 il: 02 Ottobre 2015 ore 10:15 »
lo gestisce franzmari, ti risponderà appena riesce, immagino.

Vedi se ti funziona il pacchetto jdk7 (forse è più ingombrante ma dovrebbe fornire comunque anche il jre)

Offline jmc

  • *
  • Post: 1354
  • Reputazione: 95
    • Mostra profilo
    • The Chakra Project
Re:Jre 7
« Risposta #2 il: 02 Ottobre 2015 ore 21:29 »
OpenJDK non funziona?

Offline stes

  • *
  • Post: 19
  • Reputazione: 1
    • Mostra profilo
Re:Jre 7
« Risposta #3 il: 02 Ottobre 2015 ore 21:57 »
lo gestisce franzmari, ti risponderà appena riesce, immagino.

Vedi se ti funziona il pacchetto jdk7 (forse è più ingombrante ma dovrebbe fornire comunque anche il jre)
OK provo. Grazie

Offline stes

  • *
  • Post: 19
  • Reputazione: 1
    • Mostra profilo
Re:Jre 7
« Risposta #4 il: 02 Ottobre 2015 ore 21:59 »
OpenJDK non funziona?
No è un client mail che richiede jre... Il problema in realtà è che non trovo nessun client in ambiente linux che gestisca i server zimbra.

Offline gnastyle

  • *
  • Post: 62
  • Reputazione: 11
    • Mostra profilo
Re:Jre 7
« Risposta #5 il: 02 Ottobre 2015 ore 22:12 »
Per caso il software è questo? https://www.zimbra.com/downloads/zimbra-collaboration-open-source
Così lo posso caricare su CCR

Offline stes

  • *
  • Post: 19
  • Reputazione: 1
    • Mostra profilo
Re:Jre 7
« Risposta #6 il: 02 Ottobre 2015 ore 22:20 »
Davvero? Si si è quello

Offline stes

  • *
  • Post: 19
  • Reputazione: 1
    • Mostra profilo
Re:Jre 7
« Risposta #7 il: 02 Ottobre 2015 ore 22:21 »
No aspetta... Quello è il server... Ora linko il client

Offline stes

  • *
  • Post: 19
  • Reputazione: 1
    • Mostra profilo
Re:Jre 7
« Risposta #8 il: 02 Ottobre 2015 ore 22:22 »

Offline stes

  • *
  • Post: 19
  • Reputazione: 1
    • Mostra profilo
Re:Jre 7
« Risposta #9 il: 03 Ottobre 2015 ore 14:14 »

Vi aggiorno sul tutto:

1- con jdk che pure ho installato da CCR non fuzniona.

2- con jre7 ho proceduto ad aggiornare l' mdsum col comando updpkgsums senza utilizzare in questo caso ccr -S <nomepacchetto> adesso il file viene caricato ma incontro un altro problema:


Codice: [Seleziona]
==> Validazione dei sorgenti con md5sums in corso...
    jre-7u72-linux-x64.tar.gz ... Verificato
    java-policy-settings.desktop ... Verificato
    jre.sh ... Verificato
    jre.csh ... Verificato
    javaws-launcher ... Verificato
==> Estrazione dei sorgenti in corso...
==> Entro nell'ambiente fakeroot...
==> Avvio di package() in corso...
  -> Creating required dirs
ls: impossibile accedere a jre1.7.0_*/: File o directory non esistente
  -> Re-ordering folders a bit
mv: impossibile eseguire stat di "lib/desktop/applications": File o directory non esistente
mv: impossibile eseguire stat di "lib/desktop/icons": File o directory non esistente
mv: impossibile eseguire stat di "lib/desktop/mime": File o directory non esistente
==> ERRORE: Si è verificato un errore in package().
    L'operazione sta per essere interrotta...
The build failed.


E' un problema mio? Oppure ancora qualcosa non fuzniona?

Offline gnastyle

  • *
  • Post: 62
  • Reputazione: 11
    • Mostra profilo
Re:Jre 7
« Risposta #10 il: 03 Ottobre 2015 ore 18:59 »
Secondo me il problema è dello script di installazione.
Ho controllato e ho visto che richiede java 1.6 o superiore.
Se hai installato il pacchetto dai repository "openjdk" dovresti avere java 1.8 mi pare, ma lo script continua a dire che manca.
Allora fai cosi, installa openjdk. Poi vai nella cartella di zimbra-desktop e apri con un editor di test il file install.pl
Vai alla linea 172 ed eliminala.
Il contenuto di quelle righe dovrebbe essere:

dialog_welcome();
dialog_license();
dependency_check();
$app_root = dialog_app_root();

Continua l'installazione (comunque credo che dovresti eseguire lo script da root se non sbaglio).
Fammi sapere se funziona e se riesci a farlo partire.

Offline stes

  • *
  • Post: 19
  • Reputazione: 1
    • Mostra profilo
Re:Jre 7
« Risposta #11 il: 03 Ottobre 2015 ore 21:08 »
In effetti cosi l'installazione parte ma poi cominciano una serie di dipendenze non soddisfatte... Finché arrivo ad un fatidico couldn't load XPCOM... direi che qui mi fermo ...  A proposito una curiosità: quando Vi segnala che manca un file es. libao. so come fate a individuare il giusto pacchetto da installare?

Grazie ancora a tutti per l'interessamento

Offline FranzMari

  • *
  • Post: 2810
  • Reputazione: 103
  • [Senior Packager]
    • Mostra profilo
    • IMHO blog
Re:Jre 7
« Risposta #12 il: 03 Ottobre 2015 ore 23:31 »
Ho aggiornato jre7 all'ultima release disponibile.
Fammi sapere se funziona  ;D
«Il valore dell'essere umano si determina nella misura in cui sia grande o piccola la sua capacità di contribuire al bene collettivo.» Jigorō Kanō

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Jre 7
« Risposta #13 il: 05 Ottobre 2015 ore 09:08 »
A proposito una curiosità: quando Vi segnala che manca un file es. libao. so come fate a individuare il giusto pacchetto da installare?
ammetto la mia ignoranza: uso google.

1- cerco con locate se per caso la lib c'è ma con una versione diversa (quindi cerco un file con lo stesso nome ma senza numero)
2- vedo se c'è un pacchetto che ha un nome simile alla libreria mancante (ccr nomesimile)
3- vado su google, metto il nome della lib e vedo in giro a che pacchetto appartiene. Magari specificando arch se non vengo a capo di niente.

Forse c'è un modo migliore, ma con questo di solito ne vengo a capo abbastanza velocemente.

Offline stes

  • *
  • Post: 19
  • Reputazione: 1
    • Mostra profilo
Re:Jre 7
« Risposta #14 il: 05 Ottobre 2015 ore 20:30 »
Ho aggiornato jre7 all'ultima release disponibile.
Fammi sapere se funziona  ;D

Adesso JRE funziona, ti ringrazio... magari un girono sarò in grado di ricambiare il favore  :-[

 

Template by Homey | Sito ufficiale | Disclaimer