Autore Topic: Kdenlive non avvia più !!  (Letto 4040 volte)

Offline mrcrowley

  • *
  • Post: 876
  • Reputazione: -1
    • Mostra profilo
Kdenlive non avvia più !!
« il: 23 Settembre 2015 ore 20:55 »
Ma succedono tutte a me ??? Vedo che sono sempre in cima alla lista delle discussioni ...  :-[

Codice: [Seleziona]
mlt_repository_init: failed to dlopen /usr/lib/mlt/libmltavformat.so
  (/usr/lib/libavcodec.so.56: undefined symbol: x264_encoder_open_142)
No LADSPA plugins were found!

Check your LADSPA_PATH environment variable.
KCrash: Application 'kdenlive' crashing...
KCrash: Attempting to start /usr/lib/kde4/libexec/drkonqi from kdeinit
KCrash: Connect sock_file=/home/massimiliano/.kde4/socket-chakra-pc/kdeinit4__0

Ciao ciao

Offline whoami

  • *
  • Post: 1562
  • Reputazione: 64
  • Quando c'era init i log arrivavano in orario!
    • Mostra profilo
Re:Kdenlive non avvia più !!
« Risposta #1 il: 23 Settembre 2015 ore 22:51 »
Io ho kdenlive da [kde-next], versione 15.08.1-1 e funziona... ho provato a fare il downgrade alla versione in [apps], quella stabile e in effetti non parte... però a me non si lamenta di nessuna libreria... semplicemente crasha in avvio e parte l'odioso drkonqui... ma avendo tutto portato a plasma5 magari non c'entra nulla...

puoi controllare che il file /usr/lib/mlt/libmltavformat.so esista e che versione hai del pacchetto mlt (che lo contiene).

Però non so se porti a qualcosa... tu posta e vediamo (o vede chi ne capisce più di me ;) )
echo "VQF AHELME I BI CI WECPF"| tr "ETAOINSHRDLUBCFGJMQPVWZYXK" "A-Z"

Offline mrcrowley

  • *
  • Post: 876
  • Reputazione: -1
    • Mostra profilo
Re:Kdenlive non avvia più !!
« Risposta #2 il: 23 Settembre 2015 ore 23:39 »
Codice: [Seleziona]
platform/mlt 0.9.8-1 [installato]
    An open source multimedia framework
platform/mlt-python-bindings 0.9.8-1 [installato]
    An open source multimedia framework
platform/vid.stab 0.98b-1 [installato]
    Video stabilize library for fmpeg, mlt or transcode

il file libmltavformat.so è presente.

Offline gnastyle

  • *
  • Post: 62
  • Reputazione: 11
    • Mostra profilo
Re:Kdenlive non avvia più !!
« Risposta #3 il: 24 Settembre 2015 ore 00:42 »
Ciao, è solo una curiosità, ma prova a installare questi pacchetti (se non li hai già):

-sox
-sld_image
-ladspa
-vid.stab

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Kdenlive non avvia più !!
« Risposta #4 il: 24 Settembre 2015 ore 08:45 »
a me kdenlive in stable parte...

Il codice d'errore è: /usr/lib/libavcodec.so.56: undefined symbol: x264_encoder_open_142
Potrebbe essere un problema di x264. Che pacchetto hai installato?
Da me funziona con il pacchetto standard x264  (no x264-8bit di ccr)

Quando controlli se una lib è presente, non cercare solo il link ma la lib con tanto di versione:
/usr/lib/libavcodec.so.56
In ogni caso è certo che ci sia perchè è proprio lei che va in errore (altrimenti ti direbbe che è assente).

Offline blupenguin

  • *
  • Post: 366
  • Reputazione: 23
    • Mostra profilo
Re:Kdenlive non avvia più !!
« Risposta #5 il: 24 Settembre 2015 ore 09:17 »
Fatto ora la prova per curiosità e confermo che nemmeno a me parte, sono in stable.

Codice: [Seleziona]
No LADSPA plugins were found!

Check your LADSPA_PATH environment variable.
KCrash: Application 'kdenlive' crashing...
KCrash: Attempting to start /usr/lib/kde4/libexec/drkonqi from kdeinit
KCrash: Connect sock_file=/home/blu/.kde4/socket-Chakra/kdeinit4__0

[1]+  Fermato                 kdenlive
« Ultima modifica: 24 Settembre 2015 ore 09:20 da blupenguin »

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Kdenlive non avvia più !!
« Risposta #6 il: 24 Settembre 2015 ore 09:22 »
a me parte, solo questo errore:
Codice: [Seleziona]
mlt_repository_init: failed to dlopen /usr/lib/mlt/libmltqt.so
  (libQt5Svg.so.5: impossibile aprire il file oggetto condiviso: File o directory non esistente)

Riepilogando:

mirror-check - OK
Codice: [Seleziona]
[lib32] is synced.
[core] is synced.
[platform] is synced.
[desktop] is synced.
[apps] is synced.
[games] is synced.
[extra] is synced.

sudo pacman -Syu - OK

platform/mlt 0.9.8-1 [installato]
apps/kdenlive 0.9.10-3 [installato]
platform/x264 20141218-1 [installato]
platform/ffmpeg 2.5.6-1 [installato]

Se siete allineati su tutto non so cosa possa essere. Io ho installato di recente.
Con pacman -Syyuu aggiorna qualcosa? x264-8bit è stato portato a una versione precedente, magari è quello

Offline mrcrowley

  • *
  • Post: 876
  • Reputazione: -1
    • Mostra profilo
Re:Kdenlive non avvia più !!
« Risposta #7 il: 24 Settembre 2015 ore 09:54 »
Io tutto come te.

Inviato dal mio HTC One utilizzando Tapatalk


Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Kdenlive non avvia più !!
« Risposta #8 il: 24 Settembre 2015 ore 11:09 »
prova queste (non pretendo di risolvere, ma vorrei almeno capirci qualcosa!):

Codice: [Seleziona]
chakra-pc% locate libavcodec.so.56
/usr/lib/libavcodec.so.56
/usr/lib/libavcodec.so.56.13.100

Codice: [Seleziona]
chakra-pc% nm -D /usr/lib/libavcodec.so.56 | grep 264
00000000001dbe30 T avpriv_h264_has_num_reorder_frames
                 U x264_bit_depth
                 U x264_encoder_close
                 U x264_encoder_delayed_frames
                 U x264_encoder_encode
                 U x264_encoder_headers
                 U x264_encoder_open_142
                 U x264_encoder_reconfig
                 U x264_levels
                 U x264_param_apply_fastfirstpass
                 U x264_param_apply_profile
                 U x264_param_default
                 U x264_param_default_preset
                 U x264_param_parse
                 U x264_picture_init

Offline mrcrowley

  • *
  • Post: 876
  • Reputazione: -1
    • Mostra profilo
Re:Kdenlive non avvia più !!
« Risposta #9 il: 24 Settembre 2015 ore 11:16 »

Con locate non trova niente.

Con il secondo, uguale a te.


Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Kdenlive non avvia più !!
« Risposta #10 il: 24 Settembre 2015 ore 12:28 »
sudo updatedb

poi lanci locate

Già che ci sei prova anche questa:
Codice: [Seleziona]
chakra-pc% locate libx264
/usr/lib/libx264.so
/usr/lib/libx264.so.142

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Kdenlive non avvia più !!
« Risposta #11 il: 24 Settembre 2015 ore 12:32 »
La funzione esposta che non trova sta qui, anche tu DEVI averla:
Codice: [Seleziona]
chakra-pc% nm -D /usr/lib/libx264.so.142  | grep encoder_open
0000000000086ba0 T x264_encoder_open_142

Le alternative sono che hai più di una libx264 nel sistema o non hai la versione correttamente installata.


Altro comando utile per l'indagine (puoi modificarlo a piacimento per scoprire chi ti ha installato i file incriminati):
Codice: [Seleziona]
chakra-pc% pacman -Qo /usr/lib/libx264.so.142
/usr/lib/libx264.so.142 è contenuto in x264 20141218-1
« Ultima modifica: 24 Settembre 2015 ore 12:33 da dinolib »

Offline mrcrowley

  • *
  • Post: 876
  • Reputazione: -1
    • Mostra profilo
Re:Kdenlive non avvia più !!
« Risposta #12 il: 24 Settembre 2015 ore 21:22 »
Codice: [Seleziona]
chakra-pc ~]$ locate libavcodec.so.56
/usr/lib/libavcodec.so.56
/usr/lib/libavcodec.so.56.13.100

Codice: [Seleziona]
chakra-pc ~]$ locate libx264
/home/massimiliano/Scaricati/4kslideshowmaker/src/4kslideshowmaker/libx264.so.138
/srv/nfs4/home/Scaricati/4kslideshowmaker/src/4kslideshowmaker/libx264.so.138
/usr/lib/libx264.so
/usr/lib/libx264.so.142
/usr/lib/libx264.so.146
/usr/lib/vlc/plugins/codec/libx264_plugin.so

Codice: [Seleziona]
chakra-pc ~]$ nm -D /usr/lib/libx264.so.142  | grep encoder_open
0000000000089600 T x264_encoder_open_146

Codice: [Seleziona]
chakra-pc ~]$ pacman -Qo /usr/lib/libx264.so.142
errore: Nessun pacchetto contiene /usr/lib/libx264.so.142
« Ultima modifica: 24 Settembre 2015 ore 21:24 da mrcrowley »

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Kdenlive non avvia più !!
« Risposta #13 il: 24 Settembre 2015 ore 21:54 »
Come vedi il sistema è sporco. Hai due libx264. La 142 non appartiene ad alcun pacchetto mentre la 146?
Non dirti come arrivato inquesto stato ma devi correggere...
Se la 146 appartiene a qualche pacchetto rimuovilo altrimenti rimuovi a mano enreinstalla libx264 con opzione --force

Offline mrcrowley

  • *
  • Post: 876
  • Reputazione: -1
    • Mostra profilo
Re:Kdenlive non avvia più !!
« Risposta #14 il: 24 Settembre 2015 ore 21:57 »
Codice: [Seleziona]
chakra-pc ~]$ pacman -Qo /usr/lib/libx264.so.146
/usr/lib/libx264.so.146 è contenuto in x264-8bit 20150907-1

 

Template by Homey | Sito ufficiale | Disclaimer