Autore Topic: HPLIP: stampante non riconosciuta dopo upgrade  (Letto 1523 volte)

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
HPLIP: stampante non riconosciuta dopo upgrade
« il: 17 Settembre 2015 ore 15:17 »
salve gente. dopo l'aggiornamento a HPLIP 3.15 la mia laserjet 1018 ha smesso di funzionare.

Rimossa per aggiungerne una nuova di pacca HPLIP non trova stampanti collegate!

dmesg non fornisce messaggi interessanti:
Codice: [Seleziona]
[ 1768.867182] usb 3-1: USB disconnect, device number 24
[ 2513.557633] usb 3-1: new high-speed USB device number 25 using xhci_hcd
[ 2513.753733] usblp 3-1:1.0: usblp0: USB Bidirectional printer dev 25 if 0 alt 0 proto 2 vid 0x03F0 pid 0x4117
[ 2517.021262] usblp0: removed

lsusb la vede:
Codice: [Seleziona]
Bus 003 Device 025: ID 03f0:4117 Hewlett-Packard LaserJet 1018

sotto win 7 funziona (ma non sotto vbox).

la stampante di rete funziona (hp laserjet)

Che succede? Ho aperto anche un thread sul forum internazionale: http://chakraos.org/forum/viewtopic.php?id=14236

franz che dici, visto che mi serve per lavoro torno in stable?

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:HPLIP: stampante non riconosciuta dopo upgrade
« Risposta #1 il: 17 Settembre 2015 ore 15:57 »
oh mamma. ho tentato un downgrade da testing a stable.

ho scassato tutto!!!!
al boot non trova ucode intel. che ho combinato!

(ho pasticciato con systemd, lo so. il downgrade era da fare con molta più attenzione. ad un certo punto non andava più niente ed ho riavviato).

sono su un PC win7 ma ho casino di dati... intanto sto creando una chiavetta che non l'avevo.

Da win come la faccio? ho molto tempo prima che si scarichi la ISO... provo se in chroot faccio qualche miracolo

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:HPLIP: stampante non riconosciuta dopo upgrade
« Risposta #2 il: 17 Settembre 2015 ore 16:50 »
Nel caso qualche anima pia potesse rispondermi: che faccio, vado di chroot, rimetto testing, rigenero l'immagine e riavvio?

ho molti lavori da portare a termine e se non ho la macchina a disposizione è un gran casino...

Offline Cylon

  • *
  • Post: 1960
  • Reputazione: 78
  • CYbernetic Life fOrm Node
    • Mostra profilo
Re:HPLIP: stampante non riconosciuta dopo upgrade
« Risposta #3 il: 17 Settembre 2015 ore 17:09 »
invece di andare di chroot riavvia e quando sei su grub fai clic su e o c (non ricordo) e aggiungi alla riga del kernel la stringa:

Codice: [Seleziona]
systemd.unit=rescue.target

invio e avvia

da li riabiliti i repo testing e aggiorni e  dovrebbe andare... forse... tanto fallo  ;D
« Ultima modifica: 17 Settembre 2015 ore 17:19 da Cylon »
We are the Cylons. Lower your firewalll and surrender.Your PC will adapt to service our GNU/Linux systems. Resistance is futile. Extermination of human race has began!
                                                                     Non rispondo a PM

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:HPLIP: stampante non riconosciuta dopo upgrade
« Risposta #4 il: 17 Settembre 2015 ore 17:10 »
il fatto è che ho incasinato il kernel (credo a causa del rollback) e non mi trova il ucode intel al boot... kernel panic

cmq ci provo, non costa niente.

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:HPLIP: stampante non riconosciuta dopo upgrade
« Risposta #5 il: 17 Settembre 2015 ore 17:24 »
editando il menu di grub tolgo intel-unicode.img e parte.
ma... avendo incasinato systemd (e udev immagino) tutti i mount falliscono. Alla fine mi becco un paio di assert da librerie di sistema e tutto si ferma.

niente, finisco di scaricare la ISO, faccio due prove. altrimenti mi tocca reinstallare. ho fatto una gran cazzata a tornare ai repo stabili senza neanche pensare a cosa fosse stato passato.

Ah: da gran collione ho anche fatto un paio di forzature. eh vabbè, quando uno se le cerca....

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:HPLIP: stampante non riconosciuta dopo upgrade
« Risposta #6 il: 17 Settembre 2015 ore 17:43 »
ah, cylon, un favore: non ricordo dove avevo visto uno script per mettere su file i pacchetti installati ed un altro per installare quelli nell'elenco... Tu hai idea di come si possa fare?

a casa mi scarico l'elenco (visto che sono anche lì in testing e ho un processore uguale) e provo da chroot a reinstallare almeno i pacchetti di sistema.
Dici che potrebbe funzionare?

Offline Cylon

  • *
  • Post: 1960
  • Reputazione: 78
  • CYbernetic Life fOrm Node
    • Mostra profilo
Re:HPLIP: stampante non riconosciuta dopo upgrade
« Risposta #7 il: 17 Settembre 2015 ore 17:52 »
per lo script non so.. sono pigro, io se farei quello che vuoi fare tu NON lo farei  ;D ;D ;D

preferisco se installo qualcosa installare tutto exnovo.. magari avevo installato qualche pacchetto che ora non mi serve piu...

ma nel caso farei quello che c'è scritto nel sacro wiki..:

genero la lista dei pacchetti:
Codice: [Seleziona]
pacman -Qqe > pkglist
e poi la installerei sul sistema 'cavia' (mettendomi nella stessa dir che contiene la lista generata sopra) con:
Codice: [Seleziona]
sudo pacman -S $(cat pkglist)
« Ultima modifica: 17 Settembre 2015 ore 17:55 da Cylon »
We are the Cylons. Lower your firewalll and surrender.Your PC will adapt to service our GNU/Linux systems. Resistance is futile. Extermination of human race has began!
                                                                     Non rispondo a PM

Offline whoami

  • *
  • Post: 1562
  • Reputazione: 64
  • Quando c'era init i log arrivavano in orario!
    • Mostra profilo
Re:HPLIP: stampante non riconosciuta dopo upgrade
« Risposta #8 il: 17 Settembre 2015 ore 18:19 »
domanda, anche se penso che ormai sia tardi... Avevi installato hplip-plugin da CCR?
echo "VQF AHELME I BI CI WECPF"| tr "ETAOINSHRDLUBCFGJMQPVWZYXK" "A-Z"

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:HPLIP: stampante non riconosciuta dopo upgrade
« Risposta #9 il: 17 Settembre 2015 ore 19:04 »
domanda, anche se penso che ormai sia tardi... Avevi installato hplip-plugin da CCR?
ci ho provato ma non è compatibile con la versione in testing.

In ogni caso se prima non l'avevo e andava...

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:HPLIP: stampante non riconosciuta dopo upgrade
« Risposta #10 il: 17 Settembre 2015 ore 19:06 »
per lo script non so.. sono pigro, io se farei quello che vuoi fare tu NON lo farei  ;D ;D ;D

preferisco se installo qualcosa installare tutto exnovo.. magari avevo installato qualche pacchetto che ora non mi serve piu...

ma nel caso farei quello che c'è scritto nel sacro wiki..:

genero la lista dei pacchetti:
Codice: [Seleziona]
pacman -Qqe > pkglist
e poi la installerei sul sistema 'cavia' (mettendomi nella stessa dir che contiene la lista generata sopra) con:
Codice: [Seleziona]
sudo pacman -S $(cat pkglist)

ok grazie cylon.

Il fatto è che ho un casino di impostazioni (anche se gli script più importanti sono salvati) e dovrei tornare operativo prima possibile.
Certo, se non recupero il sistema devo piallare e reinstallare. almeno la home c'è...
si prospetta un sabato allettante  >:( >:( >:( :'( :'( :'(

Offline whoami

  • *
  • Post: 1562
  • Reputazione: 64
  • Quando c'era init i log arrivavano in orario!
    • Mostra profilo
Re:HPLIP: stampante non riconosciuta dopo upgrade
« Risposta #11 il: 18 Settembre 2015 ore 00:09 »
 Per il plugin te lo chiedevo perché ho aggiornato il plugin su CCR ma non l'ho caricato quindi te lo potevo passare per provare... ma mi sa che è tardi :'(

Comunque se devi reinstallare da live puoi entrare nella partizione di root e copiarti le conf dei programmi ( tra /etc e ~ dovresti recuperare più o meno tutto)
echo "VQF AHELME I BI CI WECPF"| tr "ETAOINSHRDLUBCFGJMQPVWZYXK" "A-Z"

Offline enzolatina

  • *
  • Post: 609
  • Reputazione: 18
    • Mostra profilo
Re:HPLIP: stampante non riconosciuta dopo upgrade
« Risposta #12 il: 18 Settembre 2015 ore 10:29 »
ma se entri in chroot, riabiliti i testing e aggiorni a come eri prima del downgrade?
noi siamo ****linux, ogni resistenza è inutile, sarete assimilati
linuxuser:408768 http://linuxcounter.net

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:HPLIP: stampante non riconosciuta dopo upgrade
« Risposta #13 il: 18 Settembre 2015 ore 16:12 »
ma se entri in chroot, riabiliti i testing e aggiorni a come eri prima del downgrade?

eccomi tornato!

ah ah Enzo, anche io ci speravo ma...
ieri il download dell'ISO è andata male. Oggi con torrent è andata meglio.
Da linux l'unica cosa con cui sono riuscito a creare una chiavetta utilizzabile è stato dd.exe (!). Ma va a meraviglia.

Ho provato il chroot: come davo chroot mi beccavo un errore in liblocale.c. Insomma: il sistema era definitivamente corrotto (e ci credo ho rollabackato systemd compromettendo di sicuro qualche libreria di sistema).

Niente, la cosa più veloce è stata davvero reinstallare. Grazie a cylon e whoami mi sono anche ricordato di backuppare /etc così non ho smadonnato con fstab etc (visto che ho tipo 3 dischi fissi e altri di rete di cui serve ricordarsi la configurazione).
E poi amo linux e le sue partizioni. La home è praticamente quella di prima, serve solo installare le app.

Ah, devo vedere dove sta il file crontab, non ho voglia di crearmi manco quello  ;D ;D

Ultima cosa: minchia non ho più i font di prima... qualche suggerimento? non ricordo proprio cosa avevo installato.  >:( >:(

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:HPLIP: stampante non riconosciuta dopo upgrade
« Risposta #14 il: 18 Settembre 2015 ore 17:13 »
E' una vita che non reinstallavo. Approfitto e prendo nota qui di alcune cose:

tribe: mentre procede l'installazione è abilitato il tasto "prosegui". l'ho fatto distrattamente e l'installazione va in errore. Fra l'altro l'unica cosa che si può fare è riavviare.

virtualbox: non si sa perchè ma se non si riavvia non vede le porte USB. preso uno spaghetto il reboot ha risolto

integrazione gtk: ho faticato un po' a capire che dovevo installare gtk-integration. In qualche modo sarebbe il caso di informare gli utenti (boh, magari come dipendenza consigliata di thuderbird e altri programmi gtk)

il font aakar di default fa altamente schifo (almeno questo è quello che mi sono trovato. non vorrei x il fatto che i font precedentemente installati non sono stati trovati. molto probabile)

provando a far andare hp-setup ottengo un erore:
Codice: [Seleziona]
error: Unable to load Qt4 support. Is it installed?Ora devo scoprire quale libreria manca...
TROVATA: python2-gobject2   (trovata per vie traverse usando l'opzione da linea di comando. mah)
« Ultima modifica: 18 Settembre 2015 ore 17:21 da dinolib »

 

Template by Homey | Sito ufficiale | Disclaimer