Autore Topic: Chakra non parte più dopo l'aggiornamento  (Letto 2339 volte)

Offline Cosworth117

  • *
  • Post: 405
  • Reputazione: 12
  • Quello dei problemi strani.
    • Mostra profilo
Re:Chakra non parte più dopo l'aggiornamento
« Risposta #30 il: 25 Giugno 2015 ore 18:48 »
Allora, ho già reinstallato il sistema (povero ssd).

I driver di default come si selezionano? Sbaglio io quando all'installazione di Skype seleziono 4 o non c'entra nulla? Perché per il resto non tocco nulla!

Come faccio a non utilizzare i nouveau?



Inviato dal mio GT-N7000 utilizzando Tapatalk

i7 4790k
Asus Z97-a
Asus nvidia GTX 780
Corsair Vengeance Pro 8gb
SSD 120gb + HDD 2tb

Chakra OS + Windows 7 Ultimate

Offline Cylon

  • *
  • Post: 1960
  • Reputazione: 78
  • CYbernetic Life fOrm Node
    • Mostra profilo
Re:Chakra non parte più dopo l'aggiornamento
« Risposta #31 il: 25 Giugno 2015 ore 18:53 »
non c'è bisogno di reinstallare tutto il sistema per avere i driver nvidia, sul wiki c'è come passare dagli open agli nvidia... ma se non ricordo male la iso consentiva di avviare e installare i driver nvidia... non so se sia cambiato qualcosa, l'ultima volta che ho installato una distro GNU/Linux era il 2012  ;D ;D ;D
« Ultima modifica: 25 Giugno 2015 ore 18:54 da Cylon »
We are the Cylons. Lower your firewalll and surrender.Your PC will adapt to service our GNU/Linux systems. Resistance is futile. Extermination of human race has began!
                                                                     Non rispondo a PM

Offline Cosworth117

  • *
  • Post: 405
  • Reputazione: 12
  • Quello dei problemi strani.
    • Mostra profilo
Re:Chakra non parte più dopo l'aggiornamento
« Risposta #32 il: 25 Giugno 2015 ore 18:56 »
Ahah va be ' avevo il problema di ieri e siccome sono sotto esame non avevo altro tempo da perdere. Almeno ho un passaggio in meno! Appena ho 2 minuti controllo per lo switch dei driver. Comunque non ha mai dato problemi prima d'ora. Almeno da quando ho assemblato il PC, ottobre scorso mi pare. Grazie cylon! :) +1

Inviato dal mio GT-N7000 utilizzando Tapatalk

i7 4790k
Asus Z97-a
Asus nvidia GTX 780
Corsair Vengeance Pro 8gb
SSD 120gb + HDD 2tb

Chakra OS + Windows 7 Ultimate

Offline Cosworth117

  • *
  • Post: 405
  • Reputazione: 12
  • Quello dei problemi strani.
    • Mostra profilo
Re:Chakra non parte più dopo l'aggiornamento
« Risposta #33 il: 25 Giugno 2015 ore 19:23 »
Dai un'occhiata:

Codice: [Seleziona]
[gianluca@chakra-pc ~]$ sudo pacman -Rdd libgl
errore: il seguente pacchetto non è stato trovato: libgl
[gianluca@chakra-pc ~]$ sudo pacman -Rdd lib32-libgl
errore: il seguente pacchetto non è stato trovato: lib32-libgl
[gianluca@chakra-pc ~]$ sudo pacman -R xf86-video-noveau
errore: il seguente pacchetto non è stato trovato: xf86-video-noveau
[gianluca@chakra-pc ~]$ sudo pacman -S nvidia
risoluzione delle dipendenze in corso...
ricerca dei pacchetti in conflitto in corso...
:: nvidia-libgl e mesa-libgl vanno in conflitto (libgl). Vuoi rimuovere mesa-libgl? [s/N] s
attenzione: è stato individuato un ciclo di dipendenza:
attenzione: nvidia-utils sarà installato prima della sua dipendenza nvidia-libgl

Pacchetti (4) mesa-libgl-10.5.0-1 [rimozione]  nvidia-libgl-346.72-1
              nvidia-utils-346.72-1  nvidia-346.72-1

Dimensione totale dei pacchetti da scaricare:    25,87 MiB
Dimensione totale dei pacchetti da installare:  129,75 MiB
Dimensione netta dell'aggiornamento:            129,71 MiB

:: Vuoi procedere con l'installazione? [S/n] S
:: Download dei pacchetti in corso...
 nvidia-utils-346.72...    21,7 MiB   803K/s 00:28 [######################] 100%
 nvidia-libgl-346.72...  1396,0   B  0,00B/s 00:00 [######################] 100%
 nvidia-346.72-1-x86_64     4,2 MiB   790K/s 00:05 [######################] 100%
(3/3) verifica delle chiavi presenti nel porta...  [######################] 100%
(3/3) verifica dell'integrità dei pacchetti        [######################] 100%
(3/3) caricamento dei file dei pacchetti           [######################] 100%
(3/3) controllo dei conflitti in corso             [######################] 100%
(4/4) controllo dello spazio disponibile sul d...  [######################] 100%
(1/1) rimozione in corso di mesa-libgl             [######################] 100%
(1/3) installazione in corso di nvidia-utils       [######################] 100%
Dipendenze opzionali di nvidia-utils
    gtk2: nvidia-settings [installato]
    xorg-server-devel: nvidia-xconfig
    opencl-nvidia: OpenCL support
    nvidia-settings: Gtk GUI
(2/3) installazione in corso di nvidia-libgl       [######################] 100%
(3/3) installazione in corso di nvidia             [######################] 100%
In order to use nvidia module, reboot the system.
[gianluca@chakra-pc ~]$ sudo nvidia-xconfig

WARNING: Unable to locate/open X configuration file.

Package xorg-server was not found in the pkg-config search path.
Perhaps you should add the directory containing `xorg-server.pc'
to the PKG_CONFIG_PATH environment variable
No package 'xorg-server' found
New X configuration file written to '/etc/X11/xorg.conf'

Ho seguito la guida... Secondo te la procedura è esatta?
i7 4790k
Asus Z97-a
Asus nvidia GTX 780
Corsair Vengeance Pro 8gb
SSD 120gb + HDD 2tb

Chakra OS + Windows 7 Ultimate

Offline Cosworth117

  • *
  • Post: 405
  • Reputazione: 12
  • Quello dei problemi strani.
    • Mostra profilo
Re:Chakra non parte più dopo l'aggiornamento
« Risposta #34 il: 25 Giugno 2015 ore 19:55 »
Niente, un macello. Ho riprovato avviando la live con driver proprietari e installando da zero il sistema , ma il sistema manco sì avvia.




Inviato dal mio GT-N7000 utilizzando Tapatalk

i7 4790k
Asus Z97-a
Asus nvidia GTX 780
Corsair Vengeance Pro 8gb
SSD 120gb + HDD 2tb

Chakra OS + Windows 7 Ultimate

Offline marci

  • *
  • Post: 22
  • Reputazione: 2
    • Mostra profilo
Re:Chakra non parte più dopo l'aggiornamento
« Risposta #35 il: 25 Giugno 2015 ore 20:17 »
Non ho ben capito se può essere lo stesso problema che ho avuto io dopo l'aggiornamento di giorno 22, ma in seguito a quel funesto evento il mio sistema si è rotto alla grande e non mi faceva più accedere se non in modalità testuale... Dopo svariate prove e reinstallazioni da zero ho trovato altri utenti in una condizione analoga alla mia sul forum internazionale a questa pagina:

http://chakraos.org/forum/viewtopic.php?id=14051

Pare che le vittime siano fra coloro che hanno una cpu Haswell... Io ho risolto con l'hack suggerito nel thread, eliminando il pacchetto intel-ucode e facendo il rebuild dell'initramfs, ma mi pare di capire che non sia esattamente una soluzione, ma un rappezzo  8)
Se qualcuno più esperto magari mi sa anche spiegare cosa ho fatto, gliene sarei molto grato  ;D

P.S. In base all'esperienza fatta a mie spese, io suggerirei che è meglio reinstallare con driver nouveau e solo dopo avere ricotruito l'initramfs installare i driver nvidia.
« Ultima modifica: 25 Giugno 2015 ore 20:19 da marci »

Offline Cylon

  • *
  • Post: 1960
  • Reputazione: 78
  • CYbernetic Life fOrm Node
    • Mostra profilo
Re:Chakra non parte più dopo l'aggiornamento
« Risposta #36 il: 25 Giugno 2015 ore 22:06 »
prova quello consigliato da    marci, io 'fortunatamente' sul portatile ho un sistema optimus e quindi la scheda nvidia non la uso mai e hi i driver nvidia..
We are the Cylons. Lower your firewalll and surrender.Your PC will adapt to service our GNU/Linux systems. Resistance is futile. Extermination of human race has began!
                                                                     Non rispondo a PM

Offline Cosworth117

  • *
  • Post: 405
  • Reputazione: 12
  • Quello dei problemi strani.
    • Mostra profilo
Re:Chakra non parte più dopo l'aggiornamento
« Risposta #37 il: 26 Giugno 2015 ore 02:01 »
Normale che dopo aver eliminato intel-ucode, e aver fatto il rebuild non mi vada più l'audio del PC, o non c'entra niente? Ho un DAC esterno... Non mi tiene le modifiche nelle impostazioni multimediali. Il led nel DAC si accende ma non sento niente... Mi basta risolvere sto problema, poi Chakra non lo aggiorno finché non risolvono tutti 'sti bug.  :-X :-X :-X

Spiace dirlo ma sono veramente deluso da 'sto sistema che pensavo più solido...

EDIT. Su Windows va, qui no... nemmeno dopo un'altra installazione pulita. È troppo anche per voi, lo capisco. Basta.  ;D Qui sono al limite... Si sommano problemi a cui non so dare risposta.

Almeno fino a prima mentre cercavo la soluzione avevo la musica in sottofondo, adesso è andato a fanculo anche l'audio. ::)
« Ultima modifica: 26 Giugno 2015 ore 03:27 da Cosworth117 »
i7 4790k
Asus Z97-a
Asus nvidia GTX 780
Corsair Vengeance Pro 8gb
SSD 120gb + HDD 2tb

Chakra OS + Windows 7 Ultimate

Offline Cylon

  • *
  • Post: 1960
  • Reputazione: 78
  • CYbernetic Life fOrm Node
    • Mostra profilo
Re:Chakra non parte più dopo l'aggiornamento
« Risposta #38 il: 26 Giugno 2015 ore 10:46 »
esistono 1000 configurazioni hw diverse, quindi non è detto che in alcune tutto vada liscio.... hai provato ad usare un kernel lts? se segui il thread segnalato da marci hai notizie più fresce direttamente dai dev.
We are the Cylons. Lower your firewalll and surrender.Your PC will adapt to service our GNU/Linux systems. Resistance is futile. Extermination of human race has began!
                                                                     Non rispondo a PM

Offline Cosworth117

  • *
  • Post: 405
  • Reputazione: 12
  • Quello dei problemi strani.
    • Mostra profilo
Re:Chakra non parte più dopo l'aggiornamento
« Risposta #39 il: 26 Giugno 2015 ore 11:08 »
Ora elimino intel-ucode e poi faccio il rebuild dell'initramfs... Magari gli nvidia è meglio installarli dopo, visto che il problema è di intel, sempre se il problema è quello. Nel mio caso potrebbe non essere...
i7 4790k
Asus Z97-a
Asus nvidia GTX 780
Corsair Vengeance Pro 8gb
SSD 120gb + HDD 2tb

Chakra OS + Windows 7 Ultimate

Offline Cosworth117

  • *
  • Post: 405
  • Reputazione: 12
  • Quello dei problemi strani.
    • Mostra profilo
Re:Chakra non parte più dopo l'aggiornamento
« Risposta #40 il: 26 Giugno 2015 ore 11:25 »
Funziona tutto! o_o Ho anche messo i driver nvidia  ;D Grazie marci per l'intervento!

Però l'audio ancora non va!

Tipo lo imposto così:



Se chiudo e riapro me lo ritrovo così:

i7 4790k
Asus Z97-a
Asus nvidia GTX 780
Corsair Vengeance Pro 8gb
SSD 120gb + HDD 2tb

Chakra OS + Windows 7 Ultimate

Offline Cylon

  • *
  • Post: 1960
  • Reputazione: 78
  • CYbernetic Life fOrm Node
    • Mostra profilo
Re:Chakra non parte più dopo l'aggiornamento
« Risposta #41 il: 26 Giugno 2015 ore 13:00 »
il suono è leggermente' delicato... io ho avuto un problema con chakra e i suoni di avvio... praticamete da un giorno all'altro la scheda audio HDA intel PCH integrata non compariva più tra i dispositivi presenti e selezionabili in impostazioni di sistema e non funzionava neanche l'audio... per far tornare l'audio ho dovuto impostare la scheda da alsamixer.. e dopo un paio di mesi e qualche aggiornamento tutto è tornato alla normalita... quindi se le cose smettono di funzionare bisogna segnalare il problema e sperare in una solzione..  ;D
We are the Cylons. Lower your firewalll and surrender.Your PC will adapt to service our GNU/Linux systems. Resistance is futile. Extermination of human race has began!
                                                                     Non rispondo a PM

Offline Cosworth117

  • *
  • Post: 405
  • Reputazione: 12
  • Quello dei problemi strani.
    • Mostra profilo
Re:Chakra non parte più dopo l'aggiornamento
« Risposta #42 il: 26 Giugno 2015 ore 17:18 »
Ho trovato la soluzione nel forum internazionale di Arch.

Basta digitare:

Citazione
alsamixer -Dhw

Premere F6 e selezionare la scheda audio preferita. Poi controllare che i canali audio siano aperti, quindi con 00. Nel mio caso erano mutati, e quindi figurava MM, e li ho aperti premendo M. Poi uscire.

Tutto risolto per il momento.  :)
i7 4790k
Asus Z97-a
Asus nvidia GTX 780
Corsair Vengeance Pro 8gb
SSD 120gb + HDD 2tb

Chakra OS + Windows 7 Ultimate

Offline Cosworth117

  • *
  • Post: 405
  • Reputazione: 12
  • Quello dei problemi strani.
    • Mostra profilo
Re:Chakra non parte più dopo l'aggiornamento
« Risposta #43 il: 02 Luglio 2015 ore 09:33 »
Ragazzi nel forum ufficiale hanno trovato il fix al problema iniziale, aggiornando glibc:

Codice: [Seleziona]
sudo pacman -U http://rsync.chakraos.org/packages/staging/x86_64/glibc-2.20-6-x86_64.pkg.tar.xz
Io l'ho fatto e ho pure reinstallato intel-ucode, e tutto va liscio.  :)
i7 4790k
Asus Z97-a
Asus nvidia GTX 780
Corsair Vengeance Pro 8gb
SSD 120gb + HDD 2tb

Chakra OS + Windows 7 Ultimate

Offline marci

  • *
  • Post: 22
  • Reputazione: 2
    • Mostra profilo
Re:Chakra non parte più dopo l'aggiornamento
« Risposta #44 il: 02 Luglio 2015 ore 20:21 »
Grazie dell'avviso Cosworth, anche sul mio pc pare che tutto sia filato liscio  :)

 

Template by Homey | Sito ufficiale | Disclaimer