Autore Topic: Configurare stampanti multifunzione - Epson stylus SX235W e Canon prixma MG5250  (Letto 13728 volte)

Offline peter46

  • *
  • Post: 116
  • Reputazione: 0
    • Mostra profilo
Ciao, mi questo errore di dipendenze:

Codice: [Seleziona]
[pietro@chakra-pc ~]$ ccr -S canon-pixma-mg5200-complete

Ccr Targets    (3): lib32-popt deb2targz canon-pixma-mg5200-complete
Pacman Targets (4): gcc-multilib lib32-gtk2 lib32-libpng12 lib32-libusb-compat

Proceed with installation? [Y/n] y
risoluzione delle dipendenze in corso...
ricerca dei conflitti in corso...
:: gcc-libs-multilib e gcc-libs vanno in conflitto. Vuoi rimuovere gcc-libs? [s/N]
errore: sono stati rilevati dei conflitti irrisolvibili tra i pacchetti
errore: impossibile eseguire l'operazione richiesta (dipendenze in conflitto)
:: gcc-libs-multilib e gcc-libs vanno in conflitto
Installation failed.
[pietro@chakra-pc ~]$

Ciao Pietro

Offline whoami

  • *
  • Post: 1562
  • Reputazione: 64
  • Quando c'era init i log arrivavano in orario!
    • Mostra profilo
Ora non ho il PC davanti, ma tu hai risposto si o no? Prova con il si, se non dovesse andare (anche a me faceva cosi), dai sudo pacman -S gcc-libs-multilib e di di si quando ti chiede, poi ritenta l'installazione e ti si riblocchera per un altro paio di pacchetti multilib. tu installali da pacman come quello di prima e continua a dire di si. Alla quarta volta dovrebbe andare.

Sul perche non li faccia sostituire in automatico non so ma provo ad informarmi!
echo "VQF AHELME I BI CI WECPF"| tr "ETAOINSHRDLUBCFGJMQPVWZYXK" "A-Z"

Offline peter46

  • *
  • Post: 116
  • Reputazione: 0
    • Mostra profilo
Installazione andata a buon fine, ma non riesco ad installarla ne con la modalità grafica che con CUPS.

Ti allego la fine dopo la compilazione del pacchetto.-

Codice: [Seleziona]
==> Uscita dall'ambiente di fakeroot.
==> Compilazione terminata: canon-pixma-mg5200-complete 3.40-1 (mer 26 feb 2014, 12.35.40, CET)
Password:
caricamento dei pacchetti in corso...
attenzione: canon-pixma-mg5200-complete-3.40-1 è aggiornato ma sarà reinstallato
risoluzione delle dipendenze in corso...
ricerca dei conflitti in corso...

Pacchetti (1): canon-pixma-mg5200-complete-3.40-1

Dimensione totale dei pacchetti da installare:   7,75 MiB
Dimensione netta dell'aggiornamento:             0,00 MiB

:: Vuoi procedere con l'installazione? [S/n] s
(1/1) verifica delle chiavi presenti nel portachiavi                     [########################################] 100%
(1/1) verifica dell'integrità dei pacchetti                              [########################################] 100%
(1/1) caricamento dei file dei pacchetti                                 [########################################] 100%
(1/1) controllo dei conflitti in corso                                   [########################################] 100%
(1/1) reinstallazione canon-pixma-mg5200-complete                        [########################################] 100%
[pietro@chakra-pc ~]$

Ciao Pietro


Offline whoami

  • *
  • Post: 1562
  • Reputazione: 64
  • Quando c'era init i log arrivavano in orario!
    • Mostra profilo
Quando ho provato ad installarlo io alla fine dell'installazione mi è apparsa questo messaggio:
Codice: [Seleziona]
====================================================================================>
[2014-02-25 11:49] [ALPM-SCRIPTLET] ==>
[2014-02-25 11:49] [ALPM-SCRIPTLET] ==> Final steps you have to take:
[2014-02-25 11:49] [ALPM-SCRIPTLET] ==>   
[2014-02-25 11:49] [ALPM-SCRIPTLET] ==>   1.  Connect & turn on your printer
[2014-02-25 11:49] [ALPM-SCRIPTLET] ==>   
[2014-02-25 11:49] [ALPM-SCRIPTLET] ==>   2.a If connected via USB:
[2014-02-25 11:49] [ALPM-SCRIPTLET] ==>       run command
[2014-02-25 11:49] [ALPM-SCRIPTLET] ==>          /usr/lib/cups/backend/cnijusb
[2014-02-25 11:49] [ALPM-SCRIPTLET] ==>       or
[2014-02-25 11:49] [ALPM-SCRIPTLET] ==>          /usr/lib64/cups/backend/cnijusb
[2014-02-25 11:49] [ALPM-SCRIPTLET] ==>   
[2014-02-25 11:49] [ALPM-SCRIPTLET] ==>   2.b If connected via (W)LAN:
[2014-02-25 11:49] [ALPM-SCRIPTLET] ==>       run command
[2014-02-25 11:49] [ALPM-SCRIPTLET] ==>          cnijnetprn --installer --search auto
[2014-02-25 11:49] [ALPM-SCRIPTLET] ==>   
[2014-02-25 11:49] [ALPM-SCRIPTLET] ==>   3.  Identify your printer's address (starting with 'cnijnet:/' or
[2014-02-25 11:49] [ALPM-SCRIPTLET] ==>       'cnijusb:/') provided by above command
[2014-02-25 11:49] [ALPM-SCRIPTLET] ==>   
[2014-02-25 11:49] [ALPM-SCRIPTLET] ==>   4.  Register printer with command
[2014-02-25 11:49] [ALPM-SCRIPTLET] ==>          sudo lpadmin -p MG5200 -m canonmg5200.ppd -v <printer-address> -E
[2014-02-25 11:49] [ALPM-SCRIPTLET] ==>   
[2014-02-25 11:49] [ALPM-SCRIPTLET] ==> How to scan:
[2014-02-25 11:49] [ALPM-SCRIPTLET] ==>   
[2014-02-25 11:49] [ALPM-SCRIPTLET] ==>   A 'Cannon Scangear' icon has been installed in your application menu.
[2014-02-25 11:49] [ALPM-SCRIPTLET] ==>   Alternatively, run this command from the command line:
[2014-02-25 11:49] [ALPM-SCRIPTLET] ==>          scangearmp
[2014-02-25 11:49] [ALPM-SCRIPTLET] ==>   
[2014-02-25 11:49] [ALPM-SCRIPTLET] ====================================================================================>
Il mio è un po' più pasticciato perchè sono andato a recuperarlo nel log di pacman...

A te non è apparso? Forse nella schermata che hai postato non c'era perchè era una reinstallazione... prova a seguire le istruzioni e scrivi come va!
echo "VQF AHELME I BI CI WECPF"| tr "ETAOINSHRDLUBCFGJMQPVWZYXK" "A-Z"

Offline peter46

  • *
  • Post: 116
  • Reputazione: 0
    • Mostra profilo
....ciao per seguire le istruzioni intendi reistallare il pacchetto ccr perchè se l'ho già fatto.

P.S.
riavviando il computer ho visto nella schermata di caricamento sistema, prima di quella grafica per l'inserimento della password molte righe scorrere velocemente dove sono riuscito a leggere "canon", prima queste righe non c'erano.-

Ciao Pietro
« Ultima modifica: 26 Febbraio 2014 ore 14:36 da peter46 »

Offline whoami

  • *
  • Post: 1562
  • Reputazione: 64
  • Quando c'era init i log arrivavano in orario!
    • Mostra profilo
Io dicevo quello che appariva dalla schermata di pacman:


1. Connetti e accendi la stampante

2.a Se connessa via usb:
 dai il comando:
        /usr/lib/cups/backend/cnijusb
 o
       /usr/lib64/cups/backend/cnijusb

2.b Se connessa via (W)LAN:
  Dai il comando:
          cnijnetprn --installer --search auto

3.  Identifica l'indirizzo della tua stampante (che comincerà con
      cnijnet:/ o cnijusb:/) dal comando dato in precedenza

4.  Registra la stampante con il comando  (<printer-address> è l'indirizzo di cui sopra, NdT)
          sudo lpadmin -p MG5200 -m canonmg5200.ppd -v <printer-address> -E   


Se poi volessi vedere cosa ti dice il sistema quando parte puoi provare con sudo journalctl -b | grep canon o dmesg | grep canon
echo "VQF AHELME I BI CI WECPF"| tr "ETAOINSHRDLUBCFGJMQPVWZYXK" "A-Z"

Offline peter46

  • *
  • Post: 116
  • Reputazione: 0
    • Mostra profilo
la stampante è collegata con wireless alla rete di casa e ha un ip fisso 192.168.1.9.

provo con wireless in caso contrario la devo collegare fisicamente al al computer con usb (non ha la porta ethernet).

Ciao Pietro

Offline peter46

  • *
  • Post: 116
  • Reputazione: 0
    • Mostra profilo
collegata con wireless, la risposta al comando

Codice: [Seleziona]
[pietro@chakra-pc ~]$ cnijnetprn --installer --search auto
network cnijnet:/2C-9E-FC-8C-1D-6F "Canon MG5200 series" "IP:192.168.1.9"
[pietro@chakra-pc ~]$

non volermene ma ho dato il comando che ti posto sotto e secondo me manca l'ip della stampante che non so dove inserirlo...!

Codice: [Seleziona]
[pietro@chakra-pc ~]$ sudo lpadmin -p MG5200 -m canonmg5200.ppd -v "Canon MG5200 series" -E
lpadmin: Bad device-uri "Canon MG5200 series".
[pietro@chakra-pc ~]$

ciao pietro


Offline whoami

  • *
  • Post: 1562
  • Reputazione: 64
  • Quando c'era init i log arrivavano in orario!
    • Mostra profilo
L'indirizzo è cnijnet:/2C-9E-FC-8C-1D-6F quindi il comando diventa


sudo lpadmin -p MG5200 -m canonmg5200.ppd -v cnijnet:/2C-9E-FC-8C-1D-6F -E
echo "VQF AHELME I BI CI WECPF"| tr "ETAOINSHRDLUBCFGJMQPVWZYXK" "A-Z"

Offline peter46

  • *
  • Post: 116
  • Reputazione: 0
    • Mostra profilo
fatto, ma non riesco lo stesso a configurare la stampante ne con CUPS ne con la modalità grafica,

scelgo l'opzione "AppSocket/HP JetDirect ", inserisco l'indirizzo IP 192.168.1.9, canon, cerco la canon prixma mg5200....... che in elenco ne ho sempre trovate 2 anche prima di installare il pacchetto dai CCR, continuo con la configurazione della medesima ma quando mando in stampa la pagine di prova o creo un documento mi dice che la stampante non risponde. Ho provato a variare i valori ma niente.
 
Ciao Pietro

Offline francesco_dem

  • *
  • Post: 321
  • Reputazione: 9
    • Mostra profilo
Prova ad installare da ccr cups-bjnp (CUPS backend for the canon proprietary network printing protocol, BJNP.)
una volta fatto questo, riavvia, entra in cups e  rileva la stampante usando il protocollo di trasmissione di stampa di rete "proprietario" di Canon.

Fonte:
http://www.archlinux.it/forum/viewtopic.php?nomobile=1&p=131004
« Ultima modifica: 26 Febbraio 2014 ore 20:12 da francesco_dem »

Offline peter46

  • *
  • Post: 116
  • Reputazione: 0
    • Mostra profilo
scusami mi sento proprio impotente, non capisco ogni cosa mi venga proposta, ho installato il pacchetto che mi hai indicato da CCR, ho riavviato il notebook, sono rientratro in CUPS ma non so quale sia la voce che mi hai indicato "entra in cups e  rileva la stampante usando il protocollo di trasmissione di stampa di rete "proprietario" di Canon",  CUPS ha queste voci. quale selezionare?

Add Printer

Local Printers:    CUPS-PDF (Virtual PDF Printer)
HP Printer (HPLIP)
HP Fax (HPLIP)
Discovered Network Printers:    Epson Stylus SX235 (EPSON EPSON Epson Stylus SX235)
Other Network Printers:    Internet Printing Protocol (https)
Backend Error Handler
AppSocket/HP JetDirect
Internet Printing Protocol (ipps)
Internet Printing Protocol (http)
Internet Printing Protocol (ipp)
LPD/LPR Host or Printer
Windows Printer via SAMBA

ciao pietro
   

Offline whoami

  • *
  • Post: 1562
  • Reputazione: 64
  • Quando c'era init i log arrivavano in orario!
    • Mostra profilo
prova a dare lpstat -p -d e posta il risultato
« Ultima modifica: 27 Febbraio 2014 ore 00:54 da whoami »
echo "VQF AHELME I BI CI WECPF"| tr "ETAOINSHRDLUBCFGJMQPVWZYXK" "A-Z"

Offline peter46

  • *
  • Post: 116
  • Reputazione: 0
    • Mostra profilo
Ciao, questa la risposta al comando, le stampanti sono entrambe accese e collegate con la rete wireless;

Codice: [Seleziona]
[pietro@chakra-pc ~]$ lpstat -p -d
printer EPSON_EPSON_Epson_Stylus_SX235 is idle.  enabled since mer 26 feb 2014 22:55:41 CET
system default destination: EPSON_EPSON_Epson_Stylus_SX235
[pietro@chakra-pc ~]$

Pietro.

Offline FranzMari

  • *
  • Post: 2812
  • Reputazione: 103
  • [Senior Packager]
    • Mostra profilo
    • IMHO blog
scusami mi sento proprio impotente, non capisco ogni cosa mi venga proposta, ho installato il pacchetto che mi hai indicato da CCR, ho riavviato il notebook, sono rientratro in CUPS ma non so quale sia la voce che mi hai indicato "entra in cups e  rileva la stampante usando il protocollo di trasmissione di stampa di rete "proprietario" di Canon",  CUPS ha queste voci. quale selezionare?

ciao pietro

Io a occhio e croce selezionerei questo:
Codice: [Seleziona]
Discovered Network Printers: Epson Stylus SX235 (EPSON EPSON Epson Stylus SX235)
«Il valore dell'essere umano si determina nella misura in cui sia grande o piccola la sua capacità di contribuire al bene collettivo.» Jigorō Kanō

 

Template by Homey | Sito ufficiale | Disclaimer