Autore Topic: Non riesco a far funzionare usb-wifi tp-link TL-wn725n  (Letto 8695 volte)

Offline ronnydaca

  • *
  • Post: 511
  • Reputazione: 1
    • Mostra profilo
Re:Non riesco a far funzionare usb-wifi tp-link TL-wn725n
« Risposta #30 il: 14 Novembre 2013 ore 22:28 »
All'avvio parte già con il processore al 55% e torna normale solo se do modprobe -r
Lo avevo attivato usando depmod -a e poi modprobe

Ora ho fatto come dici, ho riavviato e ho sempre il processore a 55% e dando il comando modprobe -r mi compare:
Citazione
libkmod: kmod_config_parse: /etc/modprobe.d/8188eu.conf line 1: ignoring bad line starting with '8188eu'

Allora do il journal...
Citazione
[ronny@chakra-pc ~]$ sudo journalctl -b | grep 8188
nov 14 22:23:28 chakra-pc systemd-modules-load[116]: libkmod: kmod_config_parse: /etc/modprobe.d/8188eu.conf line 1: ignoring bad line starting with '8188eu'
nov 14 22:23:29 chakra-pc kernel: Chip Version Info: CHIP_8188E_Normal_Chip_TSMC_A_CUT_1T1R_RomVer(0)
nov 14 22:23:29 chakra-pc kernel: usbcore: registered new interface driver r8188eu
nov 14 22:23:41 chakra-pc dkms[288]: libkmod: kmod_config_parse: /etc/modprobe.d/8188eu.conf line 1: ignoring bad line starting with '8188eu'
nov 14 22:23:41 chakra-pc NetworkManager[303]: <info> (wlp0s29f7u6): new 802.11 WiFi device (driver: 'r8188eu' ifindex: 3)
nov 14 22:24:42 chakra-pc NetworkManager[303]: <error> [1384464282.818841] [nm-supplicant-interface.c:997] interface_add_cb(): (wlp0s29f7u6): error adding interface: wpa_supplicant couldn't grab this interface.
nov 14 22:26:08 chakra-pc sudo[6331]: ronny : TTY=pts/0 ; PWD=/home/ronny ; USER=root ; COMMAND=/sbin/modprobe -r 8188eu
nov 14 22:26:08 chakra-pc kernel: usbcore: deregistering interface driver r8188eu

Offline whoami

  • *
  • Post: 1562
  • Reputazione: 64
  • Quando c'era init i log arrivavano in orario!
    • Mostra profilo
Re:Non riesco a far funzionare usb-wifi tp-link TL-wn725n
« Risposta #31 il: 15 Novembre 2013 ore 00:17 »
ooooops... con quel comando hai creato il file /etc/modprobe.d/8188eu, invece andava messo in /etc/modules-load.d/ (scusa...) infatti ti dice che il file è sbagliato! riprova dopo aver dato sudo mv /etc/modprobe.d/8188eu /etc/modules-load.d/... riavvii e vedi come va, poi riprova col Journal e con lsmod per vedere se l'ha caricato...

exit: prova a dare rfkill unblock wifi se continua a non funzionare... brute force...
« Ultima modifica: 15 Novembre 2013 ore 00:32 da whoami »
echo "VQF AHELME I BI CI WECPF"| tr "ETAOINSHRDLUBCFGJMQPVWZYXK" "A-Z"

Offline ronnydaca

  • *
  • Post: 511
  • Reputazione: 1
    • Mostra profilo
Re:Non riesco a far funzionare usb-wifi tp-link TL-wn725n
« Risposta #32 il: 15 Novembre 2013 ore 08:47 »
Preso dallo sconforto ieri ho disinstallato il pacchetto perché a ogni riavvio la cpu mi parte in quarta.
Ok, lo sto reinstallando. Quando ha finito l'installazione do direttamente echo '8188eu' > /etc/modules-load.d/8188eu.conf e riavvio.

Edit:
Appena riavviato, cpu al 65% circa con udevd al lavoro.
Ecco output di journal

Codice: [Seleziona]
nov 15 08:48:00 chakra-pc kernel: Chip Version Info: CHIP_8188E_Normal_Chip_TSMC_A_CUT_1T1R_RomVer(0)
nov 15 08:48:00 chakra-pc systemd-modules-load[115]: Inserted module '8188eu'
nov 15 08:48:00 chakra-pc kernel: usbcore: registered new interface driver r8188eu
nov 15 08:48:10 chakra-pc NetworkManager[305]: <info> (wlp0s29f7u6): new 802.11 WiFi device (driver: 'r8188eu' ifindex: 2)

E quello di lsmod
Codice: [Seleziona]
Module                  Size  Used by
joydev                  9663  0
hid_generic             1153  0
coretemp                6038  0
usbhid                 41466  0
hid                    88502  2 hid_generic,usbhid
kvm_intel             128057  0
kvm                   374351  1 kvm_intel
iTCO_wdt                5407  0
iTCO_vendor_support     1929  1 iTCO_wdt
ppdev                   7118  0
evdev                   9880  8
microcode              12852  0
psmouse                85484  0
r8169                  57576  0
serio_raw               5041  0
mii                     4059  1 r8169
i2c_i801               11173  0
i2c_core               23720  1 i2c_i801
snd_hda_codec_hdmi     29765  1
acpi_cpufreq           10374  0
snd_hda_codec_realtek    35645  1
mperf                   1203  1 acpi_cpufreq
pci_stub                1381  1
snd_hda_intel          33599  5
snd_hda_codec         147346  3 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_intel
lpc_ich                12849  0
snd_hwdep               6332  1 snd_hda_codec
parport_pc             30514  0
snd_pcm                77765  3 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel
parport                30709  2 ppdev,parport_pc
snd_page_alloc          7202  2 snd_pcm,snd_hda_intel
snd_timer              18718  1 snd_pcm
snd                    58950  17 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_hda_codec,snd_hda_intel
intel_agp              10936  0
intel_gtt              12664  1 intel_agp
soundcore               5418  1 snd
asus_atk0110           12000  0
processor              27531  1 acpi_cpufreq
vboxpci                14485  0
vboxnetflt             17452  0
vboxnetadp             18323  0
vboxdrv               262746  3 vboxnetadp,vboxnetflt,vboxpci
nfs                   127133  0
lockd                  63227  1 nfs
sunrpc                187699  2 nfs,lockd
fscache                44575  1 nfs
vhba                    9720  0
fglrx                5178445  130
amd_iommu_v2            7188  1 fglrx
button                  4669  1 fglrx
8188eu                648964  0
ext4                  454619  4
crc16                   1359  1 ext4
mbcache                 5866  1 ext4
jbd2                   81658  1 ext4
sd_mod                 30730  7
sr_mod                 14898  0
cdrom                  34880  1 sr_mod
ata_generic             3370  0
pata_acpi               3387  0
ata_piix               23352  5
libata                169030  3 pata_acpi,ata_generic,ata_piix
scsi_mod              127708  4 vhba,libata,sd_mod,sr_mod
ehci_pci                4120  0
uhci_hcd               24531  0
ehci_hcd               47576  1 ehci_pci
usbcore               177055  5 uhci_hcd,ehci_hcd,ehci_pci,usbhid,8188eu
usb_common              1648  1 usbcore

In questo momento la cpu è sempre al lavoro con systemd udevd (2 volte), wpa supplicant. La chiavetta continua a non funzionare.
Devo dare modprobe -r per calmare la cpu che arriva a picchi di 80%.
« Ultima modifica: 15 Novembre 2013 ore 08:55 da ronnydaca »

Offline whoami

  • *
  • Post: 1562
  • Reputazione: 64
  • Quando c'era init i log arrivavano in orario!
    • Mostra profilo
Re:Non riesco a far funzionare usb-wifi tp-link TL-wn725n
« Risposta #33 il: 15 Novembre 2013 ore 11:16 »
A me detta così sembra un problema del driver! Se viene caricato il sistema impazzisce e comunque non va... non è normale!!! E il journal non segnala niente... si accorge che c'è un nuovo hw, carica il modulo, viene registrata la nuova interfaccia usb e viene creata la rete wifi da NetworkManager... prova con rfkill come ti ho scritto sopra, per vedere se per qualche arcano motivo sia soft-blocked... forse però devi prima installare rfkill con pacman... e poi non so proprio che dire... hai per caso un pc con windows per vedere se lì la chiavetta va?
comunque se sei ancora nel tempo del diritto di recesso e proprio non va vedi se puoi ridarla indietro...
echo "VQF AHELME I BI CI WECPF"| tr "ETAOINSHRDLUBCFGJMQPVWZYXK" "A-Z"

Offline ronnydaca

  • *
  • Post: 511
  • Reputazione: 1
    • Mostra profilo
Re:Non riesco a far funzionare usb-wifi tp-link TL-wn725n
« Risposta #34 il: 15 Novembre 2013 ore 11:47 »
Dando rfkill unblock wifi ottengo

Citazione
Can't open RFKILL control device: No such file or directory

Offline ronnydaca

  • *
  • Post: 511
  • Reputazione: 1
    • Mostra profilo
Re:Non riesco a far funzionare usb-wifi tp-link TL-wn725n
« Risposta #35 il: 15 Novembre 2013 ore 11:47 »
Non ho nessun pc con windows. Non esiste una live che supporta già questo adattatore?

Offline whoami

  • *
  • Post: 1562
  • Reputazione: 64
  • Quando c'era init i log arrivavano in orario!
    • Mostra profilo
Re:Non riesco a far funzionare usb-wifi tp-link TL-wn725n
« Risposta #36 il: 15 Novembre 2013 ore 13:22 »
boh... ubuntu?
echo "VQF AHELME I BI CI WECPF"| tr "ETAOINSHRDLUBCFGJMQPVWZYXK" "A-Z"

Offline danyf90

  • *
  • Post: 827
  • Reputazione: 42
  • Chakra
    • Mostra profilo
Re:Non riesco a far funzionare usb-wifi tp-link TL-wn725n
« Risposta #37 il: 15 Novembre 2013 ore 13:57 »
posta l'output di
Codice: [Seleziona]
rfkill list eventualmente (visto che a me su chakra va) puoi provarla sulla live di chakra installando il pacchetto da ccr e caricando il modulo con modprobe

Offline ronnydaca

  • *
  • Post: 511
  • Reputazione: 1
    • Mostra profilo
Re:Non riesco a far funzionare usb-wifi tp-link TL-wn725n
« Risposta #38 il: 15 Novembre 2013 ore 15:44 »
Tutto ciò che scrivo con rfkill mi dice una cosa tipo (ora non l'ho davanti) such file o directory.
Praticamente non trova nulla.

La provo con la live di chakra stasera.

Offline ronnydaca

  • *
  • Post: 511
  • Reputazione: 1
    • Mostra profilo
Re:Non riesco a far funzionare usb-wifi tp-link TL-wn725n
« Risposta #39 il: 19 Novembre 2013 ore 20:34 »
Ho appena provato la tp-link in una macchina virtuale con xp. Ho installato i driver e tutto funziona perfettamente. Quindi la chiavetta non è difettosa. Ovviamente per la prova ho scollegato il cavo ethernet.
Se funziona a dany quindi ho un problema nel sistema?

Ora masterizzo una live di chakra e vedo se riesco a farla partire.

Offline danyf90

  • *
  • Post: 827
  • Reputazione: 42
  • Chakra
    • Mostra profilo
Re:Non riesco a far funzionare usb-wifi tp-link TL-wn725n
« Risposta #40 il: 28 Novembre 2013 ore 19:03 »
dopo il recente aggiornamento del kernel la chiavetta non funziona più nemmeno a me  :'( :'( :'( :'( non riesco a vedere nessuna rete, network manager vede la chiavetta ma non trova nessuna rete

Offline ronnydaca

  • *
  • Post: 511
  • Reputazione: 1
    • Mostra profilo
Re:Non riesco a far funzionare usb-wifi tp-link TL-wn725n
« Risposta #41 il: 28 Novembre 2013 ore 19:25 »
Ecco. Se riuscirai a risolvere fai un fischio.
Io l'ho provata in live. Ho installato il pacchetto e pur rilevandola, non vede nessuna rete.
La stessa chiavetta invece funziona in un xp virtualizzato dove imposti la periferica usb come attiva nella guest. Rileva la rete wifi e ti connette.
Non ho ancora provato in un’altra distribuzione. Ho manjaro in virtualbox. Magari la provo.

Nel frattempo ho optato per un tethering usb.

Offline danyf90

  • *
  • Post: 827
  • Reputazione: 42
  • Chakra
    • Mostra profilo
Re:Non riesco a far funzionare usb-wifi tp-link TL-wn725n
« Risposta #42 il: 28 Novembre 2013 ore 20:45 »
purtroppo ancora non sono riuscito a risolvere ma ho una bella notizia, dal kernel 3.12 la chiavetta dovrebbe funzionare senza installare niente ed infatti su arch va ;D non ci resta che aspettare!

Offline ronnydaca

  • *
  • Post: 511
  • Reputazione: 1
    • Mostra profilo
Re:Non riesco a far funzionare usb-wifi tp-link TL-wn725n
« Risposta #43 il: 29 Novembre 2013 ore 11:44 »
Ottimo.

Offline danyf90

  • *
  • Post: 827
  • Reputazione: 42
  • Chakra
    • Mostra profilo
Re:Non riesco a far funzionare usb-wifi tp-link TL-wn725n
« Risposta #44 il: 06 Gennaio 2014 ore 18:24 »
Confermo che con il passaggio al kernel 3.12 la chiavetta funziona senza bisogno di nessun modulo aggiuntivo :D

 

Template by Homey | Sito ufficiale | Disclaimer