Autore Topic: Non riesco a far funzionare usb-wifi tp-link TL-wn725n  (Letto 8920 volte)

Offline danyf90

  • *
  • Post: 827
  • Reputazione: 42
  • Chakra
    • Mostra profilo
Re:Non riesco a far funzionare usb-wifi tp-link TL-wn725n
« Risposta #15 il: 13 Novembre 2013 ore 18:25 »
wifi-menu che dice?

Offline ronnydaca

  • *
  • Post: 511
  • Reputazione: 1
    • Mostra profilo
Re:Non riesco a far funzionare usb-wifi tp-link TL-wn725n
« Risposta #16 il: 13 Novembre 2013 ore 18:32 »
wifi-menu dice
Codice: [Seleziona]
No such interface: wlan0

Ma prima con dsmeg tail in una riga diceva:
Codice: [Seleziona]
[  147.253646] systemd-udevd[29424]: renamed network interface wlan0 to wlp0s29f7u6
Sarà per questo che non funziona? Me l'ha rinominata?

Offline danyf90

  • *
  • Post: 827
  • Reputazione: 42
  • Chakra
    • Mostra profilo
Re:Non riesco a far funzionare usb-wifi tp-link TL-wn725n
« Risposta #17 il: 13 Novembre 2013 ore 18:39 »
Codice: [Seleziona]
sudo wifi-menu wlp0s29f7u6

Offline ronnydaca

  • *
  • Post: 511
  • Reputazione: 1
    • Mostra profilo
Re:Non riesco a far funzionare usb-wifi tp-link TL-wn725n
« Risposta #18 il: 13 Novembre 2013 ore 18:45 »
Codice: [Seleziona]
[ronny@chakra-pc ~]$ sudo wifi-menu wlp0s29f7u6
Password:
:: Scanning for networks                                                 [FAILED]
 > No networks found
[ronny@chakra-pc ~]$

Mentre mia moglie naviga con il tablet.

Offline ronnydaca

  • *
  • Post: 511
  • Reputazione: 1
    • Mostra profilo
Re:Non riesco a far funzionare usb-wifi tp-link TL-wn725n
« Risposta #19 il: 13 Novembre 2013 ore 19:48 »
Non mi abbandonate ragazzi  :'(

Offline ronnydaca

  • *
  • Post: 511
  • Reputazione: 1
    • Mostra profilo
Re:Non riesco a far funzionare usb-wifi tp-link TL-wn725n
« Risposta #20 il: 13 Novembre 2013 ore 20:12 »
Dando
Codice: [Seleziona]
[ronny@chakra-pc ~]$ ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT qlen 1000
    link/ether 00:26:18:66:03:5c brd ff:ff:ff:ff:ff:ff
3: wlp0s29f7u6: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT qlen 1000
    link/ether f8:1a:67:26:ea:23 brd ff:ff:ff:ff:ff:ff
[ronny@chakra-pc ~]$

Si può vedere che
3: wlp0s29f7u6: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT qlen 1000

Se do
Codice: [Seleziona]
[ronny@chakra-pc ~]$ sudo ip link set wlp0s29f7u6 up
RTNETLINK answers: Operation not permitted
Mi sa che il problema è questo. Spero.

Offline danyf90

  • *
  • Post: 827
  • Reputazione: 42
  • Chakra
    • Mostra profilo
Re:Non riesco a far funzionare usb-wifi tp-link TL-wn725n
« Risposta #21 il: 13 Novembre 2013 ore 21:15 »
 :-\ :-\ :-\ prova con ifconfig  :-\ :-\ :-\ :-\

Codice: [Seleziona]
sudo ifconfig wlp0s29f7u6 up

Offline danyf90

  • *
  • Post: 827
  • Reputazione: 42
  • Chakra
    • Mostra profilo
Re:Non riesco a far funzionare usb-wifi tp-link TL-wn725n
« Risposta #22 il: 13 Novembre 2013 ore 21:16 »
posta anche l'output di lsmod

Offline ronnydaca

  • *
  • Post: 511
  • Reputazione: 1
    • Mostra profilo
Re:Non riesco a far funzionare usb-wifi tp-link TL-wn725n
« Risposta #23 il: 13 Novembre 2013 ore 22:04 »
:-\ :-\ :-\ prova con ifconfig  :-\ :-\ :-\ :-\

Codice: [Seleziona]
sudo ifconfig wlp0s29f7u6 up

Ecco:
Codice: [Seleziona]
[ronny@chakra-pc ~]$ sudo ifconfig wlp0s29f7u6 up
Password:
SIOCSIFFLAGS: Operation not permitted
[ronny@chakra-pc ~]$


Output lsmod:
Codice: [Seleziona]
[ronny@chakra-pc ~]$ lsmod
Module                  Size  Used by
joydev                  9663  0
hid_generic             1153  0
8188eu                648964  0
usbhid                 41466  0
hid                    88502  2 hid_generic,usbhid
coretemp                6038  0
kvm_intel             128057  0
kvm                   374351  1 kvm_intel
iTCO_wdt                5407  0
iTCO_vendor_support     1929  1 iTCO_wdt
ppdev                   7118  0
microcode              12852  0
psmouse                85484  0
serio_raw               5041  0
i2c_i801               11173  0
i2c_core               23720  1 i2c_i801
snd_hda_codec_hdmi     29765  1
snd_hda_codec_realtek    35645  1
lpc_ich                12849  0
snd_hda_intel          33599  5
r8169                  57576  0
mii                     4059  1 r8169
snd_hda_codec         147346  3 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_intel
snd_hwdep               6332  1 snd_hda_codec
snd_pcm                77765  3 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel
snd_page_alloc          7202  2 snd_pcm,snd_hda_intel
snd_timer              18718  1 snd_pcm
snd                    58950  17 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_hda_codec,snd_hda_intel
soundcore               5418  1 snd
intel_agp              10936  0
intel_gtt              12664  1 intel_agp
parport_pc             30514  0
parport                30709  2 ppdev,parport_pc
pci_stub                1381  1
asus_atk0110           12000  0
vboxpci                14485  0
vboxnetflt             17452  0
vboxnetadp             18323  0
acpi_cpufreq           10374  0
mperf                   1203  1 acpi_cpufreq
vboxdrv               262746  3 vboxnetadp,vboxnetflt,vboxpci
processor              27531  1 acpi_cpufreq
nfs                   127133  0
evdev                   9880  8
lockd                  63227  1 nfs
sunrpc                187699  2 nfs,lockd
fscache                44575  1 nfs
vhba                    9720  0
fglrx                5178445  99
amd_iommu_v2            7188  1 fglrx
button                  4669  1 fglrx
ext4                  454619  4
crc16                   1359  1 ext4
mbcache                 5866  1 ext4
jbd2                   81658  1 ext4
sr_mod                 14898  0
cdrom                  34880  1 sr_mod
sd_mod                 30730  7
ata_generic             3370  0
pata_acpi               3387  0
ata_piix               23352  5
libata                169030  3 pata_acpi,ata_generic,ata_piix
scsi_mod              127708  4 vhba,libata,sd_mod,sr_mod
ehci_pci                4120  0
uhci_hcd               24531  0
ehci_hcd               47576  1 ehci_pci
usbcore               177055  5 uhci_hcd,ehci_hcd,ehci_pci,usbhid,8188eu
usb_common              1648  1 usbcore

Offline danyf90

  • *
  • Post: 827
  • Reputazione: 42
  • Chakra
    • Mostra profilo
Re:Non riesco a far funzionare usb-wifi tp-link TL-wn725n
« Risposta #24 il: 13 Novembre 2013 ore 23:05 »
cercando su internet credo ci sia un problema di conflitto tra driver, devi aggiungere alla blacklist quelli "vecchi" ma non so quali siano ;D

Offline whoami

  • *
  • Post: 1562
  • Reputazione: 64
  • Quando c'era init i log arrivavano in orario!
    • Mostra profilo
Re:Non riesco a far funzionare usb-wifi tp-link TL-wn725n
« Risposta #25 il: 14 Novembre 2013 ore 08:46 »
prova a dare hwinfo --wlan per vedere il dettaglio delle tue schede di rete wireless (dovresti vedere sia quella integrata che quella usb) e vedere quali driver carica per farle funzionare (quella usb dovrebbe avere come driver 8188eu) e scaricare il modulo della scheda integrata come diceva danyf con sudo modprobe -r nomedriver

ps: non mi ricordo se hwinfo è preinstallato, se no prova ad installarlo con pacman (magari ci sono altri modi per vedere i driver ma quato lo trovo comodo)
echo "VQF AHELME I BI CI WECPF"| tr "ETAOINSHRDLUBCFGJMQPVWZYXK" "A-Z"

Offline ronnydaca

  • *
  • Post: 511
  • Reputazione: 1
    • Mostra profilo
Re:Non riesco a far funzionare usb-wifi tp-link TL-wn725n
« Risposta #26 il: 14 Novembre 2013 ore 08:59 »
prova a dare hwinfo --wlan per vedere il dettaglio delle tue schede di rete wireless (dovresti vedere sia quella integrata che quella usb) e vedere quali driver carica per farle funzionare (quella usb dovrebbe avere come driver 8188eu) e scaricare il modulo della scheda integrata come diceva danyf con sudo modprobe -r nomedriver

ps: non mi ricordo se hwinfo è preinstallato, se no prova ad installarlo con pacman (magari ci sono altri modi per vedere i driver ma quato lo trovo comodo)
Buongiorno.
Io non ho un notebook. Non ho una scheda wifi integrata. Sto usando un pc fisso e ho acquistato questo adattatore wifi proprio per dotarlo di wifi.

Ecco l'output:
Codice: [Seleziona]
[ronny@chakra-pc ~]$ hwinfo --wlan
24: USB 00.0: 0282 WLAN controller                             
  [Created at usb.122]
  Unique ID: aCV0.M1BlfozBLm7
  Parent ID: zPk0.9T1GDCLyFd9
  SysFS ID: /devices/pci0000:00/0000:00:1d.7/usb4/4-6/4-6:1.0
  SysFS BusID: 4-6:1.0
  Hardware Class: network
  Model: "Realtek 802.11n NIC"
  Hotplug: USB
  Vendor: usb 0x0bda "Realtek Semiconductor Corp."
  Device: usb 0x8179 "802.11n NIC"
  Serial ID: "00E04C0001"
  Driver: "r8188eu"
  Driver Modules: "8188eu"
  Device File: wlp0s29f7u6
  Features: WLAN
  Speed: 480 Mbps
  HW Address: f8:1a:67:26:ea:23
  Link detected: no
  WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13
  WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472
  WLAN bitrates: 1 2 5.5 11
  WLAN encryption modes: TKIP CCMP
  WLAN authentication modes: open wpa-psk wpa-eap
  Module Alias: "usb:v0BDAp8179d0000dc00dsc00dp00icFFiscFFipFFin00"
  Driver Info #0:
    Driver Status: 8188eu is active
    Driver Activation Cmd: "modprobe 8188eu"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #23 (Hub)

Non riesco in nessun modo a fare l'up della scheda.

Offline ronnydaca

  • *
  • Post: 511
  • Reputazione: 1
    • Mostra profilo
Re:Non riesco a far funzionare usb-wifi tp-link TL-wn725n
« Risposta #27 il: 14 Novembre 2013 ore 11:48 »
Nessuna buona nuova? Mi dovrò rassegnare?  >:(

Offline ronnydaca

  • *
  • Post: 511
  • Reputazione: 1
    • Mostra profilo
Re:Non riesco a far funzionare usb-wifi tp-link TL-wn725n
« Risposta #28 il: 14 Novembre 2013 ore 19:38 »
Ho notato ora che ho la cpu sempre al 55% circa e vedo che i processi che la usano sono:

systemd-udevd
wpa-supplicant

Dando:
Codice: [Seleziona]
sudo modprobe -r 8188eu

Tutto ritorna alla normalità.
« Ultima modifica: 14 Novembre 2013 ore 19:40 da ronnydaca »

Offline whoami

  • *
  • Post: 1562
  • Reputazione: 64
  • Quando c'era init i log arrivavano in orario!
    • Mostra profilo
Re:Non riesco a far funzionare usb-wifi tp-link TL-wn725n
« Risposta #29 il: 14 Novembre 2013 ore 21:24 »
Ti chiedo due robe anche se non so se servano... il modulo come lo carichi? L'hai messo in avvio automatico o lo carichi a mano? Pensavo a quell'udevd che si sbatte così tanto... se facevi a mano prova invece a metterlo all'avvio (da root echo '8188eu' > /etc/modprobe.d/8188eu.conf) e riavviare e vedere cosa succede... se non va vedere il journal con sudo journalctl -b | grep 8188 per vedere se c'è qualcosa che lo fa piantare...

naturalmente è probabile che non serva a niente... :(
« Ultima modifica: 14 Novembre 2013 ore 21:26 da whoami »
echo "VQF AHELME I BI CI WECPF"| tr "ETAOINSHRDLUBCFGJMQPVWZYXK" "A-Z"

 

Template by Homey | Sito ufficiale | Disclaimer