Autore Topic: Luminosità bloccata a 0%  (Letto 1702 volte)

Offline vellerofonte

  • *
  • Post: 1374
  • Reputazione: 58
  • #Chakra: Kde for life
    • Mostra profilo
Luminosità bloccata a 0%
« il: 18 Settembre 2013 ore 21:19 »
Dopo l'aggiornamento a KDE 4.11.1 e al nuovo kernel 3.10, il mio portatile con scheda Intel non ne vuole sapere di impostare la luminosità che resta fissa allo 0%.


Non funzionano nè i tasti seconda funzione e neppure il plasmoide dove anche muovendo il cursore di regolazione non c'è nessun cambiamento di luminosità.

Offline Cylon

  • *
  • Post: 1958
  • Reputazione: 78
  • CYbernetic Life fOrm Node
    • Mostra profilo
Re:Luminosità bloccata a 0%
« Risposta #1 il: 18 Settembre 2013 ore 21:32 »
postami i file /etc/default/grub, la sezione relativa a chakra di grub.cfg e la sezione MODULES di mkinicpio.conf.

ps: a me funziona normalmente
We are the Cylons. Lower your firewalll and surrender.Your PC will adapt to service our GNU/Linux systems. Resistance is futile. Extermination of human race has began!
                                                                     Non rispondo a PM

Offline vellerofonte

  • *
  • Post: 1374
  • Reputazione: 58
  • #Chakra: Kde for life
    • Mostra profilo
Re:Luminosità bloccata a 0%
« Risposta #2 il: 18 Settembre 2013 ore 21:37 »
/etc/default/grub

Codice: [Seleziona]
GRUB_DEFAULT=saved
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="Chakra"
GRUB_CMDLINE_LINUX_DEFAULT="quiet rw"
GRUB_CMDLINE_LINUX="quiet resume=UUID=97883a79-3d23-4074-b185-bd1b0c22eaca"

grub.cfg

Codice: [Seleziona]
menuentry 'Chakra Linux' --class chakra --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-d221279f-e146-4200-a611-526c03f0f486' {
savedefault
load_video
set gfxpayload=keep
insmod gzio
insmod part_gpt
insmod ext2
set root='hd0,gpt6'
if [ x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt6 --hint-efi=hd0,gpt6 --hint-baremetal=ahci0,gpt6  d221279f-e146-4200-a611-526c03f0f486
else
  search --no-floppy --fs-uuid --set=root d221279f-e146-4200-a611-526c03f0f486
fi
echo 'Caricamento Linux linux...'
linux /boot/vmlinuz-linux root=UUID=d221279f-e146-4200-a611-526c03f0f486 ro quiet resume=UUID=97883a79-3d23-4074-b185-bd1b0c22eaca quiet rw
echo 'Caricamento ramdisk iniziale...'
initrd /boot/initramfs-linux.img
}
submenu 'Opzioni avanzate per Chakra Linux' $menuentry_id_option 'gnulinux-advanced-d221279f-e146-4200-a611-526c03f0f486' {
menuentry 'Chakra Linux, con Linux linux' --class chakra --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-linux-advanced-d221279f-e146-4200-a611-526c03f0f486' {
savedefault
load_video
set gfxpayload=keep
insmod gzio
insmod part_gpt
insmod ext2
set root='hd0,gpt6'
if [ x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt6 --hint-efi=hd0,gpt6 --hint-baremetal=ahci0,gpt6  d221279f-e146-4200-a611-526c03f0f486
else
  search --no-floppy --fs-uuid --set=root d221279f-e146-4200-a611-526c03f0f486
fi
echo 'Caricamento Linux linux...'
linux /boot/vmlinuz-linux root=UUID=d221279f-e146-4200-a611-526c03f0f486 ro quiet resume=UUID=97883a79-3d23-4074-b185-bd1b0c22eaca quiet rw
echo 'Caricamento ramdisk iniziale...'
initrd /boot/initramfs-linux.img
}
menuentry 'Chakra Linux, con Linux linux (modalità ripristino)' --class chakra --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-linux-recovery-d221279f-e146-4200-a611-526c03f0f486' {
load_video
set gfxpayload=keep
insmod gzio
insmod part_gpt
insmod ext2
set root='hd0,gpt6'
if [ x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt6 --hint-efi=hd0,gpt6 --hint-baremetal=ahci0,gpt6  d221279f-e146-4200-a611-526c03f0f486
else
  search --no-floppy --fs-uuid --set=root d221279f-e146-4200-a611-526c03f0f486
fi
echo 'Caricamento Linux linux...'
linux /boot/vmlinuz-linux root=UUID=d221279f-e146-4200-a611-526c03f0f486 ro single quiet resume=UUID=97883a79-3d23-4074-b185-bd1b0c22eaca
echo 'Caricamento ramdisk iniziale...'
initrd /boot/initramfs-linux.img
}
}

mkinicpio.conf

Codice: [Seleziona]
MODULES="ahci libahci xhci-hcd ehci-hcd asus-nb-wmi"

Offline Cylon

  • *
  • Post: 1958
  • Reputazione: 78
  • CYbernetic Life fOrm Node
    • Mostra profilo
Re:Luminosità bloccata a 0%
« Risposta #3 il: 18 Settembre 2013 ore 21:51 »
aggiungi a MODULES i915 (questo è il mio)

Codice: [Seleziona]
MODULES="i915 asus-nb-wmi ahci libahci xhci-hcd ehci-hcd"
rigenera initramfs

aggiungi acpi_osi=

alla riga del kernel di chakra un grub.cfg

Citazione
   linux   /boot/vmlinuz-linux root=UUID=d221279f-e146-4200-a611-526c03f0f486 ro quiet resume=UUID=97883a79-3d23-4074-b185-bd1b0c22eaca quiet rw acpi_osi=

correggila perché è incasinata ci sono 2 quiet e un ro e rw. o l'hai fatta tu cosi? sulla stessa riga oltre all'UUID di root c'è anche quello di resume, why?

hai controllato poi se la nuova polita di gestione delle frequenze di intel non ti scalda il portatile? ora non stà mai alla frequanza minima ma oscilla continuamente dalla minima alla max, se vuoi riprestinare la veccia maniera devi aggiungere un'altra stringa alla riga del kernel di avvio di chakra.
« Ultima modifica: 18 Settembre 2013 ore 21:53 da Cylon »
We are the Cylons. Lower your firewalll and surrender.Your PC will adapt to service our GNU/Linux systems. Resistance is futile. Extermination of human race has began!
                                                                     Non rispondo a PM

Offline vellerofonte

  • *
  • Post: 1374
  • Reputazione: 58
  • #Chakra: Kde for life
    • Mostra profilo
Re:Luminosità bloccata a 0%
« Risposta #4 il: 18 Settembre 2013 ore 22:13 »
aggiungi a MODULES i915 (questo è il mio)

Codice: [Seleziona]
MODULES="i915 asus-nb-wmi ahci libahci xhci-hcd ehci-hcd"
rigenera initramfs

aggiungi acpi_osi=

alla riga del kernel di chakra un grub.cfg

correggila perché è incasinata ci sono 2 quiet e un ro e rw. o l'hai fatta tu cosi? sulla stessa riga oltre all'UUID di root c'è anche quello di resume, why?

hai controllato poi se la nuova polita di gestione delle frequenze di intel non ti scalda il portatile? ora non stà mai alla frequanza minima ma oscilla continuamente dalla minima alla max, se vuoi riprestinare la veccia maniera devi aggiungere un'altra stringa alla riga del kernel di avvio di chakra.

Grazie Cylon risolto perfettamente, credo che l'ultimo sudo update-grub dato dopo l'aggiornamento abbia piallato via le modifiche fatte su grub.cfg dopo l'installazione di Chakra, ecco perchè non bisognerebbe mai toccare quel file...

Comunque riguardo alla configurazione della riga, non l'ho modificata direttamente (eccetto l'aggiunta che mi hai suggerito), quella stringa è strutturata esattamente nel medesimo modo anche sul pc desktop  :-\

La tua stringa relativa al kernel com'è fatta?

Quanto alle temperature del processore grafico non le ho controllate (in realtà non ho strumenti per farlo, tu che pacchetto usi?),  non mi accorgo per ora di un maggior riscaldamento del portatile che continua ad essere silenzioso come fosse spento  :-\

Offline Cylon

  • *
  • Post: 1958
  • Reputazione: 78
  • CYbernetic Life fOrm Node
    • Mostra profilo
Re:Luminosità bloccata a 0%
« Risposta #5 il: 18 Settembre 2013 ore 22:23 »
io infatti non aggiorno quasi mai grub... lo modifico a mano, ;D .. comunque ne conservo sempre una copia di backup ;D

la mia stringa è questa:

Codice: [Seleziona]
linux /boot/vmlinuz-linux root=UUID=3621c9fc-a9d9-40af-890e-5d1dd06969a6 rw acpi_osi=
quando avevo corretto l'errore del resume al boot avevo aggiornato il grub e la riga GRUB_CMDLINE_LINUX è esattamente uguale alla tua.

per conoscere il driver che gestisce il gestisce il gorvernor dello scaling della cpu:

Codice: [Seleziona]
  cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_driver
 
    * acpi-cpufreq - se è gestito dal kernel.
    * intel_pstate - se è gestito dalla cpu.

invece se vuoi vedere le frequenze dei core della cpu dai nella konsole:

Codice: [Seleziona]
watch 'grep "cpu MHz" /proc/cpuinfo'
« Ultima modifica: 18 Settembre 2013 ore 22:25 da Cylon »
We are the Cylons. Lower your firewalll and surrender.Your PC will adapt to service our GNU/Linux systems. Resistance is futile. Extermination of human race has began!
                                                                     Non rispondo a PM

Offline danyf90

  • *
  • Post: 827
  • Reputazione: 42
  • Chakra
    • Mostra profilo
Re:Luminosità bloccata a 0%
« Risposta #6 il: 19 Settembre 2013 ore 11:30 »
Cylon grazie della segnalazione non mi ero accorto delle frequenze che andavano su e giù (molto su e poco giù, stavano quasi sempre al massimo). Aggiungendo intel_pstate=disable adesso quando non serve stanno al minimo ;D

Offline vellerofonte

  • *
  • Post: 1374
  • Reputazione: 58
  • #Chakra: Kde for life
    • Mostra profilo
Re:Luminosità bloccata a 0%
« Risposta #7 il: 19 Settembre 2013 ore 11:37 »
Cylon grazie della segnalazione non mi ero accorto delle frequenze che andavano su e giù (molto su e poco giù, stavano quasi sempre al massimo). Aggiungendo intel_pstate=disable adesso quando non serve stanno al minimo ;D

Dove andrebbe fatta esattamente la modifica?

inoltre andrebbe fatta solo se  driver il che gestisce il gorvernor dello scaling della cpu è intel_pstate?

Offline Cylon

  • *
  • Post: 1958
  • Reputazione: 78
  • CYbernetic Life fOrm Node
    • Mostra profilo
Re:Luminosità bloccata a 0%
« Risposta #8 il: 19 Settembre 2013 ore 11:42 »
nella riga del kernel di grub.cfg relativa a chakra.. mi sono dimenticato di scriverlo  ;D ;D ;D

Citazione
inoltre andrebbe fatta solo se  driver il che gestisce il gorvernor dello scaling della cpu è intel_pstate?
ovvio solo nel caso che sia gestita dalla cpu e non dal kernel.

PS: ricordate di aggiungerlo anche alla riga di /etc/default/grub, cosi da evitare di "perderlo" se aggiornate grub

Codice: [Seleziona]
GRUB_CMDLINE_LINUX_DEFAULT="quiet rw intel_pstate=disable"
edit: a me comunque, su chakra, il governor lo gestisce il kernel senza modificare nulla.
« Ultima modifica: 19 Settembre 2013 ore 12:41 da Cylon »
We are the Cylons. Lower your firewalll and surrender.Your PC will adapt to service our GNU/Linux systems. Resistance is futile. Extermination of human race has began!
                                                                     Non rispondo a PM

Offline danyf90

  • *
  • Post: 827
  • Reputazione: 42
  • Chakra
    • Mostra profilo
Re:Luminosità bloccata a 0%
« Risposta #9 il: 19 Settembre 2013 ore 13:38 »
edit: a me comunque, su chakra, il governor lo gestisce il kernel senza modificare nulla.

questo non lo so al momento sono su arch

 

Template by Homey | Sito ufficiale | Disclaimer