Autore Topic: ASUS S500CA - audio in cuffia assente  (Letto 2740 volte)

Offline vellerofonte

  • *
  • Post: 1374
  • Reputazione: 58
  • #Chakra: Kde for life
    • Mostra profilo
ASUS S500CA - audio in cuffia assente
« il: 17 Agosto 2013 ore 20:10 »
Notebook con Windows 8  e Chakra, solo sotto Chakra nel momento in cui infilo il jack delle cuffie l'audio non fa lo switch automatico sulle cuffie che non producono alcun suono, la cosa avviene con svariate cuffie / auricolari (escluso quindi il problema alle cuffie), non accade sotto windows 8 (escluso quindi il problema hardware).

Cosa molto curiosa: se infilo il jack delle cuffie solo parzialmente e non sino in fondo, l'audio viene trasmesso in cuffia regolarmente.... :o

Già controllato i volumi in alsamixer e provato ad attuare la soluzione proposta da dinolib in questo 3d: http://forum.chakra-project.it/index.php/topic,4629.msg28807.html#msg28807

ovviamente senza risultati...
« Ultima modifica: 17 Agosto 2013 ore 20:26 da vellerofonte »

Offline Cylon

  • *
  • Post: 1958
  • Reputazione: 78
  • CYbernetic Life fOrm Node
    • Mostra profilo
Re:ASUS S500CA - audio in cuffia assente
« Risposta #1 il: 17 Agosto 2013 ore 20:41 »
posta cosa ti restituisce

Codice: [Seleziona]
cat /etc/modprobe.d/snd-hda-intel
We are the Cylons. Lower your firewalll and surrender.Your PC will adapt to service our GNU/Linux systems. Resistance is futile. Extermination of human race has began!
                                                                     Non rispondo a PM

Offline vellerofonte

  • *
  • Post: 1374
  • Reputazione: 58
  • #Chakra: Kde for life
    • Mostra profilo
Re:ASUS S500CA - audio in cuffia assente
« Risposta #2 il: 17 Agosto 2013 ore 22:14 »
posta cosa ti restituisce

Codice: [Seleziona]
cat /etc/modprobe.d/snd-hda-intel

Codice: [Seleziona]
cat: /etc/modprobe.d/snd-hda-intel: File o directory non esistente

Offline Cylon

  • *
  • Post: 1958
  • Reputazione: 78
  • CYbernetic Life fOrm Node
    • Mostra profilo
Re:ASUS S500CA - audio in cuffia assente
« Risposta #3 il: 17 Agosto 2013 ore 22:39 »
dai i comandi che seguono e posta cosa restituiscono:

Codice: [Seleziona]
lspci | grep -i Audio
Codice: [Seleziona]
aplay -l
Codice: [Seleziona]
cat /proc/asound/card*/codec* | grep Codec
Codice: [Seleziona]
cat /proc/asound/card*/codec* | grep name
Codice: [Seleziona]
lsmod | grep '^snd' | column -t
We are the Cylons. Lower your firewalll and surrender.Your PC will adapt to service our GNU/Linux systems. Resistance is futile. Extermination of human race has began!
                                                                     Non rispondo a PM

Offline vellerofonte

  • *
  • Post: 1374
  • Reputazione: 58
  • #Chakra: Kde for life
    • Mostra profilo
Re:ASUS S500CA - audio in cuffia assente
« Risposta #4 il: 17 Agosto 2013 ore 22:45 »
dai i comandi che seguono e posta cosa restituiscono:

Codice: [Seleziona]
lspci | grep -i Audio

Codice: [Seleziona]
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)


Codice: [Seleziona]
aplay -l

Codice: [Seleziona]
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: VT1802 Analog [VT1802 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 2: VT1802 Alt Analog [VT1802 Alt Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Codice: [Seleziona]
cat /proc/asound/card*/codec* | grep Codec

Codice: [Seleziona]
Codec: VIA VT1802
Codec: Intel PantherPoint HDMI

Codice: [Seleziona]
cat /proc/asound/card*/codec* | grep name

Codice: [Seleziona]
  Control: name="Headphone Playback Volume", index=0, device=0
  Device: name="VT1802 Analog", type="Audio", device=0
  Device: name="VT1802 Alt Analog", type="Audio", device=2
  Control: name="Speaker Playback Volume", index=0, device=0
  Control: name="Capture Volume", index=0, device=0
  Control: name="Capture Switch", index=0, device=0
  Device: name="VT1802 Analog", type="Audio", device=0
  Control: name="Speaker Playback Switch", index=0, device=0
  Control: name="Speaker Phantom Jack", index=0, device=0
  Control: name="Headphone Playback Switch", index=0, device=0
  Control: name="Front Headphone Jack", index=0, device=0
  Control: name="Mic Boost Volume", index=0, device=0
  Control: name="Mic Phantom Jack", index=0, device=0
  Control: name="HDMI/DP,pcm=3 Jack", index=0, device=0
  Control: name="IEC958 Playback Con Mask", index=0, device=0
  Control: name="IEC958 Playback Pro Mask", index=0, device=0
  Control: name="IEC958 Playback Default", index=0, device=0
  Control: name="IEC958 Playback Switch", index=0, device=0
  Control: name="ELD", index=0, device=3

Codice: [Seleziona]
lsmod | grep '^snd' | column -t

Codice: [Seleziona]
snd_hda_codec_hdmi  29298   1
snd_hda_codec_via   19791   1
snd_hda_intel       34138   3
snd_hda_codec       145704  3   snd_hda_codec_hdmi,snd_hda_codec_via,snd_hda_intel
snd_hwdep           6364    1   snd_hda_codec
snd_pcm             76860   3   snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel
snd_page_alloc      7298    2   snd_pcm,snd_hda_intel
snd_timer           18687   1   snd_pcm
snd                 58893   13  snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_hda_codec_via,snd_pcm,snd_hda_codec,snd_hda_intel

Offline Cylon

  • *
  • Post: 1958
  • Reputazione: 78
  • CYbernetic Life fOrm Node
    • Mostra profilo
Re:ASUS S500CA - audio in cuffia assente
« Risposta #5 il: 17 Agosto 2013 ore 23:00 »
mbo... avevo un problema simile nel vecchio portatile... devo recuperare i file di quello che avevo fatto.. si mi scrivo sempre le cose che faccio al sistema :)
« Ultima modifica: 17 Agosto 2013 ore 23:02 da Cylon »
We are the Cylons. Lower your firewalll and surrender.Your PC will adapt to service our GNU/Linux systems. Resistance is futile. Extermination of human race has began!
                                                                     Non rispondo a PM

Offline vellerofonte

  • *
  • Post: 1374
  • Reputazione: 58
  • #Chakra: Kde for life
    • Mostra profilo
R: Re:ASUS S500CA - audio in cuffia assente
« Risposta #6 il: 17 Agosto 2013 ore 23:04 »
mbo... avevo un problema simile nel vecchio portatile... devo recuperare i file di quello che avevo fatto.. si mi scrivo sempre le cose che faccio al sistema :)

Siamo in due :))

Inviato dal mio GT-I9300 con Tapatalk 2


Offline AlmAck

  • *
  • Post: 360
  • Reputazione: 42
    • Mostra profilo
    • AlmAck.ch
Re:ASUS S500CA - audio in cuffia assente
« Risposta #7 il: 17 Agosto 2013 ore 23:42 »
a me la cosa spuzza di pulseaudio, non è che fa lo switch su un'altro canale, o che imposta un volume/muto in modo sbagliato?
pulseaudio ha diverse configurazioni, normalmente quelle di default funzionano per tutti ma magari qualche eccezione c'è.
Prova con una LiveISO per vedere se riesci a riprodurre il problema.

Offline vellerofonte

  • *
  • Post: 1374
  • Reputazione: 58
  • #Chakra: Kde for life
    • Mostra profilo
Re:ASUS S500CA - audio in cuffia assente
« Risposta #8 il: 20 Agosto 2013 ore 23:25 »
Dovrei aver risolto:

da un terminale ho avviato alsamixer dando

Codice: [Seleziona]
alsamixer
Premuto F6 che corrisponde all'opzione: "Select sound card"

Nel mio caso la scheda è: HDA Intel PCH

Selezionata la scheda, ho premuto F5 che corrisponde all'opzione: "View All"

Mi sono portato in corrispondenza dell'item: "Auto-Mute" impostandolo su "Disabled"

Ora l'audio viene trasmesso tranquillamente in cuffia  8)

Se l'audio fosse riprodotto contemporaneamente in cuffia e dagli speaker editare il file analog-output-headphones.conf

Codice: [Seleziona]
sudo nano /usr/share/pulseaudio/alsa-mixer/paths/analog-output-headphones.conf
nel modo che segue

Codice: [Seleziona]
[Element Speaker]
switch = off
volume = off
« Ultima modifica: 21 Agosto 2013 ore 05:58 da vellerofonte »

 

Template by Homey | Sito ufficiale | Disclaimer