Autore Topic: Nexus 4 e MTP non funzionante  (Letto 3847 volte)

Offline danyf90

  • *
  • Post: 827
  • Reputazione: 42
  • Chakra
    • Mostra profilo
Nexus 4 e MTP non funzionante
« il: 13 Giugno 2013 ore 20:33 »
Come da titolo ho problemi con il mio nuovo Nexus 4 ed MTP.
In pratica da dolphin posso vedere i file ma le varie operazioni non vanno a buon fine. Inoltre vedo anche file che non ci sono più e non vedo file che adesso ci sono ma alla prima connessione non c'erano  :-\

ho letto le altre discusioni sul forum e ho installato sia kio-mtp-git che mtpfs.

Anche usando qtmtp da ccr niente

cosa posso fare?  :'(

Offline danyf90

  • *
  • Post: 827
  • Reputazione: 42
  • Chakra
    • Mostra profilo
Re:Nexus 4 e MTP non funzionante
« Risposta #1 il: 17 Giugno 2013 ore 17:49 »
nessun altro ha problemi con MTP?  :'(

Offline kdekda

  • *
  • Post: 441
  • Reputazione: 22
    • Mostra profilo
R: Nexus 4 e MTP non funzionante
« Risposta #2 il: 17 Giugno 2013 ore 20:22 »
Proprio oggi stavo provando ad connettere un nexus 7. Viene correttamente rilevato ma non riesco ad accedere a nessun file salvato

Inviato dal mio HTC Sensation con Tapatalk 2

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Nexus 4 e MTP non funzionante
« Risposta #3 il: 24 Agosto 2013 ore 18:25 »
novità con MTP?

oggi ho provato con un galaxy S, sembra che trovi il telefono in dolphin, ma non vi accede/non trova nulla.

dmesg ha una quintalata di messaggi riguardo usb che non so da dove partire.

Giusto un estratto:
Codice: [Seleziona]
[67117.441973] usb 4-3: USB disconnect, device number 6
[67122.161338] usb 4-3: new high-speed USB device number 7 using ehci-pci
[67122.287515] cdc_acm 4-3:1.1: This device cannot do calls on its own. It is not a modem.
[67122.287607] cdc_acm 4-3:1.1: ttyACM0: USB ACM device
[68185.805403] usb 4-3: usbfs: process 23985 (python2) did not claim interface 0 before use
[68185.915181] usb 4-3: reset high-speed USB device number 7 using ehci-pci
[68186.039722] cdc_acm 4-3:1.1: This device cannot do calls on its own. It is not a modem.
[68186.039836] cdc_acm 4-3:1.1: ttyACM0: USB ACM device
[68186.040161] usb 4-3: usbfs: process 23985 (python2) did not claim interface 0 before use
[68186.049565] usb 4-3: usbfs: process 22959 (EMT) did not claim interface 0 before use
[68186.206762] usb 4-3: usbfs: process 22959 (EMT) did not claim interface 0 before use
[68186.218670] usb 4-3: usbfs: process 22959 (EMT) did not claim interface 0 before use
[68187.220078] usb 4-3: usbfs: process 22959 (EMT) did not claim interface 0 before use
[68187.297539] usb 4-3: usbfs: process 22959 (EMT) did not claim interface 0 before use
[68188.256652] usb 4-3: usbfs: process 22959 (EMT) did not claim interface 0 before use
[68189.292419] usb 4-3: usbfs: process 22959 (EMT) did not claim interface 0 before use
[68190.323140] usb 4-3: usbfs: process 22959 (EMT) did not claim interface 0 before use
[68191.374066] usb 4-3: usbfs: process 22959 (EMT) did not claim interface 0 before use
[68192.411854] usb 4-3: usbfs: process 22959 (EMT) did not claim interface 0 before use
[68642.007881] usb 4-3: usbfs: process 22959 (EMT) did not claim interface 0 before use
[68759.690473] usb 4-3: usbfs: process 22959 (EMT) did not claim interface 2 before use
[68761.266602] usb 4-3: usbfs: process 22959 (EMT) did not claim interface 2 before use
[68762.282594] usb 4-3: usbfs: process 22959 (EMT) did not claim interface 1 before use
[68811.570677] usb 4-3: usbfs: process 22959 (EMT) did not claim interface 2 before use
[68917.125590] usb 4-3: reset high-speed USB device number 7 using ehci-pci
[68917.250868] cdc_acm 4-3:1.1: This device cannot do calls on its own. It is not a modem.
[68917.250953] cdc_acm 4-3:1.1: ttyACM0: USB ACM device
[68947.274506] usb 4-3: USB disconnect, device number 7
[68952.818996] usb 4-3: new high-speed USB device number 8 using ehci-pci
[68952.945915] cdc_acm 4-3:1.1: This device cannot do calls on its own. It is not a modem.
[68952.946006] cdc_acm 4-3:1.1: ttyACM0: USB ACM device
[68958.431974] usb 4-3: usbfs: process 24352 (kio_mtp) did not claim interface 0 before use
[68958.562303] usb 4-3: reset high-speed USB device number 8 using ehci-pci
[68958.686596] cdc_acm 4-3:1.1: This device cannot do calls on its own. It is not a modem.
[68958.686688] cdc_acm 4-3:1.1: ttyACM0: USB ACM device
[68958.695100] usb 4-3: usbfs: process 24352 (kio_mtp) did not claim interface 0 before use
[68961.927062] usb 4-3: usbfs: process 24359 (kio_mtp) did not claim interface 0 before use

Offline andreazube

  • *
  • Post: 1595
  • Reputazione: 64
  • I AM THE INTERSECT
    • Mostra profilo
    • Lupo mannaro
Re:Nexus 4 e MTP non funzionante
« Risposta #4 il: 24 Agosto 2013 ore 18:39 »
Non è una soluzione, ma meglio di niente: provate ad installare [spoiler]airdroid : permette di fare molte cose attraverso il browser del pc, tra le quali gestire le cartelle. Personalmente mi ci trovo più che bene. Certo, bisogna essere a casa o comunque dove ci sia un wifi senza limiti, altrimenti non è che convenga molto  :P[/spoiler]


Con l'mtp ci sono diventato pazzo, ho provato di tutto, ma rimane il fatto che a volte lo trova e a volte no, e quando lo trova è in sola lettura  >:(
Eppure non penso sia  colpa di KDE, niente da fare neanche con altri tool.
« Ultima modifica: 24 Agosto 2013 ore 18:41 da andreazube »

Offline FranzMari

  • *
  • Post: 2808
  • Reputazione: 103
  • [Senior Packager]
    • Mostra profilo
    • IMHO blog
Re:Nexus 4 e MTP non funzionante
« Risposta #5 il: 24 Agosto 2013 ore 22:24 »
A me funziona benissimo  :-\
«Il valore dell'essere umano si determina nella misura in cui sia grande o piccola la sua capacità di contribuire al bene collettivo.» Jigorō Kanō

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Nexus 4 e MTP non funzionante
« Risposta #6 il: 25 Agosto 2013 ore 08:04 »
Franz, raccontaci tutto!  ;D

Cosa hai installato? Lo usi da dolphin? Che versione Android hai, telefono, ROM? Posti il log del kernel quando colleghi il cavo USB?

PS OT: x la cronaca, titanium backup se non sei root non parte proprio!!  >:(
risolto in altro modo (dropbox x foto, indirizzi su gmail, x gli sms c'è un'app...)

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Nexus 4 e MTP non funzionante
« Risposta #7 il: 26 Agosto 2013 ore 12:45 »
Piccolo aggiornamento: ieri ho attaccato il telefono di mia moglie (unico android in casa) e a differenza delle altre volte sono riuscito a leggerne il contenuto senza strani errori!
Purtroppo la proprietaria aveva fretta e non ho potuto fare prove più approfondite. Unica cosa che ho fatto è stato cambiare la porta USB.

Ieri, fra l'altro, mi sono preso un tab2 (regalo di compleanno in ritardo  8)). Stasera posso quindi provare se anche con questo funziona l'MTP  ;D  Se non sbaglio ha su android 4, giusto? (che sega che sono con il mobile!  ;D ;D)

Offline FranzMari

  • *
  • Post: 2808
  • Reputazione: 103
  • [Senior Packager]
    • Mostra profilo
    • IMHO blog
Re:Nexus 4 e MTP non funzionante
« Risposta #8 il: 26 Agosto 2013 ore 12:53 »
Franz, raccontaci tutto!  ;D

Cosa hai installato? Lo usi da dolphin? Che versione Android hai, telefono, ROM? Posti il log del kernel quando colleghi il cavo USB?
Stasera posto tutto!
«Il valore dell'essere umano si determina nella misura in cui sia grande o piccola la sua capacità di contribuire al bene collettivo.» Jigorō Kanō

Offline danyf90

  • *
  • Post: 827
  • Reputazione: 42
  • Chakra
    • Mostra profilo
Re:Nexus 4 e MTP non funzionante
« Risposta #9 il: 26 Agosto 2013 ore 13:48 »
Piccolo aggiornamento: ieri ho attaccato il telefono di mia moglie (unico android in casa) e a differenza delle altre volte sono riuscito a leggerne il contenuto senza strani errori!
Purtroppo la proprietaria aveva fretta e non ho potuto fare prove più approfondite. Unica cosa che ho fatto è stato cambiare la porta USB.

Ieri, fra l'altro, mi sono preso un tab2 (regalo di compleanno in ritardo  8)). Stasera posso quindi provare se anche con questo funziona l'MTP  ;D  Se non sbaglio ha su android 4, giusto? (che sega che sono con il mobile!  ;D ;D)

a leggere non ho problemi (di solito) finché non tento di scrivere qualcosa, da quel momento non funziona più niente  >:(

Offline danyf90

  • *
  • Post: 827
  • Reputazione: 42
  • Chakra
    • Mostra profilo
Re:Nexus 4 e MTP non funzionante
« Risposta #10 il: 20 Marzo 2014 ore 10:47 »
Noto con piacere che adesso mtp funziona senza problemi  ;D

l'unica cosa è che dolphin mostra più icone per lo stesso device (vedi allegato), idee?

Offline senso42

  • *
  • Post: 580
  • Reputazione: -4
    • Mostra profilo
Re:Nexus 4 e MTP non funzionante
« Risposta #11 il: 28 Marzo 2014 ore 11:36 »
Buongiorno a tutti, sto sempre qui a chiedere  :D
Vorrei capire questa funzione MTP come farla funzionare.
Ho il mio telefono collegato in usb, un HTC, che non viene rilevato, ma ha la MTP attiva e non so da dove cominciare per vederla su dolphin.
Mi manca qualcosa?

EDIT: ok risolto.  8)
« Ultima modifica: 28 Marzo 2014 ore 12:00 da senso42 »

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Nexus 4 e MTP non funzionante
« Risposta #12 il: 12 Maggio 2014 ore 14:17 »
Non capisco perchè con il moto g (andr. 4.4) mtp non parta. Il telefono si accorge della connessione e dice dispositivo multimediale (MTP), ma Chakra non dice niente.

Il tab2 non mi da problemi (andr. 4.2). A qualcuno di voi capita?

lsusb mi dice: Bus 001 Device 012: ID 22b8:2e82 Motorola PCS

Ho installato ovviamente libmtp e kio-mtp-git.

Fate sapere  :-\

Offline dongongo

  • *
  • Post: 445
  • Reputazione: 16
    • Mostra profilo
Re:Nexus 4 e MTP non funzionante
« Risposta #13 il: 12 Maggio 2014 ore 22:48 »
Stesso identico problema. Ho dovuto virtualizzare windows per il moto g. :(



Offline danyf90

  • *
  • Post: 827
  • Reputazione: 42
  • Chakra
    • Mostra profilo
Re:Nexus 4 e MTP non funzionante
« Risposta #14 il: 12 Maggio 2014 ore 23:14 »
A me adesso MTP sembra funzionare ma ormai preferisco utilizzare adb almeno sono sicuro che funziona  ;D

 

Template by Homey | Sito ufficiale | Disclaimer