Autore Topic: problema con la stampante canon in wlan  (Letto 8491 volte)

Offline microfilm

  • *
  • Post: 55
  • Reputazione: 0
    • Mostra profilo
Re:problema con la stampante canon in wlan
« Risposta #30 il: 09 Aprile 2013 ore 19:09 »
Hai installato il pacchetto cups-bjnp o no?

si.

sono d'accordo co te nel fatto che tanti e fortunatamente quesi tutti i pacchetti si installano in 1 minuto,
ma ti ripeto io ho scaricato il file da qui:
Citazione
http://www.canon.it/Support/Consumer_Products/products/Fax__Multifunctionals/InkJet/PIXMA_MG_series/PIXMA_MG5350.aspx?type=download&page=1
e quello che mi dici te che non funziona e aggiornato da AUR non l'ho preso in considerazione, ora,  dal link che ho appena postato, scarico il pacchetto lo decomprimo con ARK e poi nn riesco più a proseguire nell installazione.

Citazione
Citazione da: microfilm - Oggi alle 18:34


    in ogni caso la guida mi da problemi il pacchetto build-essential non si installa  il readme del file che ho scaricato dal sito originale canon mi dice questo:

Si, naturalmente ho già letto il readme, altrimenti non avrei detto che non riesco a compilarlo, ma che non ci ho provato a compilarlo... in ogni caso, può essere utile ad altri, quindi ok.

il readme in questione è del pacchetto del sito originale canon
questo lo sapevi vero?
(prima quando mi riferivo che leggi metà dei miei post intendevo questo)
non ti riferisci al readme del pacchetto che non riesci a compilare da AUR...

Offline andreazube

  • *
  • Post: 1595
  • Reputazione: 64
  • I AM THE INTERSECT
    • Mostra profilo
    • Lupo mannaro
Re:problema con la stampante canon in wlan
« Risposta #31 il: 09 Aprile 2013 ore 19:22 »
si.

sono d'accordo co te nel fatto che tanti e fortunatamente quesi tutti i pacchetti si installano in 1 minuto,
ma ti ripeto io ho scaricato il file da qui: e quello che mi dici te che non funziona e aggiornato da AUR non l'ho preso in considerazione, ora,  dal link che ho appena postato, scarico il pacchetto lo decomprimo con ARK e poi nn riesco più a proseguire nell installazione.

Cosa ho detto io che non funziona? Ho detto di aspettare che il manteiner di AUR aggiorni...
E ti ho detto pure che nemmeno io ci riesco (dal file .tar.gz preso dal sito ufficiale, per essere chiari), e sinceramente l'ho detto più di una volta quindi pensavo di essere stato chiaro

Citazione
il readme in questione è del pacchetto del sito originale canon[/u] questo lo sapevi vero?
(prima quando mi riferivo che leggi metà dei miei post intendevo questo)
non ti riferisci al readme del pacchetto che non riesci a compilare da AUR...



Ovviamente mi riferivo all'archivio (ammazza oh) sul sito ufficiale, mi pare che sia piuttosto chiaro
Se vuoi provare a fare manualmente, scarica da qui, quindi estrai il file scaricato e apri il terminale dentro la cartella estratta. (non funziona, almeno a me)

p.s. un PKGBUILD non ha un readme, quindi  è ancora più ovvio che mi riferivo al .tar.gz...
« Ultima modifica: 09 Aprile 2013 ore 19:25 da andreazube »

Offline microfilm

  • *
  • Post: 55
  • Reputazione: 0
    • Mostra profilo
Re:problema con la stampante canon in wlan
« Risposta #32 il: 09 Aprile 2013 ore 19:28 »
grazie, rimango in attesa fiducioso!

Offline FranzMari

  • *
  • Post: 2810
  • Reputazione: 103
  • [Senior Packager]
    • Mostra profilo
    • IMHO blog
Re:problema con la stampante canon in wlan
« Risposta #33 il: 09 Aprile 2013 ore 19:30 »
si.

sono d'accordo co te nel fatto che tanti e fortunatamente quesi tutti i pacchetti si installano in 1 minuto,
ma ti ripeto io ho scaricato il file da qui:

A giudicare dal contenuto del file readme che hai postato, direi che hai scaricato il file sbagliato.
Dato che all'indirizzo da te indicato sono presenti 6 diversi pacchetti, potresti dirci quale hai scaricato di preciso?
«Il valore dell'essere umano si determina nella misura in cui sia grande o piccola la sua capacità di contribuire al bene collettivo.» Jigorō Kanō


Offline FranzMari

  • *
  • Post: 2810
  • Reputazione: 103
  • [Senior Packager]
    • Mostra profilo
    • IMHO blog
Re:problema con la stampante canon in wlan
« Risposta #35 il: 09 Aprile 2013 ore 19:46 »
Bene, abbiamo appurato che per la Canon Linux = Red Hat.
Da quell'archivio si possono "costruire" solo rpm...che sola...

A giudicare dal nome del pacchetto, direi che puoi provare ad installare cnijfilter-common-x86_64, presente su ccr: è una versione meno recente, ma potrebbe comunque funzionare.

Codice: [Seleziona]
ccr -S --noedit cnijfilter-common-x86_64
«Il valore dell'essere umano si determina nella misura in cui sia grande o piccola la sua capacità di contribuire al bene collettivo.» Jigorō Kanō

Offline andreazube

  • *
  • Post: 1595
  • Reputazione: 64
  • I AM THE INTERSECT
    • Mostra profilo
    • Lupo mannaro
Re:problema con la stampante canon in wlan
« Risposta #36 il: 09 Aprile 2013 ore 19:50 »
@franz Sinceramente non credo, perchè se vedi il link è
http://www.canon.dk/Support/Consumer_Products/products/Fax__Multifunctionals/InkJet/PIXMA_MP_series/MP495.aspx?type=download&page=1

Da notare il "MP_series" mentre lui ha un MG... si può tentare, ma sono dubbioso sinceramente

Offline FranzMari

  • *
  • Post: 2810
  • Reputazione: 103
  • [Senior Packager]
    • Mostra profilo
    • IMHO blog
Re:problema con la stampante canon in wlan
« Risposta #37 il: 09 Aprile 2013 ore 19:53 »
@franz Sinceramente non credo, perchè se vedi il link è
http://www.canon.dk/Support/Consumer_Products/products/Fax__Multifunctionals/InkJet/PIXMA_MP_series/MP495.aspx?type=download&page=1

Da notare il "MP_series" mentre lui ha un MG... si può tentare, ma sono dubbioso sinceramente

Nella pagina del pacchetto guarda sotto risorse: in pratica scarica un rpm compilato dai sorgenti che microfilm ha scaricato, solo che si tratta della versione precedente. Il nome del pacchetto è lo stesso
«Il valore dell'essere umano si determina nella misura in cui sia grande o piccola la sua capacità di contribuire al bene collettivo.» Jigorō Kanō

Offline microfilm

  • *
  • Post: 55
  • Reputazione: 0
    • Mostra profilo
Re:problema con la stampante canon in wlan
« Risposta #38 il: 09 Aprile 2013 ore 20:06 »
allora qualcosa meglio di prima vi posto un immagine, ma non riesco a proseguire è tutto spento e da cups non vede la stampante

Offline andreazube

  • *
  • Post: 1595
  • Reputazione: 64
  • I AM THE INTERSECT
    • Mostra profilo
    • Lupo mannaro
Re:problema con la stampante canon in wlan
« Risposta #39 il: 09 Aprile 2013 ore 20:09 »
Nella pagina del pacchetto guarda sotto risorse: in pratica scarica un rpm compilato dai sorgenti che microfilm ha scaricato, solo che si tratta della versione precedente. Il nome del pacchetto è lo stesso

Veramente non ho ben capito, il nome del pacchetto mi pare diverso... ma forse sono io che leggo male, comunque se dici che va bene mi fido di te  ;D (davvero non ho capito -preciso perchè rileggendo mi sono accorto che la mia frase può essere fraintesa)


edit: mi sa proprio che hai ragione te al 100%, a giudicare dallo screen  :beer:

Offline andreazube

  • *
  • Post: 1595
  • Reputazione: 64
  • I AM THE INTERSECT
    • Mostra profilo
    • Lupo mannaro
Re:problema con la stampante canon in wlan
« Risposta #40 il: 09 Aprile 2013 ore 20:12 »
Ho trovato questo, solo che... non  ho tempo di leggerlo per capire se l'utente ha risolto o meno, mi spiace, ma comunque ci sono tante risposte quindi mi pare interessante  :)

Offline FranzMari

  • *
  • Post: 2810
  • Reputazione: 103
  • [Senior Packager]
    • Mostra profilo
    • IMHO blog
Re:problema con la stampante canon in wlan
« Risposta #41 il: 09 Aprile 2013 ore 20:21 »
allora qualcosa meglio di prima vi posto un immagine, ma non riesco a proseguire è tutto spento e da cups non vede la stampante

riavvia cups con
Codice: [Seleziona]
sudo systemctl restart cups.service
«Il valore dell'essere umano si determina nella misura in cui sia grande o piccola la sua capacità di contribuire al bene collettivo.» Jigorō Kanō

Offline microfilm

  • *
  • Post: 55
  • Reputazione: 0
    • Mostra profilo
Re:problema con la stampante canon in wlan
« Risposta #42 il: 09 Aprile 2013 ore 20:26 »
niente ne da cups ne da installa stampanti tutto come prima

Offline microfilm

  • *
  • Post: 55
  • Reputazione: 0
    • Mostra profilo
Re:problema con la stampante canon in wlan
« Risposta #43 il: 09 Aprile 2013 ore 20:34 »
per favore  FranzMari, prova a riguardare le mie risposte 22/23 magari ti sono di aiuto e poi aggiungo:

anche su kubuntu (altro pc) lsusb mi restituisce canon e basta senza dirmi il nome esatto della stampante, con la differenza che su kubuntu funziona, inoltre con l'ultimo driver che mi hai fatto installare
Citazione
ccr -S --noedit cnijfilter-common-x86_64
se la stampante è accesa compare, se è spenta non compare (il driver, in impostazioni di sistema ,stampanti,) significa che in qualche modo la vede ma nn ne vuole sapere di stampare.



« Ultima modifica: 10 Aprile 2013 ore 11:01 da microfilm »

Offline andreazube

  • *
  • Post: 1595
  • Reputazione: 64
  • I AM THE INTERSECT
    • Mostra profilo
    • Lupo mannaro
Re:problema con la stampante canon in wlan
« Risposta #44 il: 11 Aprile 2013 ore 16:07 »
Il driver che ti dicevo è ora a posto e l'ho caricato su CCR, per installarlo dai

Codice: [Seleziona]
ccr -S cnijfilter-mg5300
Va in conflitto con i driver suggeriti da Franzmari però, e ci mette un po' per compilare.

Il manteiner del pacchetto su AUR mi ha anche fornito un driver modificato contenente delle parti prese dal driver per MACos, a suo dire questo nuovo pacchetto è migliore di quello normale, ma non può caricarlo su AUR per motivi di licenza. Ho il pacchetto .pkg.tar.gz a disposizione se ti interessa, comunque


 

Template by Homey | Sito ufficiale | Disclaimer