Autore Topic: "could not identify your computer" conseguenza dell'ultimo aggiornam.?  (Letto 890 volte)

Offline marci

  • *
  • Post: 22
  • Reputazione: 2
    • Mostra profilo
Ho aggiornato ieri sera, oggi Google Music Manager non mi permette l'accesso dicendomi che "could not identify your computer"... Visto che l'aggiornamento di ieri mi è parso di capire abbia modificato qualcosa nella gestione della rete  o nei nomi dei network device - corregetemi se dico minxxate  ;D - posso dedurre che il mancato riconoscimento ne sia conseguenza? e se si, c'è come mettere rimedio??? è come se il software abbia l'impressione che stia utilizzando un sistema virtuale...  :-\
« Ultima modifica: 11 Febbraio 2013 ore 10:56 da FranzMari »

Robbonzo

Hai seguito le indicazioni fornite per l'aggiornamento (sempore se si tratta della questione relativa alla news)?

Offline marci

  • *
  • Post: 22
  • Reputazione: 2
    • Mostra profilo
si, l'aggiornamento è andato a buon fine e non noto problemi con altri programmi... Ho supposto che Music Manager registri in qualche modo il computer che effettua l'accesso e adesso non lo riconosce più a causa della variazione, ma in effetti non ho ben capito "cosa" è cambiato, per questo chiedo conferma  :)

Offline Cylon

  • *
  • Post: 1960
  • Reputazione: 78
  • CYbernetic Life fOrm Node
    • Mostra profilo
questo è il warning che dava durante l'aggiornamento:

Citazione
WARNING
 Systemd 197 has moved to persistent network naming, for most users this will have
 no effect.  To check what the new name for your network device will be, run:
 hwinfo --network, and look for: Device File: xxxxx, were xxxx is your device.
 This will be used in /usr/lib/udev/rules.d/80-net-name-slot.rules
 If you use dhcpcd instead of networkmanager to connect, re-enable the service before rebooting
 Configuration files like conky.conf will need the new naming scheme too
 http://www.freedesktop.org/wiki/Software/systemd/PredictableNetworkInterfaceNames

ps: hai dato uno sguardo a questo... anche se è per ubuntu
« Ultima modifica: 30 Gennaio 2013 ore 18:56 da Cylon »
We are the Cylons. Lower your firewalll and surrender.Your PC will adapt to service our GNU/Linux systems. Resistance is futile. Extermination of human race has began!
                                                                     Non rispondo a PM

Offline marci

  • *
  • Post: 22
  • Reputazione: 2
    • Mostra profilo
grazie!!!! mi hai proprio messo sulla strada giusta, e ho risolto il problema  ;D

[spiego come per eventuali altri interessati]

In effetti si trattava di mettere in atto uno di questi suggerimenti

Citazione
I don't like this, how do I disable this?

You basically have three options:

    You disable the assignment of fixed names, so that the unpredictable kernel names are used again. For this, simply mask udev's rule file for the default policy: ln -s /dev/null /etc/udev/rules.d/80-net-name-slot.rules

    You create your own manual naming scheme, for example by naming your interfaces "internet0", "dmz0" or "lan0". For that create your own udev rules file and set the NAME property for the devices. Make sure to order it before the default policy file, for example by naming it /etc/udev/rules.d/70-my-net-names.rules

    You alter the default policy file, for picking a different naming scheme, for example for naming all interface names after their MAC address by default: cp /usr/lib/udev/rules.d/80-net-name-slot.rules /etc/udev/rules.d/80-net-name-slot.rules, then edit the file there and change the lines as necessary.

e ridare il vecchio nome "eth0" al posto dell'attuale e nuovo "enp2s0".  Ho scelto la terza opzione e visto che non sapevo come modificare il file seguente "80-net-name-slot.rules"

Codice: [Seleziona]
# do not edit this file, it will be overwritten on update

ACTION=="remove", GOTO="net_name_slot_end"
SUBSYSTEM!="net", GOTO="net_name_slot_end"
NAME!="", GOTO="net_name_slot_end"

NAME=="", ENV{ID_NET_NAME_ONBOARD}!="", NAME="$env{ID_NET_NAME_ONBOARD}"
NAME=="", ENV{ID_NET_NAME_SLOT}!="", NAME="$env{ID_NET_NAME_SLOT}"
NAME=="", ENV{ID_NET_NAME_PATH}!="", NAME="$env{ID_NET_NAME_PATH}"

LABEL="net_name_slot_end"

ho cancellato tutto e sostituito il contenuto con la riga presente in quello della partizione di ubuntu
Codice: [Seleziona]
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="xx:xx:xx:xx:xx:xx", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
(l'ATTR{address} è l'HW address del pc) e adesso ho di nuovo il vecchio caro device "eth0".

Spero, naturalmente, di non avere fatto danni, ma al momento sembra di no  ;D

 

Template by Homey | Sito ufficiale | Disclaimer