Autore Topic: Mencoder e problemi con PMS  (Letto 9650 volte)

Offline UnderTheGun

  • *
  • Post: 716
  • Reputazione: 69
  • [ Official Packager ]
    • Mostra profilo
    • kernel-CK repository
Re:Mencoder e problemi con PMS
« Risposta #60 il: 28 Dicembre 2013 ore 15:02 »
p.s. dai un occhio anche ad una mia guida (incompleta!) su Mplayer - Mencoder !!
http://forum.chakra-project.it/index.php/topic,3461.0.html

Kernel ottimizzati per Chakra
*Kernel CK - Kernel PF*

Offline mrcrowley

  • *
  • Post: 876
  • Reputazione: -1
    • Mostra profilo
Re:Mencoder e problemi con PMS
« Risposta #61 il: 28 Dicembre 2013 ore 16:30 »
Allora ho controllato ... tutte le dipendenze ci sono.
Avevo fatto un pò di casino tra le varie versioni di Mencoder installate e alla fine, stranamente, non ce ne era più installata neanche una. Cmq adesso ho reinstallato la 36505 e i problemi sono gli stessi di Ffmpeg.
Ovvero non riproduce gli MKV, riportando un errore Code 1. Adesso almeno gli AVI e MP4 funzionano.
Se vuoi, metto l'estratto del debug.log di PMS.


Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Mencoder e problemi con PMS
« Risposta #62 il: 28 Dicembre 2013 ore 17:05 »
Ho provato a generare un mkv convertento un file pre-esistente.

ffmpeg FUNZIONA.

mencoder da errore. Purtroppo il log non dice niente di interessante.
Provando da linea di comando invece ottengo un errore. Probabile ci sia un'incompatibilità fra la linea di comando ed il codec utilizzato. Dovrei provare a segnalare nel forum PMS.

Posto qui, magari qualcuno riesc anche a capire cosa c'è che non va, così provo a suggerire una soluzione.

Linea di comando:
Codice: [Seleziona]
mencoder -ss 0 /file.mkv -msglevel statusline=2 -oac lavc -of mpeg -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -ovc lavc -channels 2 -lavdopts debug=0:threads=2:skiploopfilter=all -lavcopts autoaspect=1:vcodec=mpeg2video:acodec=ac3:abitrate=448:threads=2:keyint=25:vqscale=1:vqmin=2:vqmax=3:vrc_maxrate=54000:vrc_buf_size=1835 -nosub -noautosub -fps 25 -ofps 25 -vf scale=632:404 -lavdopts fast -af lavcresample=48000 -srate 48000 -o /tmp/ps3mediaserver/mencoder1388246317974

L'errore che ottengo è il seguente:
Codice: [Seleziona]
MEncoder UNKNOWN-4.8.1 (C) 2000-2013 MPlayer Team
206 audio & 433 video codecs
success: format: 0  data: 0x0 - 0x1fb0bc70
libavformat version 55.19.104 (internal)
libavformat file format detected.
[lavf] stream 0: video (h264), -vid 0
[lavf] stream 1: audio (aac), -aid 0, -alang und
VIDEO:  [H264]  720x404  0bpp  25.000 fps    0.0 kbps ( 0.0 kbyte/s)
[V] filefmt:44  fourcc:0x34363248  size:720x404  fps:25.000  ftime:=0.0400
Input fps will be interpreted as 25.000 instead.
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
libavcodec version 55.39.100 (internal)
AUDIO: 48000 Hz, 2 ch, floatle, 0.0 kbit/0.00% (ratio: 0->384000)
Selected audio codec: [ffaac] afm: ffmpeg (FFmpeg AAC (MPEG-2/MPEG-4 Audio))
==========================================================================
PACKET SIZE: 2048 bytes, deltascr: 884
Opening video filter: [expand osd=1]
Expand: -1 x -1, -1 ; -1, osd: 1, aspect: 0.000000, round: 1
Opening video filter: [scale w=632 h=404]
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
[ac3 @ 0x7f3358fcd260]Channel layout not specified
[ac3 @ 0x7f3358fcd260]No channel layout specified. The encoder will guess the layout, but it might be incorrect.
Limiting audio preload to 0.4s.
Increasing audio density to 4.
[VD_FFMPEG] Trying pixfmt=0.
[VD_FFMPEG] XVMC-accelerated MPEG-2.
The selected video_out device is incompatible with this codec.
Try appending the scale filter to your filter list,
e.g. -vf spp,scale instead of -vf spp.
[VD_FFMPEG] Trying pixfmt=0.
[VD_FFMPEG] XVMC-accelerated MPEG-2.
The selected video_out device is incompatible with this codec.
Try appending the scale filter to your filter list,
e.g. -vf spp,scale instead of -vf spp.

Il suggerimento finale di aggiungere lo scale filter non ho ancora capito qual'è. Nel caso risolvesse aggiungerei l'opzione in PMS

EDIT: l'opzione di scale 632 l'avevo aggiunta proprio perchè si lagnava di questo. Ma evidentemente non era sufficiente...
« Ultima modifica: 28 Dicembre 2013 ore 17:08 da dinolib »

Offline mrcrowley

  • *
  • Post: 876
  • Reputazione: -1
    • Mostra profilo
Re:Mencoder e problemi con PMS
« Risposta #63 il: 28 Dicembre 2013 ore 18:23 »
Adesso almeno gli AVI e MP4 funzionano.

correzione .... ho degli mp4 che non funzionano. Sono quelli con audio aac o ac3. Mentre quelli con audio mpeg funzionano.

Offline UnderTheGun

  • *
  • Post: 716
  • Reputazione: 69
  • [ Official Packager ]
    • Mostra profilo
    • kernel-CK repository
Re:Mencoder e problemi con PMS
« Risposta #64 il: 29 Dicembre 2013 ore 17:53 »
Avete la possibilità di fare un test su un'altra distro?
Così per curiosità...per sapere se dipende tutto da mencoder oppure da qualche configurazione.

Kernel ottimizzati per Chakra
*Kernel CK - Kernel PF*

Offline mrcrowley

  • *
  • Post: 876
  • Reputazione: -1
    • Mostra profilo
Re:Mencoder e problemi con PMS
« Risposta #65 il: 29 Dicembre 2013 ore 22:02 »

Posso provare con Lubuntu ... però è su un portatile alquanto scarsino di potenza ....

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Mencoder e problemi con PMS
« Risposta #66 il: 30 Dicembre 2013 ore 08:00 »
non importa la potenza, basta che dia un output  ;)

Offline mrcrowley

  • *
  • Post: 876
  • Reputazione: -1
    • Mostra profilo
Re:Mencoder e problemi con PMS
« Risposta #67 il: 30 Dicembre 2013 ore 16:55 »
Effettivamente su Lubuntu funziona tutto !!!  :o

La versione installata di PS3MediaServer è la 1.81.0 + mencoder35004-1 da ppa:happy-neko.

Con Chakra ho notato che se utilizzo la PS3 come renderer, qualche file in più della tv Sony EX, lo visualizza, anche se cmq molti file non si vedono.

Dovrei forse provare a installare la stessa versione di PS3MediaServer su Lubuntu ??

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Mencoder e problemi con PMS
« Risposta #68 il: 30 Dicembre 2013 ore 17:32 »
fai qualche prova e fai sapere. Prova con una vecchia versione di PMS ma anche con un vecchio mencoder...

Se il vecchio PMS funziona sarebbe da vedere che cosa è cambiato nella linea di comando che genera.

Offline mrcrowley

  • *
  • Post: 876
  • Reputazione: -1
    • Mostra profilo
Re:Mencoder e problemi con PMS
« Risposta #69 il: 30 Dicembre 2013 ore 17:42 »
quindi mi consigli di installare vecchie versioni di PMS e Mencoder su Chakra ...
puoi indicarmi dove posso trovarle ???

« Ultima modifica: 30 Dicembre 2013 ore 17:48 da mrcrowley »

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Mencoder e problemi con PMS
« Risposta #70 il: 30 Dicembre 2013 ore 17:58 »
https://code.google.com/p/ps3mediaserver/downloads/list?can=1

EDIT: cmq se ci sono problemi io sono sempre propenso per un problema con mencoder. Si dovrebbe riuscire ad installare la stessa versione che hai su lubuntu. Ed in ogni caso le dipendenze sono tante e tali che anche in tal caso il risultato non è garantito.

PS: stai provando sempre con gli stessi file, vero?
« Ultima modifica: 30 Dicembre 2013 ore 18:01 da dinolib »

Offline mrcrowley

  • *
  • Post: 876
  • Reputazione: -1
    • Mostra profilo
Re:Mencoder e problemi con PMS
« Risposta #71 il: 30 Dicembre 2013 ore 18:23 »
..eheh ... l'avevo trovato anch'io, ma come si installano ??

basta copiare la cartella estratta dall'archivio in /opt/pms ???
« Ultima modifica: 30 Dicembre 2013 ore 18:26 da mrcrowley »

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Mencoder e problemi con PMS
« Risposta #72 il: 30 Dicembre 2013 ore 18:27 »
non ci ho guardato, ma hai due modi:
1- scarichi il pacchetto e modifichi il PKGBUILD per utilizzare i pacchetti più vecchi
2- scompatti e installi il pacchetto in /opt/pms (magari prima disinstalla pms)

La terza possibilità è quella di scompattare in una cartella qualsiasi e provare a lanciarlo. Non so se funziona così, però (ocio che il file pms.conf potrebbe non essere più compatibile con le vecchie versioni e magari è meglio eliminarlo salvandolo con altro nome)

Offline mrcrowley

  • *
  • Post: 876
  • Reputazione: -1
    • Mostra profilo
Re:Mencoder e problemi con PMS
« Risposta #73 il: 30 Dicembre 2013 ore 18:36 »
Niente ... con PMS 1.81 non cambia il risultato, quindi bisogna provare con le vecchie versioni di Mencoder.

Ho scaricato MPlayer-0.90.tar.bz2 .... ma non so come installarlo.

Aiutoooo ...  :o

PS: sicuro che provo con gli stessi file  ;)
« Ultima modifica: 30 Dicembre 2013 ore 18:50 da mrcrowley »

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Mencoder e problemi con PMS
« Risposta #74 il: 31 Dicembre 2013 ore 07:59 »
Mi sembra che mencoder sia un unico eseguibile, quindi puoi metterlo dove vuoi e dire a PMS di usare quello lì. Il problema sono le librerie che gli stanno intorno.

Qui http://www.ps3mediaserver.org/forum/viewtopic.php?f=3&t=14605spiega come usare tool diversi da quelli del tuo sistema

La cosa più semplice per usare vecchi mencoder forse è scaricare il PKGBUILD e cambiare il numero di versione. Sperando che con le librerie attuali compili. Il tempo di compilazione non è lunghissimo. Debian sembra usi la 34540. Di ubuntu non sono riuscito a trovarlo  >:(

Per non sclerare con file "impropri", prova prima gli mkv indicati qui: http://matroska.org/downloads/test_w1.html (in fondo dove parla di sourceforge)

Mi incuriosisce anche plexmediaserver (non credo sia open, però), quasi quasi lo provo  ;)
« Ultima modifica: 31 Dicembre 2013 ore 08:22 da dinolib »

 

Template by Homey | Sito ufficiale | Disclaimer