Autore Topic: Mencoder e problemi con PMS  (Letto 9601 volte)

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Mencoder e problemi con PMS
« Risposta #15 il: 13 Gennaio 2013 ore 11:43 »
 :( niente da fare, stesso problema anche con il pacchetto mplayer-svn

Potrebbero essere due cose (almeno fin dove arrivo io):
1- come si compila ora mplayer/mencoder non va bene
2- pms non è compatilbile con le ultime versioni di mencoder

visto che hai un account per il forum di PMS, puoi postare la versione di mencoder (35624) per vedere se altri utenti hanno lo stesso?

Domanda x jmc (c'è qualcunoooo?  ;D): l'ultimo aggiornamento di mplayer è stato proprio sul pacchetto audio. Però passare dalla lib libpulse a pulseaudio, ammesso che qualcosa sia cambiato, non credo possa interferire sul encoder audio!
Hai qualche idea, please?

al tuo ultimo post: fa lui da solo, anche la rimozione di mplayer. Ma come ho detto a me non ha funzionato

Offline mrcrowley

  • *
  • Post: 876
  • Reputazione: -1
    • Mostra profilo
Re:Mencoder e problemi con PMS
« Risposta #16 il: 13 Gennaio 2013 ore 12:15 »
Scusa ma la svn invece è 35247 !!???
Sono indipendenti le numerazioni ??

Offline mrcrowley

  • *
  • Post: 876
  • Reputazione: -1
    • Mostra profilo
Re:Mencoder e problemi con PMS
« Risposta #17 il: 13 Gennaio 2013 ore 12:52 »
Ho scaricato i pacchetti dal forum di PS3 Media Server, ho estratto i fle ... e c'è quello di mencoder.
Come faccio a vedere che versione è ???

ciaociao

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Mencoder e problemi con PMS
« Risposta #18 il: 13 Gennaio 2013 ore 19:22 »
lanci l'eseguibile :)

la versione scritta sul PKGBUILD non conta. Quando scarica i sorgenti viene aggiornata.

La versione che ho compilato io è la SVN-r35738-4.7.2

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Mencoder e problemi con PMS
« Risposta #19 il: 13 Gennaio 2013 ore 19:42 »
dove hai trovato il log di DEBUG?

Voglio provare da terminale il comando di mencoder

EDIT: ok /tmp/debug.log
ora ci guardo
« Ultima modifica: 13 Gennaio 2013 ore 19:48 da dinolib »

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Mencoder e problemi con PMS
« Risposta #20 il: 13 Gennaio 2013 ore 19:51 »
PEr chi volesse contribuire, al momento la linea di comando è la seguente:
Codice: [Seleziona]
mencoder -ss 0 /home/dinoc/file.avi -msglevel statusline=2 -oac lavc -of mpeg -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -ovc lavc -channels 2 -lavdopts debug=0:threads=2 -lavcopts autoaspect=1:vcodec=mpeg2video:acodec=ac3:abitrate=448:threads=2:keyint=4:vqscale=1:vqmin=2 -subdelay 20000 -ofps 25 -lavdopts fast -mc 0 -noskip -af lavcresample=48000 -srate 48000 -o /tmp/ps3mediaserver/mencoder1358102843266
Farò sapere l'esito di questo intanto

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Mencoder e problemi con PMS
« Risposta #21 il: 13 Gennaio 2013 ore 19:53 »
Ecco fatto: questo comando genera una output con audio corrotto!!

Ma perchè!?!?  E' l'encode ac3 scassato??
Ora provo a mettere mp3, vedo se si sistema (ma non so se poi lo accetta la PS3)

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Mencoder e problemi con PMS
« Risposta #22 il: 13 Gennaio 2013 ore 20:12 »
Anche l'encode mp3 non funziona. Mi sa che devo sottoporre ai guru di mencoder...

Questa la linea di comando usata:
Codice: [Seleziona]
mencoder -ss 0 /home/file.avi -msglevel statusline=2 -oac lavc -of mpeg -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -ovc lavc -channels 2 -lavdopts debug=0:threads=2 -lavcopts autoaspect=1:vcodec=mpeg2video:acodec=libmp3lame:abitrate=448:threads=2:keyint=4:vqscale=1:vqmin=2 -subdelay 20000 -ofps 25 -lavdopts fast -mc 0 -noskip -af lavcresample=48000 -srate 48000 -o /tmp/prova.mpg

Si indaga anche su libmediainfo...

Offline mrcrowley

  • *
  • Post: 876
  • Reputazione: -1
    • Mostra profilo
Re:Mencoder e problemi con PMS
« Risposta #23 il: 13 Gennaio 2013 ore 20:59 »
lanci l'eseguibile :)


si, ma così lo installi giusto ?? Io invece volevo prima vedere che versione era.

ciao

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Mencoder e problemi con PMS
« Risposta #24 il: 13 Gennaio 2013 ore 21:56 »
La versione è quella che ti ho postato :)
Dovresti vederla da svn, immagino.

Ho postato su doom9, vediamo se qualcuno risponde: http://forum.doom9.org/showthread.php?p=1610687#post1610687

Non riesco a trovare un forum per utenti di mencoder. C'è almeno un bug report?  :-\

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Mencoder e problemi con PMS
« Risposta #25 il: 13 Gennaio 2013 ore 23:28 »
Ho inserito un bug sul traker di mplayer. Se mi rimbalzano è qualcosa qui da noi x come compiliamo... speriamo che confermino il bug:
http://bugzilla.mplayerhq.hu/show_bug.cgi?id=2125

Offline mrcrowley

  • *
  • Post: 876
  • Reputazione: -1
    • Mostra profilo
Re:Mencoder e problemi con PMS
« Risposta #26 il: 18 Gennaio 2013 ore 15:20 »
Altri problemi ... http://forum.chakra-project.it/index.php/topic,4987.msg32881.html#msg32881

Che siano causati dalla medesima origine ???

Ciaociao

Offline mrcrowley

  • *
  • Post: 876
  • Reputazione: -1
    • Mostra profilo
Re:Mencoder e problemi con PMS
« Risposta #27 il: 01 Febbraio 2013 ore 21:31 »
Ho visto degli aggiornamenti di gstreamer .... ma il problema di Mencoder è rimasto lo stesso.

Dinolib hai avuto altre notizie ???


Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Mencoder e problemi con PMS
« Risposta #28 il: 02 Febbraio 2013 ore 13:12 »
Come puoi vedere dai link, ai bug che ho segnalato nessuna risposta.

In questi giorni ho stressato i dev di chakra per altre cosette, fino alla ISO non voglio approfittarne. Dopodichè passerò all'attacco a rompere su questo.

Inutile dire che il problema permane...  :'(

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Mencoder e problemi con PMS
« Risposta #29 il: 02 Febbraio 2013 ore 21:39 »
Aggiornamento:

sto stressando qualche dev. Ma siamo vicini alla conclusione che è un problema upstream.

Dopo la versione 35136 ha smesso di funzionare. Siamo alla ricerca del motivo.

Puoi installare il pacchetto mplayer-vaapi che è ancora ad una versione precedente e funziona!

Farò sapere se ci sono novità...

 

Template by Homey | Sito ufficiale | Disclaimer