Autore Topic: Pacchetto out of date in CCR  (Letto 907 volte)

Offline cerelli

  • *
  • Post: 70
  • Reputazione: 0
    • Mostra profilo
Pacchetto out of date in CCR
« il: 29 Dicembre 2012 ore 22:10 »
Ciao a tutti, io avrei bisogno del pacchetto "remmina" che è segnato in CCR come "This package has been flagged out of date".
Come devo comportarmi ?
Ho visto che c'è una versione aggiornata in AUR: posso adottarlo io ?
Grazie.

Offline FranzMari

  • *
  • Post: 2814
  • Reputazione: 103
  • [Senior Packager]
    • Mostra profilo
    • IMHO blog
Re:Pacchetto out of date in CCR
« Risposta #1 il: 29 Dicembre 2012 ore 22:20 »
Visto che il pacchetto è già stato segnalato come obsoleto, quello che puoi fare è provare a scrivere al manutentore del pacchetto, chiedendogli di aggiornare il pacchetto o di abbandonarlo se non vuole più mantenerlo.
Se questo non dovesse bastare, puoi rivolgerti ad un TU.

Nel frattempo, se proprio non puoi aspettare, puoi scaricare il tarball contenente il pkgbuild, modificarlo perché utilizzi la versione più recente di remmina e far compilare il pacchetto che ti serve, installandolo poi con
Codice: [Seleziona]
sudo pacman -U 'nomepacchettogenerato'.tar.xz
«Il valore dell'essere umano si determina nella misura in cui sia grande o piccola la sua capacità di contribuire al bene collettivo.» Jigorō Kanō

Offline cerelli

  • *
  • Post: 70
  • Reputazione: 0
    • Mostra profilo
Re:Pacchetto out of date in CCR
« Risposta #2 il: 29 Dicembre 2012 ore 23:00 »
E se uso packer ??

Offline cerelli

  • *
  • Post: 70
  • Reputazione: 0
    • Mostra profilo
Re:Pacchetto out of date in CCR
« Risposta #3 il: 29 Dicembre 2012 ore 23:06 »
Se scarico il tarball, modifico pkgbuild con quello che trovo in AUR e poi installo con pacman -U funziona?
Come faccio a contattare il manutentore?
Grazie.

Offline FranzMari

  • *
  • Post: 2814
  • Reputazione: 103
  • [Senior Packager]
    • Mostra profilo
    • IMHO blog
Re:Pacchetto out of date in CCR
« Risposta #4 il: 29 Dicembre 2012 ore 23:44 »
Lascia perdere quello di AUR: perché devi rischiare di complicarti la vita?
Basta aprire il pkgbuild del pacchetto su ccr ed inserire il numero di versione corretto, dopodiché sistemi l'md5sum e fai partire la compilazione con
Codice: [Seleziona]
makepkg -s
In ogni caso, se non hai necessariamente bisogno della versione più recente di remmina, puoi installare il pacchetto così com'è: il fatto che sia obsoleto non ne dovrebbe pregiudicare il funzionamento.
«Il valore dell'essere umano si determina nella misura in cui sia grande o piccola la sua capacità di contribuire al bene collettivo.» Jigorō Kanō

Offline cerelli

  • *
  • Post: 70
  • Reputazione: 0
    • Mostra profilo
Re:Pacchetto out of date in CCR
« Risposta #5 il: 30 Dicembre 2012 ore 22:06 »
Ok, ho provato ad installare la versione presente in CCR, ma da errore:

Codice: [Seleziona]
[marco@notemarco ~]$ ccr -S remmina
warning: remmina is flagged out of date

Ccr Targets    (2): libunique remmina

Proceed with installation? [Y/n]

Edit libunique PKGBUILD with $EDITOR? [Y/n] n
==> Creazione del pacchetto: libunique 1.1.6-1 (dom 30 dic 2012, 22.06.15, CET)
==> Controllo delle dipendenze durante l'avvio in corso...
==> Controllo delle dipendenze durante la compilazione in corso...
==> Download dei sorgenti in corso...
  -> È stato trovato libunique-1.1.6.tar.bz2
  -> È stato trovato unique-gdbus.patch
==> Validazione dei file sorgenti con sha256sums in corso...
    libunique-1.1.6.tar.bz2 ... Verificato
    unique-gdbus.patch ... Verificato
==> Estrazione dei sorgenti in corso...
  -> Estrazione di libunique-1.1.6.tar.bz2 con bsdtar in corso...
==> Rimozione dell'esistente directory pkg/ in corso...
==> Entro nell'ambiente fakeroot...
==> Avvio di build() in corso...
patching file configure.ac
Hunk #1 succeeded at 119 (offset 3 lines).
Hunk #2 succeeded at 163 (offset 4 lines).
Hunk #3 succeeded at 283 (offset 21 lines).
Hunk #4 succeeded at 302 (offset 21 lines).
patching file doc/reference/Makefile.am
patching file unique/Makefile.am
The next patch would create the file unique/gdbus/.gitignore,
which already exists!  Skipping patch.
1 out of 1 hunk ignored
The next patch would create the file unique/gdbus/Makefile.am,
which already exists!  Skipping patch.
1 out of 1 hunk ignored
The next patch would create the file unique/gdbus/uniquebackend-gdbus.c,
which already exists!  Skipping patch.
1 out of 1 hunk ignored
The next patch would create the file unique/gdbus/uniquebackend-gdbus.h,
which already exists!  Skipping patch.
1 out of 1 hunk ignored
patching file unique/uniquebackend.c
==> ERRORE: Si è verificato un errore in build().
    L'operazione sta per essere interrotta...
The build failed.
Dependencies for `remmina' are not met, not building...
[marco@notemarco ~]$

Cosa posso fare ?

Offline FranzMari

  • *
  • Post: 2814
  • Reputazione: 103
  • [Senior Packager]
    • Mostra profilo
    • IMHO blog
Re:Pacchetto out of date in CCR
« Risposta #6 il: 30 Dicembre 2012 ore 22:24 »
Devi segnalare il problema al manutentore del pacchetto libunique
«Il valore dell'essere umano si determina nella misura in cui sia grande o piccola la sua capacità di contribuire al bene collettivo.» Jigorō Kanō

 

Template by Homey | Sito ufficiale | Disclaimer