Autore Topic: VLC non funzionante  (Letto 1242 volte)

Offline barondem

  • *
  • Post: 75
  • Reputazione: 2
    • Mostra profilo
VLC non funzionante
« il: 30 Dicembre 2012 ore 23:28 »
Ciao a tutti!
Ho installato oggi con piacere Chakra (o meglio sono riuscito ad installarla correttamente poiché ieri l'avevo installata con una partizione separata per usr salvo capire in seguito che a causa di systemd ciò non andava bene ergo ho reinstallato cambiando le partizioni) e inizio già a tempestarvi di domande! :)
Per prima cosa (vabbé, a parte bellissima distro :)) vorrei segnalarvi un problema con vlc: dopo averlo installato da pacman (e aver installato anche il pacchetto multimedia-pack) l'ho aperto e sopresa, non mi legge un bel niente, poiché appena gli do in pasto il video, mi scompare il programma, senza generare finestre d'errore... Ho provato sia con filmati avi sia mkv (per la precisione, letti da una partizione ntfs non facente parte di quelle usate per l'installazione, ma come partizione "dati") ma il risultato è il medesimo... Ho anche provato a rimuovere il pacchetto e a reinstallarlo, ma senza ottenere miglioramenti. Dragon invece funziona tranquillamente. Ah, sono su nouveau, poiché già in live mi ero reso conto di come i proprietari mi facessero lo stesso difetto che mi facevano su kubuntu: ogniqualvolta si manovrasse qualcosa che aveva a che fare con i video, mi lampeggiava lo schermo (es.: passare da una scheda del browser a una con youtube o con contenuti flash, o passare da dolphin a vlc e cose simili se non ricordo male) e a lungo andare la cosa si era fatta fastidiosa...
Questo è l'output generato se eseguo vlc da terminale e provo ad aprire un video...
Codice: [Seleziona]
VLC media player 2.0.5 Twoflower (revision 2.0.5-0-g1661b7d)
[0x1ed3108] main libvlc: Esecuzione di vlc con l'interfaccia predefinita. Usa 'cvlc' per utilizzare vlc senza interfaccia.
kfilemodule(22604) KSambaSharePrivate::testparmParamValue: We got some errors while running testparm "Load smb config files from /etc/samba/smb.conf
Error loading services.
"
kfilemodule(22604) KSambaSharePrivate::findSmbConf: KSambaShare: Could not find smb.conf!
Errore di segmentazione (core dumped)
Vi viene in mente una possibile soluzione?
Grazie in anticipo per l'aiuto che spero mi vorrete darei!
« Ultima modifica: 01 Gennaio 2013 ore 19:07 da FranzMari »

Offline whoami

  • *
  • Post: 1562
  • Reputazione: 64
  • Quando c'era init i log arrivavano in orario!
    • Mostra profilo
Re:VLC non funzionante
« Risposta #1 il: 31 Dicembre 2012 ore 00:17 »
Premesso che non me ne intendo granchè ma vlc dice che ha bisogno di smb.conf, che se hai installato samba, e lo verifichi con
Codice: [Seleziona]
pacman -Qs samba, dovresti risolvere con
Codice: [Seleziona]
# cp /etc/samba/smb.conf.default /etc/samba/smb.conf
Prova e dicci come va...
echo "VQF AHELME I BI CI WECPF"| tr "ETAOINSHRDLUBCFGJMQPVWZYXK" "A-Z"

Offline Cylon

  • *
  • Post: 1960
  • Reputazione: 78
  • CYbernetic Life fOrm Node
    • Mostra profilo
Re:VLC non funzionante
« Risposta #2 il: 31 Dicembre 2012 ore 00:41 »
dai una lettura a questo thread sul foum internazionale.
We are the Cylons. Lower your firewalll and surrender.Your PC will adapt to service our GNU/Linux systems. Resistance is futile. Extermination of human race has began!
                                                                     Non rispondo a PM

Offline barondem

  • *
  • Post: 75
  • Reputazione: 2
    • Mostra profilo
Re:VLC non funzionante
« Risposta #3 il: 31 Dicembre 2012 ore 12:11 »
Premesso che non me ne intendo granchè ma vlc dice che ha bisogno di smb.conf, che se hai installato samba, e lo verifichi con
Codice: [Seleziona]
pacman -Qs samba, dovresti risolvere con
Codice: [Seleziona]
# cp /etc/samba/smb.conf.default /etc/samba/smb.conf
Prova e dicci come va...
fatto... ma sparisce solo quel messaggio... se provo con gli stessi file mi da:
Codice: [Seleziona]
VLC media player 2.0.5 Twoflower (revision 2.0.5-0-g1661b7d)
[0x1375108] main libvlc: Esecuzione di vlc con l'interfaccia predefinita. Usa 'cvlc' per utilizzare vlc senza interfaccia.
Errore di segmentazione (core dumped)
oppure con un altro file:
Codice: [Seleziona]
LC media player 2.0.5 Twoflower (revision 2.0.5-0-g1661b7d)
[0x171e108] main libvlc: Esecuzione di vlc con l'interfaccia predefinita. Usa 'cvlc' per utilizzare vlc senza interfaccia.
kfilemodule(3332) KSambaSharePrivate::testparmParamValue: Running testparm ("-d0", "-s", "--parameter-name", "usershare path")
[0x7f9df4c01bc8] avi demux error: no key frame set for track 1
Errore di segmentazione (core dumped)
ma visto che dice core dumped non potrei trovare il dump e postarvelo?

Offline barondem

  • *
  • Post: 75
  • Reputazione: 2
    • Mostra profilo
Re:VLC non funzionante
« Risposta #4 il: 31 Dicembre 2012 ore 12:23 »
se può servire, non riuscendo a registrare alcun log da vlc stesso (mi scrive solo righe bianche) ho salvato quello che mi da gdb... si trova su http://paste.chakra-project.org/3587/

Offline whoami

  • *
  • Post: 1562
  • Reputazione: 64
  • Quando c'era init i log arrivavano in orario!
    • Mostra profilo
Re:VLC non funzionante
« Risposta #5 il: 31 Dicembre 2012 ore 13:22 »
come c'è scritto nel forum internazionale hai schroedinger installato? li parla di repo testing ma c'è solo in platform ora, prova ad installarlo

Codice: [Seleziona]
sudo pacman -S schroedinger
echo "VQF AHELME I BI CI WECPF"| tr "ETAOINSHRDLUBCFGJMQPVWZYXK" "A-Z"

Offline barondem

  • *
  • Post: 75
  • Reputazione: 2
    • Mostra profilo
Re:VLC non funzionante
« Risposta #6 il: 31 Dicembre 2012 ore 14:13 »
 >:( quel post non l'avevo letto... installato e funziona a meraviglia grazie mille :)  ora se lo eseguo da terminale da questo... è importante o posso sorvolare?
Codice: [Seleziona]
[mpeg4 @ 0x7f77f4c1dae0] Invalid and inefficient vfw-avi packed B frames detected
No accelerated IMDCT transform found

Offline whoami

  • *
  • Post: 1562
  • Reputazione: 64
  • Quando c'era init i log arrivavano in orario!
    • Mostra profilo
Re:VLC non funzionante
« Risposta #7 il: 31 Dicembre 2012 ore 14:21 »
uh, non saprei... ma se funziona... :P

se ti senti soddisfatto metti risolto!
echo "VQF AHELME I BI CI WECPF"| tr "ETAOINSHRDLUBCFGJMQPVWZYXK" "A-Z"

Offline barondem

  • *
  • Post: 75
  • Reputazione: 2
    • Mostra profilo
Re:[RISOLTO] VLC non funzionante
« Risposta #8 il: 31 Dicembre 2012 ore 15:09 »
con piacere :) ora passerò ad aprire un altro thread XD

 

Template by Homey | Sito ufficiale | Disclaimer