Autore Topic: strano errore aggiornamento ?  (Letto 4197 volte)

Offline Cylon

  • *
  • Post: 1960
  • Reputazione: 78
  • CYbernetic Life fOrm Node
    • Mostra profilo
Re:strano errore aggiornamento ?
« Risposta #15 il: 27 Novembre 2012 ore 15:25 »
be se non c'era ci sarà un motivo, tipo chi "traduce" le news usa altra distro  e l'unico modo per sapere di nuove news è avere akregator attivo ..  ;D ;D ;D
We are the Cylons. Lower your firewalll and surrender.Your PC will adapt to service our GNU/Linux systems. Resistance is futile. Extermination of human race has began!
                                                                     Non rispondo a PM

Offline andreazube

  • *
  • Post: 1595
  • Reputazione: 64
  • I AM THE INTERSECT
    • Mostra profilo
    • Lupo mannaro
Re:strano errore aggiornamento ?
« Risposta #16 il: 27 Novembre 2012 ore 16:24 »
Di solito basta dare "s" alla richiesta,ma se mi chiede qualcosa o se l'aggiornamento è più grosso di 100mb io guardo sempre la sezione notizie...
Sto aggiornando adesso,o meglio ho lanciato l'aggiornamento un oretta fa ma ho la conessione lenta e 250mb da scaricare  :(

Offline jimthedoors

  • *
  • Post: 44
  • Reputazione: 0
  • L I N U X on the road...
    • Mostra profilo
Re:strano errore aggiornamento ?
« Risposta #17 il: 27 Novembre 2012 ore 21:56 »
Di nuovo Ciao a tutti!!
Grazie per le risposte sempre precise e puntuali !!!
Ora però vorrei precisare che io le news le ho lette prima di aggiornare...
ma non dicevano niente riguardo a: procps con core/procps-ng
                                                      util-linux e eject vanno in conflitto

quindi... Prima di fare casini... penso sia meglio chiedere  8)
un Saluto
...non può piovere per sempre...

Offline Cylon

  • *
  • Post: 1960
  • Reputazione: 78
  • CYbernetic Life fOrm Node
    • Mostra profilo
Re:strano errore aggiornamento ?
« Risposta #18 il: 27 Novembre 2012 ore 22:26 »
vero non precisavano quali pacchetti ma la news diceva :

Citazione
Come al solito, assicuratevi che i mirror siano sincronizzati, e a qualsiasi domanda su sostituzioni/conflitti rispondete “si”.

poi nel dubbio chiedere sempre :)
We are the Cylons. Lower your firewalll and surrender.Your PC will adapt to service our GNU/Linux systems. Resistance is futile. Extermination of human race has began!
                                                                     Non rispondo a PM

Offline fabbrilli

  • *
  • Post: 157
  • Reputazione: 3
    • Mostra profilo
Re:strano errore aggiornamento ?
« Risposta #19 il: 23 Dicembre 2012 ore 17:29 »
scusate, ragazzi, ho installato pclinuxos e per mia incompetenza ho crashiato tutto >:( ho dovuto reinstallare TUTTO.
ho reinstallato anche chakra, versione 2012-10 appena scaricata dal sito pensando che la versione successiva a quella ghe avevo installato precedentemente, fosse meglio, ma al momento di aprire il terminale, per aggiornare mi dà:
Codice: [Seleziona]
[fabio@fabio-pc ~]$ sudo pacman -Syy
Password:
:: Sincronizzazione dei database in corso...
 lib32                     28,4 KiB   713K/s 00:00 [######################] 100%
 core                      51,9 KiB   766K/s 00:00 [######################] 100%
 platform                 189,7 KiB   789K/s 00:00 [######################] 100%
 desktop                   88,3 KiB   786K/s 00:00 [######################] 100%
 apps                     126,1 KiB   789K/s 00:00 [######################] 100%
 games                     32,5 KiB   734K/s 00:00 [######################] 100%
[fabio@fabio-pc ~]$ sudo pacman -Syu
:: Sincronizzazione dei database in corso...
 lib32 è aggiornato
 core è aggiornato
 platform è aggiornato
 desktop è aggiornato
 apps è aggiornato
 games è aggiornato
:: I seguenti pacchetti dovrebbero essere aggiornati prima :
    pacman
:: Vuoi annullare l'operazione corrente
:: e aggiornare adesso questi pacchetti? [S/n] s

risoluzione delle dipendenze in corso...
ricerca dei conflitti in corso...
errore: impossibile eseguire l'operazione richiesta (impossibile soddisfare le dipendenze)
:: gcc: richiede gcc-libs=4.7.0-1
[fabio@fabio-pc ~]$
ho provato a scrivere :
Codice: [Seleziona]
[fabio@fabio-pc ~]$ ccr gcc-libs --noedit
0 lib32/gcc-libs-multilib 4.7.2-1
      Runtime libraries shipped by GCC for multilib
1 lib32/lib32-gcc-libs 4.7.2-1
      Runtime libraries shipped by GCC (32-bit)
2 core/gcc-libs 4.7.2-1 (base) [installato: 4.7.0-1]
      Runtime libraries shipped by GCC

Type numbers to install. Separate each number with a space.
Numbers: 0
Password:
:: I seguenti pacchetti dovrebbero essere aggiornati prima :
    pacman
:: Vuoi annullare l'operazione corrente
:: e aggiornare adesso questi pacchetti? [S/n] s

risoluzione delle dipendenze in corso...
ricerca dei conflitti in corso...
errore: impossibile eseguire l'operazione richiesta (impossibile soddisfare le dipendenze)
:: gcc: richiede gcc-libs=4.7.0-1
[fabio@fabio-pc ~]$
non riesco a trovare : gcc-libs=4.7.0-1 per soddisfare quanto richiestomi.  :( mi aiutate?

Offline vellerofonte

  • *
  • Post: 1374
  • Reputazione: 58
  • #Chakra: Kde for life
    • Mostra profilo
Re:strano errore aggiornamento ?
« Risposta #20 il: 23 Dicembre 2012 ore 18:42 »
Come puoi vedere da qui: http://www.chakra-project.org/packages/index.php?act=search&subdir=&sortby=date&order=descending&searchpattern=gcc-libs

il pacchetto incriminato è presente nei repository ufficiali, dunque lanciare ccr -S non ha senso  ;)

Vai piuttosto con un:

Codice: [Seleziona]
sudo pacman -S gcc-libs
Questo dovrebbe mettere a posto la questione pacchetto mancante, quindi vai con:

Codice: [Seleziona]
sudo pacman -Syyu
ti chiederà di aggiornare proprio il pacchetto pacman, accetti e questa volta dovrebbe filare tutto liscio, terminato di aggiornare pacman dai finalmente:

Codice: [Seleziona]
sudo pacman -Syu
per verificare la presenza di eventuali aggiornamenti, in caso comparissero istruzioni a video (avvisi del nuovo pacchetto pacman-helpme), seguili attentamente  :)

Offline fabbrilli

  • *
  • Post: 157
  • Reputazione: 3
    • Mostra profilo
Re:strano errore aggiornamento ?
« Risposta #21 il: 23 Dicembre 2012 ore 18:57 »
ho dato il comando:
Codice: [Seleziona]
[fabio@fabio-pc ~]$ sudo pacman -S gcc-libs
Password:
:: I seguenti pacchetti dovrebbero essere aggiornati prima :
    pacman
:: Vuoi annullare l'operazione corrente
:: e aggiornare adesso questi pacchetti? [S/n] n

risoluzione delle dipendenze in corso...
ricerca dei conflitti in corso...
errore: impossibile eseguire l'operazione richiesta (impossibile soddisfare le dipendenze)
:: gcc: richiede gcc-libs=4.7.0-1
[fabio@fabio-pc ~]$
tutto come prima ::)

Offline andreazube

  • *
  • Post: 1595
  • Reputazione: 64
  • I AM THE INTERSECT
    • Mostra profilo
    • Lupo mannaro
Re:strano errore aggiornamento ?
« Risposta #22 il: 23 Dicembre 2012 ore 19:01 »
ho dato il comando:
Codice: [Seleziona]
[fabio@fabio-pc ~]$ sudo pacman -S gcc-libs
Password:
:: I seguenti pacchetti dovrebbero essere aggiornati prima :
    pacman
:: Vuoi annullare l'operazione corrente
:: e aggiornare adesso questi pacchetti? [S/n] n

risoluzione delle dipendenze in corso...
ricerca dei conflitti in corso...
errore: impossibile eseguire l'operazione richiesta (impossibile soddisfare le dipendenze)
:: gcc: richiede gcc-libs=4.7.0-1
[fabio@fabio-pc ~]$
tutto come prima ::)
Per prima cosa, non rifiutare quando ti chiede di aggiornare pacman...

Offline FranzMari

  • *
  • Post: 2814
  • Reputazione: 103
  • [Senior Packager]
    • Mostra profilo
    • IMHO blog
Re:strano errore aggiornamento ?
« Risposta #23 il: 23 Dicembre 2012 ore 19:06 »
Dai prima
Codice: [Seleziona]
sudo pacman -S pacmane vedi se ti aggiorna pacman.
«Il valore dell'essere umano si determina nella misura in cui sia grande o piccola la sua capacità di contribuire al bene collettivo.» Jigorō Kanō

Offline fabbrilli

  • *
  • Post: 157
  • Reputazione: 3
    • Mostra profilo
Re:strano errore aggiornamento ?
« Risposta #24 il: 23 Dicembre 2012 ore 19:22 »
innanzi tutto grazie a tutti.@ FranzMari, credevo fosse la soluzione, dopo il tuo comando, ma ... ti riporto leultime:
Codice: [Seleziona]
                sed-4.2.1-6  shadow-4.1.5.1-1  shared-color-profiles-0.1.5-1
                 shared-mime-info-1.0-1  sip-4.14.2-1
                 smbclient-3.6.7-1 [removal]  soundtouch-1.7.0-1  sox-14.4.0-5
                 speex-1.2rc1-9  spideroak-4.8.3-1  sshfs-2.4-2  strigi-0.7.7-3
                 sysfsutils-2.1.0-7  system-config-printer-1.3.12-1
                 systemd-196-2  systemd-units-20120528-15  talloc-2.0.8-1
                 telepathy-haze-0.6.0-3  telepathy-mission-control-5.14.0-2
                 tiacx-20080210-40  transcode-1.1.7-8  tzdata-2012i-1
                 udisks-1.0.4-6  unionfs-fuse-0.26-2  usb-modeswitch-1.2.5-1
                 util-linux-2.22.1-3  vcdimager-0.7.24-1
                 vhba-module-20120422-6  vim-7.3.744-1  vim-runtime-7.3.744-1
                 webrtc-audio-processing-0.1-4  which-2.20-6  x264-20121206-1
                 xbitmaps-1.1.1-1  xbmc-11.0-5  xdelta3-3.0.4-1
                 xdg-utils-1.1.0.1-1  xerces-c-3.1.1-1  xfsprogs-3.1.8-1
                 xine-lib-1.2.2-3  xorg-apps-7.6-2

Dimensione totale dei pacchetti da scaricare:    0,61 MiB

Dimensione totale dei pacchetti da installare:   2246,63 MiB

Dimensione dell'aggiornamento di rete: 100,83 MiB

Vuoi procedere con l'installazione? [S/n] s
:: Download dei pacchetti da core...
 mirror-check-0.4-1-...  1128,0   B  19,9M/s 00:00 [######################] 100%
:: Download dei pacchetti da platform...
 cairo-1.12.6-2-x86_64    624,2 KiB   564K/s 00:01 [######################] 100%
(288/288) controllo dell'integrità del pacchetto   [######################] 100%
(288/288) caricamento dei file del pacchetto       [######################] 100%
(288/288) controllo dei conflitti in corso         [######################] 100%
errore: impossibile eseguire l'operazione richiesta (file in conflitto)
talloc: /usr/lib/libtalloc.so.1 è già presente nel filesystem
talloc: /usr/lib/libtalloc.so.2 è già presente nel filesystem
Si sono verificati degli errori, nessun pacchetto è stato aggiornato.
[fabio@fabio-pc ~]$

Offline andreazube

  • *
  • Post: 1595
  • Reputazione: 64
  • I AM THE INTERSECT
    • Mostra profilo
    • Lupo mannaro
Re:strano errore aggiornamento ?
« Risposta #25 il: 23 Dicembre 2012 ore 19:25 »
innanzi tutto grazie a tutti.@ FranzMari, credevo fosse la soluzione, dopo il tuo comando, ma ... ti riporto leultime:
Codice: [Seleziona]
                sed-4.2.1-6  shadow-4.1.5.1-1  shared-color-profiles-0.1.5-1
                 shared-mime-info-1.0-1  sip-4.14.2-1
                 smbclient-3.6.7-1 [removal]  soundtouch-1.7.0-1  sox-14.4.0-5
                 speex-1.2rc1-9  spideroak-4.8.3-1  sshfs-2.4-2  strigi-0.7.7-3
                 sysfsutils-2.1.0-7  system-config-printer-1.3.12-1
                 systemd-196-2  systemd-units-20120528-15  talloc-2.0.8-1
                 telepathy-haze-0.6.0-3  telepathy-mission-control-5.14.0-2
                 tiacx-20080210-40  transcode-1.1.7-8  tzdata-2012i-1
                 udisks-1.0.4-6  unionfs-fuse-0.26-2  usb-modeswitch-1.2.5-1
                 util-linux-2.22.1-3  vcdimager-0.7.24-1
                 vhba-module-20120422-6  vim-7.3.744-1  vim-runtime-7.3.744-1
                 webrtc-audio-processing-0.1-4  which-2.20-6  x264-20121206-1
                 xbitmaps-1.1.1-1  xbmc-11.0-5  xdelta3-3.0.4-1
                 xdg-utils-1.1.0.1-1  xerces-c-3.1.1-1  xfsprogs-3.1.8-1
                 xine-lib-1.2.2-3  xorg-apps-7.6-2

Dimensione totale dei pacchetti da scaricare:    0,61 MiB

Dimensione totale dei pacchetti da installare:   2246,63 MiB

Dimensione dell'aggiornamento di rete: 100,83 MiB

Vuoi procedere con l'installazione? [S/n] s
:: Download dei pacchetti da core...
 mirror-check-0.4-1-...  1128,0   B  19,9M/s 00:00 [######################] 100%
:: Download dei pacchetti da platform...
 cairo-1.12.6-2-x86_64    624,2 KiB   564K/s 00:01 [######################] 100%
(288/288) controllo dell'integrità del pacchetto   [######################] 100%
(288/288) caricamento dei file del pacchetto       [######################] 100%
(288/288) controllo dei conflitti in corso         [######################] 100%
errore: impossibile eseguire l'operazione richiesta (file in conflitto)
talloc: /usr/lib/libtalloc.so.1 è già presente nel filesystem
talloc: /usr/lib/libtalloc.so.2 è già presente nel filesystem
Si sono verificati degli errori, nessun pacchetto è stato aggiornato.
[fabio@fabio-pc ~]$
È la soluzione, leggi le news  :P
Citazione
Con il prossimo pacman -Syu, riceverete un aggiornamento di pacman, che installerà pacman-helpme, e l’installazione di esso vi spiegherà cosa fare riguardo i conflitti che sorgeranno con l’aggiornamento di talloc.

Credo che tu debba dare
Citazione
sudo pacman -S talloc --force

e successivamente

sudo pacman -Syu
(fonte chakra galaxy)
Non ne sono sicuro al 100% (ora non sono su chakra), ma molto probabilmente devi dare i comandi scritti sopra
« Ultima modifica: 23 Dicembre 2012 ore 19:28 da andreazube »

Offline fabbrilli

  • *
  • Post: 157
  • Reputazione: 3
    • Mostra profilo
Re:strano errore aggiornamento ?
« Risposta #26 il: 23 Dicembre 2012 ore 19:34 »
È la soluzione, leggi le news  :P
Credo che tu debba dare(fonte chakra galaxy)
Non ne sono sicuro al 100% (ora non sono su chakra), ma molto probabilmente devi dare i comandi scritti sopra
ho riprovato, ma il risultato è identico. :-\

Offline andreazube

  • *
  • Post: 1595
  • Reputazione: 64
  • I AM THE INTERSECT
    • Mostra profilo
    • Lupo mannaro
Re:strano errore aggiornamento ?
« Risposta #27 il: 23 Dicembre 2012 ore 19:40 »
ho riprovato, ma il risultato è identico. :-\
Riprovato cosa?
Hai dato i comandi suggeriti da chakra galaxy?
ora cosa esce (output)?

Offline fabbrilli

  • *
  • Post: 157
  • Reputazione: 3
    • Mostra profilo
Re:strano errore aggiornamento ?
« Risposta #28 il: 23 Dicembre 2012 ore 20:16 »
scusa, non riuscivo a leggere il resto del tuo post:
Codice: [Seleziona]
Credo che tu debba dare
Citazione
sudo pacman -S talloc --force

e successivamente

sudo pacman -Syu
(fonte chakra galaxy)
Non ne sono sicuro al 100% (ora non sono su chakra), ma molto probabilmente devi dare i comandi scritti sopra
« Ultima modifica: Oggi alle 19:28 da andreazube »
però come hai suggerito ho visitato il sito, e ..........credo sia risolto il tutto anche se nel'installazione ogni tanto dava qualche errore (vari errori) non sono riuscito ad appuntarmeli. terminata l'0perazione, però ho controllato e, kde è aggiornato a 4.9.4 e linux a 3.6.6-1. riavviato e ora è tutto o.k. come sempre,  G R A Z I E   G R A N D I. auguro a tutti un sereno e buon natale. fabio. :beer:

 

Template by Homey | Sito ufficiale | Disclaimer