Autore Topic: Samba non parte causa macanza di rete locale...  (Letto 6238 volte)

Offline francesco_dem

  • *
  • Post: 321
  • Reputazione: 9
    • Mostra profilo
Re:Samba non parte causa macanza di rete locale...
« Risposta #15 il: 20 Febbraio 2013 ore 05:33 »
ho letto qui: https://wiki.archlinux.org/index.php/Daemon

questo è il comando: systemctl enable|disable <service_name>

evidentemente ho sbagliato il service name

Il wiki lo stavo seguendo, ma mi bloccavo al punto relativo all'avvio dei demoni poichè sbagliavo il comando.
Ora finalmente chakra è visibile in rete, ma come accade a whoami, non riesco ad accedere alla cartella condivisa; mi chiede nome utente e password sebbene io abbia impostato come livello di condivisione share.inoltre da dolphin quando aggiungo nuove cartelle condivise, dopo un po' scompare l'icona della condivisione.
sono riuscito anche ad aggiungere al macbook la stampante di rete collegata fisicamente a chakra ma non stampa. :nono:
riproverò a fare tutti i passaggi e ti farò sapere, intanto grazie per la pazienza

Offline francesco_dem

  • *
  • Post: 321
  • Reputazione: 9
    • Mostra profilo
Re:Samba non parte causa macanza di rete locale...
« Risposta #16 il: 21 Febbraio 2013 ore 12:13 »
Boungiorno a tutti, faccio il punto della situazione.
installato samba
installato swat
aggiunto samba ai demoni, ciò nonostante samba non parte all'avvio del sistema, ma devo inizializzarlo da swat
adesso sono fermo al punto: Manual mounting - To list public shares on a server:
è rchiesta l'installazione del pacchetto smbnetfs che non è presente nei pacchetti nè in ccr
Grazie...

Offline francesco_dem

  • *
  • Post: 321
  • Reputazione: 9
    • Mostra profilo
Re:Samba non parte causa macanza di rete locale...
« Risposta #17 il: 26 Febbraio 2013 ore 22:09 »
Ho risolto, ho ripetuto i passaggi del wiki fino al punto client configuration e riesco ad accedere alle cartelle condivise.
Era un errore nei parametri di samba (dovevo impostare guest ok =yes) ;D
Unico neo devo inizializzare samba dall'interfaccia swat, poichè non parte in automatico all'avvio sebbene io abbia aggiunto i demoni, comunque non è un problema, l'importante è che la condivisione funzioni.
Post i parametri della mia configurazione semmai dovesse servire a qualcuno
Vi consiglio di consulatere anche:
http://guide.debianizzati.org/index.php/SAMBA:_configurazione_lato_server
Codice: [Seleziona]
[global]
security = SHARE
obey pam restrictions = Yes
guest account = francesco
username map = /etc/samba/smbusers
log file = /var/log/samba/%m.log
max log size = 50
dns proxy = No
idmap config * : range =
idmap config * : backend = tdb
invalid users = root

[printers]
comment = All Printers
path = /var/spool/samba
read only = No
guest ok = Yes
printable = Yes
print ok = Yes
browseable = No

[Epson_Stylus_SX235]
comment = Epson Stylus SX235
path = /var/spool/samba
read only = No
printable = Yes
print ok = Yes
printer name = Epson_Stylus_SX235
browseable = No
oplocks = No
share modes = No

[public]
path = /home/francesco/public
read only = No
guest ok = Yes

[Documents]
path = /home/francesco/Documents/
invalid users =
read only = No
guest ok = Yes

Offline andreazube

  • *
  • Post: 1595
  • Reputazione: 64
  • I AM THE INTERSECT
    • Mostra profilo
    • Lupo mannaro
Re:Samba non parte causa macanza di rete locale...
« Risposta #18 il: 26 Febbraio 2013 ore 22:11 »
Non parte all'avvio? che comando(i) hai dato?

Offline francesco_dem

  • *
  • Post: 321
  • Reputazione: 9
    • Mostra profilo
Re:Samba non parte causa macanza di rete locale...
« Risposta #19 il: 26 Febbraio 2013 ore 22:13 »
systemctl enable nmbd
systemctl enable smbd

Offline andreazube

  • *
  • Post: 1595
  • Reputazione: 64
  • I AM THE INTERSECT
    • Mostra profilo
    • Lupo mannaro
Re:Samba non parte causa macanza di rete locale...
« Risposta #20 il: 26 Febbraio 2013 ore 22:16 »
In teoria dovrebbe andare... ma non va proprio samba all'avvio o non ti monta la cartella?

Offline francesco_dem

  • *
  • Post: 321
  • Reputazione: 9
    • Mostra profilo
Re:Samba non parte causa macanza di rete locale...
« Risposta #21 il: 26 Febbraio 2013 ore 22:19 »
non va proprio samba all'avvio

Offline andreazube

  • *
  • Post: 1595
  • Reputazione: 64
  • I AM THE INTERSECT
    • Mostra profilo
    • Lupo mannaro
Re:Samba non parte causa macanza di rete locale...
« Risposta #22 il: 26 Febbraio 2013 ore 22:22 »
non va proprio samba all'avvio

leggi

Però io non uso Samba, quindi più che indicarti una possibile soluzione non posso fare  :-[

Offline francesco_dem

  • *
  • Post: 321
  • Reputazione: 9
    • Mostra profilo
Re:Samba non parte causa macanza di rete locale...
« Risposta #23 il: 28 Febbraio 2013 ore 21:01 »
ho letto e provato le configurazioni suggerite, adesso si avviano nmbd e winbindd, ma samba non vuole saperne di partire, unico modo e tramite l' interafaccia swat come ti dicevo.
Adesso sto provando a mettre in rete la stampante, collegata fisicamente a chakra...speriamo bene

Offline whoami

  • *
  • Post: 1562
  • Reputazione: 64
  • Quando c'era init i log arrivavano in orario!
    • Mostra profilo
Re:Samba non parte causa macanza di rete locale...
« Risposta #24 il: 01 Marzo 2013 ore 00:21 »
@francesco ti ho risposto nell'altro topic, prova a guardare...
echo "VQF AHELME I BI CI WECPF"| tr "ETAOINSHRDLUBCFGJMQPVWZYXK" "A-Z"

Offline rodolforizzo76

  • *
  • Post: 180
  • Reputazione: 2
  • Aaron Nimzowitsch
    • Mostra profilo
    • painteronline.org
Re:Samba non parte causa macanza di rete locale...
« Risposta #25 il: 02 Dicembre 2013 ore 14:00 »
whoami@
come sei messo adesso con samba? io ho creato il file smb.conf come indicato dal wiki di arch:

Codice: [Seleziona]
# cp /etc/samba/smb.conf.default /etc/samba/smb.conf

ed ora se in dolphin vado su Rete -> Condivisioni Samba compare anche Mygroup che prima non compariva, e se clicco su Mygroup vedo anche gli altri computer. Solo che non visualizzo le cartelle che ho messo in condivisione (tramite knetwork-filesharing).

Inoltre riesco ad avviare i servizi con:

Codice: [Seleziona]
# systemctl start smbd
# systemctl start nmbd

che prima mi davano errore.

Resta da capire perche' non vede le cartelle condivise...


Sei un artista? Visita il mio sito http://www.painteronline.org

Offline whoami

  • *
  • Post: 1562
  • Reputazione: 64
  • Quando c'era init i log arrivavano in orario!
    • Mostra profilo
Re:Samba non parte causa macanza di rete locale...
« Risposta #26 il: 02 Dicembre 2013 ore 15:05 »
Il mio pc fisso è un attimo pensionato in attesa della ricollocazione post-trasloco, quindi non ho fatto più esperimenti, e prima me la cavavo con nfs... l'unica roba che ho provato a fare è una condivisione tramite samba con il portatile come server e il cell come client, usando ES File Manager... mi ricordo che per farlo funzionare avevo dovuto fare qualcosa ma non mi ricordo cosa... comunque ti posto il smb.conf del portatile (server), considerando che da dolphin se vado nelle proprietà della mia home mi dice che devo installare samba con un pulsante che se lo premo si lamenta perchè non ho installato KPackageKit (!!!), con evidentemente sia samba che kdenetwork-filesharing installato, però dal cell vedo tutto quello che c'è nella mia home

Codice: [Seleziona]
[14:58:04][whoami--> ~]$cat /etc/samba/smb.conf
# This is the main Samba configuration file. You should read the
# smb.conf(5) manual page in order to understand the options listed
# here. Samba has a huge number of configurable options (perhaps too
# many!) most of which are not shown in this example
#
# For a step to step guide on installing, configuring and using samba,
# read the Samba-HOWTO-Collection. This may be obtained from:
#  http://www.samba.org/samba/docs/Samba-HOWTO-Collection.pdf
#
# Many working examples of smb.conf files can be found in the
# Samba-Guide which is generated daily and can be downloaded from:
#  http://www.samba.org/samba/docs/Samba-Guide.pdf
#
# Any line which starts with a ; (semi-colon) or a # (hash)
# is a comment and is ignored. In this example we will use a #
# for commentry and a ; for parts of the config file that you
# may wish to enable
#
# NOTE: Whenever you modify this file you should run the command "testparm"
# to check that you have not made any basic syntactic errors.
#
#======================= Global Settings =====================================
[global]

# workgroup = NT-Domain-Name or Workgroup-Name, eg: MIDEARTH                                                                                                           
   workgroup = Zumpappero                                                                                                                                           
                                                                                                                                                                       
# server string is the equivalent of the NT Description field                                                                                                         
   server string = Samba Server                                                                                                                                       
                                                                                                                                                                       
# Security mode. Defines in which mode Samba will operate. Possible                                                                                                   
# values are share, user, server, domain and ads. Most people will want                                                                                               
# user level security. See the Samba-HOWTO-Collection for details.                                                                                                     
   security = user                                                                                                                                                     
                                                                                                                                                                       
# This option is important for security. It allows you to restrict                                                                                                     
# connections to machines which are on your local network. The                                                                                                         
# following example restricts access to two C class networks and
# the "loopback" interface. For more examples of the syntax see
# the smb.conf man page
;   hosts allow = 192.168.1. 192.168.2. 127.

# If you want to automatically load your printer list rather
# than setting them up individually then you'll need this
   load printers = yes

# you may wish to override the location of the printcap file
;   printcap name = /etc/printcap

# on SystemV system setting printcap name to lpstat should allow
# you to automatically obtain a printer list from the SystemV spool
# system
;   printcap name = lpstat

# It should not be necessary to specify the print system type unless
# it is non-standard. Currently supported print systems include:
# bsd, cups, sysv, plp, lprng, aix, hpux, qnx
;   printing = cups

# Uncomment this if you want a guest account, you must add this to /etc/passwd
# otherwise the user "nobody" is used
;  guest account = pcguest

# this tells Samba to use a separate log file for each machine
# that connects
   log file = /var/log/samba/%m.log

# Put a capping on the size of the log files (in Kb).
   max log size = 50

# Use password server option only with security = server
# The argument list may include:
#   password server = My_PDC_Name [My_BDC_Name] [My_Next_BDC_Name]
# or to auto-locate the domain controller/s
#   password server = *
;   password server = <NT-Server-Name>

# Use the realm option only with security = ads
# Specifies the Active Directory realm the host is part of
;   realm = MY_REALM

# Backend to store user information in. New installations should
# use either tdbsam or ldapsam. smbpasswd is available for backwards
# compatibility. tdbsam requires no further configuration.
;   passdb backend = tdbsam

# Using the following line enables you to customise your configuration
# on a per machine basis. The %m gets replaced with the netbios name
# of the machine that is connecting.
# Note: Consider carefully the location in the configuration file of
#       this line.  The included file is read at that point.
;   include = /usr/local/samba/lib/smb.conf.%m

# Configure Samba to use multiple interfaces
# If you have multiple network interfaces then you must list them
# here. See the man page for details.
;   interfaces = 192.168.12.2/24 192.168.13.2/24

# Browser Control Options:
# set local master to no if you don't want Samba to become a master
# browser on your network. Otherwise the normal election rules apply
;   local master = no

# OS Level determines the precedence of this server in master browser
# elections. The default value should be reasonable
;   os level = 33

# Domain Master specifies Samba to be the Domain Master Browser. This
# allows Samba to collate browse lists between subnets. Don't use this
# if you already have a Windows NT domain controller doing this job
;   domain master = yes

# Preferred Master causes Samba to force a local browser election on startup
# and gives it a slightly higher chance of winning the election
;   preferred master = yes

# Enable this if you want Samba to be a domain logon server for
# Windows95 workstations.
;   domain logons = yes

# if you enable domain logons then you may want a per-machine or
# per user logon script
# run a specific logon batch file per workstation (machine)
;   logon script = %m.bat
# run a specific logon batch file per username
;   logon script = %U.bat

# Where to store roving profiles (only for Win95 and WinNT)
#        %L substitutes for this servers netbios name, %U is username
#        You must uncomment the [Profiles] share below
;   logon path = \\%L\Profiles\%U

# Windows Internet Name Serving Support Section:
# WINS Support - Tells the NMBD component of Samba to enable it's WINS Server
;   wins support = yes

# WINS Server - Tells the NMBD components of Samba to be a WINS Client
#       Note: Samba can be either a WINS Server, or a WINS Client, but NOT both
;   wins server = w.x.y.z

# WINS Proxy - Tells Samba to answer name resolution queries on
# behalf of a non WINS capable client, for this to work there must be
# at least one  WINS Server on the network. The default is NO.
;   wins proxy = yes

# DNS Proxy - tells Samba whether or not to try to resolve NetBIOS names
# via DNS nslookups. The default is NO.
   dns proxy = no

# These scripts are used on a domain controller or stand-alone
# machine to add or delete corresponding unix accounts
;  add user script = /usr/sbin/useradd %u
;  add group script = /usr/sbin/groupadd %g
;  add machine script = /usr/sbin/adduser -n -g machines -c Machine -d /dev/null -s /bin/false %u
;  delete user script = /usr/sbin/userdel %u
;  delete user from group script = /usr/sbin/deluser %u %g
;  delete group script = /usr/sbin/groupdel %g


#============================ Share Definitions ==============================
[homes]
   # comment = Home Directories
   browseable = no
   writable = yes
   
# Un-comment the following and create the netlogon directory for Domain Logons
; [netlogon]
;   comment = Network Logon Service
;   path = /usr/local/samba/lib/netlogon
;   guest ok = yes
;   writable = no
;   share modes = no


# Un-comment the following to provide a specific roving profile share
# the default is to use the user's home directory
;[Profiles]
;    path = /usr/local/samba/profiles
;    browseable = no
;    guest ok = yes


# NOTE: If you have a BSD-style print system there is no need to
# specifically define each individual printer
[printers]
   comment = All Printers
   path = /var/spool/samba
   browseable = no
# Set public = yes to allow user 'guest account' to print
   guest ok = no
   writable = no
   printable = yes

# This one is useful for people to share files
;[tmp]
;   comment = Temporary file space
;   path = /tmp
;   read only = no
;   public = yes

# A publicly accessible directory, but read only, except for people in
# the "staff" group
;[public]
;   comment = Public Stuff
;   path = /home/samba
;   public = yes
;   writable = no
;   printable = no
;   write list = @staff

# Other examples.
#
# A private printer, usable only by fred. Spool data will be placed in fred's
# home directory. Note that fred must have write access to the spool directory,
# wherever it is.
;[fredsprn]
;   comment = Fred's Printer
;   valid users = fred
;   path = /homes/fred
;   printer = freds_printer
;   public = no
;   writable = no
;   printable = yes

# A private directory, usable only by fred. Note that fred requires write
# access to the directory.
;[fredsdir]
;   comment = Fred's Service
;   path = /usr/somewhere/private
;   valid users = fred
;   public = no
;   writable = yes
;   printable = no

# a service which has a different directory for each machine that connects
# this allows you to tailor configurations to incoming machines. You could
# also use the %U option to tailor it by user name.
# The %m gets replaced with the machine name that is connecting.
;[pchome]
;  comment = PC Directories
;  path = /usr/pc/%m
;  public = no
;  writable = yes

# A publicly accessible directory, read/write to all users. Note that all files
# created in the directory by users will be owned by the default user, so
# any user with access can delete any other user's files. Obviously this
# directory must be writable by the default user. Another user could of course
# be specified, in which case all files would be owned by that user instead.
;[public]
;   path = /usr/somewhere/else/public
;   public = yes
;   only guest = yes
;   writable = yes
;   printable = no

# The following two entries demonstrate how to share a directory so that two
# users can place files there that will be owned by the specific users. In this
# setup, the directory should be writable by both users and should have the
# sticky bit set on it to prevent abuse. Obviously this could be extended to
# as many users as required.
;[myshare]
;   comment = Mary's and Fred's stuff
;   path = /usr/somewhere/shared
;   valid users = mary fred
;   public = no
;   writable = yes
;   printable = no
;   create mask = 0765

« Ultima modifica: 02 Dicembre 2013 ore 15:08 da whoami »
echo "VQF AHELME I BI CI WECPF"| tr "ETAOINSHRDLUBCFGJMQPVWZYXK" "A-Z"

Offline rodolforizzo76

  • *
  • Post: 180
  • Reputazione: 2
  • Aaron Nimzowitsch
    • Mostra profilo
    • painteronline.org
Re:Samba non parte causa macanza di rete locale...
« Risposta #27 il: 02 Dicembre 2013 ore 16:38 »
ok, ho controllato riga per riga tutto il file e sono identici. Continuero' a cercare una soluzione. Nel caso scoprissi tu qualcosa (anche a distanza di tempo) potresti postarmelo qui? io faro' lo stesso. Grazie ciao.


Sei un artista? Visita il mio sito http://www.painteronline.org

Offline francesco_dem

  • *
  • Post: 321
  • Reputazione: 9
    • Mostra profilo
Re:Samba non parte causa macanza di rete locale...
« Risposta #28 il: 02 Dicembre 2013 ore 19:00 »
Ciao ti posto la mia configurazione (generata da swat), spero  possa esserti utile.
Ho usato swat per l'aggiunta di cartelle.
La mia condivisione funziona egregiamente, sia per le cartelle, sia per la stampante

Codice: [Seleziona]
# Samba config file created using SWAT
# from UNKNOWN (127.0.0.1)
# Date: 2013/05/29 16:11:06

[global]
security = SHARE
obey pam restrictions = Yes
guest account = francesco
username map = /etc/samba/smbusers
log file = /var/log/samba/%m.log
max log size = 50
dns proxy = No
idmap config * : range =
idmap config * : backend = tdb
invalid users = root

[printers]
comment = Stampanti
path = /var/spool/samba
read only = No
guest ok = Yes
printable = Yes
print ok = Yes
use client driver = Yes
browseable = No

[Epson_Stylus_SX235]
comment = Epson Stylus SX235
path = /var/spool/samba
read only = No
guest ok = Yes
printable = Yes
print ok = Yes
printer name = Epson_Stylus_SX235
use client driver = Yes
oplocks = No
share modes = No

[film]
comment = Film
path = /home/francesco/Film/
read only = No
guest ok = Yes

[public]
comment = public
path = /home/francesco/public/
read only = No
guest ok = Yes

[Documenti]
comment = Documenti
path = /home/francesco/Documents/
read only = No
guest ok = Yes

Offline rodolforizzo76

  • *
  • Post: 180
  • Reputazione: 2
  • Aaron Nimzowitsch
    • Mostra profilo
    • painteronline.org
Re:Samba non parte causa macanza di rete locale...
« Risposta #29 il: 02 Dicembre 2013 ore 20:44 »
francesco_dem@
provo a fare delle prove. Come hai installato swat su chakra?
Grazie per l'interessamento.


Sei un artista? Visita il mio sito http://www.painteronline.org

 

Template by Homey | Sito ufficiale | Disclaimer