Autore Topic: Tempi di avvio systemd  (Letto 11382 volte)

TheImmortalPhoenix

Re:Tempi di avvio systemd
« Risposta #15 il: 21 Ottobre 2012 ore 16:16 »
A me 18.87 secondi, però ho tanti servizi all'avvio e inoltre monto tutte le partizioni...devo provare a diminuire le tty e togliere qualche servizio

Offline Fatto di note

  • *
  • Post: 133
  • Reputazione: 4
  • Marco, minimal is the word
    • Mostra profilo
Re:Tempi di avvio systemd
« Risposta #16 il: 21 Ottobre 2012 ore 16:20 »
Tre hd, uno dell'anteguerra.
15 partizioni tutte montate all'avvio. 8)
Mi spiace ma non credo nei +1 e -1, vi ringrazierò magari più volte ma scrivendovelo direttamente.

Offline andreazube

  • *
  • Post: 1595
  • Reputazione: 64
  • I AM THE INTERSECT
    • Mostra profilo
    • Lupo mannaro
Re:Tempi di avvio systemd
« Risposta #17 il: 21 Ottobre 2012 ore 16:23 »
Codice: [Seleziona]
$ systemd-analyze
Startup finished in 4443ms (kernel) + 16522ms (userspace) = 20966ms

E' una mia impressione o il mio pc ci mette un po troppo? (no ssd, no er4t)  :-\

EDIT: @Andreazube, grazie per la risposta... all'avvio mi da (anzi mi ha da sempre dato un warning sul punto di ibernazione non trovato)... nonostante tutto però, con systemd i tempi di avvio si sono almeno ridotti del 35% a occhio e croce, non ho mai cronometrato).

Premesso che per me va benissimo anche così, in caso ci sarebbe un modo per velocizzare ulteriormente l'avvio (che ne so, servizi inutili da disattivare, migliorie da apportare) senza usare er4t?

Per kde...disattivare desktop virtali,impostare sessione vuota in impostazioni di sistema---->avvio e spegnimento--->gestione di sessione
disattivare servizi "inutili" come bluetooth
non mettere troppi effetti e pochi plasmoidi sul desktop...non usare dekstop virtuali
Per l'ibernazione:
Scopri qual'è la tua partizione di swp (es /dev/sda2)
Quindi apri (come root)  il file /etc/default/grub e alla voce GRUB_CMDLINE_LINUX_DEFAULT= aggiungi resume=dev/sdax
dove sdax è la partizione di swap
ad esempio
GRUB_CMDLINE_LINUX_DEFAULT="init=/sbin/e4rat-preload quiet resume=/dev/sda2"

Aggiorna grub con
Codice: [Seleziona]
sudo grub-mkconfig -o /boot/grub/grub.cfg
quindi salvi il file modificato
---------------
Perchè non usare e4rat,comunque?
« Ultima modifica: 21 Ottobre 2012 ore 16:27 da andreazube »

Offline elvis

  • *
  • Post: 136
  • Reputazione: 9
    • Mostra profilo
Re:Tempi di avvio systemd
« Risposta #18 il: 21 Ottobre 2012 ore 16:27 »
Codice: [Seleziona]
$ systemd-analyze
Startup finished in 4443ms (kernel) + 16522ms (userspace) = 20966ms

E' una mia impressione o il mio pc ci mette un po troppo? (no ssd, no er4t)  :-\

EDIT: @Andreazube, grazie per la risposta... all'avvio mi da (anzi mi ha da sempre dato un warning sul punto di ibernazione non trovato)... nonostante tutto però, con systemd i tempi di avvio si sono almeno ridotti del 35% a occhio e croce, non ho mai cronometrato).

Premesso che per me va benissimo anche così, in caso ci sarebbe un modo per velocizzare ulteriormente l'avvio (che ne so, servizi inutili da disattivare, migliorie da apportare) senza usare er4t?
Con il comando

Codice: [Seleziona]
# systemd-analyze blame
ottieni una lista di unità in esecuzione, ordinate per tempi di "inizializzazione"
Pc Config
--phenom x4 965 @ 3.4 ghz
--corsair 8GB ddr3
--nvidia gtx 460
--ocz agility 3 60GB (chakra)
--crucial m4 128GB (windows 8.1)

Offline andreazube

  • *
  • Post: 1595
  • Reputazione: 64
  • I AM THE INTERSECT
    • Mostra profilo
    • Lupo mannaro
Re:Tempi di avvio systemd
« Risposta #19 il: 21 Ottobre 2012 ore 16:31 »
Con il comando

Codice: [Seleziona]
# systemd-analyze blame
ottieni una lista di unità in esecuzione, ordinate per tempi di "inizializzazione"
a me esce
Codice: [Seleziona]
   504ms systemd-udev-trigger.service
   469ms systemd-remount-fs.service
   213ms NetworkManager.service
   185ms systemd-vconsole-setup.service
   183ms systemd-sysctl.service
   146ms systemd-udevd.service
   143ms dev-hugepages.mount
   124ms home.mount
   123ms cdemu-daemon.service
    93ms systemd-modules-load.service
    89ms dcron.service
    82ms media-dati.mount
    76ms sys-kernel-debug.mount
    73ms dev-mqueue.mount
    63ms systemd-logind.service
    36ms modem-manager.service
    34ms polkit.service
    29ms systemd-tmpfiles-setup.service
    24ms rtkit-daemon.service
    14ms systemd-user-sessions.service
    12ms udisks.service
     6ms tmp.mount
     4ms upower.service
     3ms proc-sys-fs-binfmt_misc.mount
È normale?

Offline Neal Caffrey

  • *
  • Post: 58
  • Reputazione: 3
    • Mostra profilo
Re:Tempi di avvio systemd
« Risposta #20 il: 21 Ottobre 2012 ore 16:42 »
@andreabuze; @elvis:

in primis grazie.  :)

Premetto che, non ho plasmoidi sul desktop. Gli unici plasmoidi che ho sono due vista delle cartelle sul pannello (ho un solo pannello in basso), ed il plasmoide del tempo (semre sul pannello) Allego l'immagine.

Ecco invece l'output di # systemd-analyze blame
Codice: [Seleziona]
$ systemd-analyze blame
  9687ms NetworkManager.service
  7504ms cdemu-daemon.service
  7243ms systemd-logind.service
  2683ms systemd-vconsole-setup.service
  1618ms polkit.service
  1456ms systemd-remount-fs.service
  1203ms systemd-tmpfiles-setup.service
  1094ms sys-kernel-debug.mount
   610ms systemd-sysctl.service
   595ms systemd-udev-trigger.service
   590ms systemd-udevd.service
   559ms dev-hugepages.mount
   540ms dev-mqueue.mount
   439ms systemd-modules-load.service
   373ms systemd-user-sessions.service
   338ms ntpd.service
   319ms modem-manager.service
   251ms bluetooth.service
   220ms rtkit-daemon.service
    96ms upower.service
    77ms udisks.service
     7ms tmp.mount


Chakra Linux User since September 15th 2012
Intel core i5 430M, GeForce GT320M CUDA 1Gb - RAM 6GB

Offline andreazube

  • *
  • Post: 1595
  • Reputazione: 64
  • I AM THE INTERSECT
    • Mostra profilo
    • Lupo mannaro
Re:Tempi di avvio systemd
« Risposta #21 il: 21 Ottobre 2012 ore 16:54 »
@andreabuze; @elvis:

in primis grazie.  :)

Premetto che, non ho plasmoidi sul desktop. Gli unici plasmoidi che ho sono due vista delle cartelle sul pannello (ho un solo pannello in basso), ed il plasmoide del tempo (semre sul pannello) Allego l'immagine.

Ecco invece l'output di # systemd-analyze blame
Codice: [Seleziona]
$ systemd-analyze blame
  9687ms NetworkManager.service
  7504ms cdemu-daemon.service
  7243ms systemd-logind.service
  2683ms systemd-vconsole-setup.service
  1618ms polkit.service
  1456ms systemd-remount-fs.service
  1203ms systemd-tmpfiles-setup.service
  1094ms sys-kernel-debug.mount
   610ms systemd-sysctl.service
   595ms systemd-udev-trigger.service
   590ms systemd-udevd.service
   559ms dev-hugepages.mount
   540ms dev-mqueue.mount
   439ms systemd-modules-load.service
   373ms systemd-user-sessions.service
   338ms ntpd.service
   319ms modem-manager.service
   251ms bluetooth.service
   220ms rtkit-daemon.service
    96ms upower.service
    77ms udisks.service
     7ms tmp.mount

:o
decisamente c'è qualche problema.
Che pc hai?

Offline Neal Caffrey

  • *
  • Post: 58
  • Reputazione: 3
    • Mostra profilo
Re:Tempi di avvio systemd
« Risposta #22 il: 21 Ottobre 2012 ore 16:57 »
:o
decisamente c'è qualche problema.
Che pc hai?

Aspire 5741G, Intel Core i5 430M, GeForce GT320M e 6Gb di RAM  :-[
« Ultima modifica: 21 Ottobre 2012 ore 17:00 da Neal Caffrey »
Chakra Linux User since September 15th 2012
Intel core i5 430M, GeForce GT320M CUDA 1Gb - RAM 6GB

Offline andreazube

  • *
  • Post: 1595
  • Reputazione: 64
  • I AM THE INTERSECT
    • Mostra profilo
    • Lupo mannaro
Re:Tempi di avvio systemd
« Risposta #23 il: 21 Ottobre 2012 ore 17:00 »
Aspire 5751G, Intel Core i5 430M, GeForce GT320M e 6Gb di RAM  :-[
Allora c'è qualche problema molto serio  ;D
Io ho un totale di circa 30 sec. (con e4rat) su un asus x54c e sui 40 sec. pure su un vaio di 7-8 anni fa  :-[

Come hai fatto l'aggiornamento?hai notato problemi?prima dell'aggiornamento andavi meglio?con altre distro come va?

posta l'output di
Codice: [Seleziona]
journalctl (scorre con la freccia in basso del pc,si chiude con la lettera "q")
« Ultima modifica: 21 Ottobre 2012 ore 17:02 da andreazube »

Offline Neal Caffrey

  • *
  • Post: 58
  • Reputazione: 3
    • Mostra profilo
Re:Tempi di avvio systemd
« Risposta #24 il: 21 Ottobre 2012 ore 17:05 »
Allora c'è qualche problema molto serio  ;D
Io ho un totale di circa 30 sec. (con e4rat) su un asus x54c e sui 40 sec. pure su un vaio di 7-8 anni fa  :-[

Come hai fatto l'aggiornamento?hai notato problemi?prima dell'aggiornamento andavi meglio?con altre distro come va?

A dire il vero prima del passaggio a systemd andava ancora peggio. (aumento prestazioni 35%).  Su questo Pc a parte Kubuntu non ho mai montato altre distro e più o meno, siamo sempre stati li  :-\ (forse kubuntu leggermente piu veloce, ma poca roba). Ho provato per sfizio Ubuntu 12.10 in live, e si, questa era decisamente più rapida in boot.

L'aggiornamento l'ho fatto seguendo la guida passo passo ed è andato a buon fine. Non so cos'altro dire  :)
Per problema grave, a parte i tempi biblici, che si intende?
Mi consigli di reistallare il sistema da capo, aspettando la nuova iso?
NOTA Aggiuntiva: ho un dual boot con windows 7, che ha una partizioncina di 60GB

Ecco l'output da te richiesto, che è sta roba chilometrica? ???
Codice: [Seleziona]
Link a pastebin perchè il messaggio veniva troppo lungo e l'allegato troppo pesante  ::)

""http://pastebin.com/pJ4M1Jp6""
« Ultima modifica: 21 Ottobre 2012 ore 17:13 da Neal Caffrey »
Chakra Linux User since September 15th 2012
Intel core i5 430M, GeForce GT320M CUDA 1Gb - RAM 6GB

Offline andreazube

  • *
  • Post: 1595
  • Reputazione: 64
  • I AM THE INTERSECT
    • Mostra profilo
    • Lupo mannaro
Re:Tempi di avvio systemd
« Risposta #25 il: 21 Ottobre 2012 ore 17:08 »
A dire il vero prima del passaggio a systemd andava ancora peggio. (aumento prestazioni 35%).  Su questo Pc a parte Kubuntu non ho mai montato altre distro e più o meno, siamo sempre stati li  :-\ (forse kubuntu leggermente piu veloce, ma poca roba). Ho provato per sfizio Ubuntu 12.10 in live, e si, questa era decisamente più rapida in boot.

L'aggiornamento l'ho fatto seguendo la guida passo passo ed è andato a buon fine. Non so cos'altro dire  :)
Per problema grave, a parte i tempi biblici, che si intende?
Mi consigli di reistallare il sistema da capo, aspettando la nuova iso?
NOTA Aggiuntiva: ho un dual boot con windows 7, che ha una partizioncina di 60GB
Problema grave----tempi biblici
Hai un pc di gran lunga migliore di quello di molti di noi e tempi di avvio di gran lunga superiori...
Quando uscirà la nuova iso potresti provarla in live usb...ma comunque io cercherei di capire perchè hai questi tempi astronomici

Offline Neal Caffrey

  • *
  • Post: 58
  • Reputazione: 3
    • Mostra profilo
Re:Tempi di avvio systemd
« Risposta #26 il: 21 Ottobre 2012 ore 17:21 »
Problema grave----tempi biblici
Hai un pc di gran lunga migliore di quello di molti di noi e tempi di avvio di gran lunga superiori...
Quando uscirà la nuova iso potresti provarla in live usb...ma comunque io cercherei di capire perchè hai questi tempi astronomici

Ho editato il messaggio precedente :)
Chakra Linux User since September 15th 2012
Intel core i5 430M, GeForce GT320M CUDA 1Gb - RAM 6GB

Offline NightLord

  • *
  • Post: 3
  • Reputazione: 0
    • Mostra profilo
Re:Tempi di avvio systemd
« Risposta #27 il: 21 Ottobre 2012 ore 17:31 »
Io ho aggiornato stanotte ed ecco qua
Codice: [Seleziona]
Startup finished in 3732ms (kernel) + 9620ms (userspace) = 13353ms

Offline Cylon

  • *
  • Post: 1960
  • Reputazione: 78
  • CYbernetic Life fOrm Node
    • Mostra profilo
Re:Tempi di avvio systemd
« Risposta #28 il: 21 Ottobre 2012 ore 17:36 »
anche da me chakra si avvia in circa 20 secondi
oggi invece
Startup finished in 8720ms (kernel) + 9405ms (userspace) = 18126ms


... mentre arch in 16 circa...

llol ieri era 16 secondi.. oggi senza aggiornare nulla

Startup finished in 5242ms (kernel) + 14764ms (userspace) = 20006ms  :o :o :o

PS: maledetto networkmanager solo lui ci mette 7 secondi... maledetta scheda wireless :)
« Ultima modifica: 21 Ottobre 2012 ore 17:49 da Cylon »
We are the Cylons. Lower your firewalll and surrender.Your PC will adapt to service our GNU/Linux systems. Resistance is futile. Extermination of human race has began!
                                                                     Non rispondo a PM

Offline andreazube

  • *
  • Post: 1595
  • Reputazione: 64
  • I AM THE INTERSECT
    • Mostra profilo
    • Lupo mannaro
Re:Tempi di avvio systemd
« Risposta #29 il: 21 Ottobre 2012 ore 17:38 »
Ho editato il messaggio precedente :)
Mi dispiace ma...non lo so.
20 secondi sono tanti,ma non  c'è un punto "di blocco".
Quanto ci metti a caricare il sistema,KDE compreso?
IHMO ti conviene contattare il nostro semi-dio,jmc.Spesso lo trovi su irc

 

Template by Homey | Sito ufficiale | Disclaimer