Autore Topic: Velocizzare Chakra con e4rat versione systemd  (Letto 8135 volte)

Offline Pippo

  • *
  • Post: 4
  • Reputazione: 0
    • Mostra profilo
Re:Velocizzare Chakra con e4rat...versione systemd
« Risposta #30 il: 23 Ottobre 2012 ore 13:29 »
Eccezionale!  :D
Che bella accoppiata systemd+e4rat  :D :D :D

Salve sono un nuovo utente chakra, volevo ringraziare @andreazube per la guida e volevo dare assolutamente ragione ad @homey, con systemd+e4rat ti cambiano le cose ...  :)

Offline andreazube

  • *
  • Post: 1595
  • Reputazione: 64
  • I AM THE INTERSECT
    • Mostra profilo
    • Lupo mannaro
Re:Velocizzare Chakra con e4rat...versione systemd
« Risposta #31 il: 23 Ottobre 2012 ore 14:10 »
Salve sono un nuovo utente chakra, volevo ringraziare @andreazube per la guida e volevo dare assolutamente ragione ad @homey, con systemd+e4rat ti cambiano le cose ...  :)
Grazie mille  :)

Offline andreazube

  • *
  • Post: 1595
  • Reputazione: 64
  • I AM THE INTERSECT
    • Mostra profilo
    • Lupo mannaro
Re:Velocizzare Chakra con e4rat...versione systemd
« Risposta #32 il: 24 Ottobre 2012 ore 15:47 »
Mi sa che ho detto una cavolata:qui su chakra e4rat e readahead vanno anche insieme.O perlomeno,l'output mi dice che e4rat è ok e poi arrivano due stringhe su readahead che sembrano dire che sta andando.
Non so se readahead è cosi di suo o è perchè è insieme a e4rat,ma alla fine fa guadagnare neanche un secondo...

Offline ronnydaca

  • *
  • Post: 511
  • Reputazione: 1
    • Mostra profilo
Re:Velocizzare Chakra con e4rat versione systemd
« Risposta #33 il: 27 Aprile 2013 ore 13:54 »
Sto provando questa guida ma ho dei dubbi.

Dici:
Citazione
Aggiungiamo init=/sbin/e4rat-collectalla riga linux della nostra Chakra,subito prima di ro quiet
Ma nel tuo codice è dopo ro quiet:

Citazione
echo   'Caricamento Linux linux...'
 --------------> linux   /boot/vmlinuz-linux root=UUID=5307ad5e-1330-4cfb-b9f2-b0c3ed2d6660 ro  quiet init=/sbin/e4rat-collect <---------------------------------------------------------------
   echo   'Caricamento ramdisk iniziale...'
   initrd   /boot/initramfs-linux.img
}
E poi io ho due volte ro quiet:
Citazione
   echo   'Loading Linux linux ...'
   linux   /boot/vmlinuz-linux resume=UUID=ebeda5cc-8ea0-4b44-974d-43d094cc2a0b root=UUID=4d0c68c5-0e11-4438-a3b2-8df37c1d65d0 ro  quiet
   echo   'Loading initial ramdisk ...'
   initrd   /boot/initramfs-linux.img
}
submenu 'Advanced options for Chakra Linux' $menuentry_id_option 'gnulinux-advanced-4d0c68c5-0e11-4438-a3b2-8df37c1d65d0' {
   menuentry 'Chakra Linux, with Linux linux' --class chakra --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-linux-advanced-4d0c68c5-0e11-4438-a3b2-8df37c1d65d0' {
   savedefault
      load_video
      set gfxpayload=keep
      insmod gzio
      insmod part_msdos
      insmod ext2
      set root='hd0,msdos2'
      if [ x$feature_platform_search_hint = xy ]; then
        search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos2 --hint-efi=hd0,msdos2 --hint-baremetal=ahci0,msdos2  4d0c68c5-0e11-4438-a3b2-8df37c1d65d0
      else
        search --no-floppy --fs-uuid --set=root 4d0c68c5-0e11-4438-a3b2-8df37c1d65d0
      fi
      echo   'Loading Linux linux ...'
      linux   /boot/vmlinuz-linux resume=UUID=ebeda5cc-8ea0-4b44-974d-43d094cc2a0b root=UUID=4d0c68c5-0e11-4438-a3b2-8df37c1d65d0 ro  quiet
      echo   'Loading initial ramdisk ...'
      initrd   /boot/initramfs-linux.img

Dove lo inserisco?

Offline andreazube

  • *
  • Post: 1595
  • Reputazione: 64
  • I AM THE INTERSECT
    • Mostra profilo
    • Lupo mannaro
Re:Velocizzare Chakra con e4rat versione systemd
« Risposta #34 il: 27 Aprile 2013 ore 13:59 »
Posizionarlo prima o dopo di quiet è indifferente.

Quanto al secondo punto, tu hai ovviamente un solo ro quiet. Sono due cose diverse, come pare anche abbastanza evidente da questo pezzo:

Codice: [Seleziona]
submenu 'Advanced options for Chakra Linux' $menuentry_id_option 'gnulinux-advanced-4d0c68c5-0e11-4438-a3b2-8df37c1d65d0' {
   menuentry 'Chakra Linux, with Linux linux'

Quando accedi a grub, ti escono due voci per chakra:

chakra
e
opzioni avanzate per chakra

(non ricordo con precisione, ma è una cosa simile) Bene, la prima riga "Linux" si riferisce a "chakra", la seconda si riferisce a una delle opzioni che escono selezionando "opzioni avanzate per chakra". Mi spiego?  :)

Offline ronnydaca

  • *
  • Post: 511
  • Reputazione: 1
    • Mostra profilo
Re:Velocizzare Chakra con e4rat versione systemd
« Risposta #35 il: 27 Aprile 2013 ore 14:00 »
Capito.
Quindi nella prima riga dove compare ro quiet.
Grazie ;)

Offline ronnydaca

  • *
  • Post: 511
  • Reputazione: 1
    • Mostra profilo
Re:Velocizzare Chakra con e4rat versione systemd
« Risposta #36 il: 27 Aprile 2013 ore 14:06 »
Aiuto!
Kernel panic notte syncing attempted to kill init
 
Poi sotto PID 1 comm: e4rat-collect not tainted
« Ultima modifica: 27 Aprile 2013 ore 14:09 da ronnydaca »

Offline ronnydaca

  • *
  • Post: 511
  • Reputazione: 1
    • Mostra profilo
Re:Velocizzare Chakra con e4rat versione systemd
« Risposta #37 il: 27 Aprile 2013 ore 14:08 »
E poi una serie di codici.
Sto su tablet e quindi non riesco a scriver tutto

Offline andreazube

  • *
  • Post: 1595
  • Reputazione: 64
  • I AM THE INTERSECT
    • Mostra profilo
    • Lupo mannaro
Re:Velocizzare Chakra con e4rat versione systemd
« Risposta #38 il: 27 Aprile 2013 ore 14:08 »
Aiuto!
Kernel panico notte syncing attempted tokill init

Poi sotto PID 1 comm: e4rat-collect not tainted
E??? ho capito solo "aiuto"  ;D per favore spiegati meglio.

Comunque, puoi usare l'opzione "opzioni avanzate per chakra", se non le hai modificate, oppure fare cosi: da grub, vai alla voce di chakra e premi "e", quindi togli quello che hai messo prima e avvia con f10

Offline ronnydaca

  • *
  • Post: 511
  • Reputazione: 1
    • Mostra profilo
Re:Velocizzare Chakra con e4rat versione systemd
« Risposta #39 il: 27 Aprile 2013 ore 14:16 »
Sono entrato con "E" ma non c'era quella stringa.
Poi si è riavviato ma nel file grub la vedo.

Perché è successo questo?
Dove ho sbagliato?

Offline ronnydaca

  • *
  • Post: 511
  • Reputazione: 1
    • Mostra profilo
Re:Velocizzare Chakra con e4rat versione systemd
« Risposta #40 il: 27 Aprile 2013 ore 14:18 »
Era una cosa del genere:

Citazione
Kernel panic not syncing attempted to kill init
 
Poi sotto PID 1 comm: e4rat-collect not tainted

Offline andreazube

  • *
  • Post: 1595
  • Reputazione: 64
  • I AM THE INTERSECT
    • Mostra profilo
    • Lupo mannaro
Re:Velocizzare Chakra con e4rat versione systemd
« Risposta #41 il: 27 Aprile 2013 ore 14:21 »
Quando premi con e, poi devi andare giù, non ti fa vedere tutto... l'hai fatto, vero?

Per il secondo quiesito... sei sicuro di aver seguito bene la guida? In particolare, hai modificato correttamente e4rat.conf ?

Se è tutto a posto, bisognerà provare cosi:

Codice: [Seleziona]
sudo nano /etc/default/grub
aggiungere init=/sbin/e4rat-collect  a GRUB_CMDLINE_LINUX_DEFAULT

Aggiornare grub
Codice: [Seleziona]
grub-mkconfig -o /boot/grub/grub.cfg
Riavviare, fare quel che devi fare nei 120 secondi, poi rifare come sopra per togliere init=/sbin/e4rat-collect

Offline ronnydaca

  • *
  • Post: 511
  • Reputazione: 1
    • Mostra profilo
Re:Velocizzare Chakra con e4rat versione systemd
« Risposta #42 il: 27 Aprile 2013 ore 14:25 »
Citazione
; path to init process binary (DEFAULT: /sbin/init)
 init /sbin/systemd
Questa è la riga di e4rat.conf come l'ho scritta.

Così?
Citazione
GRUB_CMDLINE_LINUX_DEFAULT="quiet init=/sbin/e4rat-collect"

Ma anche dopo ro quiet come nella guida nel file dentro /boot/?


Offline ronnydaca

  • *
  • Post: 511
  • Reputazione: 1
    • Mostra profilo
Re:Velocizzare Chakra con e4rat versione systemd
« Risposta #43 il: 27 Aprile 2013 ore 14:29 »
Ho fatto queste modifiche ma ora si avvia normalmente, senza scritte relative a e4rat.
Come se non avessi modificato nulla.

Offline andreazube

  • *
  • Post: 1595
  • Reputazione: 64
  • I AM THE INTERSECT
    • Mostra profilo
    • Lupo mannaro
Re:Velocizzare Chakra con e4rat versione systemd
« Risposta #44 il: 27 Aprile 2013 ore 14:31 »
NO!NO!NO!

Ecco perchè avevi il kernel panic! Hai sbagliato a modificare e4rat.conf!

non è /sbin/systemd, ma /bin/systemd !!

Nella guida infatti è scritto

Citazione
Quindi,cerchiamo la stringa "; path to init process binary (DEFAULT: /sbin/init)
; init /sbin/init".Togliamo il punto e virgola prima di init e sostituiamo /sbin/init con /bin/systemd

Ho postato il file come deve venire, e pure le due righe interessate zoomate: per favore, fai più attenzione  :P :P

 

Template by Homey | Sito ufficiale | Disclaimer