Autore Topic: [Risolto]Problema amule  (Letto 2315 volte)

mcmaur

[Risolto]Problema amule
« il: 22 Luglio 2012 ore 17:17 »
Come potete vedere amule non partiva:
Codice: [Seleziona]
[mauro@chakra-pc ~]$ amule
amule: error while loading shared libraries: libcryptopp.so: cannot open shared object file: No such file or directory
ho quindi pensato di disinstallarlo:
Codice: [Seleziona]
[mauro@chakra-pc ~]$ pacman -R amule-adnza
errore: questa operazione è possibile solo da root.
[mauro@chakra-pc ~]$ sudo !!
sudo pacman -R amule-adnza
controllo delle dipendenze in corso...

Pacchetti (1): amule-adnza-2010.1-3

Dimensione totale dei pacchetti rimossi: 13,41 MiB

Vuoi rimuovere questi pacchetti? [S/n] s
(1/1) rimozione in corso di amule-adnza            [#####################] 100%
per poi installarlo di nuovo:
Codice: [Seleziona]
[mauro@chakra-pc ~]$ ccr -S amule-adnza-svn

Ccr Targets    (1): amule-adnza-svn

Proceed with installation? [Y/n] y
Edit amule-adnza-svn PKGBUILD with $EDITOR? [Y/n] n
==> Determinazione dell'ultima revisione di svn in corso...
  -> Versione trovata: 345
==> Creazione del pacchetto: amule-adnza-svn 345-1 (dom 22 lug 2012, 17.12.48, CEST)
==> Controllo delle dipendenze durante l'avvio in corso...
==> Controllo delle dipendenze durante la compilazione in corso...
==> Download dei sorgenti in corso...
  -> È stato trovato fix_icon+comment+name2.patch
  -> È stato trovato fix_window_title2.patch
  -> È stato trovato gcc-4.7.patch
==> Validazione dei file sorgenti con md5sums in corso...
    fix_icon+comment+name2.patch ... Verificato
    fix_window_title2.patch ... Verificato
    gcc-4.7.patch ... Verificato
==> Estrazione dei sorgenti in corso...
==> Rimozione dell'esistente directory pkg/ in corso...
==> Avvio di build() in corso...
Updating '.':
Alla revisione 345.
==> SVN checkout done or server timeout
==> Starting make...
patching file src/ObservableQueue.h
Hunk #1 FAILED at 331.
1 out of 1 hunk FAILED -- saving rejects to file src/ObservableQueue.h.rej
==> ERRORE: Si è verificato un errore in build().
    L'operazione sta per essere interrotta...
The build failed.

Qualcosa non va in ccr o sbaglio io? e cosa aveva causato l'errore iniziale?
« Ultima modifica: 29 Luglio 2012 ore 14:37 da mcmaur »

Offline leozzo

  • *
  • Post: 180
  • Reputazione: 12
    • Mostra profilo
Re:Problema amule
« Risposta #1 il: 22 Luglio 2012 ore 17:30 »
Beh ma stai installando un pacchetto diverso da quello che hai rimosso: in ccr ci sono sia amule-adnza che amule-adnza-svn. Prova a reinstallare il primo.

mcmaur

Re:Problema amule
« Risposta #2 il: 23 Luglio 2012 ore 12:44 »
mi serve per fastweb. non è il secondo?

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Problema amule
« Risposta #3 il: 23 Luglio 2012 ore 12:56 »
C'è un problema nella compila col nuovo gcc.

Prova l'svn
http://chakra-linux.org/ccr/packages.php?ID=3941

E' lo stesso ma usa codice (in teoria) più aggiornato.
Qui hanno già corretto con una patch

Offline FranzMari

  • *
  • Post: 2814
  • Reputazione: 103
  • [Senior Packager]
    • Mostra profilo
    • IMHO blog
Re:Problema amule
« Risposta #4 il: 23 Luglio 2012 ore 12:58 »
Entrambi i pacchetti vanno bene per Fastweb, l'unica differenza è che amule-adnza-svn recupera l'ultima versione disponibile da svn.
L'errore non è dovuto al fatto che stai installando un altro pacchetto, c'è un problema nella patch: dovresti scrivere al manutentore del pacchetto su CCR, così può correggerlo.
Nel frattempo puoi provare ad installare il pacchetto amule-adnza "normale"; se hai problemi puoi seguire questo post.

C'è un problema nella compila col nuovo gcc.

Prova l'svn
http://chakra-linux.org/ccr/packages.php?ID=3941

E' lo stesso ma usa codice (in teoria) più aggiornato.
Qui hanno già corretto con una patch

E' quello che ha provato ad installare...

Codice: [Seleziona]
[mauro@chakra-pc ~]$ ccr -S amule-adnza-svn

Ccr Targets    (1): amule-adnza-svn

Proceed with installation? [Y/n] y
Edit amule-adnza-svn PKGBUILD with $EDITOR? [Y/n] n
==> Determinazione dell'ultima revisione di svn in corso...
  -> Versione trovata: 345
==> Creazione del pacchetto: amule-adnza-svn 345-1 (dom 22 lug 2012, 17.12.48, CEST)
==> Controllo delle dipendenze durante l'avvio in corso...
==> Controllo delle dipendenze durante la compilazione in corso...
==> Download dei sorgenti in corso...
  -> È stato trovato fix_icon+comment+name2.patch
  -> È stato trovato fix_window_title2.patch
  -> È stato trovato gcc-4.7.patch
==> Validazione dei file sorgenti con md5sums in corso...
    fix_icon+comment+name2.patch ... Verificato
    fix_window_title2.patch ... Verificato
    gcc-4.7.patch ... Verificato
==> Estrazione dei sorgenti in corso...
==> Rimozione dell'esistente directory pkg/ in corso...
==> Avvio di build() in corso...
Updating '.':
Alla revisione 345.
==> SVN checkout done or server timeout
==> Starting make...
patching file src/ObservableQueue.h
Hunk #1 FAILED at 331.
1 out of 1 hunk FAILED -- saving rejects to file src/ObservableQueue.h.rej
==> ERRORE: Si è verificato un errore in build().
    L'operazione sta per essere interrotta...
The build failed.
«Il valore dell'essere umano si determina nella misura in cui sia grande o piccola la sua capacità di contribuire al bene collettivo.» Jigorō Kanō

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Problema amule
« Risposta #5 il: 23 Luglio 2012 ore 14:27 »
E' quello che ha provato ad installare...

Ops, letto troppo di fretta!  >:(

mcmaur

Re:Problema amule
« Risposta #6 il: 23 Luglio 2012 ore 15:37 »
Codice: [Seleziona]
[mauro@chakra-pc ~]$ ccr -S amule-adnza

Ccr Targets    (1): amule-adnza
Pacman Targets (1): cvs

Proceed with installation? [Y/n] y
Password:
risoluzione delle dipendenze in corso...
ricerca dei conflitti in corso...

Pacchetti (1): cvs-1.11.23-10

Dimensione totale dei pacchetti da scaricare:    0,51 MiB

Dimensione totale dei pacchetti da installare:   1,12 MiB


Vuoi procedere con l'installazione? [S/n]
:: Download dei pacchetti da core...
 cvs-1.11.23-10-x86_64                     521,5 KiB  63,3K/s 00:08 [#####################################] 100%
.........................................
CObservableQueue<ValueType>::ObserverRemoved(CObservableQueue<ValueType>::ObserverType*) [with ValueType = CPartFile*; CObservableQueue<ValueType>::ObserverType = CObserver<CQueueEvent<CPartFile*> >]’:
DownloadQueue.cpp:1753:1:   required from here
ObservableQueue.h:341:2: error: ‘NotifyObservers’ was not declared in this scope, and no declarations were found by argument-dependent lookup at the point of instantiation [-fpermissive]
ObservableQueue.h:341:2: note: declarations in dependent base ‘CObservable<CQueueEvent<CPartFile*> >’ are not found by unqualified lookup
ObservableQueue.h:341:2: note: use ‘this->NotifyObservers’ instead
make[3]: *** [amule-DownloadQueue.o] Errore 1
make[2]: *** [all-recursive] Errore 1
make[1]: *** [all-recursive] Errore 1
make: *** [all] Errore 2
==> ERRORE: Si è verificato un errore in build().
    L'operazione sta per essere interrotta...
The build failed.
anche l'altro non funziona.

mcmaur

Re:Problema amule
« Risposta #7 il: 23 Luglio 2012 ore 16:03 »

Offline FranzMari

  • *
  • Post: 2814
  • Reputazione: 103
  • [Senior Packager]
    • Mostra profilo
    • IMHO blog
Re:Problema amule
« Risposta #8 il: 23 Luglio 2012 ore 16:54 »
anche l'altro non funziona.

Nel frattempo puoi provare ad installare il pacchetto amule-adnza "normale"; se hai problemi puoi seguire questo post.
«Il valore dell'essere umano si determina nella misura in cui sia grande o piccola la sua capacità di contribuire al bene collettivo.» Jigorō Kanō

mcmaur

Re:Problema amule
« Risposta #9 il: 24 Luglio 2012 ore 15:09 »
Riassumo il procedimento:
Dare il comando "ccr -S amule-adnza". Lasciare in sospeso l'installazione quando chiede se vuoi editare il PKGBUILD (domanda in giallo). Recarsinel seguente percorso:  "/tmp/ccrbuild-1000/amule-adnza/amule-adnza/". Copiare dentro il contenuto dell'archivio che trovate www.archlinux.it/forum/download/file.php?id=6 sovrascrivendo i file. Dare il comando "makepkg". Installare il pacchetto appena creato con "sudo pacman -U amule-adnza-2010.1-3-x86_64.pkg.tar.xz".

In alternativa procedere (a vostro rischio :P ) con l'ultima istruzione con il pachetto che trovate qui: https://www.dropbox.com/s/55th4l2ps6w4ni7/amule-adnza-2010.1-3-x86_64.pkg.tar.xz (Chakra 64 bit).

P.S:funzionerà un pacchetto compilato per me? :-\
PP.S: se mettessimo queste istruzioni come "importanti" quindi in primo piano? Anche se l'uso della funzione cerca dovrebbe evitare queste cose ( come le mie.. scusate  :'( )
« Ultima modifica: 24 Luglio 2012 ore 15:14 da mcmaur »

Offline FranzMari

  • *
  • Post: 2814
  • Reputazione: 103
  • [Senior Packager]
    • Mostra profilo
    • IMHO blog
Re:Problema amule
« Risposta #10 il: 24 Luglio 2012 ore 16:49 »
il pacchetto amule-adnza è stato aggiornato stamattina; riprova ad installarlo e vedi se funziona  ;)
« Ultima modifica: 24 Luglio 2012 ore 21:57 da FranzMari »
«Il valore dell'essere umano si determina nella misura in cui sia grande o piccola la sua capacità di contribuire al bene collettivo.» Jigorō Kanō

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Problema amule
« Risposta #11 il: 24 Luglio 2012 ore 20:40 »
Qui amule-adnza compila correttamente, ora :)

mcmaur

Re:Problema amule
« Risposta #12 il: 25 Luglio 2012 ore 13:20 »
tutto a posto per amule-adnza ma non per amule-adnza-svn: magie delle segnalazione ai manutentori :)

Metto risolto.
P.S: avrebbe funzionato il pacchetto già pronto?

 

Template by Homey | Sito ufficiale | Disclaimer