Autore Topic: Mouse non riconosciuto su KVM switch  (Letto 1344 volte)

Offline lapescara

  • *
  • Post: 14
  • Reputazione: 0
    • Mostra profilo
Mouse non riconosciuto su KVM switch
« il: 15 Luglio 2012 ore 16:42 »
Sono su chakra x86_64 kernel 3.4.3-1 e utilizzo un KVM switch ma da ieri il mouse non funziona più se attaccato allo switch.
Sembra come se l'uscita venga disconnessa (luce spenta sul mouse) ma se lo attacco direttamente alle altre uscite usb funziona.
Lo strano è che la tastiera funziona correttamente mentre sull'altro pc funzionano tutti e due.
Ieri ho effettuato un sacco di aggiornamenti (più di 300 MB) ed installato vari programmi (opera, akregator, keepassx, deluge, cute giraffe, luckybackup, soundkonverter) ma non mi pare che nessuno di queste installazioni sia la causa, il problema è nato dopo.
Uso i driver open.
Provato a fare il riavvio ma niente.
Ho notato una scritta "fail" al boot solo che non so dove andare a guardare i log.
Da lsusb:
Codice: [Seleziona]
[antonio@chakra-pc ~]$ lsusb
Bus 001 Device 002: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 002 Device 002: ID 093a:2510 Pixart Imaging, Inc. Optical Mouse
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 004: ID 0461:0010 Primax Electronics, Ltd HP Keyboard
Bus 001 Device 005: ID 10d5:000d Uni Class Technology Co., Ltd
[antonio@chakra-pc ~]$ lsusb
Bus 001 Device 002: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 007: ID 093a:2510 Pixart Imaging, Inc. Optical Mouse
Bus 001 Device 004: ID 0461:0010 Primax Electronics, Ltd HP Keyboard
Bus 001 Device 005: ID 10d5:000d Uni Class Technology Co., Ltd

Il primo comando è col mouse attaccato allo switch mentre il secondo ad una delle porte usb (2).
Attendo fiducioso

giannifur

Re:Mouse non riconosciuto su KVM switch
« Risposta #1 il: 15 Luglio 2012 ore 17:14 »
Per guardare il log vai in var/log/boot il file in genere è lungo vai a cercarti gli ultimi boot in fondo al file!

Offline lapescara

  • *
  • Post: 14
  • Reputazione: 0
    • Mostra profilo
Re:Mouse non riconosciuto su KVM switch
« Risposta #2 il: 15 Luglio 2012 ore 18:11 »
L'errore al boot si riferiva ad alsa:

Codice: [Seleziona]
Sun Jul 15 17:44:21 2012: :: Restoring ALSA Levels    [BUSY] Found hardware: "HDA-Intel" "Nvidia MCP79/7A HDMI" "HDA:10ec0885,18495890,00100101 HDA:10de0007,10de0101,0010
Sun Jul 15 17:44:21 2012: Hardware is initialized using a generic method
Sun Jul 15 17:44:21 2012:    [FAIL]

Risolto stoppando  e facendo ripartire alsa:
Codice: [Seleziona]
sudo rc.d stop alsa
sudo rc.d start alsa

Ultimo boot:
Codice: [Seleziona]
Sun Jul 15 17:55:00 2012: :: Restoring ALSA Levels    [BUSY]    [DONE]
Visto che il mio KVM gestisce anche l'audio speravo di aver risolto ma purtroppo non è così.

Offline lapescara

  • *
  • Post: 14
  • Reputazione: 0
    • Mostra profilo
Re:Mouse non riconosciuto su KVM switch
« Risposta #3 il: 16 Luglio 2012 ore 16:41 »
Siccome su questo pc ho anche una partizione con debian testing ho provato ad avviarla e il mouse funziona quindi almeno non è un problema che dipende dal pc.

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Mouse non riconosciuto su KVM switch
« Risposta #4 il: 16 Luglio 2012 ore 17:46 »
Se colleghi e sconnetti il mouse, cosa dice dmesg?

per risolvere definit. l'errore di alsa (http://forum.chakra-project.it/index.php/topic,4038.msg20281.html#msg20281):
Codice: [Seleziona]
sudo alsactl store

Offline lapescara

  • *
  • Post: 14
  • Reputazione: 0
    • Mostra profilo
Re:Mouse non riconosciuto su KVM switch
« Risposta #5 il: 16 Luglio 2012 ore 20:17 »
Allora, la situazione col mouse collegato direttamente:
Codice: [Seleziona]
[   87.434140] input: PIXART USB OPTICAL MOUSE as /devices/pci0000:00/0000:00:04.0/usb2/2-5/2-5:1.0/input/input12
[   87.435311] generic-usb 0003:093A:2510.0005: input,hidraw0: USB HID v1.11 Mouse [PIXART USB OPTICAL MOUSE] on usb-0000:00:04.0-5/input0

Lo collego allo switch:
Codice: [Seleziona]
[   84.026757] usb 1-6.1: USB disconnect, device number 3
[   87.226985] usb 2-5: new low-speed USB device number 2 using ohci_hcd
[   87.434140] input: PIXART USB OPTICAL MOUSE as /devices/pci0000:00/0000:00:04.0/usb2/2-5/2-5:1.0/input/input12
[   87.435311] generic-usb 0003:093A:2510.0005: input,hidraw0: USB HID v1.11 Mouse [PIXART USB OPTICAL MOUSE] on usb-0000:00:04.0-5/input0
[  571.144034] usb 2-5: USB disconnect, device number 2
[  577.000695] usb 1-6.1: new low-speed USB device number 7 using ehci_hcd
[  577.092298] input: PIXART USB OPTICAL MOUSE as /devices/pci0000:00/0000:00:04.1/usb1/1-6/1-6.1/1-6.1:1.0/input/input13
[  577.092900] generic-usb 0003:093A:2510.0006: input,hidraw0: USB HID v1.11 Mouse [PIXART USB OPTICAL MOUSE] on usb-0000:00:04.1-6.1/input0

Lo scollego:

Codice: [Seleziona]
[   84.026757] usb 1-6.1: USB disconnect, device number 3
[   87.226985] usb 2-5: new low-speed USB device number 2 using ohci_hcd
[   87.434140] input: PIXART USB OPTICAL MOUSE as /devices/pci0000:00/0000:00:04.0/usb2/2-5/2-5:1.0/input/input12
[   87.435311] generic-usb 0003:093A:2510.0005: input,hidraw0: USB HID v1.11 Mouse [PIXART USB OPTICAL MOUSE] on usb-0000:00:04.0-5/input0
[  571.144034] usb 2-5: USB disconnect, device number 2
[  577.000695] usb 1-6.1: new low-speed USB device number 7 using ehci_hcd
[  577.092298] input: PIXART USB OPTICAL MOUSE as /devices/pci0000:00/0000:00:04.1/usb1/1-6/1-6.1/1-6.1:1.0/input/input13
[  577.092900] generic-usb 0003:093A:2510.0006: input,hidraw0: USB HID v1.11 Mouse [PIXART USB OPTICAL MOUSE] on usb-0000:00:04.1-6.1/input0
[  647.980817] usb 1-6.1: USB disconnect, device number 7

 

Template by Homey | Sito ufficiale | Disclaimer