Autore Topic: Aggiornamento(risolto)  (Letto 1675 volte)

Offline alessio

  • *
  • Post: 6
  • Reputazione: 0
    • Mostra profilo
Aggiornamento(risolto)
« il: 15 Aprile 2012 ore 12:42 »
Ciao a tutti, questa mattina Apper mi segnalava 58 aggiornamenti,ho provato a farli ma si blocca segnalandomi che non riesce a risolvere una dipendenza relativa a Pacman,ho provato anche da terminale,senza riuscire a risolvere
Codice: [Seleziona]
[root@chakra-pc alessio]# pacman -Syu
:: Sincronizzazione dei database in corso...
 testing è aggiornato
 core è aggiornato
 platform è aggiornato
 desktop è aggiornato
 apps è aggiornato
 games è aggiornato
:: I seguenti pacchetti dovrebbero essere aggiornati prima :
    pacman  pacman
:: Vuoi annullare l'operazione corrente
:: e aggiornare adesso questi pacchetti? [S/n] s

attenzione: sto ignorando il pacchetto: pacman
risoluzione delle dipendenze in corso...
ricerca dei conflitti in corso...
errore: impossibile eseguire l'operazione richiesta (impossibile soddisfare le dipendenze)
:: packagekit: richiede pacman<3.6.0
[root@chakra-pc alessio]# pacman -Syu
:: Sincronizzazione dei database in corso...
 testing è aggiornato
 core è aggiornato
 platform è aggiornato
 desktop è aggiornato
 apps è aggiornato
 games è aggiornato
:: I seguenti pacchetti dovrebbero essere aggiornati prima :
    pacman  pacman
:: Vuoi annullare l'operazione corrente
:: e aggiornare adesso questi pacchetti? [S/n] n

:: Aggiornamento del sistema in corso...
:: Vuoi sostituire gtk-integration con testing/chakra-gtk-config? [S/n] n
risoluzione delle dipendenze in corso...
ricerca dei conflitti in corso...
errore: impossibile eseguire l'operazione richiesta (impossibile soddisfare le dipendenze)
:: packagekit: richiede pacman<3.6.0
[root@chakra-pc alessio]# pacman -Syu
:: Sincronizzazione dei database in corso...                                                                                                                                                                   
 testing è aggiornato                                                                                                                                                                                         
 core è aggiornato                                                                                                                                                                                             
 platform è aggiornato                                                                                                                                                                                         
 desktop è aggiornato                                                                                                                                                                                         
 apps è aggiornato                                                                                                                                                                                             
 games è aggiornato                                                                                                                                                                                           
:: I seguenti pacchetti dovrebbero essere aggiornati prima :                                                                                                                                                   
    pacman  pacman                                                                                                                                                                                             
:: Vuoi annullare l'operazione corrente                                                                                                                                                                       
:: e aggiornare adesso questi pacchetti? [S/n] n                                                                                                                                                               
                                                                                                                                                                                                               
:: Aggiornamento del sistema in corso...                                                                                                                                                                       
:: Vuoi sostituire gtk-integration con testing/chakra-gtk-config? [S/n] s                                                                                                                                     
risoluzione delle dipendenze in corso...                                                                                                                                                                       
ricerca dei conflitti in corso...                                                                                                                                                                             
errore: impossibile eseguire l'operazione richiesta (impossibile soddisfare le dipendenze)                                                                                                                     
:: gtk-integration-engine-molecule: richiede gtk-integration                                                                                                                                                   
:: packagekit: richiede pacman<3.6.0
e come potete vedere anche selezionando no all'aggiornamento di Pacman non riesco ad andare avanti,di solito su Debian e derivate me la cavo abbastanza bene anche con le Testing,ma Chakra la uso da poco e non so come muovermi   :) forse basta solo aspettare che sistemino le dipendenze?
Grazie.
« Ultima modifica: 15 Aprile 2012 ore 16:23 da alessio »
Ubuntu 10.04  Kubuntu 12.04  Ubuntu 12.04  Debian "sid"  Chakra-Achimedes  Sabayon-8

Offline danyf90

  • *
  • Post: 827
  • Reputazione: 42
  • Chakra
    • Mostra profilo
Re:Aggiornamento
« Risposta #1 il: 15 Aprile 2012 ore 13:15 »
devi rimuovere il pacchetto packagekit ed aggiornare pacman... dopodiché provi a reinstallare packagekit :D

Offline alessio

  • *
  • Post: 6
  • Reputazione: 0
    • Mostra profilo
Re:Aggiornamento
« Risposta #2 il: 15 Aprile 2012 ore 13:49 »
non me lo fa fare,Apper risponde, "Non è consentita la rimozione di un pacchetto di sistema protetto" forzarne la rimozione da terminale non mi sembra il caso.
Ubuntu 10.04  Kubuntu 12.04  Ubuntu 12.04  Debian "sid"  Chakra-Achimedes  Sabayon-8

Offline alessio

  • *
  • Post: 6
  • Reputazione: 0
    • Mostra profilo
Re:Aggiornamento
« Risposta #3 il: 15 Aprile 2012 ore 15:53 »
ho forzato la rimozione da terminale
Codice: [Seleziona]
[root@chakra-pc alessio]# pacman -R packagekit
controllo delle dipendenze in corso...
errore: impossibile eseguire l'operazione richiesta (impossibile soddisfare le dipendenze)
:: packagekit-qt2: richiede packagekit
[root@chakra-pc alessio]# pacman -Rs packagekit
controllo delle dipendenze in corso...
errore: impossibile eseguire l'operazione richiesta (impossibile soddisfare le dipendenze)
:: packagekit-qt2: richiede packagekit
[root@chakra-pc alessio]# pacman -Rs packagekit-qt2
controllo delle dipendenze in corso...
errore: impossibile eseguire l'operazione richiesta (impossibile soddisfare le dipendenze)
:: apper: richiede packagekit-qt2>=0.6.11
[root@chakra-pc alessio]# pacman -Rsc packagekit
controllo delle dipendenze in corso...

Da rimuovere (3): apper-0.7.1-3  packagekit-qt2-0.7.1-5  packagekit-0.7.1-5

Dimensione totale dei pacchetti da rimuovere:   11,25 MB

Vuoi rimuovere questi pacchetti? [S/n] s
(1/3) rimozione in corso di apper                                                  [###############################################] 100%
(2/3) rimozione in corso di packagekit-qt2                                         [###############################################] 100%
(3/3) rimozione in corso di packagekit                                             [###############################################] 100%
attenzione: /var/lib/PackageKit/transactions.db è stato salvato come /var/lib/PackageKit/transactions.db.pacsave
attenzione: /etc/PackageKit/alpm.d/repos.list è stato salvato come /etc/PackageKit/alpm.d/repos.list.pacsave
[root@chakra-pc alessio]# pacman -Syy
:: Sincronizzazione dei database in corso...
 testing                                                  22,6K   77,7K/s 00:00:00 [###############################################] 100%
 core                                                     51,4K  217,9K/s 00:00:00 [###############################################] 100%
 platform                                                184,1K  341,3K/s 00:00:01 [###############################################] 100%
 desktop                                                  93,0K  387,8K/s 00:00:00 [###############################################] 100%
 apps                                                    109,6K  380,9K/s 00:00:00 [###############################################] 100%
 games                                                    33,4K  392,7K/s 00:00:00 [###############################################] 100%
[root@chakra-pc alessio]# pacman -Syu
:: Sincronizzazione dei database in corso...
 testing è aggiornato
 core è aggiornato
 platform è aggiornato
 desktop è aggiornato
 apps è aggiornato
 games è aggiornato
:: I seguenti pacchetti dovrebbero essere aggiornati prima :
    pacman  pacman
:: Vuoi annullare l'operazione corrente
:: e aggiornare adesso questi pacchetti? [S/n] s

attenzione: sto ignorando il pacchetto: pacman
risoluzione delle dipendenze in corso...
ricerca dei conflitti in corso...

Pacchetti (2): libarchive-3.0.3-1  pacman-4.0.2-2

Dimensione totale dei pacchetti da scaricare:    0,49 MB
Dimensione totale dei pacchetti da installare:   6,18 MB

Vuoi procedere con l'installazione? [S/n] s
:: Download dei pacchetti da core...
 pacman-4.0.2-2-x86_64                                   504,1K  293,9K/s 00:00:02 [###############################################] 100%
(2/2) controllo dell'integrità del pacchetto                                       [###############################################] 100%
(2/2) controllo dei conflitti in corso                                             [###############################################] 100%
(1/2) aggiornamento in corso di libarchive                                         [###############################################] 100%
(2/2) aggiornamento in corso di pacman                                             [###############################################] 100%
[root@chakra-pc alessio]# pacman -S apper
errore: il seguente pacchetto non è stato trovato: apper
[root@chakra-pc alessio]# pacman -S apper-0.7.1-3
errore: il seguente pacchetto non è stato trovato: apper-0.7.1-3
solo che adesso non mi trova Apper per reinstallarlo.
Ubuntu 10.04  Kubuntu 12.04  Ubuntu 12.04  Debian "sid"  Chakra-Achimedes  Sabayon-8

Offline Homey

  • (s)Coordinatore Team Traduzioni e (ir)Responsabile Template
  • *
  • Post: 687
  • Reputazione: 57
  • Tizio a tempo perso
    • Mostra profilo
Re:Aggiornamento
« Risposta #4 il: 15 Aprile 2012 ore 16:14 »
Apper non è più presente nei repo. Secondo me, finché akabei e shaman non saranno pronti, è meglio gestire i pacchetti da pacman.
Homey

Offline alessio

  • *
  • Post: 6
  • Reputazione: 0
    • Mostra profilo
Re:Aggiornamento
« Risposta #5 il: 15 Aprile 2012 ore 16:22 »
Apper non è più presente nei repo. Secondo me, finché akabei e shaman non saranno pronti, è meglio gestire i pacchetti da pacman.
Ok,grazie.
Ubuntu 10.04  Kubuntu 12.04  Ubuntu 12.04  Debian "sid"  Chakra-Achimedes  Sabayon-8

Offline whoami

  • *
  • Post: 1562
  • Reputazione: 64
  • Quando c'era init i log arrivavano in orario!
    • Mostra profilo
Re:Aggiornamento(risolto)
« Risposta #6 il: 15 Aprile 2012 ore 16:45 »
io riproverei ad aggiornare visto che ti diceva che c'erano degli agg ma prima doveva aggiornare pacman, quello sei riuscito ma poi ci sono tutti quelli che erano in attesa, penso...
echo "VQF AHELME I BI CI WECPF"| tr "ETAOINSHRDLUBCFGJMQPVWZYXK" "A-Z"

Offline alessio

  • *
  • Post: 6
  • Reputazione: 0
    • Mostra profilo
Re:Aggiornamento(risolto)
« Risposta #7 il: 15 Aprile 2012 ore 17:41 »
io riproverei ad aggiornare visto che ti diceva che c'erano degli agg ma prima doveva aggiornare pacman, quello sei riuscito ma poi ci sono tutti quelli che erano in attesa, penso...
Ciao,hai ragione,non l'ho detto,ma dopo la rimozione di Packagekit ho anche aggiornato,e l'aggiornamento è riuscito,anche se ho dovuto selezionare no quando mi chiedeva se volevo sostituire alcuni pacchetti con altri,perchè se selezionavo si mi segnalava problemi con le dipendenze e non andava avanti,ho provato a postare l'output del terminale,ma il forum non me lo permetteva perchè superava il numero dei caratteri consentiti.
Ubuntu 10.04  Kubuntu 12.04  Ubuntu 12.04  Debian "sid"  Chakra-Achimedes  Sabayon-8

 

Template by Homey | Sito ufficiale | Disclaimer