Autore Topic: SynPS/2 Synaptics TouchPad configurazione tasto destro  (Letto 1983 volte)

Offline loken

  • *
  • Post: 152
  • Reputazione: 1
    • Mostra profilo
SynPS/2 Synaptics TouchPad configurazione tasto destro
« il: 01 Marzo 2012 ore 11:47 »
come ho scritto in un altro topic dopo l'ultimo aggiornamento (stable) il sistema non riconosce il touchpad.
non so se la causa è kmod o altro ma per far funzionare "bene" il touchpad dovevo dare solo questo semplice comando
Codice: [Seleziona]
sudo su

echo options psmouse proto=exps > /etc/modprobe.d/psmouse.modprobe

reboot

è tutto andava bene.

ora questo comando non solo non funziona più ma non fa attivare il touchpad.
cosi ho eliminato il file e ora utilizzo il synaptics.
ho fatto un bel pò di configurazioni ma il risultato non cambia, il tasto destro non funziona.
la configurazione attuale su /etc/X11/xorg.conf.d/10-synaptics.conf è questa
Codice: [Seleziona]
Section "InputDevice"
  Identifier "touchpad"
  Driver "synaptics"
  Option "AutoServerLayout" "on"
  #Option "SHMConfig" "on"
  Option "EmulateTwoFingerMinZ" "50" #Emulazione multitouch
  Option "EmulateTwoFingerMinW" "7" #Emulazione multitouch
  Option "VertTwoFingerScroll" "1"  #Scroll verticale con due dita
  Option "HorizTwoFingerScroll" "1" #Scroll orizzontale con due dita
  Option "TapButton1" "1"
  Option "TapButton2" "2"
  Option "TapButton3" "3"
EndSection

ma con altre configurazioni il risultato non cambia.
se do il comando
Codice: [Seleziona]
xinput list-props "SynPS/2 Synaptics TouchPad" | grep Capabilities

mi da

Codice: [Seleziona]
1, 0, 0, 1, 1, 1, 1
ovvero che il tasto centrale e il destro non sono abilitati.

come posso risolvere? il modello è SynPS/2 Synaptics TouchPad... è so che ha sempre avuto problemi con linux anche se si era risolto con il primo comando citato.

-SOLUZIONE-
Da terminale

Codice: [Seleziona]
sudo modprobe -r psmouse
sudo modprobe psmouse proto=imps

spero possa servire :D

- TEST 1-

al riavvio il touchpad non viene riconosciuto
inserire gli ultimi due coduci citati sopra.

- SOLUZIONE 100% -

Ok soluzione finale trovata!

Codice: [Seleziona]
sudo kate /etc/modprobe.d/modprobe.conf
ed inserire

Codice: [Seleziona]
options psmouse proto=imps

e poi riavviate

Codice: [Seleziona]
reboot
 :D :D :D :D 8)
 
« Ultima modifica: 26 Febbraio 2013 ore 15:38 da FranzMari »

Offline fedefox

  • *
  • Post: 1453
  • Reputazione: 34
    • Mostra profilo
    • Allevamento Della Repubblica Pisana
Re: [RISOLTO] SynPS/2 Synaptics TouchPad configurazione tasto destro
« Risposta #1 il: 01 Marzo 2012 ore 12:06 »
bene è sempre una cosa buona mettere la soluzione al problema  ;)

Offline Homey

  • (s)Coordinatore Team Traduzioni e (ir)Responsabile Template
  • *
  • Post: 687
  • Reputazione: 57
  • Tizio a tempo perso
    • Mostra profilo
Re: [RISOLTO] SynPS/2 Synaptics TouchPad configurazione tasto destro
« Risposta #2 il: 01 Marzo 2012 ore 13:16 »
Visto che è una soluzione, non si potrebbe spostare nella sezione Guide opportunamente modificata?
Homey

Offline loken

  • *
  • Post: 152
  • Reputazione: 1
    • Mostra profilo
scusate ho fatto dei test... se riavvio il touchpad non funziona più è bisogna inserire di nuovo gli ultimi 2 codici...quindi semi risolto.. come faccio a far partire direttamente quei 2 codici all'avvio?

Offline Homey

  • (s)Coordinatore Team Traduzioni e (ir)Responsabile Template
  • *
  • Post: 687
  • Reputazione: 57
  • Tizio a tempo perso
    • Mostra profilo
Prova ad eseguire questo comando
Codice: [Seleziona]
sudo su
echo options psmouse proto=imps > /etc/modprobe.d/modprobe.conf
« Ultima modifica: 01 Marzo 2012 ore 15:07 da Homey »
Homey

Offline loken

  • *
  • Post: 152
  • Reputazione: 1
    • Mostra profilo
sono arrivato alla stessa soluzione (anche se compilata in un altro modo)
grazie comunque.

dopo 1 giorno a smanettare è bello ritrovarsi il pc funzionante :D

 

Template by Homey | Sito ufficiale | Disclaimer