Autore Topic: Converseen  (Letto 1837 volte)

Offline vellerofonte

  • *
  • Post: 1374
  • Reputazione: 58
  • #Chakra: Kde for life
    • Mostra profilo
Converseen
« il: 20 Dicembre 2011 ore 20:45 »
Ho installato il pacchetto converseen, ma praticamente...non parte  :-\

se tento di avviarlo da pacman ottengo:

Codice: [Seleziona]
terminate called after throwing an instance of 'Magick::ErrorModule'
  what():  Magick: unable to load module `/usr/lib/ImageMagick-6.6.6/modules-Q16/coders/svg.la': file not found @ error/module.c/OpenModule/1276
Annullato

Ho provato a reinstallare ImageMagick senza risultati.
« Ultima modifica: 20 Dicembre 2011 ore 20:48 da vellerofonte »

Offline d4n1x

  • *
  • Post: 257
  • Reputazione: 18
    • Mostra profilo
Re:Converseen
« Risposta #1 il: 20 Dicembre 2011 ore 21:30 »
prova ad installare libwmf è necessaria come dipendenza pena il crash che riscontri ora non ho molto tempo di vedere il nome preciso del pacchetto nei repo, in caso non ci sia facci sapere ;)

Offline vellerofonte

  • *
  • Post: 1374
  • Reputazione: 58
  • #Chakra: Kde for life
    • Mostra profilo
Re:Converseen
« Risposta #2 il: 20 Dicembre 2011 ore 21:39 »
prova ad installare libwmf è necessaria come dipendenza pena il crash che riscontri ora non ho molto tempo di vedere il nome preciso del pacchetto nei repo, in caso non ci sia facci sapere ;)

Installato, ma non cambia nulla anche perchè riguarda i windows metafile....non credo serva... ???

Offline vellerofonte

  • *
  • Post: 1374
  • Reputazione: 58
  • #Chakra: Kde for life
    • Mostra profilo
Re:Converseen
« Risposta #3 il: 20 Dicembre 2011 ore 23:55 »
Non so se può essere utile se ha un'attinenza o se non c'entra nulla, comunque

il pacchetto libwmf ha come dipendenze:

libpng>=1.4.0
libx11
freetype2
libjpeg>=8
gsfonts
expat>=2.0

Tutti i pacchetti sono installati tranne libjpeg che tra l'altro non si trova neanche nella lista dei pacchetti di Chakra

Esiste invece libjpeg-turbo...

Non è che converseen tenta in qualche modo di utilizzare ancora libjpeg che presumibilmente è stato sostituito da libjpeg-turbo?

Offline d4n1x

  • *
  • Post: 257
  • Reputazione: 18
    • Mostra profilo
Re:Converseen
« Risposta #4 il: 21 Dicembre 2011 ore 11:01 »
Allora ho appena installato anche io il pacchetto e ho riscontrato lo stesso errore, cercando in rete ho trovato questo:
https://bugs.archlinux.org/task/27644

A questo punto credo che puoi segnalare il bug su: http://chakra-linux.org/bugs/

E vediamo loro cosa ti rispondono :D magari se ti danno una soluzione postala qui anche per i prossimi che avranno problemi ;)


Offline jmc

  • *
  • Post: 1354
  • Reputazione: 95
    • Mostra profilo
    • The Chakra Project
Re:Converseen
« Risposta #5 il: 22 Dicembre 2011 ore 00:27 »
Qui su x86_64 stable funziona tutto a dovere, e quel file c'è:

Codice: [Seleziona]
$ pacman -Ql imagemagick | grep svg
imagemagick /usr/lib/ImageMagick-6.6.6/modules-Q16/coders/svg.la
imagemagick /usr/lib/ImageMagick-6.6.6/modules-Q16/coders/svg.so

Per caso siete entrambi su i686?

Offline jmc

  • *
  • Post: 1354
  • Reputazione: 95
    • Mostra profilo
    • The Chakra Project
Re:Converseen
« Risposta #6 il: 22 Dicembre 2011 ore 00:34 »
Appena possibile datemi l'output dei seguenti comandi:

Codice: [Seleziona]
ls -lh /usr/lib/ImageMagick-6.6.6/modules-Q16/coders/svg.la
Codice: [Seleziona]
ldd /usr/lib/ImageMagick-6.6.6/modules-Q16/coders/svg.so

Offline vellerofonte

  • *
  • Post: 1374
  • Reputazione: 58
  • #Chakra: Kde for life
    • Mostra profilo
Re:Converseen
« Risposta #7 il: 22 Dicembre 2011 ore 06:53 »
Appena possibile datemi l'output dei seguenti comandi:

Codice: [Seleziona]
ls -lh /usr/lib/ImageMagick-6.6.6/modules-Q16/coders/svg.la
Codice: [Seleziona]
ldd /usr/lib/ImageMagick-6.6.6/modules-Q16/coders/svg.so

Prima di tutto ti dico che io sono su 32 bit

dando il comando

Codice: [Seleziona]
ls -lh /usr/lib/ImageMagick-6.6.6/modules-Q16/coders/svg.la
ottengo

Codice: [Seleziona]
-rwxr-xr-x 1 root root 1,2K 06.01.2011 22:02 /usr/lib/ImageMagick-6.6.6/modules-Q16/coders/svg.la*
mentre dando

Codice: [Seleziona]
ldd /usr/lib/ImageMagick-6.6.6/modules-Q16/coders/svg.so
ottengo

Codice: [Seleziona]
linux-gate.so.1 =>  (0xb778c000)
        libMagickWand.so.4 => /usr/lib/libMagickWand.so.4 (0xb7645000)
        libMagickCore.so.4 => /usr/lib/libMagickCore.so.4 (0xb73de000)
        liblcms2.so.2 => /usr/lib/liblcms2.so.2 (0xb739e000)
        libtiff.so.3 => /usr/lib/libtiff.so.3 (0xb7344000)
        libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xb72aa000)
        libjpeg.so.8 => /usr/lib/libjpeg.so.8 (0xb7259000)
        liblqr-1.so.0 => /usr/lib/liblqr-1.so.0 (0xb7248000)
        libfftw3.so.3 => /usr/lib/libfftw3.so.3 (0xb718d000)
        libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xb715e000)
        libXext.so.6 => /usr/lib/libXext.so.6 (0xb7150000)
        libXt.so.6 => /usr/lib/libXt.so.6 (0xb70fe000)
        libbz2.so.1.0 => /lib/libbz2.so.1.0 (0xb70ee000)
        libpthread.so.0 => /lib/libpthread.so.0 (0xb70d3000)
        libltdl.so.7 => /usr/lib/libltdl.so.7 (0xb70c9000)
        libSM.so.6 => /usr/lib/libSM.so.6 (0xb70c2000)
        libICE.so.6 => /usr/lib/libICE.so.6 (0xb70ab000)
        libX11.so.6 => /usr/lib/libX11.so.6 (0xb6f74000)
        libgomp.so.1 => /usr/lib/libgomp.so.1 (0xb6f65000)
        librsvg-2.so.2 => not found
        libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0xb6f47000)
        libcairo.so.2 => /usr/lib/libcairo.so.2 (0xb6e90000)
        libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0xb6e4a000)
        libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0xb6e47000)
        libpng14.so.14 => /usr/lib/libpng14.so.14 (0xb6e21000)
        libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0 (0xb6e1d000)
        librt.so.1 => /lib/librt.so.1 (0xb6e14000)
        libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0xb6d3e000)
        libxml2.so.2 => /usr/lib/libxml2.so.2 (0xb6c17000)
        liblzma.so.5 => /usr/lib/liblzma.so.5 (0xb6bf6000)
        libz.so.1 => /usr/lib/libz.so.1 (0xb6be1000)
        libm.so.6 => /lib/libm.so.6 (0xb6bb7000)
        libc.so.6 => /lib/libc.so.6 (0xb6a3b000)
        libexpat.so.1 => /usr/lib/libexpat.so.1 (0xb6a12000)
        /lib/ld-linux.so.2 (0xb778d000)
        libdl.so.2 => /lib/libdl.so.2 (0xb6a0d000)
        libuuid.so.1 => /lib/libuuid.so.1 (0xb6a09000)
        libxcb.so.1 => /usr/lib/libxcb.so.1 (0xb69f1000)
        libgio-2.0.so.0 => /usr/lib/libgio-2.0.so.0 (0xb68f1000)
        libpixman-1.so.0 => /usr/lib/libpixman-1.so.0 (0xb685a000)
        libXrender.so.1 => /usr/lib/libXrender.so.1 (0xb6852000)
        libpcre.so.0 => /lib/libpcre.so.0 (0xb6815000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0xb6812000)
        libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xb680d000)
        libresolv.so.2 => /lib/libresolv.so.2 (0xb67f5000)
« Ultima modifica: 22 Dicembre 2011 ore 06:55 da vellerofonte »

Offline d4n1x

  • *
  • Post: 257
  • Reputazione: 18
    • Mostra profilo
Re:Converseen
« Risposta #8 il: 22 Dicembre 2011 ore 12:20 »
Confermo anche io sono su i386.

Offline jmc

  • *
  • Post: 1354
  • Reputazione: 95
    • Mostra profilo
    • The Chakra Project
Re:Converseen
« Risposta #9 il: 22 Dicembre 2011 ore 13:14 »
Scommetto che questo è il colpevole:

Codice: [Seleziona]
        librsvg-2.so.2 => not found
Installate il pacchetto "librsvg", e ditemi se risolve. In quel caso è una dipendenza mancante.

Offline vellerofonte

  • *
  • Post: 1374
  • Reputazione: 58
  • #Chakra: Kde for life
    • Mostra profilo
Re:Converseen
« Risposta #10 il: 22 Dicembre 2011 ore 18:43 »
Scommetto che questo è il colpevole:

Codice: [Seleziona]
        librsvg-2.so.2 => not found
Installate il pacchetto "librsvg", e ditemi se risolve. In quel caso è una dipendenza mancante.

Grazie JMC, il problema era proprio quella dipendenza

+1  :D

enziosavio

Re:Converseen
« Risposta #11 il: 22 Dicembre 2011 ore 22:06 »
Domanda  stupida  :  ma  che  te  ne  fai  di  Converseen ?

Offline vellerofonte

  • *
  • Post: 1374
  • Reputazione: 58
  • #Chakra: Kde for life
    • Mostra profilo
Re:Converseen
« Risposta #12 il: 23 Dicembre 2011 ore 15:19 »
Domanda  stupida  :  ma  che  te  ne  fai  di  Converseen ?

Stavo cercando tutt'altro, un visualizzatore immagini per KDE più leggero ed essenziale di Gwenview, senza nessuna funzione oltre la visualizzazione e mi sono imbattuto in Converseen che è un convertitore, mi sembrava interessante volevo provarlo, magari per fare conversioni da un formato all'altro può essere più utile che scomodare Gimp.

 

Template by Homey | Sito ufficiale | Disclaimer