Autore Topic: Emulatore PS2  (Letto 5968 volte)

Offline DareDevil

  • *
  • Post: 339
  • Reputazione: 3
    • Mostra profilo
    • Il mio blog
Emulatore PS2
« il: 02 Dicembre 2011 ore 00:51 »
https://aur.archlinux.org/packages.php?ID=10268

Questo manca nel CCr di chakra (o almeno io non l'ho visto)

potreste spiegarmi se conviene inserire le dipendenze, come fare ecc.... vorrei provare ad installarlo su chakra

-EDIT-

http://chakra-linux.org/wiki/index.php/How_to_upload_a_package_to_CCR_when_it_exists_on_Arch_or_Aur/it questa dovrebbe essere la procedura... provo :D
« Ultima modifica: 02 Dicembre 2011 ore 11:45 da DareDevil »
- DareK -

Offline bmax84

  • *
  • Post: 377
  • Reputazione: 15
    • Mostra profilo
Re:Emulatore PS2
« Risposta #1 il: 02 Dicembre 2011 ore 11:02 »
nei repository di chakra ci sono quasi tutte le dipendenze del pacchetto, manca solo il pacchetto wxgtk.
Quindi prima fai il pacchetto wxgtk, lo carichi su ccr, poi fai il pacchetto principale e lo carichi su ccr.
Come fare è spiegato abbastanza bene nel wiki, unico consiglio che ti posso dare è che quando dovrai copiare i file PKGBUILD o altre patch o file install ecc... non usare il copia incolla! apri la pagina del file che ti serve, tasto destro, e selezioni salva come.

Offline jmc

  • *
  • Post: 1354
  • Reputazione: 95
    • Mostra profilo
    • The Chakra Project
Re:Emulatore PS2
« Risposta #2 il: 02 Dicembre 2011 ore 12:30 »
Vorrei farvi notare però che wxgtk è già in CCR. :D

Offline DareDevil

  • *
  • Post: 339
  • Reputazione: 3
    • Mostra profilo
    • Il mio blog
Re:Emulatore PS2
« Risposta #3 il: 02 Dicembre 2011 ore 12:51 »
scusate, ma sapete perchè gli serve un pacchetto nvidia? io ho schde ati, con driver open.....  ::)
- DareK -

Offline jmc

  • *
  • Post: 1354
  • Reputazione: 95
    • Mostra profilo
    • The Chakra Project
Re:Emulatore PS2
« Risposta #4 il: 02 Dicembre 2011 ore 14:07 »
Lo richiede per questo: http://developer.nvidia.com/cg-toolkit
È un prodotto NVIDIA, ma non è limitato a schede NVIDIA, ovviamente, per cui vai tranquillo.

Offline DareDevil

  • *
  • Post: 339
  • Reputazione: 3
    • Mostra profilo
    • Il mio blog
Re:Emulatore PS2
« Risposta #5 il: 03 Dicembre 2011 ore 15:40 »
Codice: [Seleziona]
È possibile cercare i pacchetti su AUR da qui: http://aur.archlinux.org/
Aprire la pagina del pacchetto che si vuole caricare su CCR.
Nella sezione Dettagli Pacchetto (o Package Details) si trova un link Tarball . Scaricare questo file ed estrarlo. Esso contiene tutto il necessario per la creazione del pacchetto. C'è sempre il PKGBUILD, e alcune volte altri file come: .patch, .install, .desktop ecc.
Aprire il PKGBUILD e controllare che le dipendenze del pacchetto siano presenti nei repository di Chakra o su CCR. Se non ci sono, sarà necessario caricare anche le depends/makedepends mancanti su CCR, seguendo la medesima procedura. Tenere presente che i nomi dei pacchetti per alcuni programmi di Arch sono diversi da quelli di Chakra, quindi prestare attenzione e cambiare le stringhe diverse con quelle corrette.
Se si vuole, modificare la riga #Maintainer all'inizio del file con le proprie credenziali.
Ora c'è bisogno di creare il file *.src.tar.gz e caricarlo su CCR, aprendo il terminale nella cartella del pacchetto ed eseguendo
$makepkg --source


Ho fatto tutto questo e adesso ho un pacchetto da 23 kb..... possibile? scusate la niubbaggine mma è la prima volta che provo a fare una cosa del genere
- DareK -

Offline bmax84

  • *
  • Post: 377
  • Reputazione: 15
    • Mostra profilo
Re:Emulatore PS2
« Risposta #6 il: 03 Dicembre 2011 ore 16:51 »
si.
praticamente tu non hai creato un pachhetto, ma solo un file di installazzione. adesso carica quel pacchetto *.scr.tar.gz su ccr, e poi vedi se funziona.

Offline DareDevil

  • *
  • Post: 339
  • Reputazione: 3
    • Mostra profilo
    • Il mio blog
Re:Emulatore PS2
« Risposta #7 il: 03 Dicembre 2011 ore 16:53 »
http://chakra-linux.org/ccr/packages.php?ID=2585

Codice: [Seleziona]
Dependency `lib32-bzip2' of `pcsx2' does not exist.
Premi Invio per continuare

 :'(

su aur non lo trovo

è su i repo di arch

http://www.archlinux.org/packages/multilib/x86_64/lib32-bzip2/
« Ultima modifica: 03 Dicembre 2011 ore 17:02 da DareDevil »
- DareK -

Offline bmax84

  • *
  • Post: 377
  • Reputazione: 15
    • Mostra profilo
Re:Emulatore PS2
« Risposta #8 il: 03 Dicembre 2011 ore 17:12 »
perche si chaima bzip2 in chakra!
devi cambiare il PKGBUILD, mettergli il nome corretto e rifare tutta la procedura di creazione e caricamento del pacchetto!

Offline DareDevil

  • *
  • Post: 339
  • Reputazione: 3
    • Mostra profilo
    • Il mio blog
Re:Emulatore PS2
« Risposta #9 il: 03 Dicembre 2011 ore 17:32 »
Codice: [Seleziona]
Dependency `glew-1.5.8-1' of `pcsx2' does not exist.
Premi Invio per continuare

questo però c'è!
- DareK -

Offline bmax84

  • *
  • Post: 377
  • Reputazione: 15
    • Mostra profilo
Re:Emulatore PS2
« Risposta #10 il: 03 Dicembre 2011 ore 18:47 »
Secondo te perche?

Nel pkgbuild c'è scritto glew1.5, mentre nei repositori chakra siamo alla versione 1.7!
Secondo me basta che scrivi nel PKGBUILD solo glew, senza il numero della versione, cosi automaticamente si scarica l'ultima.
« Ultima modifica: 03 Dicembre 2011 ore 19:00 da bmax84 »

Offline DareDevil

  • *
  • Post: 339
  • Reputazione: 3
    • Mostra profilo
    • Il mio blog
Re:Emulatore PS2
« Risposta #11 il: 03 Dicembre 2011 ore 18:51 »
provo..... ti faccio sapere.... sono niubbo!  :-[

-EDIT-

Dipendenze risolte, pacchetto installato ma mi dà quessto errore

Codice: [Seleziona]
[dario@dario-chakra ~]$ pcsx2
./pcsx2: error while loading shared libraries: libwx_baseu-2.8.so.0: cannot open shared object file: No such file or directory
« Ultima modifica: 03 Dicembre 2011 ore 19:06 da DareDevil »
- DareK -

Offline bmax84

  • *
  • Post: 377
  • Reputazione: 15
    • Mostra profilo
Re:Emulatore PS2
« Risposta #12 il: 03 Dicembre 2011 ore 20:40 »
perche non riesce a trovare le libreria in questione.
Sei sicuro di aver installato wxgtk?
Se l'hai installato allora devi spostare le librerie nella cartella in cui le cerca il programma che tu lanci. (non so dove pero)
« Ultima modifica: 03 Dicembre 2011 ore 20:48 da bmax84 »

Offline enzolatina

  • *
  • Post: 609
  • Reputazione: 18
    • Mostra profilo
Re:Emulatore PS2
« Risposta #13 il: 03 Dicembre 2011 ore 21:04 »
controlla con locate libwx_baseu se quella libreria effettivamente è installata sul tuo sistema, se per caso hai installata una versione con un altro numero di versione fai un link a quella (sperando non vi siano modifiche importanti che danno fastidio al sistema), se non la hai installata la installi
noi siamo ****linux, ogni resistenza è inutile, sarete assimilati
linuxuser:408768 http://linuxcounter.net

Offline DareDevil

  • *
  • Post: 339
  • Reputazione: 3
    • Mostra profilo
    • Il mio blog
Re:Emulatore PS2
« Risposta #14 il: 03 Dicembre 2011 ore 21:49 »
Codice: [Seleziona]
[dario@dario-chakra ~]$ locate libwx_baseu
/opt/dropbox/libwx_baseud-2.8.so.0
/opt/dropbox/libwx_baseud_net-2.8.so.0
/opt/dropbox/libwx_baseud_xml-2.8.so.0
/usr/lib/libwx_baseu-2.8.so
/usr/lib/libwx_baseu-2.8.so.0
/usr/lib/libwx_baseu-2.8.so.0.8.0
/usr/lib/libwx_baseu_net-2.8.so
/usr/lib/libwx_baseu_net-2.8.so.0
/usr/lib/libwx_baseu_net-2.8.so.0.8.0
/usr/lib/libwx_baseu_xml-2.8.so
/usr/lib/libwx_baseu_xml-2.8.so.0
/usr/lib/libwx_baseu_xml-2.8.so.0.8.0
[dario@dario-chakra ~]$
- DareK -

 

Template by Homey | Sito ufficiale | Disclaimer