Autore Topic: cinelerra problemi installazione  (Letto 1308 volte)

Offline peter46

  • *
  • Post: 116
  • Reputazione: 0
    • Mostra profilo
cinelerra problemi installazione
« il: 12 Novembre 2011 ore 23:20 »
Ciao, sono pietro da poco nel mondo chakra, seguendo un post del forum ho provato ad installare Cinelerra ma non è andata a buon fine, incollo l'ultima parte della compilazione

Codice: [Seleziona]
/OpenEXR    -I/usr/include/libavcodec -I/usr/include/libswscale -DHAVE_SWSCALER -DPLUGIN_DIR=\"/usr/lib/cinelerra\" -march=x86-64 -mtune=generic -O2 -pipe -MT vdevicebase.o -MD -MP -MF .deps/vdevicebase.Tpo -c -o vdevicebase.o vdevicebase.C
In file included from ../guicast/guicast.h:42:0,
                 from formattools.h:26,
                 from file.h:35,
                 from vdevicebase.C:22:
../guicast/bcpot.h: In member function ‘virtual char* BC_Pot::get_caption()’:
../guicast/bcpot.h:56:39: warning: deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
mv -f .deps/vdevicebase.Tpo .deps/vdevicebase.Po
g++ -DHAVE_CONFIG_H -I. -I.. -I../guicast -I../quicktime -I../libmpeg3  -D__STDC_CONSTANT_MACROS -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -DHAVE_FIREWIRE     -DHAVE_ESOUND  -DHAVE_ALSA -DHAVE_OSS   -I/usr/include/mjpegtools -I/usr/include/mjpegtools/mpeg2enc -I/usr/include/mjpegtools/mplex   -pthread -I/usr/include/OpenEXR    -I/usr/include/libavcodec -I/usr/include/libswscale -DHAVE_SWSCALER -DPLUGIN_DIR=\"/usr/lib/cinelerra\" -march=x86-64 -mtune=generic -O2 -pipe -MT vdevicebuz.o -MD -MP -MF .deps/vdevicebuz.Tpo -c -o vdevicebuz.o vdevicebuz.C
vdevicebuz.C:48:28: fatal error: linux/videodev.h: File o directory non esistente
compilation terminated.
make[3]: *** [vdevicebuz.o] Error 1
make[3]: Leaving directory `/tmp/ccrbuild-1000/cinelerra-cv/cinelerra-cv/src/cinelerra-build/cinelerra'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/tmp/ccrbuild-1000/cinelerra-cv/cinelerra-cv/src/cinelerra-build/cinelerra'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/ccrbuild-1000/cinelerra-cv/cinelerra-cv/src/cinelerra-build'
make: *** [all] Error 2
==> ERRORE: Si è verificato un errore in build().
    L'operazione sta per essere interrotta...
The build failed.
[pietro@chakra-pc ~]$

la mia macchina Acer 8942G, scheda grafica ati 1 gb, 2 hd da 640 gb, 8 gb di ram, cpu intel core i7 x64 bit.

ho sbagliato io oppure se non ho capito male questi è l'errore, "vdevicebuz.C:48:28: fatal error: linux/videodev.h: File o directory non esistente" ma come si può risolvere se questa è la causa?

Ciao pietro nuovo fans di Chakra
« Ultima modifica: 12 Novembre 2011 ore 23:22 da peter46 »

Offline enzolatina

  • *
  • Post: 609
  • Reputazione: 18
    • Mostra profilo
Re:cinelerra problemi installazione
« Risposta #1 il: 13 Novembre 2011 ore 02:31 »
il problema è che non trova videodev.h, installa v4l-utils e dovresti riuscire a risolvere....
noi siamo ****linux, ogni resistenza è inutile, sarete assimilati
linuxuser:408768 http://linuxcounter.net

Offline peter46

  • *
  • Post: 116
  • Reputazione: 0
    • Mostra profilo
Re:cinelerra problemi installazione
« Risposta #2 il: 13 Novembre 2011 ore 07:58 »
no, mi da lo stesso errore anche dopo avere installato "v4l-utils", l'unica cosa che non ho fatto è avere riavviato la macchina dopo l'installazione ma penso non serva..

Codice: [Seleziona]
../guicast/bcpot.h: In member function ‘virtual char* BC_Pot::get_caption()’:
../guicast/bcpot.h:56:39: warning: deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
mv -f .deps/vdevicebase.Tpo .deps/vdevicebase.Po
g++ -DHAVE_CONFIG_H -I. -I.. -I../guicast -I../quicktime -I../libmpeg3  -D__STDC_CONSTANT_MACROS -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -DHAVE_FIREWIRE     -DHAVE_ESOUND  -DHAVE_ALSA -DHAVE_OSS   -I/usr/include/mjpegtools -I/usr/include/mjpegtools/mpeg2enc -I/usr/include/mjpegtools/mplex   -pthread -I/usr/include/OpenEXR    -I/usr/include/libavcodec -I/usr/include/libswscale -DHAVE_SWSCALER -DPLUGIN_DIR=\"/usr/lib/cinelerra\" -march=x86-64 -mtune=generic -O2 -pipe -MT vdevicebuz.o -MD -MP -MF .deps/vdevicebuz.Tpo -c -o vdevicebuz.o vdevicebuz.C
vdevicebuz.C:48:28: fatal error: linux/videodev.h: File o directory non esistente
compilation terminated.
make[3]: *** [vdevicebuz.o] Error 1
make[3]: Leaving directory `/tmp/ccrbuild-1000/cinelerra-cv/cinelerra-cv/src/cinelerra-build/cinelerra'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/tmp/ccrbuild-1000/cinelerra-cv/cinelerra-cv/src/cinelerra-build/cinelerra'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/ccrbuild-1000/cinelerra-cv/cinelerra-cv/src/cinelerra-build'
make: *** [all] Error 2
==> ERRORE: Si è verificato un errore in build().
    L'operazione sta per essere interrotta...
The build failed.
[pietro@chakra-pc ~]$

Ciao Pietro.-


Offline enzolatina

  • *
  • Post: 609
  • Reputazione: 18
    • Mostra profilo
Re:cinelerra problemi installazione
« Risposta #3 il: 13 Novembre 2011 ore 11:31 »
ma da dove lo  hai preso cinellera? vedi dove lo hai scaricato se trovi qualche notizia in merito o vedi se hanno un forum, mi fa pensare il fatto che cerca linux/videodev.h mentre io ho /usr/include/v4l-videodev.h, non vorrei ci fosse una differenza di nomi o di percorso....
noi siamo ****linux, ogni resistenza è inutile, sarete assimilati
linuxuser:408768 http://linuxcounter.net

Offline peter46

  • *
  • Post: 116
  • Reputazione: 0
    • Mostra profilo
Re:cinelerra problemi installazione
« Risposta #4 il: 13 Novembre 2011 ore 14:14 »
ciao, grazie per la disponibilità, cinelerra l'ho installato da ccr dando il comando "ccr -S cinelerra-cv" e l'ouptut che vedi è la parte finale della compilazione.-

ciao pietro

Offline enzolatina

  • *
  • Post: 609
  • Reputazione: 18
    • Mostra profilo
Re:cinelerra problemi installazione
« Risposta #5 il: 13 Novembre 2011 ore 17:56 »
prova a lasciare un commento su ccr al responsabile del pacchetto con i problemi che hai e vedi se ti dice qualcosa che ti aiuta a risolvere....
magari prima riprova a compilare riavviando il pc, magari anche un pacman -Ql v4l-utils per vedere se è installato quel file (oppure updatedb e poi locate videodev.h)
noi siamo ****linux, ogni resistenza è inutile, sarete assimilati
linuxuser:408768 http://linuxcounter.net

Offline peter46

  • *
  • Post: 116
  • Reputazione: 0
    • Mostra profilo
Re:cinelerra problemi installazione
« Risposta #6 il: 13 Novembre 2011 ore 18:32 »
grazie, adesso provo

 

Template by Homey | Sito ufficiale | Disclaimer