Autore Topic: Problemi con i pacchetti lirc-utilis e libtxc_dxtn durante l'aggiornamento.  (Letto 1867 volte)

Offline pico

  • *
  • Post: 109
  • Reputazione: 5
    • Mostra profilo
Ciao a tutti, oggi ho provato anch'io a fare il tanto atteso aggiornamento al nuovo kernel ma a quanto pare c'è qualche problemino. Non ho avuto modo di provare a disinstallare i pacchetti indicati o fare altro per ora, vi segnalo comunque l'errore perché potrebbe trattarsi di qualche dipendenza mancante. I mirror sono sincronizzati ovviamente  ;)

Codice: [Seleziona]
mirror-check && ccr -Syyu
 
Checking lib32 core platform desktop apps games extra...
 
[lib32] is synced.
[core] is synced.
[platform] is synced.
[desktop] is synced.
[apps] is synced.
[games] is synced.
[extra] is synced.
 
Password:
:: Sincronizzazione dei database in corso...
 lib32                                                                    47,6 KiB   342K/s 00:00 [#########################################################] 100%
 core                                                                     67,6 KiB   422K/s 00:00 [#########################################################] 100%
 platform                                                                277,8 KiB   198K/s 00:01 [#########################################################] 100%
 desktop                                                                 190,6 KiB   229K/s 00:01 [#########################################################] 100%
 apps                                                                    204,2 KiB   330K/s 00:01 [#########################################################] 100%
 games                                                                    39,6 KiB   514K/s 00:00 [#########################################################] 100%
 extra                                                                    16,8 KiB   454K/s 00:00 [#########################################################] 100%
:: Aggiornamento del sistema in corso...
:: Vuoi sostituire lib32-libgl con lib32/lib32-mesa-libgl? [S/n]
:: Vuoi sostituire lib32-libglapi con lib32/lib32-mesa? [S/n]
:: Vuoi sostituire libgl con platform/mesa-libgl? [S/n]
:: Vuoi sostituire libglapi con platform/mesa? [S/n]
risoluzione delle dipendenze in corso...
attenzione: è stato individuato un ciclo di dipendenza:
attenzione: harfbuzz sarà installato prima della sua dipendenza freetype2
attenzione: è stato individuato un ciclo di dipendenza:
attenzione: lib32-harfbuzz sarà installato prima della sua dipendenza lib32-freetype2
ricerca dei conflitti in corso...

Pacchetti (216): acpi_call-1.1.0-10  at-spi2-atk-2.11.5-2  at-spi2-core-2.11.5-2  ati-dri-10.2.4-1  atk-2.11.6-2  automake-1.14.1-1  bash-4.2.042-2  bc-1.06.95-1
                 cairo-1.12.16-4  clamav-0.98.4-2  clementine-1.2.3-2  cloog-0.18.1-2  cmake-3.0.0-1  colord-1.2.0-1  cups-1.6.3-4  curl-7.31.0-2
                 dbus-c++-0.9.0-4  dbus-glib-0.102-1  device-mapper-2.02.97-2  docbook-xml-4.5-7  docbook-xsl-1.78.1-2  dri3proto-1.0-1
                 epson-inkjet-printer-escpr-1.4.0-1  ffmpeg-2.1.4-3  filesystem-2014.07-2  fontconfig-2.11.0-2  fontsproto-2.1.3-1  freetype2-2.5.3-3
                 gamin-0.1.10-3  gc-7.4.0-3  gdk-pixbuf2-2.30.4-2  gimp-2.8.10-2  glamor-egl-0.6.0-2  glew-1.10.0-1  glib2-2.38.2-2  glibmm-2.38.1-2
                 glproto-1.4.17-1  glu-9.0.0-2  gnupg-2.0.24-1  gnutls-3.2.15-2  gobject-introspection-1.38.0-2  gst-plugins-good-1.2.1-1
                 gst-plugins-ugly-1.2.1-2  gstreamer-1.2.4-1  gstreamer0.10-0.10.36-9  gtk-update-icon-cache-2.24.24-1  gtk2-2.24.24-1  gtk3-3.10.9-1
                 harfbuzz-0.9.28-4  inetutils-1.9.2-1  inputproto-2.3.1-1  isl-0.12.1-2  kde-workspace-4.11.10-3  kdelibs-4.13.2-3  lib32-acl-2.2.52-2
                 lib32-atk-2.11.6-2  lib32-cairo-1.12.16-3  lib32-fontconfig-2.11.0-2  lib32-freetype2-2.5.3-1  lib32-gdk-pixbuf2-2.30.4-2  lib32-glib2-2.38.2-3
                 lib32-glu-9.0.0-2  lib32-gstreamer0.10-0.10.36-6  lib32-gtk2-2.24.24-1  lib32-harfbuzz-0.9.28-2  lib32-libdrm-2.4.54-2
                 lib32-libgl-10.0.5-2 [rimozione]  lib32-libglapi-10.0.5-2 [rimozione]  lib32-libvdpau-0.8-1  lib32-libxcb-1.10-1  lib32-libxfixes-5.0.1-1
                 lib32-libxft-2.3.2-1  lib32-libxml2-2.9.1-1  lib32-llvm-libs-3.4.1-1  lib32-mesa-10.2.4-1  lib32-mesa-libgl-10.2.4-1  lib32-mpg123-1.16.0-2
                 lib32-pango-1.36.3-2  lib32-pcre-8.35-1  lib32-pixman-0.32.4-1  lib32-systemd-214-1  lib32-wayland-1.3.0-1  libarchive-3.1.2-3
                 libatomic_ops-7.2.e-3  libbsd-0.6.0-2  libcroco-0.6.8-5  libcups-1.6.3-4  libdrm-2.4.54-4  libevdev-1.2.2-2  libevent-2.0.21-4  libffi-3.0.13-2
                 libfontenc-1.1.2-2  libgl-10.0.5-6 [rimozione]  libglapi-10.0.5-6 [rimozione]  libgphoto2-2.5.4-3  libgusb-0.1.6-2  liblqr-0.4.2-2
                 libltdl-2.4.2-16  libmms-0.6.2-4  libmtp-1.1.6-4  libmwaw-0.2.0-2  libpulse-5.0-3  libqalculate-0.9.7-6  libraw-0.15.4-2  libsasl-2.1.23-8
                 libsoup-2.44.2-2  libtool-2.4.2-16  libtxc_dxtn-1.0.1-5  libupnp-1.6.15-2  libva-1.3.1-2  libvdpau-0.8-1  libx11-1.6.2-3  libxau-1.0.8-2
                 libxcb-1.10-2  libxdmcp-1.1.1-3  libxfixes-5.0.1-2  libxfont-1.4.7-1  libxft-2.3.2-2  libxkbcommon-0.4.2-1  libxmi-1.2-2  libxml2-2.9.1-2
                 libxshmfence-1.1-2  libxslt-1.1.28-2  libyaml-0.1.4-3  linux-3.15.5-1  linux-firmware-20140603.a4f3bc0-2  linux-headers-3.15.5-1
                 lirc-utils-0.9.1-2  llvm-3.4.1-2  llvm-libs-3.4.1-2  lvm2-2.02.97-2  man-db-2.6.3-2  mesa-10.2.4-1  mesa-libgl-10.2.4-1  mpg123-1.16.0-2
                 ndiswrapper-1.59-6  neon-0.29.6-6  opus-1.1-3  pacman-mirrorlist-20140509-3  pam-1.1.8-2  pango-1.36.3-2  pcre-8.35-2  pixman-0.32.4-2
                 poppler-0.24.5-3  poppler-glib-0.24.5-3  poppler-qt-0.24.5-3  presentproto-1.0-1  procps-ng-3.3.9-2  pulseaudio-5.0-3  qpdf-5.1.2-1
                 qt5-base-5.3.1-5  qt5-declarative-5.3.1-5  qt5-xmlpatterns-5.3.1-5  readline-6.2.004-2  resourceproto-1.2.0-1  ruby-1.9.3_p448-3
                 shadow-4.1.5.1-4  shared-mime-info-1.3-1  sqlite3-3.8.4.1-2  systemd-214-4  udisks2-2.1.3-1  unixodbc-2.3.1-2  v4l-utils-1.2.1-1
                 vhba-module-20130607-4  vim-7.4.131-3  vim-runtime-7.4.131-3  vlc-2.1.4-2  wayland-1.3.0-2  wine-1.7.22-1  wpa_supplicant-2.0-3
                 xapian-core-1.2.18-1  xcb-proto-1.10-2  xcb-util-0.3.9-4  xcb-util-image-0.3.9-5  xcb-util-keysyms-0.3.9-5  xcb-util-renderutil-0.3.8-5
                 xcb-util-wm-0.4.1-3  xextproto-7.3.0-1  xf86-input-evdev-2.9.0-3  xf86-input-keyboard-1.8.0-4  xf86-input-mouse-1.9.0-4
                 xf86-input-synaptics-1.8.0-3  xf86-video-ati-7.4.0-2  xf86-video-vesa-2.3.2-3  xf86driproto-2.1.1-2  xkeyboard-config-2.12-1
                 xorg-bdftopcf-1.0.4-1  xorg-font-util-1.3.0-1  xorg-font-utils-7.6-4  xorg-iceauth-1.0.6-1  xorg-mkfontdir-1.0.7-1  xorg-mkfontscale-1.1.1-1
                 xorg-server-1.15.2-1  xorg-server-common-1.15.2-1  xorg-server-utils-7.6-6  xorg-sessreg-1.0.8-1  xorg-setxkbmap-1.3.0-1
                 xorg-util-macros-1.19.0-1  xorg-utils-8.0-1  xorg-xauth-1.0.9-1  xorg-xbacklight-1.2.1-1  xorg-xcmsdb-1.0.4-1  xorg-xgamma-1.0.5-1
                 xorg-xhost-1.0.6-1  xorg-xinput-1.6.1-1  xorg-xkb-utils-7.6-5  xorg-xkbcomp-1.2.4-1  xorg-xkbevd-1.1.3-1  xorg-xkbutils-1.0.4-1
                 xorg-xmodmap-1.0.8-1  xorg-xrandr-1.4.2-1  xorg-xrdb-1.1.0-1  xorg-xrefresh-1.0.5-1  xorg-xset-1.2.3-1  xorg-xsetroot-1.1.1-1  xproto-7.0.26-1

Dimensione totale dei pacchetti da scaricare:    11,99 MiB
Dimensione totale dei pacchetti da installare:   1530,56 MiB
Dimensione netta dell'aggiornamento:             -93,15 MiB

:: Vuoi procedere con l'installazione? [S/n]
:: Download dei pacchetti in corso...
 gimp-2.8.10-2-x86_64                                                     12,0 MiB  3,24M/s 00:04 [#########################################################] 100%
(212/212) verifica delle chiavi presenti nel portachiavi                                          [#########################################################] 100%
(212/212) verifica dell'integrità dei pacchetti                                                   [#########################################################] 100%
(212/212) caricamento dei file dei pacchetti                                                      [#########################################################] 100%
(212/212) controllo dei conflitti in corso                                                        [#########################################################] 100%
errore: impossibile eseguire l'operazione richiesta (file in conflitto)
lirc-utils: /etc/lirc/lircd.conf è già presente nel filesystem
libtxc_dxtn: /usr/include/txc_dxtn.h è già presente nel filesystem
libtxc_dxtn: /usr/lib/libtxc_dxtn.so è già presente nel filesystem
libtxc_dxtn: /usr/share/licenses/libtxc_dxtn/LICENSE è già presente nel filesystem
Si sono verificati degli errori, nessun pacchetto è stato aggiornato.

Se posso fare qualche test appena torno a casa provo.
Grazie!

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Intanto prova a dare
Codice: [Seleziona]
pacman -Qo /etc/lirc/lircd.conf(o uno dei file di cui ti segnala l'esistenza)

Se non ti trova niente, puoi forzare (--force). Altrimenti dicci quale pacchetto risulta averli installati

Offline pico

  • *
  • Post: 109
  • Reputazione: 5
    • Mostra profilo
Lirc-utils l'avevo installato io per far funzionare il telecomando ad infrarossi della scheda audio esterna e credo faccia a se. Se devo posso anche disinstallare e reinstallare, al massimo perdo un po' di tempo a sistemare di nuovo la configurazione, non è un problema solo noioso.

L'altro mi preoccupa di più e non so bene cosa sia...

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
ma il comando che ti ho postato non l'hai lanciato???

cmq con
Codice: [Seleziona]
sudo pacman -Syu --forcepenso dovresti risolvere

Offline pico

  • *
  • Post: 109
  • Reputazione: 5
    • Mostra profilo
Il comando che mi hai dato restituisce

Codice: [Seleziona]
Nessun pacchetto contiene /etc/lirc/lircd.conf
Cmq forzando l'aggiornamento sembra essere andato tutto a buon fine, faccio un po' di verifiche e vi informo se ci sono problemi, se no segno il post come risolto. Grazie Dino  :beer:

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
OK, se non ti ha trovato niente significa che in qualche modo era spazzatura lasciata da qualche pacchetto rimosso male (o installato manualmente?)

Offline senso42

  • *
  • Post: 580
  • Reputazione: -4
    • Mostra profilo
Salve a tutti, sono un pò di giorni che non riesco ad aggiornare, ho queste dipendenze non soddisfatte che riguardano lib32-libgl ...

Codice: [Seleziona]
[senso41@chakra-MAX ~]$ sudo pacman -Syu
:: Sincronizzazione dei database in corso...
 core è aggiornato
 platform è aggiornato
 desktop è aggiornato
 apps è aggiornato
 games è aggiornato
 lib32 è aggiornato
 extra è aggiornato
:: Aggiornamento del sistema in corso...
:: Vuoi sostituire lib32-libglapi con lib32/lib32-mesa? [S/n] s
:: Vuoi sostituire libglapi con platform/mesa? [S/n] s
:: Vuoi sostituire python-pysqlite con platform/python2-pysqlite? [S/n] s
risoluzione delle dipendenze in corso...
:: Ci sono 6 provider disponibili per libgl:
:: Repository platform
   1) catalyst-libgl  2) catalystpxp-utils  3) mesa-libgl  4) nvidia-173xx-utils  5) nvidia-304xx-libgl  6) nvidia-libgl

Digita un numero (default=1):
attenzione: è stato individuato un ciclo di dipendenza:
attenzione: harfbuzz sarà installato prima della sua dipendenza freetype2
attenzione: è stato individuato un ciclo di dipendenza:
attenzione: lib32-harfbuzz sarà installato prima della sua dipendenza lib32-freetype2
ricerca dei conflitti in corso...
errore: impossibile eseguire l'operazione richiesta (impossibile soddisfare le dipendenze)
:: draftsight: richiede lib32-libgl
:: lib32-glu: richiede lib32-libgl
:: lib32-qt: richiede lib32-libgl
[senso41@chakra-MAX ~]$

EDIT: ho cancellato tutte le dipendenze, e si sta aggiornando. Spero non servivano ad altre cose oltre che a draftsight  ;D lib32-glu e lib32-qt
« Ultima modifica: 02 Agosto 2014 ore 12:16 da senso42 »

Offline FranzMari

  • *
  • Post: 2812
  • Reputazione: 103
  • [Senior Packager]
    • Mostra profilo
    • IMHO blog
Hai una scheda ATI con i driver proprietari, presumo
«Il valore dell'essere umano si determina nella misura in cui sia grande o piccola la sua capacità di contribuire al bene collettivo.» Jigorō Kanō

Offline senso42

  • *
  • Post: 580
  • Reputazione: -4
    • Mostra profilo
Hai una scheda ATI con i driver proprietari, presumo
Si.... Spero di non avere brutti scherzi al riavvio. Incrocio le dita.

Offline senso42

  • *
  • Post: 580
  • Reputazione: -4
    • Mostra profilo
Ciao a tutti, stamattina ho questo aggiornamento
Codice: [Seleziona]
Aggiornamento del sistema in corso...
:: Vuoi sostituire ati-dri con platform/mesa-dri? [S/n]
Ogni volta mi mette paura. Procedo oppure aspetto? Grazie...

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Problemi con i pacchetti lirc-utilis e libtxc_dxtn durante l'aggiornamento.
« Risposta #10 il: 05 Dicembre 2014 ore 12:23 »
vai pure  ;)

Offline FranzMari

  • *
  • Post: 2812
  • Reputazione: 103
  • [Senior Packager]
    • Mostra profilo
    • IMHO blog
Re:Problemi con i pacchetti lirc-utilis e libtxc_dxtn durante l'aggiornamento.
« Risposta #11 il: 05 Dicembre 2014 ore 16:32 »
Visto che qualcuno continua ad andare OT in questo topic, lo chiudo.
«Il valore dell'essere umano si determina nella misura in cui sia grande o piccola la sua capacità di contribuire al bene collettivo.» Jigorō Kanō

 

Template by Homey | Sito ufficiale | Disclaimer