Autore Topic: lib32 da allineare  (Letto 1119 volte)

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
lib32 da allineare
« il: 04 Giugno 2014 ore 11:36 »
Salve dev!

Immagino sappiate già, ma meglio assicurarci: sono un paio di giorni che in testing ci sono alcune lib32 da allineare, altrimenti non riesco ad aggiornare il sistema:
Codice: [Seleziona]
:: lib32-gnutls: richiede gnutls=3.2.12.1
:: lib32-libusbx: richiede libusbx=1.0.14

Risulta anche che cmake sia stato downgradato (in realtà solo il prograssivo di compila), non so se consapevolmente:
Codice: [Seleziona]
attenzione: cmake: la versione installata (2.8.12.1-2) è più recente di quella presente in core (2.8.12.1-1)

Offline FranzMari

  • *
  • Post: 2812
  • Reputazione: 103
  • [Senior Packager]
    • Mostra profilo
    • IMHO blog
Re:lib32 da allineare
« Risposta #1 il: 04 Giugno 2014 ore 13:15 »
Grazie della segnalazione, provvedo al più presto!  :beer:

Aggiornamento: Ho aggiornato le due lib32 mancanti. Per cmake devo sentire cosa è stato fatto  ;D
« Ultima modifica: 04 Giugno 2014 ore 14:45 da FranzMari »
«Il valore dell'essere umano si determina nella misura in cui sia grande o piccola la sua capacità di contribuire al bene collettivo.» Jigorō Kanō

Offline pico

  • *
  • Post: 109
  • Reputazione: 5
    • Mostra profilo
Re:lib32 da allineare
« Risposta #2 il: 04 Giugno 2014 ore 19:07 »
Ciao Franz!

Io sono su stable e non su testing (quindi forse è per quello), ma continuo ad avere il problema con la lib32-gnutls, volevo solo segnalartelo.  ;)

Offline FranzMari

  • *
  • Post: 2812
  • Reputazione: 103
  • [Senior Packager]
    • Mostra profilo
    • IMHO blog
Re:lib32 da allineare
« Risposta #3 il: 04 Giugno 2014 ore 19:16 »
Ciao Franz!

Io sono su stable e non su testing (quindi forse è per quello), ma continuo ad avere il problema con la lib32-gnutls, volevo solo segnalartelo.  ;)

Ho caricato tutto su testing, se non ci sono problemi domani sposto su stable
«Il valore dell'essere umano si determina nella misura in cui sia grande o piccola la sua capacità di contribuire al bene collettivo.» Jigorō Kanō

Offline pico

  • *
  • Post: 109
  • Reputazione: 5
    • Mostra profilo
Re:lib32 da allineare
« Risposta #4 il: 04 Giugno 2014 ore 19:18 »
Ottimo grazie mille  :beer:

Offline FranzMari

  • *
  • Post: 2812
  • Reputazione: 103
  • [Senior Packager]
    • Mostra profilo
    • IMHO blog
Re:lib32 da allineare
« Risposta #5 il: 06 Giugno 2014 ore 09:27 »
I pacchetti sono stati spostati su stable, quindi il problema dovrebbe essere risolto anche per pico.
«Il valore dell'essere umano si determina nella misura in cui sia grande o piccola la sua capacità di contribuire al bene collettivo.» Jigorō Kanō

Offline pico

  • *
  • Post: 109
  • Reputazione: 5
    • Mostra profilo
Re:lib32 da allineare
« Risposta #6 il: 06 Giugno 2014 ore 12:10 »
Confermo funziona tutto, grazie Franz  :beer:

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:lib32 da allineare
« Risposta #7 il: 10 Giugno 2014 ore 12:04 »
Nuova richiesta:

Codice: [Seleziona]
errore: impossibile eseguire l'operazione richiesta (impossibile soddisfare le dipendenze)
:: lib32-libpng: richiede libpng=1.6.7

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:lib32 da allineare
« Risposta #8 il: 11 Giugno 2014 ore 09:17 »
Fraaanz e UtG, rilancio:
Codice: [Seleziona]
risoluzione delle dipendenze in corso...
ricerca dei conflitti in corso...
attenzione: rimozione di 'gcc-libs' dalla lista dei pacchetti perché va in conflitto con 'gcc-libs-multilib'
attenzione: rimozione di 'gcc' dalla lista dei pacchetti perché va in conflitto con 'gcc-multilib'
:: binutils e binutils-multilib vanno in conflitto. Vuoi rimuovere binutils-multilib? [s/N] s
errore: impossibile eseguire l'operazione richiesta (impossibile soddisfare le dipendenze)
:: gcc-objc: richiede gcc=4.9.0-8
:: lib32-nspr: richiede nspr=4.10.5
:: libtool-multilib: richiede gcc-multilib=4.8.1

mirror-check eseguito ;)

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:lib32 da allineare
« Risposta #9 il: 11 Giugno 2014 ore 17:42 »
Per ora ho risolto il problema delle multilib eliminandole:
- disinstallato l'unica dipendenza che non mi serviva più (era x kobo-desktop): lib32-icu44
- installato solo le lib che sostituiscono le multilib:
Codice: [Seleziona]
sudo pacman -S gcc libtool gcc-objc- Aggiornato tutto il resto
Codice: [Seleziona]
sudo pacman -Syu
Cmq non capisco com'è che ogni volta con le multilib c'è da tribolare. Forse c'è qualche dipendenza biricchina  :-\
« Ultima modifica: 11 Giugno 2014 ore 20:05 da dinolib »

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:lib32 da allineare
« Risposta #10 il: 09 Luglio 2014 ore 07:34 »
Aggiornamento di oggi:

Codice: [Seleziona]
errore: impossibile eseguire l'operazione richiesta (impossibile soddisfare le dipendenze)
:: lib32-glew: richiede glew=1.9.0

mirror-check ok

 

Template by Homey | Sito ufficiale | Disclaimer