Autore Topic: Chakra non si avvia. Multi-boot con OpenSUSE.  (Letto 1351 volte)

Offline dbAlex

  • *
  • Post: 192
  • Reputazione: 1
    • Mostra profilo
Chakra non si avvia. Multi-boot con OpenSUSE.
« il: 29 Ottobre 2013 ore 22:42 »
Ciao ragazzi,
spero di non aver sbagliato titolo, sezione e quant altro.
Il problema è questo: dopo aver selezionato Chakra dal grubdi openSUSE(12.3) al boot, il pc sembra bloccarsi nel caricare il sistema (Chakra). Accedo ad openSUSE e do da superutente grub2-mkconfig -o /boot/grub2/grub.cfg; il grub sembra aggiornarsi includendo anche Chakra (anche perché c'è anche win7).
Consigli? c'è qualcos altro da fare quando si affiancano due distro gnu/linux?

Offline danyf90

  • *
  • Post: 827
  • Reputazione: 42
  • Chakra
    • Mostra profilo
Re:Chakra non si avvia. Multi-boot con OpenSUSE.
« Risposta #1 il: 29 Ottobre 2013 ore 23:50 »
Durante il caricamento non da nessun messaggio di errore?

Offline blupenguin

  • *
  • Post: 366
  • Reputazione: 23
    • Mostra profilo
Re:Chakra non si avvia. Multi-boot con OpenSUSE.
« Risposta #2 il: 30 Ottobre 2013 ore 09:37 »
Prova a confrontare i parametri di caricamento di chakra nei due grub.cfg, potrebbe essere che il grub di suse imposti qualcosa di diverso.

Offline andreazube

  • *
  • Post: 1595
  • Reputazione: 64
  • I AM THE INTERSECT
    • Mostra profilo
    • Lupo mannaro
Re:Chakra non si avvia. Multi-boot con OpenSUSE.
« Risposta #3 il: 30 Ottobre 2013 ore 11:13 »
Verifica che grub2 sia installato nel mbr, se non sbaglio opensuse usa di default Grub legacy (fino alla 12.1 lo usava)
Codice: [Seleziona]
grub2-install /dev/sda
Se è tutto già ben configurato, posta grub.cfg di opensuse

Offline dave

  • *
  • Post: 334
  • Reputazione: 12
    • Mostra profilo
Re:Chakra non si avvia. Multi-boot con OpenSUSE.
« Risposta #4 il: 30 Ottobre 2013 ore 12:16 »
Suse con la 12.3 utilizza grub2 per poter essere compatibile con uefi (è stata la migliore distro a supportare uefi nelle macchine che ho convertito al dual-boot).
Più che altro dovresti controllare se non ti ha installato grub in una partizione di boot e non sull' mbr.
Se grub2 è sull'mbr allora ricontrolla i parametri del file di configurazione di grub...
"...e se la rana avesse le ali non sbatterebbe il culo ogni volta che salta!"

Offline dbAlex

  • *
  • Post: 192
  • Reputazione: 1
    • Mostra profilo
Re:Chakra non si avvia. Multi-boot con OpenSUSE.
« Risposta #5 il: 30 Ottobre 2013 ore 18:40 »
@bluepenguin ho notato che il grub.cfg di chakra differisce nelle righe iniziali per queste due stringhe che mancano in quello di opensuse:
Codice: [Seleziona]
#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
insmod part_gpt                                    <-------------------------questa
insmod part_msdos                                  <-------------------------e questa
if [ -s $prefix/grubenv ]; then
  load_env
fi
Ad occhio (perché non so farlo col terminale) ci sono anche altre differenze ma per lo più commentate.

@andreazube ho dato il comando nel terminale e ottengo questo:
Codice: [Seleziona]
linux-ryeg:/home/dbale # grub2-install /dev/sda-1.1-desktop
Installazione completata, nessun errore segnalato.

ringrazio anche dave per la risposta ma non mi pare di avere una partizione /boot a parte, se è questo che intendi.
« Ultima modifica: 30 Ottobre 2013 ore 18:45 da dbAlex »

Offline dbAlex

  • *
  • Post: 192
  • Reputazione: 1
    • Mostra profilo
Re:Chakra non si avvia. Multi-boot con OpenSUSE.
« Risposta #6 il: 30 Ottobre 2013 ore 22:48 »
PS: mi correggo: Chakra si avvia ma dopo molto più tempo del normale
come posso vedere a questo punto cosa lo rallenta e come velocizzare il processo di boot?
Inoltre ci sono altre righe che si aggiungono a quelle che vedevo di solito, e mi riferivo a quelle precedenti alla riga che comincia per "systemd..."
https://www.dropbox.com/sc/8ezjbpvk47tchxw/iU54RRQ_Tg

EDIT: l'ho cronometrato  :'( per avviare Chakra ho impiegato 02:30 minuti  :'( è accettabile secondo voi? :nono:
« Ultima modifica: 31 Ottobre 2013 ore 01:31 da dbAlex »

Offline andreazube

  • *
  • Post: 1595
  • Reputazione: 64
  • I AM THE INTERSECT
    • Mostra profilo
    • Lupo mannaro
Re:Chakra non si avvia. Multi-boot con OpenSUSE.
« Risposta #7 il: 31 Ottobre 2013 ore 08:10 »
Non avevi già risolto? http://forum.chakra-project.it/index.php?topic=4875.0
Comunque, fai la solita procedura, ovvero togli la opzione quiet (dovresti già sapere come fare, ma in ogni caso è stato spiegato decine di voltesul forum  :))

Offline dbAlex

  • *
  • Post: 192
  • Reputazione: 1
    • Mostra profilo
Re:Chakra non si avvia. Multi-boot con OpenSUSE.
« Risposta #8 il: 31 Ottobre 2013 ore 16:19 »
Non avevi già risolto? http://forum.chakra-project.it/index.php?topic=4875.0
Comunque, fai la solita procedura, ovvero togli la opzione quiet (dovresti già sapere come fare, ma in ogni caso è stato spiegato decine di voltesul forum  :))

Scusami andreazube ma il mio problema non è il "caso EDID"; ho caricato quell'immagine per farvi vedere le prime tre stringhe che prima di aggiungere openSuse non vedevo.

Il problema è: Chakra si avvia dopo circa 2:30 minuti..

Offline dave

  • *
  • Post: 334
  • Reputazione: 12
    • Mostra profilo
Re:Chakra non si avvia. Multi-boot con OpenSUSE.
« Risposta #9 il: 01 Novembre 2013 ore 08:55 »
Probabilmente quelle tre linee non le vedevi e basta ma ti posso assicurare che vengono praticamente sempre e con ogni distro.
Praticamente sono messaggi di sistema che ti dicono che sta avviando il kernel e che systemd ti ha controllato il disco rigido.
Del tutto innocuo.
"...e se la rana avesse le ali non sbatterebbe il culo ogni volta che salta!"

 

Template by Homey | Sito ufficiale | Disclaimer