Autore Topic: Conflitti gcc/gcc-multilib durante l'aggiornamento  (Letto 1201 volte)

Offline senso42

  • *
  • Post: 580
  • Reputazione: -4
    • Mostra profilo
Conflitti gcc/gcc-multilib durante l'aggiornamento
« il: 12 Febbraio 2013 ore 12:17 »
Ciao a tutti,
Citazione
[senso41@chakra-MAX ~]$ sudo pacman -Syyu
:: Sincronizzazione dei database in corso...
 core                                                                             52,6 KiB  14,1K/s 00:04 [##############################################################] 100%
 platform                                                                        189,3 KiB  96,7K/s 00:02 [##############################################################] 100%
 desktop                                                                          95,0 KiB  17,4K/s 00:05 [##############################################################] 100%
 apps                                                                            124,2 KiB  23,2K/s 00:05 [##############################################################] 100%
 games                                                                            32,7 KiB  12,3K/s 00:03 [##############################################################] 100%
 lib32                                                                            28,2 KiB  7,96K/s 00:04 [##############################################################] 100%
:: I seguenti pacchetti dovrebbero essere aggiornati prima :
    pacman  pacman
:: Vuoi annullare l'operazione corrente
:: e aggiornare adesso questi pacchetti? [S/n] s

attenzione: sto ignorando il pacchetto: pacman
risoluzione delle dipendenze in corso...
ricerca dei conflitti in corso...
:: gcc-libs e gcc-libs-multilib vanno in conflitto. Vuoi rimuovere gcc-libs-multilib? [s/N] s
errore: impossibile eseguire l'operazione richiesta (impossibile soddisfare le dipendenze)
:: gcc-multilib: richiede gcc-libs-multilib=4.7.2-1
[senso41@chakra-MAX ~]$

invece sembra che sia già installato
Citazione
[senso41@chakra-MAX ~]$ ccr gcc-libs-multilib
0 lib32/gcc-libs-multilib 4.7.2-1 [installato]                                                                                                                                 
      Runtime libraries shipped by GCC for multilib
Che faccio?
Grazie

Offline FranzMari

  • *
  • Post: 2812
  • Reputazione: 103
  • [Senior Packager]
    • Mostra profilo
    • IMHO blog
Re:Conflitti gcc/gcc-multilib durante l'aggiornamento
« Risposta #1 il: 12 Febbraio 2013 ore 12:26 »
devi rimuovere gcc-multilib
«Il valore dell'essere umano si determina nella misura in cui sia grande o piccola la sua capacità di contribuire al bene collettivo.» Jigorō Kanō

Offline senso42

  • *
  • Post: 580
  • Reputazione: -4
    • Mostra profilo
Re:Conflitti gcc/gcc-multilib durante l'aggiornamento
« Risposta #2 il: 12 Febbraio 2013 ore 12:39 »
Grazie, gentilissimo, adesso si aggiorna tutto.

Offline senso42

  • *
  • Post: 580
  • Reputazione: -4
    • Mostra profilo
Re:Conflitti gcc/gcc-multilib durante l'aggiornamento
« Risposta #3 il: 12 Febbraio 2013 ore 13:12 »
E che cavolo....
Citazione
(199/199) controllo dei conflitti in corso                                                                [##############################################################] 100%
errore: impossibile eseguire l'operazione richiesta (file in conflitto)
systemd: /etc/systemd/system/getty.target.wants/getty@tty1.service è già presente nel filesystem
Si sono verificati degli errori, nessun pacchetto è stato aggiornato.
Dopo mezz'ora di scaricamenti me lo dice? Che devo fare?

Offline FranzMari

  • *
  • Post: 2812
  • Reputazione: 103
  • [Senior Packager]
    • Mostra profilo
    • IMHO blog
Re:Conflitti gcc/gcc-multilib durante l'aggiornamento
« Risposta #4 il: 12 Febbraio 2013 ore 14:18 »
«Il valore dell'essere umano si determina nella misura in cui sia grande o piccola la sua capacità di contribuire al bene collettivo.» Jigorō Kanō

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Conflitti gcc/gcc-multilib durante l'aggiornamento
« Risposta #5 il: 12 Febbraio 2013 ore 14:35 »
Anche io prima rimuovevo multilib x risolvere. Ma poi mi serviva per alcune lib32.

Ora sinceramente non so se servono. cmq in questo caso avevo risolto annullando e installando esplicitamente pacman con sudo pacman -S pacman. Dopo di che ridavo sudo pacman -Syu e tutto andava liscio.

Offline andreazube

  • *
  • Post: 1595
  • Reputazione: 64
  • I AM THE INTERSECT
    • Mostra profilo
    • Lupo mannaro
Re:Conflitti gcc/gcc-multilib durante l'aggiornamento
« Risposta #6 il: 12 Febbraio 2013 ore 18:18 »
Come dice Franz, leggi la news... e magari la prossima volta aggiorna prima, ora hai due aggiornamenti importanti insieme (systemd e kde 4.10)  :P

 

Template by Homey | Sito ufficiale | Disclaimer