Autore Topic: Mouse e tastiera inutilizzabili  (Letto 2058 volte)

Offline whoami

  • *
  • Post: 1562
  • Reputazione: 64
  • Quando c'era init i log arrivavano in orario!
    • Mostra profilo
Mouse e tastiera inutilizzabili
« il: 30 Maggio 2012 ore 18:27 »
Ciao.

Ho un gravissimo problema...
Ad un certo punto il mio pc ha deciso che non riconosce più mouse e tastiera (SilverCrest MTS2219-SL), rimanendo indifferente agli stimoli. Dico da un certo punto proprio perchè l'ho usato, poi è rimasto acceso con lo schermo spento come al solito e quando sono andato per riaccendere lo schermo con un click come al olito non ho avuto reazioni e così è rimasto. Il fatto che non mi funzionino non mi permette naturalmente di farci niente... >:(

Ho provato con un'altro mouse e un'altra tastiera ma niente...

Con la live da cui sto scrivendo ora funzionano bene quindi il problema non è hardware...

Sono entrato in chroot ho provato ad eliminare i moduli di avvio sperando in udev ma non è cambiato niente, guardando xorg.conf non mi sembra molto diverso dal solito, e ho finito le idee...

Vi posto un po' di roba (rc.conf, xorg.conf, Xorg.0.log), paste.chakra-project.org/1802

aiutateme!!!
« Ultima modifica: 30 Maggio 2012 ore 18:32 da whoami »
echo "VQF AHELME I BI CI WECPF"| tr "ETAOINSHRDLUBCFGJMQPVWZYXK" "A-Z"

Offline leozzo

  • *
  • Post: 180
  • Reputazione: 12
    • Mostra profilo
Re:Mouse e tastiera inutilizzabili
« Risposta #1 il: 30 Maggio 2012 ore 20:11 »
Questo sembra interessante:
Codice: [Seleziona]
[    10.998] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    10.998] (WW) Disabling Keyboard0
[    10.998] (WW) Disabling Mouse0
Prova a commentare le righe relative alle sezioni Input Device in xorg.conf, vedi un po' che succede.

Offline whoami

  • *
  • Post: 1562
  • Reputazione: 64
  • Quando c'era init i log arrivavano in orario!
    • Mostra profilo
Re:Mouse e tastiera inutilizzabili
« Risposta #2 il: 30 Maggio 2012 ore 20:55 »
Ora il mio xorg.conf è così, dopo un nvidia-xconfig e i commenti:

Codice: [Seleziona]

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 295.53  (buildmeister@swio-display-x86-rhel47-07.nvidia.com)  Sat May 12 00:34:20 PDT 2012

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
#    InputDevice    "Keyboard0" "CoreKeyboard"
#    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

#Section "InputDevice"
    # generated from default
#    Identifier     "Mouse0"
#    Driver         "mouse"
#    Option         "Protocol" "auto"
#    Option         "Device" "/dev/psaux"
#    Option         "Emulate3Buttons" "no"
#    Option         "ZAxisMapping" "4 5"
#EndSection

#Section "InputDevice"
    # generated from default
#    Identifier     "Keyboard0"
#    Driver         "kbd"
#EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
e non va lo stesso!!!  >:(
echo "VQF AHELME I BI CI WECPF"| tr "ETAOINSHRDLUBCFGJMQPVWZYXK" "A-Z"

Offline leozzo

  • *
  • Post: 180
  • Reputazione: 12
    • Mostra profilo
Re:Mouse e tastiera inutilizzabili
« Risposta #3 il: 30 Maggio 2012 ore 21:07 »
potresti postare anche /var/log/boot e /var/log/kernel.log ?
e poi non ho capito se in rc.conf i moduli li hai lasciati o no nella riga MODULES. Io proverei a toglierli tutti, anche ora che hai commentato le righe in xorg.conf.

Offline whoami

  • *
  • Post: 1562
  • Reputazione: 64
  • Quando c'era init i log arrivavano in orario!
    • Mostra profilo
Re:Mouse e tastiera inutilizzabili
« Risposta #4 il: 30 Maggio 2012 ore 22:40 »
Allora: i moduli li avevo cancellati e rimessi, ora (con xorg.conf commentato)  li ho ritolti e comunque non cambia niente...

Ti metto i log che mi hai chiesto: boot, kernel.log e lo Xorg.0.log dopo la modifica a xorg.conf. Io li ho letti ma non mi sembra di vedere niente di che... paste.chakra-project.org/1807

Brancolo ancora nel buio!!!
echo "VQF AHELME I BI CI WECPF"| tr "ETAOINSHRDLUBCFGJMQPVWZYXK" "A-Z"

Offline AlmAck

  • *
  • Post: 360
  • Reputazione: 42
    • Mostra profilo
    • AlmAck.ch
Re:Mouse e tastiera inutilizzabili
« Risposta #5 il: 30 Maggio 2012 ore 23:25 »
Stavi magari facendo degli update?

Prova ad entrare in runlevel 1 e vedere se funziona, prova poi a rilanciare un pacman -Syu
Per entrare in runlevel 1 seleziona in grub la linea "recovery mode" che usa single come parametro.

Offline jmc

  • *
  • Post: 1354
  • Reputazione: 95
    • Mostra profilo
    • The Chakra Project
Re:Mouse e tastiera inutilizzabili
« Risposta #6 il: 31 Maggio 2012 ore 00:28 »
Segui questa guida:

https://wiki.archlinux.org/index.php/Xorg#Disabling_Input_Hot-plugging

a volte X.Org disabilita i device di input quando l'hotplugging è attivo. Può essere un problema in Udev.

Offline cippaciong

  • *
  • Post: 708
  • Reputazione: 47
  • Fletto i muscoli e sono nel vuoto
    • Mostra profilo
Re:Mouse e tastiera inutilizzabili
« Risposta #7 il: 31 Maggio 2012 ore 01:00 »
Non so quanto possa essere inerente al tuo problema, ma ho notato che tra i demoni che hai inserito in rc.conf c'è anche al, come mai?
Hal ormai è deprecato da diverso tempo e, salvo casi particolari, non dovrebbe servire.

Offline whoami

  • *
  • Post: 1562
  • Reputazione: 64
  • Quando c'era init i log arrivavano in orario!
    • Mostra profilo
Re:Mouse e tastiera inutilizzabili
« Risposta #8 il: 31 Maggio 2012 ore 01:46 »
YOOOOO!!!

Seguendo la guida che ha postato jmc (fenomeno! :-*) ho risolto!!!!! Ma poi, perchè così all'improvviso?!?

Comunque grazie a tutti!  ;D

@cippaciong hal è per la stampante (epson), che probabilmente è l'unico caso particolare rimasto!
echo "VQF AHELME I BI CI WECPF"| tr "ETAOINSHRDLUBCFGJMQPVWZYXK" "A-Z"

Offline robyshot

  • *
  • Post: 157
  • Reputazione: 5
    • Mostra profilo
Re:Mouse e tastiera inutilizzabili
« Risposta #9 il: 31 Maggio 2012 ore 10:52 »
ho avuto anchio lo stesso problema, ma non potendo scrivere... :p

comunque dopo aver applicato il trick di jmc funziona la tastiera finalmente, ma il touchpad a metà, viene riconosciuto solo il tap singolo (no scroll, pan e pitch to zoom)

potrebbe essere che questo scherzo del non riconoscimento sia dovuto a qualche cambiamento in testing?

edit: ho tolto il trick su xorg e fatto il downgrade a stable, e ora funziona tutto tastiera e mouse, negli aggiornamenti c'era qualcosa tipo xorg-video, potrebbe essere lui il pacchetto colpevole?
« Ultima modifica: 31 Maggio 2012 ore 13:50 da robyshot »
(\\(\\
( oo)
((\') (\')






Offline whoami

  • *
  • Post: 1562
  • Reputazione: 64
  • Quando c'era init i log arrivavano in orario!
    • Mostra profilo
Re:Mouse e tastiera inutilizzabili
« Risposta #10 il: 03 Giugno 2012 ore 18:53 »
Io sono su testing, dopo l'aggiornamento di xorg-server ha ripreso tutto ad andare come doveva, anche con l'hot-plugging attivo... anche perchè senza il mouse mi andava per campi...

bastava solo aspettare, quindi...
echo "VQF AHELME I BI CI WECPF"| tr "ETAOINSHRDLUBCFGJMQPVWZYXK" "A-Z"

 

Template by Homey | Sito ufficiale | Disclaimer