Autore Topic: CUPS PROBLEMA non va errore  (Letto 5495 volte)

Offline -luk-

  • *
  • Post: 59
  • Reputazione: 0
    • Mostra profilo
Re:CUPS PROBLEMA non va errore
« Risposta #15 il: 30 Novembre 2011 ore 21:08 »
Sto provando a installare anche da CCR ma non va. Inizio a pensare che ci sia un problema nel mio sistema.
Codice: [Seleziona]
[luca@chakra ~]$ sudo ccr -S dcp195c
Password:

Ccr Targets    (1): dcp195c

Proceed with installation? [Y/n] Y
--2011-11-30 21:07:59--  http://chakra-project.org/ccr/packages/dcp195c/dcp195c.tar.gz
Risoluzione di chakra-project.org... 87.106.142.6
Connessione a chakra-project.org|87.106.142.6|:80... connesso.
Richiesta HTTP inviata, in attesa di risposta... 404 Not Found                   
2011-11-30 21:08:00 ERRORE 404: Not Found.                                       
                                                                                 
tar: dcp195c.tar.gz: funzione "open" non riuscita: File o directory non esistente
tar: Error is not recoverable: exiting now                                       
/usr/bin/ccr: line 278: cd: dcp195c: File o directory non esistente               
No PKGBUILD found in directory.                                                   
[luca@chakra ~]$                                                                 
                           

Offline bmax84

  • *
  • Post: 377
  • Reputazione: 15
    • Mostra profilo
Re:CUPS PROBLEMA non va errore
« Risposta #16 il: 30 Novembre 2011 ore 21:11 »
si, c'è un problema nel tuo sistema perche da me funziona.

Hai letto il mio edit del post prima?

Assicurati di avere i pacchetti base installati:
Codice: [Seleziona]
sudo pacman -Sy base-devel


Offline -luk-

  • *
  • Post: 59
  • Reputazione: 0
    • Mostra profilo
Re:CUPS PROBLEMA non va errore
« Risposta #17 il: 30 Novembre 2011 ore 21:25 »
Ho installato i pacchetti ma il problema rimane. Ora cerco un pò su google

Codice: [Seleziona]
[luca@chakra ~]$ sudo ccr -S dcp195c

Ccr Targets    (1): dcp195c

Proceed with installation? [Y/n]
--2011-11-30 21:24:48--  http://chakra-project.org/ccr/packages/dcp195c/dcp195c.tar.gz
Risoluzione di chakra-project.org... 87.106.142.6
Connessione a chakra-project.org|87.106.142.6|:80... connesso.
Richiesta HTTP inviata, in attesa di risposta... 404 Not Found
2011-11-30 21:24:48 ERRORE 404: Not Found.

tar: dcp195c.tar.gz: funzione "open" non riuscita: File o directory non esistente
tar: Error is not recoverable: exiting now
/usr/bin/ccr: line 278: cd: dcp195c: File o directory non esistente
No PKGBUILD found in directory.

edit
Ho cambiato i repo come veniva suggerito in giro ma non è cambiato nulla.
« Ultima modifica: 30 Novembre 2011 ore 21:34 da -luk- »

Offline bmax84

  • *
  • Post: 377
  • Reputazione: 15
    • Mostra profilo
Re:CUPS PROBLEMA non va errore
« Risposta #18 il: 30 Novembre 2011 ore 21:49 »
proviamo con le cattive!
Vai sulla pagina di ccr e cerca il pachetto dcp195c,
clicca su tarball e scaricalo sul tuo pc.
Estrai il suo contenuto in una cartella.
Da terminale entra in quella cartella e lancia il comando makepkg -s.
Se funziona fai lo stesso procedimento con il pacchetto tcsh, anzi BISOGNA farlo prima con il pacchetto tcsh che è una dipendenza di dcp195c!

EDIT: dimenticavo....quando finisce la compilazione all'interno della cartella troverai il nuovo pacchetto compilato, lo dovrai installare con pacman -U nome pacchetto
« Ultima modifica: 30 Novembre 2011 ore 22:01 da bmax84 »

Offline jmc

  • *
  • Post: 1354
  • Reputazione: 95
    • Mostra profilo
    • The Chakra Project
Re:CUPS PROBLEMA non va errore
« Risposta #19 il: 30 Novembre 2011 ore 22:52 »
Mi sa che hai una vecchia versione di ccr installata: quella attuale prende i sorgenti di pacchetti CCR da chakra.sourceforge.net, che è la cosa corretta, non da chakra-project.org.

Offline -luk-

  • *
  • Post: 59
  • Reputazione: 0
    • Mostra profilo
Re:CUPS PROBLEMA non va errore
« Risposta #20 il: 30 Novembre 2011 ore 22:54 »
Ok così ha funzionato. HO installato entrambi i pacchetti ma pur riavviando cups non è trova niente. Ora riavvio il sistema.


Ps

Io pensavo di aver preso l'ultima...Controllerò.

edit

Niente, non la trova proprio. Mi sa che son costretto ad usare virtualbox
« Ultima modifica: 30 Novembre 2011 ore 23:00 da -luk- »

Offline bmax84

  • *
  • Post: 377
  • Reputazione: 15
    • Mostra profilo
Re:CUPS PROBLEMA non va errore
« Risposta #21 il: 01 Dicembre 2011 ore 00:37 »
aspetta...prima di abbondare ogni speranza prova ad inserire il demone cups nella sezione demoni del file /etc/rc.conf e inserisci il modulo usblp nella sezione moduli sempre dello stesso file!
Poi riavvia e apri di nuovo cups...dovrebbe funzionare.
Se come dice il sommo jmc  ;D hai una versione vecchia di ccr prova a dare il comando sudo pacman -Syu   (sempre se non l'hai gia fatto)...vediamo se ti aggiorna il pacchetto.

Offline -luk-

  • *
  • Post: 59
  • Reputazione: 0
    • Mostra profilo
Re:CUPS PROBLEMA non va errore
« Risposta #22 il: 01 Dicembre 2011 ore 22:53 »
Io aggiorno sempre tramite quel comando quindi l'avrò aggiornato tempo fa. Comunque non è cambiato nulla, continua a non trovarla, ne dal centro impostazioni di KDE ne dall'interfaccia web di cups.

edit

ecco perchè non aveva funzionato
Codice: [Seleziona]
# MODULES: Modules to load at boot-up. Blacklisting is no longer supported.

non si può mettere + un modulo in blacklist da rc.conf. Comunque ora la trova devo solo fargli usare i driver brother dato che lui non li trova
« Ultima modifica: 01 Dicembre 2011 ore 22:59 da -luk- »

Offline bmax84

  • *
  • Post: 377
  • Reputazione: 15
    • Mostra profilo
Re:CUPS PROBLEMA non va errore
« Risposta #23 il: 03 Dicembre 2011 ore 12:54 »
Bè...novita?
Sei riuscito a farla andare?

Offline -luk-

  • *
  • Post: 59
  • Reputazione: 0
    • Mostra profilo
Re:CUPS PROBLEMA non va errore
« Risposta #24 il: 03 Dicembre 2011 ore 12:59 »
Per ora no, sono rimasto al problema dei driver perchè non ho avuto molto tempo per rimediare. Oggi pomeriggio cerco di risolvere.

Offline -luk-

  • *
  • Post: 59
  • Reputazione: 0
    • Mostra profilo
Re:CUPS PROBLEMA non va errore
« Risposta #25 il: 11 Gennaio 2012 ore 12:50 »
Scusa se rispondo solo ora ma mi ero proprio dimenticato. Comunque ho blacklistato il modulo (infatti non risulta caricato) ma comunque quando installo la stampante questa viene trovata ma i driver non ci sono. Quindi siamo tornati punto e a capo. C'è un modo per estrarre/trasformare/installare un rpm su arch. Ho notato che quando scarica un programma da packer a volte scarica un rpm. Esisteva un programma simile anche per trasformare un rpm in deb...

Offline jmc

  • *
  • Post: 1354
  • Reputazione: 95
    • Mostra profilo
    • The Chakra Project
Re:CUPS PROBLEMA non va errore
« Risposta #26 il: 11 Gennaio 2012 ore 14:05 »
Non funziona perché il driver è fornito solo per le architetture i686, quindi se tu sei su x86_64 e non hai lib32-glibc installato non avrai fortuna. Ho lasciato un commento a bmax84 su come correggere il pacchetto, quando lo caricherà in CCR vedrai l'aggiornamento.

Offline bmax84

  • *
  • Post: 377
  • Reputazione: 15
    • Mostra profilo
Re:CUPS PROBLEMA non va errore
« Risposta #27 il: 11 Gennaio 2012 ore 19:51 »
ok corretto, prova adesso.

Offline -luk-

  • *
  • Post: 59
  • Reputazione: 0
    • Mostra profilo
Re:CUPS PROBLEMA non va errore
« Risposta #28 il: 12 Gennaio 2012 ore 00:13 »
Codice: [Seleziona]
[luca@chakra ~]$ arch
i686

La mia architettura è la i686. Comunque ho provato ad aggiornare ma non mi ha aggiornato niente. Stiamo parlando del pacchetto dcp195c

Offline jmc

  • *
  • Post: 1354
  • Reputazione: 95
    • Mostra profilo
    • The Chakra Project
Re:CUPS PROBLEMA non va errore
« Risposta #29 il: 12 Gennaio 2012 ore 00:41 »
Scusa, ricapitoliamo:

  • sei su i686
  • il pacchetto è installato (eventualmente, reinstallalo a mano, se non ricevi l'aggiornamento)
  • CUPS cosa fa? Non vede proprio la stampante, o la vede ma poi non stampa? Hai controllato i log in /var/log/cups e, se possibile, ce li posti anche qui?
  • che modello è esattamente?

 

Template by Homey | Sito ufficiale | Disclaimer