Visualizza post

Questa sezione ti permette di visualizzare tutti i post inviati da questo utente. N.B: puoi vedere solo i post relativi alle aree dove hai l'accesso.


Post - Dablim

Pagine: 1 2 [3] 4 5 ... 19
31
PKGBUILD / Re:PKGBUILD SiS671
« il: 08 Giugno 2013 ore 00:13 »
Ah, mi sa che quindi il modulo non viene caricato.. prova a dare sudo modprobe sismedia && sudo killall X così carichi il modulo giusto e riavvii X. vedi come va, nel caso vada male torni indietro con sudo modprobe -r sismedia && sudo killall X
Ma il modulo si chiama sisimedia no? Perché se do il tuo comando mi dice:
Codice: [Seleziona]
$ sudo modprobe sismedia && sudo killall X
Password:
modprobe: FATAL: Module sismedia not found.

32
PKGBUILD / Re:PKGBUILD SiS671
« il: 08 Giugno 2013 ore 00:04 »
prova a dare pacman -Ql xf86-video-sis671 per vedere i file installati dal pacchetto
Codice: [Seleziona]
$ pacman -Ql xf86-video-sis671
xf86-video-sis671 /usr/
xf86-video-sis671 /usr/lib/
xf86-video-sis671 /usr/lib/xorg/
xf86-video-sis671 /usr/lib/xorg/modules/
xf86-video-sis671 /usr/lib/xorg/modules/drivers/
xf86-video-sis671 /usr/lib/xorg/modules/drivers/sisimedia_drv.so
xf86-video-sis671 /usr/share/
xf86-video-sis671 /usr/share/licenses/
xf86-video-sis671 /usr/share/licenses/xf86-video-sis671/
xf86-video-sis671 /usr/share/licenses/xf86-video-sis671/COPYING
xf86-video-sis671 /usr/share/man/
xf86-video-sis671 /usr/share/man/man4/
xf86-video-sis671 /usr/share/man/man4/sis.4.gz

Vado con sisimedia allora? La accendiamo? xD

33
PKGBUILD / Re:PKGBUILD SiS671
« il: 07 Giugno 2013 ore 23:44 »
se hai voglia di sperimentare, io proverei a fare così:

crei il file /etc/modprobe.d/sismedia.conf (mi sembra di aver capito che il modulo si chiama sismedia, puoi verificarlo con lsmod | grep sis e dovrebbe comparirti il nome giusto, da mettere nel nome file prima di .conf)

dentro il file ci scrivi
Codice: [Seleziona]
options sismedia UseTiming1366=true
options sismedia NoAccel=true
(nota che al posto di sismedia devi mettere il nome giusto del driver che avevi trovato prima)

riavvia e spera...

se al riavvio non dovesse andare puoi eliminare il file che hai creato e riavviare
Codice: [Seleziona]
$ lsmod | grep sis
sis190                 17831  0
mii                     4059  1 sis190
sis_agp                 4197  1
sata_sis                3916  3
pata_sis               10986  1 sata_sis
libata                168174  2 sata_sis,pata_sis
Qual'è il nome del modulo fra questi?

Pensavo che il nome del modulo fosse "sisimedia" (anche nella descrizione del CCR lo dice), però qua non compare.

34
PKGBUILD / Re:PKGBUILD SiS671
« il: 07 Giugno 2013 ore 17:15 »
Si ma non mi è chiara una cosa, se non c'è bisogno di un file xorg.conf dove sono le opzioni di cui necessita il driver?
Dovrei mettere quelle opzioni che mi ha detto alla fine per aver il massimo della compatibilità (infatti Steam mi da problemi ad avviarsi). Poi non so se sia per colpa del pacchetto Steam di Chakra, sulle altre distro mi andava nonostante avessi una resa grafica peggiore.

35
Pacchetti / Re:firefox in italiano e integrazione kde
« il: 07 Giugno 2013 ore 13:42 »
Dovevo fixare la stringa general.useragent.locale, ora è apposto grazie.

36
Pacchetti / Re:firefox in italiano e integrazione kde
« il: 07 Giugno 2013 ore 13:05 »
Approfitto del thread visto che ho lo stesso problema, Firefox completamente in inglese mentre KDE è in italiano.
Vengo da un'installazione fresca dell'ultima iso Benz ed ho già applicato il fix in locale.gen

Che posso fare?

37
PKGBUILD / Re:PKGBUILD SiS671
« il: 07 Giugno 2013 ore 12:58 »

38
PKGBUILD / Re:PKGBUILD SiS671
« il: 07 Giugno 2013 ore 12:31 »
Devi avere un account su CCR
Sono separati quindi, pensavo fosse collegato con quello del forum.  :lol:

39
PKGBUILD / Re:PKGBUILD SiS671
« il: 07 Giugno 2013 ore 12:14 »
Certo, basta che lo adotti su CCR (dato che è orfano)!
Per caricare il tuo devi dare
Codice: [Seleziona]
makepkg --sourcenella cartella che contiene il PKGBUILD.
Verrà generato un pacchetto con estensione .src.tar.gz che potrai caricare su CCR
Ok ho preparato il pacchetto, ora provo a caricarlo. Ma devo farmi un account anche sul forum inglese o posso usare questo?

40
PKGBUILD / Re:PKGBUILD SiS671
« il: 07 Giugno 2013 ore 11:04 »
Wow ho riavviato e mi ha funzionato, non c'è stato bisogno di aggiungere quelle righe né aggiungere alcun file xorg.conf, grandioso!  ;D

A questo punto si potrebbe usare il mio pacchetto in modo da metterlo nelle CCR?

E un'ultima cosa, non sarebbe saggio che bloccassi gli aggiornamenti di xorg?

41
PKGBUILD / Re:PKGBUILD SiS671
« il: 07 Giugno 2013 ore 10:19 »
beh, direi che non è mai una buona idea rimuovere xorg-server! dal pkgbuild vedo che xorg-server deve essere di versione almeno 1.13, e noi abbiamo la 1.12... io da ignorante proverei a togliere dalla riga conflicts quel xorg-server<1.13 e vedere se compila, se installa e se funziona, se non funzionasse puoi sempre disinstallare il pacchetto
Ok ho fatto come mi hai detto e si è installato!

Ora mi dice:
 
Codice: [Seleziona]
Add following lines to "Device" section of your Xorg configuration:

        Option          "UseTiming1366" "true"
        Option          "NoAccel"       "true"

La prima opzione devo metterla anche se ho una risoluzione da 1280x800?

/edit
Ho notato che non mi ha proprio creato il file xorg.conf, oltre alle opzioni qui sopra cosa devo metterci?

42
PKGBUILD / Re:PKGBUILD SiS671
« il: 07 Giugno 2013 ore 08:39 »
Ah che stupido non avevo messo l'estensione del pacchetto.  :o
Comunque ora mi dice:
Codice: [Seleziona]
sudo pacman -U xf86-video-sis671-0.10.7-1-x86_64.pkg.tar.xz
Password:
caricamento dei pacchetti in corso...
risoluzione delle dipendenze in corso...
ricerca dei conflitti in corso...
:: xf86-video-sis671 e xorg-server vanno in conflitto. Vuoi rimuovere xorg-server? [s/N] s
errore: impossibile eseguire l'operazione richiesta (impossibile soddisfare le dipendenze)
:: xkit: richiede xorg-server

Che faccio?

43
PKGBUILD / Re:PKGBUILD SiS671
« il: 07 Giugno 2013 ore 08:34 »
dovresti scaricare i sorgenti dalla pagina del ccr, anche se obsoleto i file install e driver.install potrebbero andare bene... dalla pagina del ccr a destra c'è l'opzione scarica tarball e scompattandolo metti i sopracitati file nella stessa cartella del pkgbuild nuovi e riprovi a compilare
Ah ecco! Sono riuscito a creare il pacchetto, però quando faccio:
Codice: [Seleziona]
sudo pacman -U xf86-video-sis671-0.10.7-1-x86_64.pkgmi dice:
Codice: [Seleziona]
caricamento dei pacchetti in corso...
errore: 'xf86-video-sis671-0.10.7-1-x86_64.pkg': impossibile trovare o leggere il pacchetto

44
PKGBUILD / PKGBUILD SiS671
« il: 07 Giugno 2013 ore 04:20 »
Salve a tutti, in passato avevo chiesto all'utente Homey un aiuto con questa scheda video integrata, non potendomi aiutare mi ha passato il PKGBUILD, che ora volevo provare a creare.

L'attuale pacchetto è ormai obsoleto, ve n'è un altro nei CCR per questa scheda, anche quello è inutilizzabile.

Non essendo affatto esperto ho bisogno d'aiuto per installare il pacchetto, questo è il  PKGBUILD:
Codice: [Seleziona]
pkgname=xf86-video-sis671
pkgver=0.10.7
pkgrel=1
pkgdesc="SiS 671 video driver (derivate of xf86-sisimedia, latest tested version). Module name is 'sisimedia'."
arch=('i686' 'x86_64')
url="https://gitorious.org/$pkgname"
license=('custom')
depends=('glibc')
makedepends=('xorg-server>=1.11.0' 'xf86dgaproto' 'libdrm' 'xf86driproto' 'mesa' 'glproto' 'resourceproto')
provides=('xf86-video-sisimedia')
conflicts=('xorg-server<1.13.0' 'xf86-video-sisimedia')
install=driver.install
options=('!libtool')
source=("https://gitorious.org/$pkgname/sis-671-fix/archive-tarball/$pkgver")

build() {
  cd "$srcdir/$pkgname-sis-671-fix"

  autoreconf -vi
  ./configure --prefix=/usr --disable-static \
--disable-dri # it have never worked, just avoid warnings
  make
}

package() {
  cd "$srcdir/$pkgname-sis-671-fix"

  make DESTDIR="$pkgdir/" install

  install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
}

sha256sums=('84935285f31f43b658689e633d820bee1def6d7bc42adf79dece6dcf832308ed')

Provando a fare
Codice: [Seleziona]
makepkgmi dice
Codice: [Seleziona]
==> ERRORE: il file (install) non esiste.
==> ERRORE: il file (driver.install) non esiste.

So che con l'aggiornamento di Xorg sono state rese incompatibili molte vecchie schede, a quanto pare questa è fra quelle, oltre al fatto che ha sempre avuto una pessima compatibilità di suo.
Nel caso si potesse downgradare Xorg mi piacerebbe sapere come fare.

Grazie in anticipo a chi avrà la pazienza di darmi una mano.

45
Rimesso e al riavvio è comparso un avviso che alcune periferiche audio potevano essere rimosse perché inutilizzate. Io ho dato retta e ho cliccato ok, fidandomi di chakra.

Ora, è possibile disinstallare tutto il comparto audio e reinstallarlo d capo? Compreso riconoscimento delle periferiche? Oppure ci sono altri metodi?
Anche i video sul pc, file avi, mkv etc sono tutti accelerati con smplayer. Youtube pure.
A me è successa una cosa molto simile alla tua, prima mi avvertiva che potevano essere rimosse perferiche e poi non è più andato nulla, io se fossi in te riproverei con la mia soluzione e poi riavvia completamente. Altrimenti aspetta chi ne sa più di me.  ;D

Pagine: 1 2 [3] 4 5 ... 19
Template by Homey | Sito ufficiale | Disclaimer