Visualizza post

Questa sezione ti permette di visualizzare tutti i post inviati da questo utente. N.B: puoi vedere solo i post relativi alle aree dove hai l'accesso.


Post - pico

Pagine: [1] 2 3 ... 9
1
Ciao!

Scusate se ci ho messo un po' a rispondere ma ho avuto poco tempo per smanettare con il pc  :-[

Visto che non ero stato tanto chiaro nel primo post, specifico bene l'hardware che ho nel caso tornasse utile:
CPU: Intel Skylake 6700HQ
iGPU: Intel HD 530
dGPU: Nvidia 970m

Ho seguito il consiglio di dino, sono entrato in chroot, fatto gli aggiornamenti, verificato che effettivamente erano stati installati i driver open e non quelli closed, quindi ho seguito il wiki ed installato i driver proprietari nvidia.

Reboot e....schermo nero, sddm non videne caricato. Questa volta però riesco ad accedere alle console tty.

Googlando un po' ho trovato un paio di guide per PC sostanzialmente identici al mio:
https://www.pcspecialist.co.uk/forums/showthread.php?52667-Installing-Ubuntu-16-10-on-the-Defiance-II
http://www.linlap.com/santech_c47_clevo_p671re6-g

Ho fatto un po' di test e la prima cosa che ho trovato è che forzando l'uso della sola scheda nvidia dal bios (opzione "DISCRETE") sddm viene caricato, riesco ad affetture il login...e tutto funziona bene!  ;D
L'unica cosa è che al primo accesso tutta la grafica era "troppo grossa", ma modificando i dpi nelle impostazioni di sistema tutto è andato a posto.

Impostando il bios su "MSHYBRID" invece, ossia la grafica ibrida, non riesco a far partire sddm.
Se uso:
Codice: [Seleziona]
lspci | grep -e VGA -e 3Dle due schede sembra che vengano riconosciute correttamente.
Ho provato vari parametri nel grub e nel file /etc/X11/xorg.conf.d/20-intel.conf  per la scheda intel seguendo i link precedenti e il wiki di arch (https://wiki.archlinux.org/index.php/intel_graphics) ma senza successo.
Curiosamente passando da DISCRETE a MSHYBRID anche la grafica di Grub cambia, l'impressione che ho per rapporto ad esperienze passate è che non venga caricato propriamente il KMS (kernel mode setting) all'avvio. Non so se questo può suggerirvi qualcosa.

Nel wiki di arch è riportato anche che molte distro di recente preferiscono usare i driver  xf86-video-modesetting invece dei  xf86-video-intel per le schede intel. Ho provato a cercarli ma su chakra non li ho trovati. Se non ho sbagliato io, sarebbe per caso possibile aggiungerli nei repo? Anche solo per provare se aiutano oppure no. Nel caso per ragioni tecniche preferiate non metterli nei repo ufficiali, provo poi magari ad aggiungerli su CCR.

La prima guida che ho postato comunque fa riferimento a versioni del kernel e dei driver nvidia più recenti, è possibile che basti quello per risolvere il problema. Se non trovo altre soluzioni pazienterò un po' e poi vediamo come va dopo l'aggiornamento, a parte il consumo il sistema è comunque usabilissimo con la scheda nvidia (complimenti ancora per l'ottimo lavoro con Goedel!!!). Franz hai idea di quanto ci vorra indicativamente?

Grazie mille!

2
Grazie mille per i suggerimenti!

Hai ragione dino, non avevo pensato al chroot, più tardi provo e vediamo un po' cosa riesco a tirare fuori, vi faccio sapere.

Franz riguardo a grub se mi dici così....mi ritengo fortunato e cerco di non peggiorare la situazione  :lol:ri
Cercherò di ripassare su chakra in maniera stabile il prima possibile così windows lo dovrò avviare il meno possibile  ;D

3
Ciao a tutti!!!

Finalmente è uscita la nuova ISO, non vedevo l'ora di installarla sul nuovo PC, non ricordavo quanto fosse estenuante usare windows  ::)

Vorrei quindi iniziare ringraziando sviluppatori e tester per il tanto lavoro fatto, ho seguito un po' lo sviluppo in questi mesi per quanto mi era possibile e vi meritate veramente un plauso!!!  :beer: :beer:

Vengo al mio problema: ho installato la ISO su supporto USB, fatto partire il sistema e testato la live sia con driver free che non-free (CPU: i7-6700HQ, GPU: 970m). Tutto sembra funzionare bene, fluido e senza problemi.

Ho quindi ceduto alla tentazione e ho installato il sistema  ;D

Sul sistema era già installato Windows 10 ed era già presente la relativa partizione UEFI da 100MB.
E' la prima volta che uso Calamares ma l'ho trovato molto comodo, funziona bene e senza problemi. Al momento di creare le partizioni però non mi era chiaro come specificare la partizione di boot. Nella finestra per editare la partizione UEFI già presente i flag 'boot' ed 'esp' erano già selezionati in automatico e pensavo fosse sufficiente. Invece era necessario specificare anche /boot/efi come mount point, motivo per cui ho dovuto ripetere l'installazione una seconda volta. Errore mio perché è la prima volta che metto mano a partizioni GPT e boot EFI, però forse andrebbe aggiunto un commento nel Wiki, visto che credo sia un caso di installazione abbastanza tipico. Se c'è già e non l'ho visto "mea culpa"  ;D

Risolto questo piccolo inconveniente, riavvio il sistema e faccio partire chakra. GRUB rileva entrambi i sistemi operativi, seleziono chakra, il sistema parte senza problemi, sddm viene caricato correttamente e funziona bene. Quando inserisco la password e premo invio, però, il sistema si blocca. Se provo con Ctrl+Alt+F1 ad entrare in una console ttty, sddm sparisce, schermata nera ma nessuna console. Stessa cosa se provo ad accedere ad una console tty prima di immetere la password, il sistema si freeza comunque. Se devo tirare a indovinare probabilmente sono i driver video. Non potendo accedere ad una console però non so come fornire un log.

Consigli? L'installazione l'ho fatta partire dalla live avviata con i driver non-free, quindi credo abbia installato quelli, corretto? Domani pensavo di provare a reinstallare partendo dalla live con i driver free, se riesco a fare il login posso poi installare i proprietari a mano come suggeriva Franz nell'annuncio. Nel frattempo se posso fornire qualche informazione utile sul problema chiedete pure.


Oltre a questo ho riscontrato un problema abbastanza fastidioso con GRUB. Se seleziono Chakra, il sistema si avvia subito senza problemi. Se seleziono Windows, tendenzialmente dopo qualche secondo di schermo nero torno alla schermata del grub! Dopo varie volte che seleziono di nuovo Windows (oppure Chakra!!!, e questo è ancora più strano...) finalmente riesco a far partire il boot di windows. Possibile che sia un problema che si risolve con sudo update-grub, ma è abbastanza fastidioso e soprattutto sembra abbastanza casuale, ho provato diverse volte ma non sono riuscito a capire cosa effettivamente permetta o impedisca il corretto avvio di windows. Può essere legato in qualche modo alla dimensione della partizione di boot, o 100MB dovrebbero essere sufficienti?


Grazie in anticipo per l'aiuto!  :beer:

4
CCR / GNUnet
« il: 27 Gennaio 2016 ore 11:12 »
Salve a tutti!

Qualcuno potrebbe gentilmente importare su CCR i pacchetti gnunet e gnunet-gtk presenti nei repositori di Arch?

https://wiki.archlinux.org/index.php/GNUnet

Mi spiace ma al momento non ho modo di provare a farlo io. Non è una cosa urgente comunque.

Grazie mille per l'aiuto!  :beer:

5
Chakra Bar / Re:Scelta Notebook nuovo: SO ??
« il: 14 Marzo 2015 ore 21:40 »
Ciao!

Spero di non infrangere qualche regola del forum con i link che sto per mettere, nel qual caso scusatemi e provvederò subito a toglierli.

Poco tempo fa la mia ragazza ha dovuto cambiare pc e mi sono informato un po' in giro; se può essere utile qui c'è un elenco sempre abbastanza aggiornato con i pc divisi per categoria: può essere un buon punto di partenza per farsi un'idea di quello che si trova in giro.

Alla mia ragazza alla fine ho preso questo (insieme ad un altro banco di ram), ha un buon rapporto qualità/prezzo, scalda poco, le sue 4 ore di autonomia le fa e permette di fare anche un po' di gaming senza pretese. Volendo è tornata disponibile anche la versione con un po' più di ram e storage: link.

Non rispecchia le caratteristiche che cercava @mrcrowley, in particolare non ha lo schermo IPS FHD e non è un peso piuma come gli ultrabook, però per 2,4kg e 700€ è un ottimo pc, magari può interessare ad altri  ;)

6
Hai ragione Cylon, mi sono espresso male: intendevo se era possibile inserire dei riquadri simili a quelli del wiki da cui si può copiare il codice senza problemi, onde evitare di fare il niubbo come me oggi  ;D  :beer:

7
Ahahah hai ragione Whoami avevo letto male, pensavo ci fosse una qualche cartella /bash, cmq tranquillo non arrivo al punto di eliminare la root per fortuna  ;D

I comandi li avevo copiati da Chakra Galaxy perché mi sono riletto la guida anche lì per il problema relativo a libguile, @vellerofonte prova magari a cambiare la formattazione sul blog  ;)

Cmq ora sembra tutto normale, e non fa nemmeno più storie per i pacchetti su CCR.

Ora provo spero di non avere problemi, scusate il disturbo.  :beer:

8
Scusate piccolo dubbio: quando do il comando

Codice: [Seleziona]
find / lib / lib64 / usr / lib64 / bin / sbin -exec pacman -Qoq - {} +> / dev / null
mi restituisce

Codice: [Seleziona]
bash: /: È una directory
Visto che nel wiki si parla di "file" in generale, devo eliminarla quella cartella o no? Scusate se la domanda è stupida  :P

Il comando

Codice: [Seleziona]
pacman -Qqo / bin / sbin / lib / lib64 / usr / lib64 | pacman -Qm -
mi restituisce invece diversi programmi che ho installato da CCR (tipo chrome). Posso rimuoverli tranquillamente e reinstallare tutto dopo l'aggiornamento, o c'è il rischio che qualcuno non funzioni perché non ancora aggiornato? Per fare un esempio con qualche programma meno comune di chrome: se rimuovo pdfsam e poi lo rimetto dopo l'aggiornamento, funziona ancora?

Scusate forse la domanda non ha senso, ma alcuni programmi mi servono e se si tratta di aspettare qualche giorno prima di fare l'aggiornamento perché venga reso tutto compatibile non è un problema  :beer:

Grazie per l'aiuto!

9
Anch'io non riesco ad aggiornare, mi dice che il pacchetto è corrotto e chiede se voglio rimuoverlo dalla cache. Posso dirgli si o no, ma poi mi blocca anche tutti gli altri aggiornamenti comunque.

Grazie per l'aiuto!  :beer:

11
Il comando che mi hai dato restituisce

Codice: [Seleziona]
Nessun pacchetto contiene /etc/lirc/lircd.conf
Cmq forzando l'aggiornamento sembra essere andato tutto a buon fine, faccio un po' di verifiche e vi informo se ci sono problemi, se no segno il post come risolto. Grazie Dino  :beer:

12
Lirc-utils l'avevo installato io per far funzionare il telecomando ad infrarossi della scheda audio esterna e credo faccia a se. Se devo posso anche disinstallare e reinstallare, al massimo perdo un po' di tempo a sistemare di nuovo la configurazione, non è un problema solo noioso.

L'altro mi preoccupa di più e non so bene cosa sia...

13
Ciao a tutti, oggi ho provato anch'io a fare il tanto atteso aggiornamento al nuovo kernel ma a quanto pare c'è qualche problemino. Non ho avuto modo di provare a disinstallare i pacchetti indicati o fare altro per ora, vi segnalo comunque l'errore perché potrebbe trattarsi di qualche dipendenza mancante. I mirror sono sincronizzati ovviamente  ;)

Codice: [Seleziona]
mirror-check && ccr -Syyu
 
Checking lib32 core platform desktop apps games extra...
 
[lib32] is synced.
[core] is synced.
[platform] is synced.
[desktop] is synced.
[apps] is synced.
[games] is synced.
[extra] is synced.
 
Password:
:: Sincronizzazione dei database in corso...
 lib32                                                                    47,6 KiB   342K/s 00:00 [#########################################################] 100%
 core                                                                     67,6 KiB   422K/s 00:00 [#########################################################] 100%
 platform                                                                277,8 KiB   198K/s 00:01 [#########################################################] 100%
 desktop                                                                 190,6 KiB   229K/s 00:01 [#########################################################] 100%
 apps                                                                    204,2 KiB   330K/s 00:01 [#########################################################] 100%
 games                                                                    39,6 KiB   514K/s 00:00 [#########################################################] 100%
 extra                                                                    16,8 KiB   454K/s 00:00 [#########################################################] 100%
:: Aggiornamento del sistema in corso...
:: Vuoi sostituire lib32-libgl con lib32/lib32-mesa-libgl? [S/n]
:: Vuoi sostituire lib32-libglapi con lib32/lib32-mesa? [S/n]
:: Vuoi sostituire libgl con platform/mesa-libgl? [S/n]
:: Vuoi sostituire libglapi con platform/mesa? [S/n]
risoluzione delle dipendenze in corso...
attenzione: è stato individuato un ciclo di dipendenza:
attenzione: harfbuzz sarà installato prima della sua dipendenza freetype2
attenzione: è stato individuato un ciclo di dipendenza:
attenzione: lib32-harfbuzz sarà installato prima della sua dipendenza lib32-freetype2
ricerca dei conflitti in corso...

Pacchetti (216): acpi_call-1.1.0-10  at-spi2-atk-2.11.5-2  at-spi2-core-2.11.5-2  ati-dri-10.2.4-1  atk-2.11.6-2  automake-1.14.1-1  bash-4.2.042-2  bc-1.06.95-1
                 cairo-1.12.16-4  clamav-0.98.4-2  clementine-1.2.3-2  cloog-0.18.1-2  cmake-3.0.0-1  colord-1.2.0-1  cups-1.6.3-4  curl-7.31.0-2
                 dbus-c++-0.9.0-4  dbus-glib-0.102-1  device-mapper-2.02.97-2  docbook-xml-4.5-7  docbook-xsl-1.78.1-2  dri3proto-1.0-1
                 epson-inkjet-printer-escpr-1.4.0-1  ffmpeg-2.1.4-3  filesystem-2014.07-2  fontconfig-2.11.0-2  fontsproto-2.1.3-1  freetype2-2.5.3-3
                 gamin-0.1.10-3  gc-7.4.0-3  gdk-pixbuf2-2.30.4-2  gimp-2.8.10-2  glamor-egl-0.6.0-2  glew-1.10.0-1  glib2-2.38.2-2  glibmm-2.38.1-2
                 glproto-1.4.17-1  glu-9.0.0-2  gnupg-2.0.24-1  gnutls-3.2.15-2  gobject-introspection-1.38.0-2  gst-plugins-good-1.2.1-1
                 gst-plugins-ugly-1.2.1-2  gstreamer-1.2.4-1  gstreamer0.10-0.10.36-9  gtk-update-icon-cache-2.24.24-1  gtk2-2.24.24-1  gtk3-3.10.9-1
                 harfbuzz-0.9.28-4  inetutils-1.9.2-1  inputproto-2.3.1-1  isl-0.12.1-2  kde-workspace-4.11.10-3  kdelibs-4.13.2-3  lib32-acl-2.2.52-2
                 lib32-atk-2.11.6-2  lib32-cairo-1.12.16-3  lib32-fontconfig-2.11.0-2  lib32-freetype2-2.5.3-1  lib32-gdk-pixbuf2-2.30.4-2  lib32-glib2-2.38.2-3
                 lib32-glu-9.0.0-2  lib32-gstreamer0.10-0.10.36-6  lib32-gtk2-2.24.24-1  lib32-harfbuzz-0.9.28-2  lib32-libdrm-2.4.54-2
                 lib32-libgl-10.0.5-2 [rimozione]  lib32-libglapi-10.0.5-2 [rimozione]  lib32-libvdpau-0.8-1  lib32-libxcb-1.10-1  lib32-libxfixes-5.0.1-1
                 lib32-libxft-2.3.2-1  lib32-libxml2-2.9.1-1  lib32-llvm-libs-3.4.1-1  lib32-mesa-10.2.4-1  lib32-mesa-libgl-10.2.4-1  lib32-mpg123-1.16.0-2
                 lib32-pango-1.36.3-2  lib32-pcre-8.35-1  lib32-pixman-0.32.4-1  lib32-systemd-214-1  lib32-wayland-1.3.0-1  libarchive-3.1.2-3
                 libatomic_ops-7.2.e-3  libbsd-0.6.0-2  libcroco-0.6.8-5  libcups-1.6.3-4  libdrm-2.4.54-4  libevdev-1.2.2-2  libevent-2.0.21-4  libffi-3.0.13-2
                 libfontenc-1.1.2-2  libgl-10.0.5-6 [rimozione]  libglapi-10.0.5-6 [rimozione]  libgphoto2-2.5.4-3  libgusb-0.1.6-2  liblqr-0.4.2-2
                 libltdl-2.4.2-16  libmms-0.6.2-4  libmtp-1.1.6-4  libmwaw-0.2.0-2  libpulse-5.0-3  libqalculate-0.9.7-6  libraw-0.15.4-2  libsasl-2.1.23-8
                 libsoup-2.44.2-2  libtool-2.4.2-16  libtxc_dxtn-1.0.1-5  libupnp-1.6.15-2  libva-1.3.1-2  libvdpau-0.8-1  libx11-1.6.2-3  libxau-1.0.8-2
                 libxcb-1.10-2  libxdmcp-1.1.1-3  libxfixes-5.0.1-2  libxfont-1.4.7-1  libxft-2.3.2-2  libxkbcommon-0.4.2-1  libxmi-1.2-2  libxml2-2.9.1-2
                 libxshmfence-1.1-2  libxslt-1.1.28-2  libyaml-0.1.4-3  linux-3.15.5-1  linux-firmware-20140603.a4f3bc0-2  linux-headers-3.15.5-1
                 lirc-utils-0.9.1-2  llvm-3.4.1-2  llvm-libs-3.4.1-2  lvm2-2.02.97-2  man-db-2.6.3-2  mesa-10.2.4-1  mesa-libgl-10.2.4-1  mpg123-1.16.0-2
                 ndiswrapper-1.59-6  neon-0.29.6-6  opus-1.1-3  pacman-mirrorlist-20140509-3  pam-1.1.8-2  pango-1.36.3-2  pcre-8.35-2  pixman-0.32.4-2
                 poppler-0.24.5-3  poppler-glib-0.24.5-3  poppler-qt-0.24.5-3  presentproto-1.0-1  procps-ng-3.3.9-2  pulseaudio-5.0-3  qpdf-5.1.2-1
                 qt5-base-5.3.1-5  qt5-declarative-5.3.1-5  qt5-xmlpatterns-5.3.1-5  readline-6.2.004-2  resourceproto-1.2.0-1  ruby-1.9.3_p448-3
                 shadow-4.1.5.1-4  shared-mime-info-1.3-1  sqlite3-3.8.4.1-2  systemd-214-4  udisks2-2.1.3-1  unixodbc-2.3.1-2  v4l-utils-1.2.1-1
                 vhba-module-20130607-4  vim-7.4.131-3  vim-runtime-7.4.131-3  vlc-2.1.4-2  wayland-1.3.0-2  wine-1.7.22-1  wpa_supplicant-2.0-3
                 xapian-core-1.2.18-1  xcb-proto-1.10-2  xcb-util-0.3.9-4  xcb-util-image-0.3.9-5  xcb-util-keysyms-0.3.9-5  xcb-util-renderutil-0.3.8-5
                 xcb-util-wm-0.4.1-3  xextproto-7.3.0-1  xf86-input-evdev-2.9.0-3  xf86-input-keyboard-1.8.0-4  xf86-input-mouse-1.9.0-4
                 xf86-input-synaptics-1.8.0-3  xf86-video-ati-7.4.0-2  xf86-video-vesa-2.3.2-3  xf86driproto-2.1.1-2  xkeyboard-config-2.12-1
                 xorg-bdftopcf-1.0.4-1  xorg-font-util-1.3.0-1  xorg-font-utils-7.6-4  xorg-iceauth-1.0.6-1  xorg-mkfontdir-1.0.7-1  xorg-mkfontscale-1.1.1-1
                 xorg-server-1.15.2-1  xorg-server-common-1.15.2-1  xorg-server-utils-7.6-6  xorg-sessreg-1.0.8-1  xorg-setxkbmap-1.3.0-1
                 xorg-util-macros-1.19.0-1  xorg-utils-8.0-1  xorg-xauth-1.0.9-1  xorg-xbacklight-1.2.1-1  xorg-xcmsdb-1.0.4-1  xorg-xgamma-1.0.5-1
                 xorg-xhost-1.0.6-1  xorg-xinput-1.6.1-1  xorg-xkb-utils-7.6-5  xorg-xkbcomp-1.2.4-1  xorg-xkbevd-1.1.3-1  xorg-xkbutils-1.0.4-1
                 xorg-xmodmap-1.0.8-1  xorg-xrandr-1.4.2-1  xorg-xrdb-1.1.0-1  xorg-xrefresh-1.0.5-1  xorg-xset-1.2.3-1  xorg-xsetroot-1.1.1-1  xproto-7.0.26-1

Dimensione totale dei pacchetti da scaricare:    11,99 MiB
Dimensione totale dei pacchetti da installare:   1530,56 MiB
Dimensione netta dell'aggiornamento:             -93,15 MiB

:: Vuoi procedere con l'installazione? [S/n]
:: Download dei pacchetti in corso...
 gimp-2.8.10-2-x86_64                                                     12,0 MiB  3,24M/s 00:04 [#########################################################] 100%
(212/212) verifica delle chiavi presenti nel portachiavi                                          [#########################################################] 100%
(212/212) verifica dell'integrità dei pacchetti                                                   [#########################################################] 100%
(212/212) caricamento dei file dei pacchetti                                                      [#########################################################] 100%
(212/212) controllo dei conflitti in corso                                                        [#########################################################] 100%
errore: impossibile eseguire l'operazione richiesta (file in conflitto)
lirc-utils: /etc/lirc/lircd.conf è già presente nel filesystem
libtxc_dxtn: /usr/include/txc_dxtn.h è già presente nel filesystem
libtxc_dxtn: /usr/lib/libtxc_dxtn.so è già presente nel filesystem
libtxc_dxtn: /usr/share/licenses/libtxc_dxtn/LICENSE è già presente nel filesystem
Si sono verificati degli errori, nessun pacchetto è stato aggiornato.

Se posso fare qualche test appena torno a casa provo.
Grazie!

14
Installazione e Live CD / Re:Si blocca appena abbasso lo schermo
« il: 20 Giugno 2014 ore 21:40 »
Ok allora modifica il file che ti ha detto Cylon, ossia /etc/default/grub (ovviamente devi avere i permessi di root per farlo).
Quindi dai uno dei due comandi seguenti, a seconda che tu preferisca farlo dal terminale o per via grafica:

Codice: [Seleziona]
sudo nano /etc/default/grub
oppure

Codice: [Seleziona]
kdesu kate /etc/default/grub
Modifica la riga che hai riportato prima come segue

Codice: [Seleziona]
GRUB_CMDLINE_LINUX_DEFAULT="resume=/dev/sdaX acpi_sleep=nonvs quiet"
dove al posto della X devi mettere il numero della tua partizione di swap, quindi tipo /dev/sda5 o /dev/sda7 o altro.

Poi dai

Codice: [Seleziona]
sudo update-grub
per aggiornare il grub; riavvia e facci sapere se c'è qualche cambiamento.

15
Installazione e Live CD / Re:Si blocca appena abbasso lo schermo
« il: 19 Giugno 2014 ore 11:36 »
Per curiosità hai provato con l'opzione che ti avevo consigliato nell'altro post?

Codice: [Seleziona]
acpi_sleep=nonvs
Sei come metterla nel grub? (Non ti offendere per la domanda semplicemente non so quanto sei abituato a smanettare con queste cose ;) )


Controllando nella mia configurazione del grub ho visto che io utilizzo anche l'opzione

 
Codice: [Seleziona]
resume=/dev/sdaX

per la partizione di swap. Forse ti era già stata suggerita ma può darsi che servano tutte le impostazioni insieme.

Altra cosa: con quali distro ti funzionava la sospensione e con quali no? Ti ricordi per caso qual'era la versione del kernel?

Pagine: [1] 2 3 ... 9
Template by Homey | Sito ufficiale | Disclaimer