Visualizza post

Questa sezione ti permette di visualizzare tutti i post inviati da questo utente. N.B: puoi vedere solo i post relativi alle aree dove hai l'accesso.


Topics - Sparmi

Pagine: [1] 2
1
Chakra Bar / Annuncio di lavoro
« il: 09 Ottobre 2014 ore 16:24 »
ANNUNCIO LAVORATIVO:

KeysOn SRL®, azienda in continua crescita nel settore informatico e scientifico, cerca figura di programmatore (tempo indeterminato) per realizzare, ultimare, e migliorare grandi progetti in corso e non (anche OpenSource!!!!).

Competenze richieste:
  • Conoscenza linguaggio SQL ed almeno un DBMS (Mysql/PostgreSQL)
  • C++ e framework Qt
  • In alternativa al framework Qt: Ruby e framework Rails per sviluppo di Web Apps
  • Secondo linguaggio NON facoltativo: PHP (comprensivo di HTML, jQuery, quindi Javascript...)
  • Conoscenza di piattaforme Linux (principalmente in uso Chakra GNU/Linux), Windows (non indispensabile), Mac OSX.
   
Sede aziendale operativa e legale:

Centobuchi di Monteprandone, 63076, Ascoli Piceno (AP), Regione Marche, Italia

Recapiti:

+ 39 0735 383420 (KeysOn SRL Commerciale)
+ 39 0735 705202 (Centralino)
+ 39 3314343401 (Responsabile informatico)
+ info@keyson.it

Per qualsiasi informazione contattare dal Lunedì al Venerdì dalle 09:00 alle 13:30 oppure dalle 14:30 alle 18:30

"Il successo è un viaggio, non una destinazione. Decidi di viaggiare con noi."

Questo è l'annuncio della mia azienda!
Fatevi avanti!!

2
Ciao ragazzi, oggi ho scoperto che dopo il bell'aggiornamento, con le librerie Qt5 (5.3.1 System) non funziona più il debug, o meglio la funzione qDebug() non ritorna nulla su output.
Invece se uso le Qt 5.3.0 compilate a mano, tutto funziona correttamente.
Anche a voi? :)
Grazie!

3
Eccomi di nuovo qua ragazzi :)
Cerco di aggiornare il sistema ma Pacman sembra ribellarsi  :-[
Come risolvo?

Codice: [Seleziona]
claudio-pc% sudo pacman -Syyu               
Password:
:: Sincronizzazione dei database in corso...
 lib32                                                                                                  47,6 KiB   554K/s 00:00 [##############################################################################] 100%
 core                                                                                                   67,6 KiB  1090K/s 00:00 [##############################################################################] 100%
 platform                                                                                              278,6 KiB  1443K/s 00:00 [##############################################################################] 100%
 desktop                                                                                               190,6 KiB  1563K/s 00:00 [##############################################################################] 100%
 apps                                                                                                  204,1 KiB  1582K/s 00:00 [##############################################################################] 100%
 games                                                                                                  39,6 KiB  1015K/s 00:00 [##############################################################################] 100%
 extra                                                                                                  16,8 KiB   430K/s 00:00 [##############################################################################] 100%
:: Aggiornamento del sistema in corso...
:: Vuoi sostituire lib32-nvidia-utils con lib32/lib32-nvidia-libgl? [S/n]
:: Vuoi sostituire libglapi con platform/mesa? [S/n]
risoluzione delle dipendenze in corso...
attenzione: è stato individuato un ciclo di dipendenza:
attenzione: harfbuzz sarà installato prima della sua dipendenza freetype2
attenzione: è stato individuato un ciclo di dipendenza:
attenzione: lib32-harfbuzz sarà installato prima della sua dipendenza lib32-freetype2
ricerca dei conflitti in corso...
attenzione: rimozione di 'libgl' dalla lista dei pacchetti perché va in conflitto con 'nvidia-libgl'
errore: impossibile eseguire l'operazione richiesta (impossibile soddisfare le dipendenze)
:: lib32-dbus-glib: richiede dbus-glib=0.100.2
claudio-pc%

Grazie in anticipo!

4
Ciao ragazzi, qui è Sparmi che vi parla.
Ho una notizia che può interessare la comunità in generale. Dopo molto tempo sono riuscito a convincere la mia azienda, KeysOn SRL, (di cui sono il responsabile dell'area informatica) di realizzare il prossimo progetto in maniera completamente Open Source; dalla A alla Z.
Qual'è la domanda che mi pongo io.
In che maniera un'azienda deve muoversi per poter realizzare quest' idea?
Quello che ora tengo in considerazione:
  • GitHub che abbiamo tutt'ora in maniera privata verrà reso pubblico per quanto riguarda i sorgenti di questa applicazione
  • La licenza selezionata credo sia GPLv3 (LGPL in studio XD)
  • Non capisco se esistono standard di programmazione per l'open source che vanno dalla struttura del software alla semplice indentazione (per quest' ultima conosco diversi stili ma ne utilizzo uno mio ripreso da Qt ed Artistic)
  • Documentazione del codice attraverso l'utilizzo di Doxygen per elaborare pagine HTML
  • Linguaggi selezionati per lo sviluppo: PHP (lato server) o alternativa ancora da considerare Qt5 (quindi applicazione server ed il PHP per un'interfaccio Web), QtQuick2 per Client desktop e mobile, QtQuick2 per app lato pazienti, PostgreSQL database
  • Il progetto è un progetto serio ed indirizzato ad un utilizzo professionale (dico solo che riguarda ambito medico-scientifico), non si tratta di un qualcosa utilizzabile a casa (in maniera attiva, visto che il lato pazienti invece è utilizzabile da chiunque)

C'è altro che dovrei considerare? Ho tempo fino a Dicembre per organizzare il tutto.
Grazie ragazzi!

5
Schede Video, Monitor e Audio / Cambio VGA [Nvidia -> Ati]
« il: 24 Giugno 2014 ore 20:09 »
Ciao ragazzi! Eccomi di nuovo qua :)
Mi si è tritata una parte della ventola della VGA, non so come, (una vecchina 9600 GT) e quindi ora mi scalda.
Tanto che ho subito ripreso una nuova VGA (una ATI R7 240). Perchè ATI? Perchè mi piace :P
Il mio problema sono i driver, attualmente ho i nvidia.
Come devo fare il passaggio?
Installo i driver, riavvio, monto la nuova scheda e poi riaccendo? Oppure faccio tutto chroot (compreso il cambio di scheda)? :D
Grazie per l'aiuto!

6
Pacchetti / Impossibile risolvere dipendenza qt5-connectivity
« il: 21 Giugno 2014 ore 09:48 »
Ciao ragazzi :D
Ho appena effettuato l'aggiornamento internet permettendo  ;D Oltre all'errore già segnalato riguardante texinfo io ho anche questo:
Codice: [Seleziona]
:: Aggiornamento del sistema in corso...
risoluzione delle dipendenze in corso...
attenzione: impossibile risolvere "libxkbcommon-x11", una dipendenza di "qt5-connectivity"
:: Il seguente pacchetto non può essere aggiornato a causa di alcune dipendenze irrisolvibili:
      qt5-connectivity

:: Vuoi ignorare il seguente pacchetto per questo aggiornamento? [s/N] s
ricerca dei conflitti in corso...
 non ci sono aggiornamenti disponibili
[claudio@sparmi-chakra ~]$ sudo pacman -S qt5-connectivity
risoluzione delle dipendenze in corso...
attenzione: impossibile risolvere "libxkbcommon-x11", una dipendenza di "qt5-connectivity"
:: Il seguente pacchetto non può essere aggiornato a causa di alcune dipendenze irrisolvibili:
      qt5-connectivity

:: Vuoi ignorare il seguente pacchetto per questo aggiornamento? [s/N] N
errore: impossibile eseguire l'operazione richiesta (impossibile soddisfare le dipendenze)
:: qt5-connectivity: richiede libxkbcommon-x11
[claudio@sparmi-chakra ~]$ sudo pacman -S libxkbcommon-x11
errore: il seguente pacchetto non è stato trovato: libxkbcommon-x11
[claudio@sparmi-chakra ~]$ sudo pacman -S libxkbcommon-x11
errore: il seguente pacchetto non è stato trovato: libxkbcommon-x11
[claudio@sparmi-chakra ~]$ ccr -S libxkbcommon-x11
Package `libxkbcommon-x11' does not exist.

Qualsiasi approcio definibile come aiuto è ben accetto XD

Grazie in anticipo!

7
Pacchetti / Piccolo bug di firefox
« il: 12 Giugno 2014 ore 17:40 »
Ragazzi ovviamente è una stupidaggine, non so nemmeno se sia questa la sezione giusta (anche perchè tutti i miei post sono sempre stati spostati XD).
Comunque ho notato un piccolo bug di firefox, fastidioso ma niente di che.

Praticamente la modalità di ispeziona elemento se viene aperta prima che la pagina termina a caricare, rimane vuota sempre.
Si è praticamente costretti a fare un refresh con CTRL+F5.

Capita anche a voi? :D

8
Pacchetti / Errore QtCreator 3.1.1
« il: 09 Giugno 2014 ore 09:23 »
Ciao ragazzi :D
Ho appena aggiornato QtCreator e ho questo bellissimo errore da terminale.
Qualche info in più? :D
Codice: [Seleziona]
claudio-pc% qtcreator
"Qt Warning - invalid keysym: dead_actute"
qtcreator: symbol lookup error: qtcreator: undefined symbol: _ZN7QString13toUtf8_helperERKS_

9
Pacchetti / Qt Assistant problemi grafici
« il: 13 Maggio 2014 ore 23:35 »
Ciao ragazzi :D
È da un pò che noto che tutte le immagini che il Qt Assistant carica si sovrappongono ai testi che dovrei leggere XD
Molto spesso sono costretto a leggere la guida online ed avendo una connessione pietosa (il 99% delle volte) ci impiego il triplo del tempo.
Qualche info risolutiva? Grazie mille! :-[

10
Ciao ragazzi, ecco di nuovo a rompere le scatole  ;D
Volevo chiedervi come mai quando tento di aggiornare qt creator (il mio amatissimo qt creator  :-[) esce fuori:
Codice: [Seleziona]
:: Vuoi procedere con l'installazione? [S/n] s
:: Download dei pacchetti in corso...
 qtcreator-3.1.0-1-x86_64                                                                 22,3 MiB  74,3K/s 05:07 [####################################################################] 100%
(1/1) verifica delle chiavi presenti nel portachiavi                                                              [####################################################################] 100%
(1/1) verifica dell'integrità dei pacchetti                                                                       [####################################################################] 100%
:: Il file /var/cache/pacman/pkg/qtcreator-3.1.0-1-x86_64.pkg.tar.xz è corrotto (il pacchetto non è valido oppure è corrotto (verifica dell'integrità)).
Vuoi eliminarlo? [S/n] n

Grazie mille!

P.S.: Se dovessi aver sbagliato sezione di nuovo è normale XD oramai è un vizio!

11
Pacchetti / Kmail: impossibile inviare posta (KDE 4.13)
« il: 28 Aprile 2014 ore 10:48 »
Ciao ragazzi!
Ho appena effettuato l'aggiornamento a KDE 4.13.
Tuttavia ora non riesco ad inviare più la posta...
Qualsiasi account può solo ricevere...
Un aiutino? XD

12
Pacchetti / Problemi KDevelop e Samba
« il: 11 Marzo 2014 ore 11:00 »
Ciao ragazzi vorrei segnalare due errori che ho riscontrato con Kdevelop visto che lo uso 8-12 ore al giorno :D

1° Problema
- Avvio Kdevelop
- Apro progetto che si trova su server interno (ad esempio 192.168.0.110)
- Se clicco su Rete -> Condivisioni Samba -> ed inserisco nella barra l'indirizzo IP, Kdevelop in automatico inserisce il doppio slash.
Per essere più chiaro.
Dopo aver cliccato Convisioni Samba, l'url si presenta così:
Codice: [Seleziona]
smb:/in realtà dovrebbe essere:
Codice: [Seleziona]
smb://Io ingenuamente però compilo così:
Codice: [Seleziona]
smb:/192.168.0.110/Kdevelop corregge in
Codice: [Seleziona]
smb://192.168.0.110/ e crasha istantaneamente

2° problema
Se piallo per errore il server mentre Kdevelop (su un altro pc in rete locale) ha aperto il progetto, Kdevelop (dell'altro pc) non riesce più a caricare la rete samba.
Ho scoperto che basta eliminare la configurazione kdeveloprc in .kde4.
Tuttavia, cosa potrebbe piallarlo?

Grazie mille per l'aiuto :D
Se sono stato poco chiaro ditelo! XD

13
Gestione del software con Pacman/Akabei / Errore aggiornamento Php
« il: 26 Febbraio 2014 ore 16:39 »
Ciao a tutti,
oggi ho aggiornato il sistema, qui in ufficio, tuttavia al riavvio del server Apache non mi è stato più possibile utilizzare la mia app (in php) e phpmyadmin. Ritorna sempre lo stesso errore:
Codice: [Seleziona]
The json extension is missing. Please check your PHP configuration.La configurazione di php.ini ha funzionato da mesi e non è mai stata toccata.
Il modulo json.so è presente nella cartella /usr/lib/php/modules.
Non so come risolvere.

Grazie mille.

14
Ragazzi aiuto  :'(.
Di recente ho aggiornato il sistema ma qualcosa non è andato come doveva.
Mi spiego meglio.

L'aggiornamento è andato a buon fine come sempre, tuttavia al riavvio qualcosa non ha funzionato.

1) Il Laptop va spesso in blocco e non risponde a nessun comando. Compare spesso la scritta
Citazione
BUG: soft lockup - CPU#0 stuck for 22s! [kworker/0:1:89]
e sono costretto a riavviare.

2) Accade invece che se il sistema reagisce ed effettuo l'accesso la scheda di rete + la scheda wifi non vengano gestite.

3) Può accadere, inoltre, se il resto funziona, che la scheda audio non funzioni e che Pulseaudio vada in "Attesa disco".

4) Per non scoraggiare aggiungo che può accadere che il modulo vgaswitcheroo si blocchi.

Su 10 accensioni, 1 funziona, le altre no. Prima tutto funzionava egregiamente!

Come diamine ne esco fuori??
Ditemi il necessario per aiutarmi, vi scongiuro  >:(
Grazie in anticipo

15
Chakra Bar / Si tratta solo di Cross-compiling....
« il: 23 Settembre 2013 ore 00:13 »
https://sfwywflc.noblogs.org/post/2013/09/22/si-tratta-solo-di-cross-compiling/
Ho scritto una piccola guida sul Cross-compiling delle qt e qt5.
Se ci sono informazioni da aggiungere sono lieto di accoglierle.
Il S.O. su cui ho effettuato le operazioni è appunto Chakra e tutto funziona alla perfection.

;)

Pagine: [1] 2
Template by Homey | Sito ufficiale | Disclaimer