Chakra Linux Italia Forum

Supporto Tecnico Base => Chakra Testing => Topic aperto da: dinolib - 17 Settembre 2015 ore 15:17

Titolo: HPLIP: stampante non riconosciuta dopo upgrade
Inserito da: dinolib - 17 Settembre 2015 ore 15:17
salve gente. dopo l'aggiornamento a HPLIP 3.15 la mia laserjet 1018 ha smesso di funzionare.

Rimossa per aggiungerne una nuova di pacca HPLIP non trova stampanti collegate!

dmesg non fornisce messaggi interessanti:
Codice: [Seleziona]
[ 1768.867182] usb 3-1: USB disconnect, device number 24
[ 2513.557633] usb 3-1: new high-speed USB device number 25 using xhci_hcd
[ 2513.753733] usblp 3-1:1.0: usblp0: USB Bidirectional printer dev 25 if 0 alt 0 proto 2 vid 0x03F0 pid 0x4117
[ 2517.021262] usblp0: removed

lsusb la vede:
Codice: [Seleziona]
Bus 003 Device 025: ID 03f0:4117 Hewlett-Packard LaserJet 1018

sotto win 7 funziona (ma non sotto vbox).

la stampante di rete funziona (hp laserjet)

Che succede? Ho aperto anche un thread sul forum internazionale: http://chakraos.org/forum/viewtopic.php?id=14236

franz che dici, visto che mi serve per lavoro torno in stable?
Titolo: Re:HPLIP: stampante non riconosciuta dopo upgrade
Inserito da: dinolib - 17 Settembre 2015 ore 15:57
oh mamma. ho tentato un downgrade da testing a stable.

ho scassato tutto!!!!
al boot non trova ucode intel. che ho combinato!

(ho pasticciato con systemd, lo so. il downgrade era da fare con molta più attenzione. ad un certo punto non andava più niente ed ho riavviato).

sono su un PC win7 ma ho casino di dati... intanto sto creando una chiavetta che non l'avevo.

Da win come la faccio? ho molto tempo prima che si scarichi la ISO... provo se in chroot faccio qualche miracolo
Titolo: Re:HPLIP: stampante non riconosciuta dopo upgrade
Inserito da: dinolib - 17 Settembre 2015 ore 16:50
Nel caso qualche anima pia potesse rispondermi: che faccio, vado di chroot, rimetto testing, rigenero l'immagine e riavvio?

ho molti lavori da portare a termine e se non ho la macchina a disposizione è un gran casino...
Titolo: Re:HPLIP: stampante non riconosciuta dopo upgrade
Inserito da: Cylon - 17 Settembre 2015 ore 17:09
invece di andare di chroot riavvia e quando sei su grub fai clic su e o c (non ricordo) e aggiungi alla riga del kernel la stringa:

Codice: [Seleziona]
systemd.unit=rescue.target

invio e avvia

da li riabiliti i repo testing e aggiorni e  dovrebbe andare... forse... tanto fallo  ;D
Titolo: Re:HPLIP: stampante non riconosciuta dopo upgrade
Inserito da: dinolib - 17 Settembre 2015 ore 17:10
il fatto è che ho incasinato il kernel (credo a causa del rollback) e non mi trova il ucode intel al boot... kernel panic

cmq ci provo, non costa niente.
Titolo: Re:HPLIP: stampante non riconosciuta dopo upgrade
Inserito da: dinolib - 17 Settembre 2015 ore 17:24
editando il menu di grub tolgo intel-unicode.img e parte.
ma... avendo incasinato systemd (e udev immagino) tutti i mount falliscono. Alla fine mi becco un paio di assert da librerie di sistema e tutto si ferma.

niente, finisco di scaricare la ISO, faccio due prove. altrimenti mi tocca reinstallare. ho fatto una gran cazzata a tornare ai repo stabili senza neanche pensare a cosa fosse stato passato.

Ah: da gran collione ho anche fatto un paio di forzature. eh vabbè, quando uno se le cerca....
Titolo: Re:HPLIP: stampante non riconosciuta dopo upgrade
Inserito da: dinolib - 17 Settembre 2015 ore 17:43
ah, cylon, un favore: non ricordo dove avevo visto uno script per mettere su file i pacchetti installati ed un altro per installare quelli nell'elenco... Tu hai idea di come si possa fare?

a casa mi scarico l'elenco (visto che sono anche lì in testing e ho un processore uguale) e provo da chroot a reinstallare almeno i pacchetti di sistema.
Dici che potrebbe funzionare?
Titolo: Re:HPLIP: stampante non riconosciuta dopo upgrade
Inserito da: Cylon - 17 Settembre 2015 ore 17:52
per lo script non so.. sono pigro, io se farei quello che vuoi fare tu NON lo farei  ;D ;D ;D

preferisco se installo qualcosa installare tutto exnovo.. magari avevo installato qualche pacchetto che ora non mi serve piu...

ma nel caso farei quello che c'è scritto nel sacro wiki..:

genero la lista dei pacchetti:
Codice: [Seleziona]
pacman -Qqe > pkglist
e poi la installerei sul sistema 'cavia' (mettendomi nella stessa dir che contiene la lista generata sopra) con:
Codice: [Seleziona]
sudo pacman -S $(cat pkglist)
Titolo: Re:HPLIP: stampante non riconosciuta dopo upgrade
Inserito da: whoami - 17 Settembre 2015 ore 18:19
domanda, anche se penso che ormai sia tardi... Avevi installato hplip-plugin da CCR?
Titolo: Re:HPLIP: stampante non riconosciuta dopo upgrade
Inserito da: dinolib - 17 Settembre 2015 ore 19:04
domanda, anche se penso che ormai sia tardi... Avevi installato hplip-plugin da CCR?
ci ho provato ma non è compatibile con la versione in testing.

In ogni caso se prima non l'avevo e andava...
Titolo: Re:HPLIP: stampante non riconosciuta dopo upgrade
Inserito da: dinolib - 17 Settembre 2015 ore 19:06
per lo script non so.. sono pigro, io se farei quello che vuoi fare tu NON lo farei  ;D ;D ;D

preferisco se installo qualcosa installare tutto exnovo.. magari avevo installato qualche pacchetto che ora non mi serve piu...

ma nel caso farei quello che c'è scritto nel sacro wiki..:

genero la lista dei pacchetti:
Codice: [Seleziona]
pacman -Qqe > pkglist
e poi la installerei sul sistema 'cavia' (mettendomi nella stessa dir che contiene la lista generata sopra) con:
Codice: [Seleziona]
sudo pacman -S $(cat pkglist)

ok grazie cylon.

Il fatto è che ho un casino di impostazioni (anche se gli script più importanti sono salvati) e dovrei tornare operativo prima possibile.
Certo, se non recupero il sistema devo piallare e reinstallare. almeno la home c'è...
si prospetta un sabato allettante  >:( >:( >:( :'( :'( :'(
Titolo: Re:HPLIP: stampante non riconosciuta dopo upgrade
Inserito da: whoami - 18 Settembre 2015 ore 00:09
 Per il plugin te lo chiedevo perché ho aggiornato il plugin su CCR ma non l'ho caricato quindi te lo potevo passare per provare... ma mi sa che è tardi :'(

Comunque se devi reinstallare da live puoi entrare nella partizione di root e copiarti le conf dei programmi ( tra /etc e ~ dovresti recuperare più o meno tutto)
Titolo: Re:HPLIP: stampante non riconosciuta dopo upgrade
Inserito da: enzolatina - 18 Settembre 2015 ore 10:29
ma se entri in chroot, riabiliti i testing e aggiorni a come eri prima del downgrade?
Titolo: Re:HPLIP: stampante non riconosciuta dopo upgrade
Inserito da: dinolib - 18 Settembre 2015 ore 16:12
ma se entri in chroot, riabiliti i testing e aggiorni a come eri prima del downgrade?

eccomi tornato!

ah ah Enzo, anche io ci speravo ma...
ieri il download dell'ISO è andata male. Oggi con torrent è andata meglio.
Da linux l'unica cosa con cui sono riuscito a creare una chiavetta utilizzabile è stato dd.exe (!). Ma va a meraviglia.

Ho provato il chroot: come davo chroot mi beccavo un errore in liblocale.c. Insomma: il sistema era definitivamente corrotto (e ci credo ho rollabackato systemd compromettendo di sicuro qualche libreria di sistema).

Niente, la cosa più veloce è stata davvero reinstallare. Grazie a cylon e whoami mi sono anche ricordato di backuppare /etc così non ho smadonnato con fstab etc (visto che ho tipo 3 dischi fissi e altri di rete di cui serve ricordarsi la configurazione).
E poi amo linux e le sue partizioni. La home è praticamente quella di prima, serve solo installare le app.

Ah, devo vedere dove sta il file crontab, non ho voglia di crearmi manco quello  ;D ;D

Ultima cosa: minchia non ho più i font di prima... qualche suggerimento? non ricordo proprio cosa avevo installato.  >:( >:(
Titolo: Re:HPLIP: stampante non riconosciuta dopo upgrade
Inserito da: dinolib - 18 Settembre 2015 ore 17:13
E' una vita che non reinstallavo. Approfitto e prendo nota qui di alcune cose:

tribe: mentre procede l'installazione è abilitato il tasto "prosegui". l'ho fatto distrattamente e l'installazione va in errore. Fra l'altro l'unica cosa che si può fare è riavviare.

virtualbox: non si sa perchè ma se non si riavvia non vede le porte USB. preso uno spaghetto il reboot ha risolto

integrazione gtk: ho faticato un po' a capire che dovevo installare gtk-integration. In qualche modo sarebbe il caso di informare gli utenti (boh, magari come dipendenza consigliata di thuderbird e altri programmi gtk)

il font aakar di default fa altamente schifo (almeno questo è quello che mi sono trovato. non vorrei x il fatto che i font precedentemente installati non sono stati trovati. molto probabile)

provando a far andare hp-setup ottengo un erore:
Codice: [Seleziona]
error: Unable to load Qt4 support. Is it installed?Ora devo scoprire quale libreria manca...
TROVATA: python2-gobject2   (trovata per vie traverse usando l'opzione da linea di comando. mah)
Titolo: Re:HPLIP: stampante non riconosciuta dopo upgrade
Inserito da: whoami - 18 Settembre 2015 ore 17:34
Dai, quindi tutto risolto? Almeno per la produttività... poi ai font ci puoi pensare con calma...

Ora devi solo più abilitare [kde-unstable] e sei a posto ;P
Titolo: Re:HPLIP: stampante non riconosciuta dopo upgrade
Inserito da: dinolib - 18 Settembre 2015 ore 17:41
Ora devi solo più abilitare [kde-unstable] e sei a posto ;P
:nono: :nono: :nono: :nono: :nono: :nono: :nono: :nono:

Stranamente ho tribolato con hplip, non voleva scaricare il plugin. ho anche installato il pacchetto che mi hai consigliato e dato il ppd manualmente ma poi non stampava.
Alla fine da linea di comando ho visto che aveva un errore con la chiave di autenticazione al loro server, ma mi ha dato la possibilità di forzare.
Quindi al momento sono a posto devo solo schedulare i backup

EDIT: cmq il muletto a casa è con kdenext e unstable!  ;)
Titolo: Re:HPLIP: stampante non riconosciuta dopo upgrade
Inserito da: whoami - 18 Settembre 2015 ore 17:45
 :beer:  :beer: :beer:

In effetti mettere in testing la macchina di produzione è stato quantomeno coraggioso!
Titolo: Re:HPLIP: stampante non riconosciuta dopo upgrade
Inserito da: FranzMari - 18 Settembre 2015 ore 17:45
tribe: mentre procede l'installazione è abilitato il tasto "prosegui". l'ho fatto distrattamente e l'installazione va in errore. Fra l'altro l'unica cosa che si può fare è riavviare.

L'installer della prossima ISO sarà Calamares, quindi...  ;)


virtualbox: non si sa perchè ma se non si riavvia non vede le porte USB. preso uno spaghetto il reboot ha risolto

AlmAck ha sistemato qualcosa riguardo l'avvio della ISO su VB, quindi potrebbe essere stato risolto anche questo.

integrazione gtk: ho faticato un po' a capire che dovevo installare gtk-integration. In qualche modo sarebbe il caso di informare gli utenti (boh, magari come dipendenza consigliata di thuderbird e altri programmi gtk)

Non ricordo, devo controllare

il font aakar di default fa altamente schifo (almeno questo è quello che mi sono trovato. non vorrei x il fatto che i font precedentemente installati non sono stati trovati. molto probabile)

Quello non è il font di default, probabilmente cercava di sostituire quello che avevi impostato tu. Cliccando sul pulsante "ripristina predefiniti" ti dovrebbe rimettere quello (vero) di default.

provando a far andare hp-setup ottengo un erore:
Codice: [Seleziona]
error: Unable to load Qt4 support. Is it installed?Ora devo scoprire quale libreria manca...
TROVATA: python2-gobject2   (trovata per vie traverse usando l'opzione da linea di comando. mah)

Vedo di sistemare appena posso
Titolo: Re:HPLIP: stampante non riconosciuta dopo upgrade
Inserito da: dinolib - 18 Settembre 2015 ore 18:11
Grazie Franz, solerte come sempre  :beer:
Titolo: Re:HPLIP: stampante non riconosciuta dopo upgrade
Inserito da: dinolib - 18 Settembre 2015 ore 18:31
ora bestemmio come un turco xè un programma a 32bit che mi serve non ricordo che dipendenze abbia avuto. mannaggia, mi creavo un PKGBUILD dummy.... argh!

(e primad i capire perchè non partiva, cosa ho penato!  ;D)

lib32-libgl
lib32-gtk2
lib32-libgnutls (26)  (creato un link symbolico alla 28, sticazzi)
lib32-libgcrypt15

finalmente funge! :)))


Per motion serve (opzionale) anche perl-libwww ...

Ah: i file di cron stanno sotto /var/spool/cron
Questi non li ho backuppati  :nono:  ;D
Titolo: Re:HPLIP: stampante non riconosciuta dopo upgrade
Inserito da: dinolib - 22 Settembre 2015 ore 11:23
Per quanto riguarda le tribolazioni post installazione con la stampante ho risolto: l'utente non era nel gruppo sys.

Ancora non ho avuto il coraggio di passare in testing per verificare se funziona ancora...

Franz: non è che il problema più che di HPLIP è di systemd e udev? Non vorrei che per qualche motivo l'USB abbia dei problemi a seguito dell'aggiornamento.
In ogni caso gli errori USB che segnalavo prima li ho anche ora in stable  :-\
Titolo: Re:HPLIP: stampante non riconosciuta dopo upgrade
Inserito da: FranzMari - 22 Settembre 2015 ore 12:27
Franz: non è che il problema più che di HPLIP è di systemd e udev? Non vorrei che per qualche motivo l'USB abbia dei problemi a seguito dell'aggiornamento.

Io sono in testing e la mia stampante HP funziona correttamente
Titolo: Re:HPLIP: stampante non riconosciuta dopo upgrade
Inserito da: dinolib - 22 Settembre 2015 ore 14:14
Io sono in testing e la mia stampante HP funziona correttamente
ma porc... (usi HPLIP o driver foomatic?)

EDIT: fra le varie cose dopo la catastrofe mi è venuto un atroce dubbio: ma prima di dichiarare HPLIP non funzionante, ho riavviato? mi sembra proprio di no  >:( >:( >:(
E' una delle prime cose da fare, ma ho davvero perso l'abitudine a questa pratica barbara
Titolo: Re:HPLIP: stampante non riconosciuta dopo upgrade
Inserito da: FranzMari - 23 Settembre 2015 ore 11:31
Usa il driver hpcups, fornito dal pacchetto hplip