Chakra Linux Italia Forum

Supporto Tecnico Software => Pacchetti => Topic aperto da: vellerofonte - 10 Maggio 2013 ore 07:16

Titolo: KDE 4.10.3 problema system-config-printer
Inserito da: vellerofonte - 10 Maggio 2013 ore 07:16
L'aggiornamento questa mattina fallisce a causa di system-config-printer, nello specifico il terminale dopo la verifica dei pacchetti scaricati, mi restituisce:

Codice: [Seleziona]
errore: impossibile eseguire l'operazione richiesta (file in conflitto)
system-config-printer: /usr/lib/python2.7/site-packages/cupshelpers/__init__.pyc è già presente nel filesystem
system-config-printer: /usr/lib/python2.7/site-packages/cupshelpers/config.pyc è già presente nel filesystem
system-config-printer: /usr/lib/python2.7/site-packages/cupshelpers/cupshelpers.pyc è già presente nel filesystem
system-config-printer: /usr/lib/python2.7/site-packages/cupshelpers/openprinting.pyc è già presente nel filesystem
system-config-printer: /usr/lib/python2.7/site-packages/cupshelpers/ppds.pyc è già presente nel filesystem
system-config-printer: /usr/lib/python2.7/site-packages/cupshelpers/xmldriverprefs.pyc è già presente nel filesystem
Si sono verificati degli errori, nessun pacchetto è stato aggiornato.

Naturalmente i medesimi messaggi mi si presentano se cerco di installare il solo system-config-printer, mirror non ancora sincronizzati?  :-\
Titolo: Re:Aggiornamento a KDE 4.10.3
Inserito da: Cylon - 10 Maggio 2013 ore 07:50
era un errore che è comparso anche in arch un paio di mesi fa, la "soluzione" data da uno sviluppatore è stata che per aggiornare era necessario dare:

Codice: [Seleziona]
sudo pacman -Su --ignore system-config-printer
sudo  pacman -S system-config-printer --force

questa è la spiegazione:

Citazione

The system-config-printer package in [extra] is back: this package is no more
split between system-config-printer-common and -gnome.

As a side effect, this package now ships (the missing) *.pyc files and this
causes the update to fail due to some conflicts.
Titolo: Re:Aggiornamento a KDE 4.10.3
Inserito da: vellerofonte - 10 Maggio 2013 ore 08:21
era un errore che è comparso anche in arch un paio di mesi fa, la "soluzione" data da uno sviluppatore è stata che per aggiornare era necessario dare:

Codice: [Seleziona]
sudo pacman -Su --ignore system-config-printer
sudo  pacman -S system-config-printer --force

questa è la spiegazione:

Grazie Cylon  ;)