Chakra Linux Italia Forum

Supporto Tecnico Base => Gestione del software con Pacman/Akabei => Topic aperto da: fabbrilli - 24 Novembre 2012 ore 02:20

Titolo: strano errore aggiornamento ?
Inserito da: fabbrilli - 24 Novembre 2012 ore 02:20
saluti, ragazzi. ho aperto un topic, anche se ce ne erano simili al mio, ma vorrei anche chiuderlo nel caso si risolvesse il mio problema. come al solito ho dato il comando da terminale dopo la notifica apparsami di un aggiornamento disponibile, ma:
Codice: [Seleziona]
[fabio@fabio-pc ~]$ sudo pacman -Syu
Password:
:: Sincronizzazione dei database in corso...
errore: impossibile scaricare il pacchetto 'lib32.db' da archlinux.puzzle.ch : couldn't connect to host
 lib32 è aggiornato
errore: impossibile scaricare il pacchetto 'core.db' da archlinux.puzzle.ch : connect() timed out!
 core è aggiornato
errore: impossibile scaricare il pacchetto 'platform.db' da archlinux.puzzle.ch : connect() timed out!
 platform è aggiornato
errore: impossibile scaricare il pacchetto 'desktop.db' da archlinux.puzzle.ch : connect() timed out!
 desktop è aggiornato
errore: impossibile scaricare il pacchetto 'apps.db' da archlinux.puzzle.ch : couldn't connect to host
 apps è aggiornato
errore: impossibile scaricare il pacchetto 'games.db' da archlinux.puzzle.ch : connect() timed out!
 games è aggiornato
:: Aggiornamento del sistema in corso...
 non ci sono aggiornamenti disponibili
[fabio@fabio-pc ~]$
ho dato poi :
Codice: [Seleziona]
[fabio@fabio-pc ~]$ sudo pacman -Syy
Password:
:: Sincronizzazione dei database in corso...
errore: impossibile scaricare il pacchetto 'lib32.db' da archlinux.puzzle.ch : connect() timed out!
 lib32                     30,8 KiB   230K/s 00:00 [#################] 100%
errore: impossibile scaricare il pacchetto 'core.db' da archlinux.puzzle.ch : connect() timed out!
 core                      51,7 KiB  94,6K/s 00:01 [#################] 100%
errore: impossibile scaricare il pacchetto 'platform.db' da archlinux.puzzle.ch : connect() timed out!
 platform                 187,8 KiB  76,9K/s 00:02 [#################] 100%
errore: impossibile scaricare il pacchetto 'desktop.db' da archlinux.puzzle.ch : couldn't connect to host
 desktop                   87,6 KiB   187K/s 00:00 [#################] 100%
errore: impossibile scaricare il pacchetto 'apps.db' da archlinux.puzzle.ch : connect() timed out!
 apps                     124,1 KiB   207K/s 00:01 [#################] 100%
errore: impossibile scaricare il pacchetto 'games.db' da archlinux.puzzle.ch : connect() timed out!
 games                     33,0 KiB   183K/s 00:00 [#################] 100%
[fabio@fabio-pc ~]$
:o
che significa? come qualcosa che mi blocca la connessione? eppure sto scrivendo!
Titolo: Re:strano errore aggiornamento ?
Inserito da: joshuadunamis - 24 Novembre 2012 ore 02:23
Probabilmente è un problema dei servers. Riprova più tardi! Ora sto con Ubuntu e non posso verificare.
Titolo: Re:strano errore aggiornamento ?
Inserito da: fabbrilli - 24 Novembre 2012 ore 02:25
Probabilmente è un problema dei servers. Riprova più tardi! Ora sto con Ubuntu e non posso verificare.
grazie in ogni caso.
Titolo: Re:strano errore aggiornamento ?
Inserito da: vellerofonte - 24 Novembre 2012 ore 09:17
Sicuramente un problema di mirror, si risolve spontaneamente in poche ore  ;)
Titolo: Re:strano errore aggiornamento ?
Inserito da: enzolatina - 24 Novembre 2012 ore 09:22
non ti si è bloccato niente, ha solo cercato di scaricare dal primo mirror che hai in lista (puzzle.ch) non ha trovato niente, vuoi per il server down o altro motivo, ed è passato al secondo mirror che hai in lista, scaricando correttamente la lista dei pacchetti...
Titolo: Re:strano errore aggiornamento ?
Inserito da: fabbrilli - 24 Novembre 2012 ore 23:00
innanzitutto, grazie per le risposte. oggi, ho riprovato i soliti comandi "sudo pacman Syu" e "Syy", ma non ha aggiornato. era tutto ok. possibile ? eppure ieri mi proponevano aggiornamenti! che poi appunto non sono andati a buon fine. :-\
Titolo: Re:strano errore aggiornamento ?
Inserito da: enzolatina - 25 Novembre 2012 ore 08:55
prima devi usare -Syy e poi -Syu (il primo ricrea l'albero dei pacchetti e il secondo aggiorna), poi sicuro che non ha aggiornato? magari ha aggiornato dandoti qualche messaggio di warning....a meno che tra ieri e oggi non hai modificato i repo magari commentando testing....
Titolo: Re:strano errore aggiornamento ?
Inserito da: jimthedoors - 27 Novembre 2012 ore 00:08
Ciao !!!
scusate se mi intrometto, ma
stasera a me fa così:
Codice: [Seleziona]
[jimthedoors@chakra-pc-jim ~]$ sudo pacman -Syy
Password:
:: Sincronizzazione dei database in corso...
 lib32                     30,7 KiB   142K/s 00:00 [########################] 100%
 core                      52,0 KiB   192K/s 00:00 [########################] 100%
 platform                 188,7 KiB   192K/s 00:01 [########################] 100%
 desktop                   87,8 KiB   326K/s 00:00 [########################] 100%
 apps                     124,2 KiB   364K/s 00:00 [########################] 100%
 games                     33,0 KiB   385K/s 00:00 [########################] 100%
[jimthedoors@chakra-pc-jim ~]$ sudo pacman -Syu
:: Sincronizzazione dei database in corso...
 lib32 è aggiornato
 core è aggiornato
 platform è aggiornato
 desktop è aggiornato
 apps è aggiornato
 games è aggiornato
:: Aggiornamento del sistema in corso...
:: Vuoi sostituire procps con core/procps-ng? [S/n] S
risoluzione delle dipendenze in corso...
ricerca dei conflitti in corso...
:: util-linux e eject vanno in conflitto. Vuoi rimuovere eject? [s/N] N
errore: sono stati rilevati dei conflitti irrisolvibili
errore: impossibile eseguire l'operazione richiesta (dipendenze in conflitto)
:: util-linux e eject vanno in conflitto
[jimthedoors@chakra-pc-jim ~]$
che cosa vuol dire?
che faccio?
Titolo: Re:strano errore aggiornamento ?
Inserito da: Cylon - 27 Novembre 2012 ore 00:42
leggi le news e avrai le risposte. :)
Titolo: Re:strano errore aggiornamento ?
Inserito da: fedefox - 27 Novembre 2012 ore 00:54
le novità vanno sempre controllate quando ci sono degli aggiornamenti ragazzi, se nn vi viene naturale di guardare la pagina novità del sito, iscrivetevi ai canali fb e g+, http://forum.chakra-project.it/index.php/topic,2966.0.html qui trovate i link alle pagine, non li aggiorno all'istante ma comunque cerco di farlo il prima possibile :)
Titolo: Re:strano errore aggiornamento ?
Inserito da: vellerofonte - 27 Novembre 2012 ore 09:20
Corretto l'incoraggiamento a leggere le news, tuttavia in 2 anni di Chakra non mi è mai capitato di dover rispondere "n" ad una richiesta di pacman  ;D
Titolo: Re:strano errore aggiornamento ?
Inserito da: fedefox - 27 Novembre 2012 ore 10:57
Corretto l'incoraggiamento a leggere le news, tuttavia in 2 anni di Chakra non mi è mai capitato di dover rispondere "n" ad una richiesta di pacman  ;D
si infatti lol
Titolo: Re:strano errore aggiornamento ?
Inserito da: enzolatina - 27 Novembre 2012 ore 14:23
morale della favola, jimthedoors, rispondi si alle richieste di sostituzione pacchetti (generalmente sono sempre azioni volute dai pacchetti della distro per cui la cosa è (quasi) sempre sicura) se non hai tempo/voglia di leggere le news
Titolo: Re:strano errore aggiornamento ?
Inserito da: Cylon - 27 Novembre 2012 ore 15:10
se una persona che usa chakra non ha tempo/voglia di leggere le news ha semplicemente sbagliato nello scegliere distro,
Titolo: Re:strano errore aggiornamento ?
Inserito da: vellerofonte - 27 Novembre 2012 ore 15:13
se una persona che usa chakra non ha tempo/voglia di leggere le news ha semplicemente sbagliato nello scegliere distro,

Io ieri sera ho anche provato a leggere le news nel momento in cui spun mi ha segnalato l'aggiornamento...ma non vi era ancora alcuna news al riguardo  :lol:

scherzo eh......grazie a tutti per il costante supporto  ;)

MI RACCOMANDO LEGGETE NEWS E WIKI SEMPRE!  ;D
Titolo: Re:strano errore aggiornamento ?
Inserito da: Cylon - 27 Novembre 2012 ore 15:25
be se non c'era ci sarà un motivo, tipo chi "traduce" le news usa altra distro  e l'unico modo per sapere di nuove news è avere akregator attivo ..  ;D ;D ;D
Titolo: Re:strano errore aggiornamento ?
Inserito da: andreazube - 27 Novembre 2012 ore 16:24
Di solito basta dare "s" alla richiesta,ma se mi chiede qualcosa o se l'aggiornamento è più grosso di 100mb io guardo sempre la sezione notizie...
Sto aggiornando adesso,o meglio ho lanciato l'aggiornamento un oretta fa ma ho la conessione lenta e 250mb da scaricare  :(
Titolo: Re:strano errore aggiornamento ?
Inserito da: jimthedoors - 27 Novembre 2012 ore 21:56
Di nuovo Ciao a tutti!!
Grazie per le risposte sempre precise e puntuali !!!
Ora però vorrei precisare che io le news le ho lette prima di aggiornare...
ma non dicevano niente riguardo a: procps con core/procps-ng
                                                      util-linux e eject vanno in conflitto

quindi... Prima di fare casini... penso sia meglio chiedere  8)
un Saluto
Titolo: Re:strano errore aggiornamento ?
Inserito da: Cylon - 27 Novembre 2012 ore 22:26
vero non precisavano quali pacchetti ma la news diceva :

Citazione
Come al solito, assicuratevi che i mirror siano sincronizzati, e a qualsiasi domanda su sostituzioni/conflitti rispondete “si”.

poi nel dubbio chiedere sempre :)
Titolo: Re:strano errore aggiornamento ?
Inserito da: fabbrilli - 23 Dicembre 2012 ore 17:29
scusate, ragazzi, ho installato pclinuxos e per mia incompetenza ho crashiato tutto >:( ho dovuto reinstallare TUTTO.
ho reinstallato anche chakra, versione 2012-10 appena scaricata dal sito pensando che la versione successiva a quella ghe avevo installato precedentemente, fosse meglio, ma al momento di aprire il terminale, per aggiornare mi dà:
Codice: [Seleziona]
[fabio@fabio-pc ~]$ sudo pacman -Syy
Password:
:: Sincronizzazione dei database in corso...
 lib32                     28,4 KiB   713K/s 00:00 [######################] 100%
 core                      51,9 KiB   766K/s 00:00 [######################] 100%
 platform                 189,7 KiB   789K/s 00:00 [######################] 100%
 desktop                   88,3 KiB   786K/s 00:00 [######################] 100%
 apps                     126,1 KiB   789K/s 00:00 [######################] 100%
 games                     32,5 KiB   734K/s 00:00 [######################] 100%
[fabio@fabio-pc ~]$ sudo pacman -Syu
:: Sincronizzazione dei database in corso...
 lib32 è aggiornato
 core è aggiornato
 platform è aggiornato
 desktop è aggiornato
 apps è aggiornato
 games è aggiornato
:: I seguenti pacchetti dovrebbero essere aggiornati prima :
    pacman
:: Vuoi annullare l'operazione corrente
:: e aggiornare adesso questi pacchetti? [S/n] s

risoluzione delle dipendenze in corso...
ricerca dei conflitti in corso...
errore: impossibile eseguire l'operazione richiesta (impossibile soddisfare le dipendenze)
:: gcc: richiede gcc-libs=4.7.0-1
[fabio@fabio-pc ~]$
ho provato a scrivere :
Codice: [Seleziona]
[fabio@fabio-pc ~]$ ccr gcc-libs --noedit
0 lib32/gcc-libs-multilib 4.7.2-1
      Runtime libraries shipped by GCC for multilib
1 lib32/lib32-gcc-libs 4.7.2-1
      Runtime libraries shipped by GCC (32-bit)
2 core/gcc-libs 4.7.2-1 (base) [installato: 4.7.0-1]
      Runtime libraries shipped by GCC

Type numbers to install. Separate each number with a space.
Numbers: 0
Password:
:: I seguenti pacchetti dovrebbero essere aggiornati prima :
    pacman
:: Vuoi annullare l'operazione corrente
:: e aggiornare adesso questi pacchetti? [S/n] s

risoluzione delle dipendenze in corso...
ricerca dei conflitti in corso...
errore: impossibile eseguire l'operazione richiesta (impossibile soddisfare le dipendenze)
:: gcc: richiede gcc-libs=4.7.0-1
[fabio@fabio-pc ~]$
non riesco a trovare : gcc-libs=4.7.0-1 per soddisfare quanto richiestomi.  :( mi aiutate?
Titolo: Re:strano errore aggiornamento ?
Inserito da: vellerofonte - 23 Dicembre 2012 ore 18:42
Come puoi vedere da qui: http://www.chakra-project.org/packages/index.php?act=search&subdir=&sortby=date&order=descending&searchpattern=gcc-libs

il pacchetto incriminato è presente nei repository ufficiali, dunque lanciare ccr -S non ha senso  ;)

Vai piuttosto con un:

Codice: [Seleziona]
sudo pacman -S gcc-libs
Questo dovrebbe mettere a posto la questione pacchetto mancante, quindi vai con:

Codice: [Seleziona]
sudo pacman -Syyu
ti chiederà di aggiornare proprio il pacchetto pacman, accetti e questa volta dovrebbe filare tutto liscio, terminato di aggiornare pacman dai finalmente:

Codice: [Seleziona]
sudo pacman -Syu
per verificare la presenza di eventuali aggiornamenti, in caso comparissero istruzioni a video (avvisi del nuovo pacchetto pacman-helpme), seguili attentamente  :)
Titolo: Re:strano errore aggiornamento ?
Inserito da: fabbrilli - 23 Dicembre 2012 ore 18:57
ho dato il comando:
Codice: [Seleziona]
[fabio@fabio-pc ~]$ sudo pacman -S gcc-libs
Password:
:: I seguenti pacchetti dovrebbero essere aggiornati prima :
    pacman
:: Vuoi annullare l'operazione corrente
:: e aggiornare adesso questi pacchetti? [S/n] n

risoluzione delle dipendenze in corso...
ricerca dei conflitti in corso...
errore: impossibile eseguire l'operazione richiesta (impossibile soddisfare le dipendenze)
:: gcc: richiede gcc-libs=4.7.0-1
[fabio@fabio-pc ~]$
tutto come prima ::)
Titolo: Re:strano errore aggiornamento ?
Inserito da: andreazube - 23 Dicembre 2012 ore 19:01
ho dato il comando:
Codice: [Seleziona]
[fabio@fabio-pc ~]$ sudo pacman -S gcc-libs
Password:
:: I seguenti pacchetti dovrebbero essere aggiornati prima :
    pacman
:: Vuoi annullare l'operazione corrente
:: e aggiornare adesso questi pacchetti? [S/n] n

risoluzione delle dipendenze in corso...
ricerca dei conflitti in corso...
errore: impossibile eseguire l'operazione richiesta (impossibile soddisfare le dipendenze)
:: gcc: richiede gcc-libs=4.7.0-1
[fabio@fabio-pc ~]$
tutto come prima ::)
Per prima cosa, non rifiutare quando ti chiede di aggiornare pacman...
Titolo: Re:strano errore aggiornamento ?
Inserito da: FranzMari - 23 Dicembre 2012 ore 19:06
Dai prima
Codice: [Seleziona]
sudo pacman -S pacmane vedi se ti aggiorna pacman.
Titolo: Re:strano errore aggiornamento ?
Inserito da: fabbrilli - 23 Dicembre 2012 ore 19:22
innanzi tutto grazie a tutti.@ FranzMari, credevo fosse la soluzione, dopo il tuo comando, ma ... ti riporto leultime:
Codice: [Seleziona]
                sed-4.2.1-6  shadow-4.1.5.1-1  shared-color-profiles-0.1.5-1
                 shared-mime-info-1.0-1  sip-4.14.2-1
                 smbclient-3.6.7-1 [removal]  soundtouch-1.7.0-1  sox-14.4.0-5
                 speex-1.2rc1-9  spideroak-4.8.3-1  sshfs-2.4-2  strigi-0.7.7-3
                 sysfsutils-2.1.0-7  system-config-printer-1.3.12-1
                 systemd-196-2  systemd-units-20120528-15  talloc-2.0.8-1
                 telepathy-haze-0.6.0-3  telepathy-mission-control-5.14.0-2
                 tiacx-20080210-40  transcode-1.1.7-8  tzdata-2012i-1
                 udisks-1.0.4-6  unionfs-fuse-0.26-2  usb-modeswitch-1.2.5-1
                 util-linux-2.22.1-3  vcdimager-0.7.24-1
                 vhba-module-20120422-6  vim-7.3.744-1  vim-runtime-7.3.744-1
                 webrtc-audio-processing-0.1-4  which-2.20-6  x264-20121206-1
                 xbitmaps-1.1.1-1  xbmc-11.0-5  xdelta3-3.0.4-1
                 xdg-utils-1.1.0.1-1  xerces-c-3.1.1-1  xfsprogs-3.1.8-1
                 xine-lib-1.2.2-3  xorg-apps-7.6-2

Dimensione totale dei pacchetti da scaricare:    0,61 MiB

Dimensione totale dei pacchetti da installare:   2246,63 MiB

Dimensione dell'aggiornamento di rete: 100,83 MiB

Vuoi procedere con l'installazione? [S/n] s
:: Download dei pacchetti da core...
 mirror-check-0.4-1-...  1128,0   B  19,9M/s 00:00 [######################] 100%
:: Download dei pacchetti da platform...
 cairo-1.12.6-2-x86_64    624,2 KiB   564K/s 00:01 [######################] 100%
(288/288) controllo dell'integrità del pacchetto   [######################] 100%
(288/288) caricamento dei file del pacchetto       [######################] 100%
(288/288) controllo dei conflitti in corso         [######################] 100%
errore: impossibile eseguire l'operazione richiesta (file in conflitto)
talloc: /usr/lib/libtalloc.so.1 è già presente nel filesystem
talloc: /usr/lib/libtalloc.so.2 è già presente nel filesystem
Si sono verificati degli errori, nessun pacchetto è stato aggiornato.
[fabio@fabio-pc ~]$
Titolo: Re:strano errore aggiornamento ?
Inserito da: andreazube - 23 Dicembre 2012 ore 19:25
innanzi tutto grazie a tutti.@ FranzMari, credevo fosse la soluzione, dopo il tuo comando, ma ... ti riporto leultime:
Codice: [Seleziona]
                sed-4.2.1-6  shadow-4.1.5.1-1  shared-color-profiles-0.1.5-1
                 shared-mime-info-1.0-1  sip-4.14.2-1
                 smbclient-3.6.7-1 [removal]  soundtouch-1.7.0-1  sox-14.4.0-5
                 speex-1.2rc1-9  spideroak-4.8.3-1  sshfs-2.4-2  strigi-0.7.7-3
                 sysfsutils-2.1.0-7  system-config-printer-1.3.12-1
                 systemd-196-2  systemd-units-20120528-15  talloc-2.0.8-1
                 telepathy-haze-0.6.0-3  telepathy-mission-control-5.14.0-2
                 tiacx-20080210-40  transcode-1.1.7-8  tzdata-2012i-1
                 udisks-1.0.4-6  unionfs-fuse-0.26-2  usb-modeswitch-1.2.5-1
                 util-linux-2.22.1-3  vcdimager-0.7.24-1
                 vhba-module-20120422-6  vim-7.3.744-1  vim-runtime-7.3.744-1
                 webrtc-audio-processing-0.1-4  which-2.20-6  x264-20121206-1
                 xbitmaps-1.1.1-1  xbmc-11.0-5  xdelta3-3.0.4-1
                 xdg-utils-1.1.0.1-1  xerces-c-3.1.1-1  xfsprogs-3.1.8-1
                 xine-lib-1.2.2-3  xorg-apps-7.6-2

Dimensione totale dei pacchetti da scaricare:    0,61 MiB

Dimensione totale dei pacchetti da installare:   2246,63 MiB

Dimensione dell'aggiornamento di rete: 100,83 MiB

Vuoi procedere con l'installazione? [S/n] s
:: Download dei pacchetti da core...
 mirror-check-0.4-1-...  1128,0   B  19,9M/s 00:00 [######################] 100%
:: Download dei pacchetti da platform...
 cairo-1.12.6-2-x86_64    624,2 KiB   564K/s 00:01 [######################] 100%
(288/288) controllo dell'integrità del pacchetto   [######################] 100%
(288/288) caricamento dei file del pacchetto       [######################] 100%
(288/288) controllo dei conflitti in corso         [######################] 100%
errore: impossibile eseguire l'operazione richiesta (file in conflitto)
talloc: /usr/lib/libtalloc.so.1 è già presente nel filesystem
talloc: /usr/lib/libtalloc.so.2 è già presente nel filesystem
Si sono verificati degli errori, nessun pacchetto è stato aggiornato.
[fabio@fabio-pc ~]$
È la soluzione, leggi le news  :P
Citazione
Con il prossimo pacman -Syu, riceverete un aggiornamento di pacman, che installerà pacman-helpme, e l’installazione di esso vi spiegherà cosa fare riguardo i conflitti che sorgeranno con l’aggiornamento di talloc.

Credo che tu debba dare
Citazione
sudo pacman -S talloc --force

e successivamente

sudo pacman -Syu
(fonte chakra galaxy (http://chakragalaxy.blogspot.it/2012/12/news-nuovo-soud-stack-e-chakra-tools-in.html))
Non ne sono sicuro al 100% (ora non sono su chakra), ma molto probabilmente devi dare i comandi scritti sopra
Titolo: Re:strano errore aggiornamento ?
Inserito da: fabbrilli - 23 Dicembre 2012 ore 19:34
È la soluzione, leggi le news  :P
Credo che tu debba dare(fonte chakra galaxy (http://chakragalaxy.blogspot.it/2012/12/news-nuovo-soud-stack-e-chakra-tools-in.html))
Non ne sono sicuro al 100% (ora non sono su chakra), ma molto probabilmente devi dare i comandi scritti sopra
ho riprovato, ma il risultato è identico. :-\
Titolo: Re:strano errore aggiornamento ?
Inserito da: andreazube - 23 Dicembre 2012 ore 19:40
ho riprovato, ma il risultato è identico. :-\
Riprovato cosa?
Hai dato i comandi suggeriti da chakra galaxy?
ora cosa esce (output)?
Titolo: Re:strano errore aggiornamento ?
Inserito da: fabbrilli - 23 Dicembre 2012 ore 20:16
scusa, non riuscivo a leggere il resto del tuo post:
Codice: [Seleziona]
Credo che tu debba dare
Citazione
sudo pacman -S talloc --force

e successivamente

sudo pacman -Syu
(fonte chakra galaxy)
Non ne sono sicuro al 100% (ora non sono su chakra), ma molto probabilmente devi dare i comandi scritti sopra
« Ultima modifica: Oggi alle 19:28 da andreazube »
però come hai suggerito ho visitato il sito, e ..........credo sia risolto il tutto anche se nel'installazione ogni tanto dava qualche errore (vari errori) non sono riuscito ad appuntarmeli. terminata l'0perazione, però ho controllato e, kde è aggiornato a 4.9.4 e linux a 3.6.6-1. riavviato e ora è tutto o.k. come sempre,  G R A Z I E   G R A N D I. auguro a tutti un sereno e buon natale. fabio. :beer: