Chakra Linux Italia Forum

Supporto Tecnico Software => PKGBUILD => Topic aperto da: pepo - 30 Ottobre 2011 ore 10:11

Titolo: Kamoso - Problemi installazione
Inserito da: pepo - 30 Ottobre 2011 ore 10:11
Salve a tutti,


per testare la nuova webcam (che skype gentilmente ha deciso di ignorare) ho provato ad installare da CCR il software KAMOSO.
Ma apppena avvio l'installazione, chiede la password, apre un terminale e mi esce il seguente errore:

Codice: [Seleziona]
Dependency `qtgstreamer-git' of `kamoso' does not exist
Ho provato a cercare il pacchetto sia in CCR che sui repo ufficiali, ma non ne trovo traccia...
Qualcuno sa come posso reperirlo?

Grazie e Saluti.
Titolo: Re:Kamoso - Problemi installazione
Inserito da: fedefox - 30 Ottobre 2011 ore 11:39
prova a installarlo da terminale dando ccr -S kamoso magari da li ti fa installare dipendenze che appsetqt non ti fa installare
Titolo: Re:Kamoso - Problemi installazione
Inserito da: pepo - 30 Ottobre 2011 ore 12:26
Ciao, grazie del consiglio, ma anche da terminale stesso errore... (anche con sudo + il comando)  >:(
Titolo: Re:Kamoso - Problemi installazione
Inserito da: kdekda - 30 Ottobre 2011 ore 12:29
il pacchetto in questione si trova solo nei repo unstable, non se se ti convenga installarlo

http://www.chakra-project.org/packages/index.php?act=search&subdir=&sortby=date&order=descending&searchpattern=^qtgstreamer-git-[0-9]
Titolo: Re:Kamoso - Problemi installazione
Inserito da: pepo - 30 Ottobre 2011 ore 12:33
Avrei bisogno di capire se questa webcam funziona o meno... skype dove m'interesserebbe utilizzarla NON sembra gestirla (viene vista come periferica, ma non riporta le immagini).

Posso installare qualche altro software? (qui sul forum avevo letto di provare Kamoso...)
Titolo: Re:Kamoso - Problemi installazione
Inserito da: Lazy - 30 Ottobre 2011 ore 12:37
prova kamerka
http://kde-apps.org/content/show.php?content=142415
è in ccr
http://chakra.sourceforge.net/ccr/packages.php?O=0&K=kamerka&do_Search=Go
Titolo: Re:Kamoso - Problemi installazione
Inserito da: fedefox - 30 Ottobre 2011 ore 12:46
Avrei bisogno di capire se questa webcam funziona o meno... skype dove m'interesserebbe utilizzarla NON sembra gestirla (viene vista come periferica, ma non riporta le immagini).

Posso installare qualche altro software? (qui sul forum avevo letto di provare Kamoso...)
guarda a me su skype la webcam funziona, però mi si vede a testa all'ingù lol è l'unico che mi da questo problema, infatti con kopete o direttamente in google talk mi si vede benissimo, quindi è proprio skype che non è il massimo su linux purtroppo
Titolo: Re:Kamoso - Problemi installazione
Inserito da: pepo - 30 Ottobre 2011 ore 13:56
Grazie a tutti per le risposte...

kamerka lo avevo già installato, mi accende la webcam, ma a video vedo solo qualche riga verticale di color arancio... (non funziona quindi)

Ho installato anche il plugin google-talkplugin... adesso vedo se trovo qualcuno per fare una prova con quello...

Grazie per il momento... se avete altre idee io comunque le ascolto tutte volentieri... (tranne cambiare webcam :-P )
Titolo: Re:Kamoso - Problemi installazione
Inserito da: cippaciong - 30 Ottobre 2011 ore 16:16
Che modello è la webcam??
Titolo: Re:Kamoso - Problemi installazione
Inserito da: pepo - 30 Ottobre 2011 ore 21:56
Ciao, è una trust Hires Webcam Live (http://"http://www.trust.com/products/product.aspx?artnr=15354")
Titolo: Re:Kamoso - Problemi installazione
Inserito da: jmc - 31 Ottobre 2011 ore 17:04
Saresti in grado di darci device e vendor ID? Nel caso, dacci l'output di "lsusb -v".
Titolo: Re:Kamoso - Problemi installazione
Inserito da: pepo - 31 Ottobre 2011 ore 17:16
Ciao,

penso  :-[ siano questi:

Codice: [Seleziona]
  idVendor           0x093a Pixart Imaging, Inc.
  idProduct          0x2621 PAC731x Trust Webcam



Titolo: Re:Kamoso - Problemi installazione
Inserito da: jmc - 31 Ottobre 2011 ore 17:41
Ho trovato questo: https://wiki.ubuntu.com/SkypeWebCams

Citazione
Trust WB-3320X USB 2.0 Webcam, 093a:2621, gspca_main
Skype version 2.1.0.81 works with config.xml modified for video size and frame rate (see SkypeGarage), and then launch skype with the command: LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype. Only green double preview. Works if you stop your video and then restart.
Titolo: Re:Kamoso - Problemi installazione
Inserito da: pepo - 31 Ottobre 2011 ore 17:52
Sei stato gentilissimo!!!
Allora, se lancio Skype con il comando: LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype
andando nelle Opzioni, sezione Dispositivo Video, premendo sul bottone PROVA, adesso qualche "luce" appare... non vedo l'immagine, ma riesco ad avere delle luci/ombre e cmq la webcam almeno si accende...

Il link a SkypeGarage è interrotto (non valido), per avere la corretta config. del config.xml temo che servisse quello giusto?

Ma in generale per testare una webcam cosa potrei fare? vi viene in mente altro? (google talk ancora non sono riuscito a provarlo...)
Titolo: Re:Kamoso - Problemi installazione
Inserito da: jmc - 31 Ottobre 2011 ore 18:33
Penso di sì... purtroppo non ho idea di cosa esattamente andasse modificato per correggere il file di configurazione. :-/

Per testare la webcam ci sono vari programmi, di cui però non ricordo il nome... :D
Ti direi di riprovare con Kamoso: se lo vuoi precompilato, puoi prenderlo dal repository "unstable" (in /etc/pacman.conf mettilo in fondo a tutti gli altri, in modo che non rimpiazzi software già presente altrove), si chiama "kamoso-git". Altrimenti, reinstallalo da CCR, io ho appena provato ad installarlo ed è andato liscio come l'olio. :)
Titolo: Re:Kamoso - Problemi installazione
Inserito da: pepo - 31 Ottobre 2011 ore 18:37
Ciao,io ho riporovato anche ora, ma kamoso-git in ccr non lo trovo, trovo kamoso, ma ho il medesimo errore di inizio post... domani provo ad abilitarlo in testing... grazie 1000 per tutte le risposte!!!
Titolo: Re:Kamoso - Problemi installazione
Inserito da: jmc - 31 Ottobre 2011 ore 19:05
No, kamoso-git lo trovi solo se abiliti il repository unstable. Facci sapere come va con testing!
Titolo: Re:Kamoso - Problemi installazione
Inserito da: pepo - 06 Novembre 2011 ore 10:08
Scusate il ritardo...

Stamani ho impostato come ultimo sorgente dei repository in /etc/pacman.conf il "testing".
Ho poi lanciato il comando: sudo pacman -Syyu

Non trovo Kamoso-git...

Lascio stare perchè il sistema in questione è il mio principale e non me la sento di passarlo in unstable...
Grazie a tutti delle risposte...

Se a qualcuno venisse in mente un altro programma da poter installare "facilmente"... lo proverei volentieri...

Saluti a tutti!




Titolo: Re:Kamoso - Problemi installazione
Inserito da: jmc - 06 Novembre 2011 ore 10:24
Veramente il repository unstable lo puoi aggiungere alla fine di /etc/pacman.conf, in modo che sia sempre l'ultima scelta per pacman, e che preferisca i repository "normali". A quel punto puoi installare selettivamente i pacchetti da unstable, come con "sudo pacman -S kamoso-git" o, ancora più esplicitamente, "sudo pacman -S unstable/kamoso-git". Non corri nessun rischio. :)