Autore Topic: Chakra non si avvia dopo install driver video  (Letto 164 volte)

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Chakra non si avvia dopo install driver video
« Risposta #15 il: 12 Luglio 2017 ore 17:51 »
perfetto! riesegui le installazioni/rimozioni da quella console.

Offline jonajams

  • *
  • Post: 102
  • Reputazione: 0
    • Mostra profilo
Re:Chakra non si avvia dopo install driver video
« Risposta #16 il: 12 Luglio 2017 ore 17:55 »
perfetto! riesegui le installazioni/rimozioni da quella console.

se ho ben capito, funziona come un terminale normale ma non in ambiente desktop....giusto?
ps: domanda da inesperto  :-[

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Chakra non si avvia dopo install driver video
« Risposta #17 il: 12 Luglio 2017 ore 18:19 »
esatto. è un terminale, sei loggato con la tua utenza, ma l'ambiente grafico non è avviato per qualche problema.

L'unica cosa è che probabilmente i servizi di rete non sono avviati e quindi potresti non avere la connessione disponibile. ma per rimuovere i pacchetti che ti ho indicato non ci sono problemi. Se nvidia è installato vai tranquillo, rimuovi quello che c'è di troppo e riprova a partire.

Offline jonajams

  • *
  • Post: 102
  • Reputazione: 0
    • Mostra profilo
Re:Chakra non si avvia dopo install driver video
« Risposta #18 il: 12 Luglio 2017 ore 23:57 »
al volo intanto puoi:

rimuovere i driver catalyst (che non centrano niente):
Codice: [Seleziona]
sudo pacman -Rnns catalyst
rimuovere i driver nouveau:
Codice: [Seleziona]
sudo pacman -Rnns xf86-video-nouveau
ricontrolla i driver nvidia:
Codice: [Seleziona]
sudo pacman -S nvidia nvidia-utils
Non so bene cosa fare di xorg.conf.
Prova con locate xorg.conf se ce l'hai in giro. Io inizierei con l'eliminarlo il rinominarlo (*.old), ma non sono sicuro al 100%


ok ho lanciato i tuoi comandi da rescue mode ma penso di aver peggiorato le cose....
infatti, ho cancellato nouveau tranquillamente, mentre non ho potuto installare nvidia per mancanza connessione.
ho cercato anche di cancellare nvidia ma dice che nvidia-setting ha bisogno di quel programma...
in ogni caso, il problema di prima persiste

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Chakra non si avvia dopo install driver video
« Risposta #19 il: 13 Luglio 2017 ore 09:22 »
no, nvidia ti serve, va bene così!

per la connessione non temere, lanciando i giusti demoni si può far ripartire... se ne avrai bisogno vedrò come fare (da qualche parte ce l'ho scritto  ;D)

Sicuro che la situazione è come prima? cerca ancora di avviare nouveau??  >:(

Hai trovato il file xorg.conf?
Leggi qui per dettagli: https://wiki.archlinux.org/index.php/NVIDIA_(Italiano)#Configurazione

Offline jonajams

  • *
  • Post: 102
  • Reputazione: 0
    • Mostra profilo
Re:Chakra non si avvia dopo install driver video
« Risposta #20 il: 17 Luglio 2017 ore 23:20 »
no, nvidia ti serve, va bene così!

per la connessione non temere, lanciando i giusti demoni si può far ripartire... se ne avrai bisogno vedrò come fare (da qualche parte ce l'ho scritto  ;D mx)

Sicuro che la situazione è come prima? cerca ancora di avviare nouveau??  >:(

Hai trovato il file xorg.conf?
Leggi qui per dettagli: https://wiki.archlinux.org/index.php/NVIDIA_(Italiano)#Configurazione

ciao! finalmente ho risolto :D
ho cancellato i driver nvidia di nuovo, da mod provv, e riavviato e finalmente funziona!
ora, visto che vorrei evitare gli stessi problemi, come installo i veri driver nvidia per una 940 mx?!

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:[SOLVED] Chakra non si avvia dopo install driver video
« Risposta #21 il: 18 Luglio 2017 ore 08:11 »
purtroppo io non ho più (i)nvidia da un po' (processo di beatificazione in corso...  ;D ;D)

Solitamente seguendo il wiki di arch non ho avuto problemi.
Franz mi cazzierà perchè non ti indico quelli di Chakra, ma ho qualche dubbio sul fatto che siano aggiornati. Non lo so sinceramente.
Ci sono anhce le indicazioni per capire se la tua schea richiede i driver di ultima versione o qualcuno più vecchio

Offline jonajams

  • *
  • Post: 102
  • Reputazione: 0
    • Mostra profilo
Re:[SOLVED] Chakra non si avvia dopo install driver video
« Risposta #22 il: 18 Luglio 2017 ore 10:04 »
uhm quelli scaricati dal sito nvidia sono di una estensione che non so come trattare (.sh), mentre quelli di arch dubito siano specifici per la mia scheda; stasera perdo un po' di tempo su qualche guida allora...

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:[SOLVED] Chakra non si avvia dopo install driver video
« Risposta #23 il: 18 Luglio 2017 ore 12:34 »
nonono fermo!  ;D

DEVI usare i driver forniti dai nostri repo.
Segui arch solo per capire quali pacchetti installare o rimuovere, quali file di configurazione toccare o rimuovere (ho parlato del wiki non dei repo!).

Se hai problemi a riportare su Chakra quanto dice la guida di Arch chiedi pure qui.

Offline dinolib

  • *
  • Post: 3226
  • Reputazione: 110
    • Mostra profilo
Re:Chakra non si avvia dopo install driver video
« Risposta #24 il: 20 Luglio 2017 ore 14:54 »
In assenza del server wiki, riporto un post di un altro utente Chakra sulla corretta installazione dei driver video:

https://community.chakralinux.org/t/switching-between-free-and-non-free-video-drivers-from-the-wiki/6396

 

Template by Homey | Sito ufficiale | Disclaimer